Launch Printer Friendly Page Security TechCenter > > Microsoft Security Bulletin MS13-031

Microsoft Security Bulletin MS13-031 - Important

Vulnerabilities in Windows Kernel Could Allow Elevation of Privilege (2813170)

Published: | Updated:

Version: 1.1

General Information

Executive Summary

This security update resolves two privately reported vulnerabilities in Microsoft Windows. The vulnerabilities could allow elevation of privilege if an attacker logs on to the system and runs a specially crafted application. An attacker must have valid logon credentials and be able to log on locally to exploit these vulnerabilities.

This security update is rated Important for all supported releases of Microsoft Windows. For more information, see the subsection, Affected and Non-Affected Software, in this section.

The security update addresses the vulnerability by correcting the way that the Windows kernel handles objects in memory. For more information about the vulnerability, see the Frequently Asked Questions (FAQ) subsection for the specific vulnerability entry under the next section, Vulnerability Information.

Recommendation. Most customers have automatic updating enabled and will not need to take any action because this security update will be downloaded and installed automatically. Customers who have not enabled automatic updating need to check for updates and install this update manually. For information about specific configuration options in automatic updating, see Microsoft Knowledge Base Article 294871.

For administrators and enterprise installations, or end users who want to install this security update manually, Microsoft recommends that customers apply the update at the earliest opportunity using update management software, or by checking for updates using the Microsoft Update service.

See also the section, Detection and Deployment Tools and Guidance, later in this bulletin.

Knowledge Base Article

Knowledge Base article2813170
File informationYes
SHA1/SHA2 hashesYes
Known issuesNone

Affected and Non-Affected Software

The following software have been tested to determine which versions or editions are affected. Other versions or editions are either past their support life cycle or are not affected. To determine the support life cycle for your software version or edition, see Microsoft Support Lifecycle.

Affected Software 

Operating SystemMaximum Security ImpactAggregate Severity RatingUpdates Replaced
Windows XP
Windows XP Service Pack 3
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Windows XP Professional x64 Edition Service Pack 2
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Windows Server 2003
Windows Server 2003 Service Pack 2
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Windows Server 2003 x64 Edition Service Pack 2
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Windows Server 2003 with SP2 for Itanium-based Systems
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Windows Vista
Windows Vista Service Pack 2
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Vista x64 Edition Service Pack 2
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 for x64-based Systems Service Pack 2
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 for Itanium-based Systems Service Pack 2
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows 7
Windows 7 for 32-bit Systems
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows 7 for 32-bit Systems Service Pack 1
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows 7 for x64-based Systems
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows 7 for x64-based Systems Service Pack 1
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 R2 for x64-based Systems Service Pack 1
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 R2 for Itanium-based Systems
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows 8
Windows 8 for 32-bit Systems
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Windows 8 for 64-bit Systems
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Windows Server 2012
Windows Server 2012
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Windows RT
Windows RT[1]
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017
Server Core installation option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 R2 for x64-based Systems (Server Core installation)
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
(2813170)
Elevation of PrivilegeImportant2620712 in MS11-097 and
2799494 in MS13-017
Windows Server 2012 (Server Core installation)
(2813170)
Elevation of PrivilegeImportant2799494 in MS13-017

[1]This update is available via Windows Update only.

 

Update FAQ

Vulnerability Information

Severity Ratings and Vulnerability Identifiers

Kernel Race Condition Vulnerability - CVE-2013-1284

Kernel Race Condition Vulnerability - CVE-2013-1294

Update Information

Detection and Deployment Tools and Guidance

Security Update Deployment

Other Information

Acknowledgments

Microsoft thanks the following for working with us to help protect customers:

Microsoft Active Protections Program (MAPP)

To improve security protections for customers, Microsoft provides vulnerability information to major security software providers in advance of each monthly security update release. Security software providers can then use this vulnerability information to provide updated protections to customers via their security software or devices, such as antivirus, network-based intrusion detection systems, or host-based intrusion prevention systems. To determine whether active protections are available from security software providers, please go to the active protections websites provided by program partners, listed in Microsoft Active Protections Program (MAPP) Partners.

Support

How to obtain help and support for this security update

Disclaimer

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions

  • V1.0 (April 9, 2013): Bulletin published.
  • V1.1 (April 24, 2013): Corrected update replacement. This is an informational change only. There were no changes to the security update files or detection logic.