Microsoft Security Bulletin MS13-005 - Important

Vulnerability in Windows Kernel-Mode Driver Could Allow Elevation of Privilege (2778930)

Published: | Updated:

Version: 1.2

General Information

Executive Summary

This security update resolves one privately reported vulnerability in Microsoft Windows. The vulnerability could allow elevation of privilege if an attacker runs a specially crafted application.

This security update is rated Important for all supported editions of Windows Vista, Windows Server 2008, Windows 7, Windows Server 2008 R2, Windows 8, Windows Server 2012, and Windows RT. For more information, see the subsection, Affected and Non-Affected Software, in this section.

The security update addresses the vulnerability by correcting the way that the Windows kernel-mode driver handles window broadcast messages. For more information about the vulnerability, see the Frequently Asked Questions (FAQ) subsection for the specific vulnerability entry under the next section, Vulnerability Information.

Recommendation. Most customers have automatic updating enabled and will not need to take any action because this security update will be downloaded and installed automatically. Customers who have not enabled automatic updating need to check for updates and install this update manually. For information about specific configuration options in automatic updating, see Microsoft Knowledge Base Article 294871.

For administrators and enterprise installations, or end users who want to install this security update manually, Microsoft recommends that customers apply the update at the earliest opportunity using update management software, or by checking for updates using the Microsoft Update service.

See also the section, Detection and Deployment Tools and Guidance, later in this bulletin.

Known Issues. Microsoft Knowledge Base Article 2778930 documents the currently known issues that customers may experience when installing this security update. The article also documents recommended solutions for these issues.

Affected and Non-Affected Software

The following software have been tested to determine which versions or editions are affected. Other versions or editions are either past their support life cycle or are not affected. To determine the support life cycle for your software version or edition, see Microsoft Support Lifecycle.

Affected Software 

Operating SystemMaximum Security ImpactAggregate Severity RatingUpdates Replaced
Windows Vista
Windows Vista Service Pack 2
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Vista x64 Edition Service Pack 2
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 for x64-based Systems Service Pack 2
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 for Itanium-based Systems Service Pack 2
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows 7
Windows 7 for 32-bit Systems
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows 7 for 32-bit Systems Service Pack 1
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows 7 for x64-based Systems
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows 7 for x64-based Systems Service Pack 1
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 R2 for x64-based Systems Service Pack 1
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 R2 for Itanium-based Systems
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows 8
Windows 8 for 32-bit Systems
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows 8 for 64-bit Systems
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2012
Windows Server 2012
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows RT
Windows RT[1]
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Server Core Installation Option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 R2 for x64-based Systems (Server Core installation)
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930
Windows Server 2012 (Server Core installation)
(KB2778930)
Elevation of PrivilegeImportantKB2779030 in MS12-078 replaced by KB2778930

[1]This update is available via Windows Update.

Non-Affected Software

Operating System
Microsoft Windows XP Service Pack 3
Microsoft Windows XP Professional x64 Edition Service Pack 2
Microsoft Windows Server 2003 Service Pack 2
Microsoft Windows Server 2003 x64 Edition Service Pack 2
Microsoft Windows Server 2003 for Itanium-based Systems Service Pack 2

Frequently Asked Questions (FAQ) Related to This Security Update

Vulnerability Information

Severity Ratings and Vulnerability Identifiers

Win32k Improper Message Handling Vulnerability - CVE-2013-0008

Update Information

Detection and Deployment Tools and Guidance

Security Update Deployment

Other Information

Microsoft Active Protections Program (MAPP)

To improve security protections for customers, Microsoft provides vulnerability information to major security software providers in advance of each monthly security update release. Security software providers can then use this vulnerability information to provide updated protections to customers via their security software or devices, such as antivirus, network-based intrusion detection systems, or host-based intrusion prevention systems. To determine whether active protections are available from security software providers, please go to the active protections websites provided by program partners, listed in Microsoft Active Protections Program (MAPP) Partners.

Support

How to obtain help and support for this security update

Disclaimer

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions

  • V1.0 (January 8, 2013): Bulletin published.
  • V1.1 (January 9, 2013): Corrected detection and deployment summary tables. This is an informational change only. Customers who have already successfully updated their systems do not need to take any action.
  • V1.2 (February 12, 2013): Added a link to Microsoft Knowledge Base Article 2778930 under Known Issues in the Executive Summary.