Skip to main content

Upgrading to Microsoft Application Virtualization 4.6 Frequently Asked Questions

Updated: May 3, 2010

 

Application Virtualization (App-V) Client

Q. Can an application sequenced using the Microsoft SoftGrid Application Virtualization 4.2 Sequencer run on an App-V 4.6 Client?

A. We recommend you upgrade the clients to App-V 4.6 and then upgrade the server infrastructure. The following table shows when you have to sequence the applications to run with App-V 4.6 Clients and when you don’t.

 Sequenced
with 4.2
Sequenced
with 4.5
Sequenced
with 4.6 32-bit
Sequenced
with 4.6 64-bit
4.2 clientYesNoNoNo
4.5 clientYesYesNoNo
4.6 client (32-bit)YesYesYesNo
4.6 client (64-bit)YesYesYesYes
Q. Are the client cache and setting preserved during the upgrade process?

A. Yes. The client cache and settings are preserved during this upgrade. For additional detail refer to the “Planning and Deployment Guide for the Application Virtualization System,” which will be released with RTM.

Q. Can the Microsoft SoftGrid 4.2 or App-V 4.5 Client and the App-V 4.6 Client co-exist on the same machine?

A. No, the Microsoft SoftGrid 4.2 or App-V 4.5 Client and the App-V 4.6 Client cannot coexist.

Q. Can a localized App-V 4.5 Client access to EN4.2 SoftGrid Server? Is this a supported scenario?

A. Yes, this is a fully supported scenario. Any localized App-V 4.5 Client can access an EN App-V 4.2 Microsoft SoftGrid Server. In App-V 4.5, the system supports any-language-to-any-language communication.

Q. Can a localized Microsoft SoftGrid 4.2 Client be upgraded to an EN App-V 4.6 Client?

A. No. There was no official support for localization in Microsoft SoftGrid 4.2. Microsoft App-V 4.5 is the first version that introduced localized support for the following languages:

LanguageLocalized in
App-V 4.5
Localized in
App-V 4.6
Brazilian PortugueseYY
ItalianYY
Chinese SimplifiedYY
Chinese TraditionalYY
Dutch (client Only)YY
FrenchYY
GermanYY
JapaneseYY
KoreanYY
RussianYY
SpanishYY
SwedishNY
DanishNY
FinnishNY
PortugueseNY
Norwegian, BokmalNY
PolishNY
TurkishNY
HungarianNY
CzechNY
GreekNY
SlovakNY
SlovenianNY
Q. Can a localized SoftGrid 4.2 or App-V 4.5 Client co-exist with an App-V4.6 Client on the same machine?

A. No. This is not supported. Only one version of the client can be installed at a time.

Q. What server operating system versions can the App- V 4.6 Terminal Services Client be deployed to?

A. Windows Server 2003 Standard (SP1, SP2, R2, SP2+R2); Windows Server 2003 Enterprise Edition (SP1, R2, SP2, SP2+R2); Windows Server 2003 Datacenter Edition (SP1, R2, SP2, SP2+R2), and Windows Server 2008 (Standard, Enterprise, Datacenter).

Q. What operating systems can the App- V 4.6 Desktop Client be deployed to?

A. The App-V 4.6 Client can be deployed to following desktop operating systems:

  • Windows XP Pro SP2, Windows XP SP3
  • Windows Vista RTM/SP1 Business, Enterprise and Ultimate (X86 and X64)
  • Windows 7 Home Premium, Professional, Enterprise and Ultimate (X86 and X64)
Q. Do I have to clear my client cache when migrating from Microsoft SoftGrid 4.1/4.2/App-V 4.5 to App-V 4.6?

A. No, your client cache does not have to be cleared when upgrading your Client from 4.x to 4.6.

Q. Can I upgrade my App-V Client from App-V 4.6 Beta/RC to App-V 4.6 RTM?

A. No. We do not support direct upgrade for Microsoft App-V 4.6 Beta clients. In a production environment we recommend a new install.

Application Virtualization Server Infrastructure

Q. What operating systems can the App-V 4.6 Streaming Server be installed to?

A. There is no special App-V 4.6 streaming or management server; We are using App-V 4.5 SP1, which can be installed on the following operating systems:

  • Windows 2003 Standard Server (SP1;R2;SP2;SP2+R2)
  • Windows 2003 Enterprise Server (SP1;R2;SP2;SP2+R2)
  • Windows 2003 Datacenter Edition (SP1;R2;SP2;SP2+R2)
  • Windows 2003 Standard Server 64-bit (SP1;R2;SP2;SP2+R2, WOW64 only)
  • Windows 2003 Enterprise Server 64-bit (SP1;R2;SP2;SP2+R2, WOW64 only)
  • Windows 2003 Datacenter Edition 64-bit (SP1;R2;SP2;SP2+R2, WOW64 only)
  • Windows 2008 Server Standard Edition (no SP)
  • Windows 2008 Enterprise Edition (no SP)
  • Windows 2008 Datacenter Edition (no SP)
  • Windows 2008 Server Standard Edition (no SP, 64-bit, WOW64 only)
  • Windows 2008 Enterprise Edition (no SP, 64-bit, WOW64 only)
Q. Can a Microsoft SoftGrid 4.2 Server be upgraded to an App-V 4.5 SP1 Server?

A. Yes. You can upgrade a SoftGrid 4.2 Server to an App-V 4.5 SP1 Server. You should upgrade all servers at the same time and not have clients communicating with 4.2 and 4.5 SP1 servers simultaneously.

Q. What operating systems can the App-V 4.6 Terminal Server Client be installed to?

A. The App-V 4.6 Terminal Server Client can be installed on the following operating systems:

  • Windows 2003 Standard Server (SP1;R2;SP2;SP2+R2)(32 and 64-bit)
  • Windows 2003 Enterprise Server (SP1;R2;SP2;SP2+R2)(32 and 64-bit)
  • Windows 2003 Datacenter Edition (no SP;SP1;R2;SP2;SP2+R2)(32 and 64-bit)
  • Windows 2008 Server Standard Edition (no SP, 64 bit, WOW 64 only)
  • Windows 2008 Enterprise Edition (no SP, 64 bit, WOW 64 only)
  • Windows 2008 Datacenter Edition (no SP, 64 bit, WOW 64 only)
  • Windows Server 2008 R2 Standard (no SP, 64-bit, WOW64 only)
  • Windows Server 2008 R2 Enterprise (no SP, 64-bit, WOW64 only)
  • Windows Server 2008 R2 Datacenter Edition (no SP, 64-bit, WOW64 only)
Q. What operating systems can the App-v 4.6 Management Server be deployed to?

A. The App-V 4.6 Management Server can be installed on the following operating systems:

  • Windows 2003 Standard Server (SP1;R2;SP2;SP2+R2)
  • Windows 2003 Enterprise Server (SP1;R2;SP2;SP2+R2)
  • Windows 2003 Datacenter Edition (SP1;R2;SP2;SP2+R2)
  • Windows 2003 Standard Server 64-bit (SP1;R2;SP2;SP2+R2)
  • Windows 2003 Enterprise Server 64-bit (SP1;R2;SP2;SP2+R2)
  • Windows 2003 Datacenter Edition 64-bit (SP1;R2;SP2;SP2+R2)
  • Windows 2008 Server Standard Edition (no SP)
  • Windows 2008 Enterprise Edition (no SP)
  • Windows 2008 Datacenter Edition (no SP)
  • Windows 2008 Server Standard Edition (no SP, 64-bit, WOW64 only)
  • Windows 2008 Enterprise Edition (no SP, 64-bit, WOW64 only)
  • Windows 2008 Server Datacenter Edition (no SP, 64-bit, WOW64 only)
  • Windows 2008 R2 Server Standard Edition (no SP, 64-bit, WOW64 only)
  • Windows 2008 R2 Enterprise Edition (no SP, 64-bit, WOW64 only)
  • Windows 2008 R2 Server Datacenter Edition (no SP, 64-bit, WOW64 only)
Q. Can I continue to use Microsoft SoftGrid 4.2/ App-V 4.5 Management Server with an App-V 4.5 SP1 Streaming Server and App-V 4.6 Client?

A. No. It is not recommended to have the client communicating with different server versions. The recommended approach is to have all servers in the same site at the same version level.

Q. What versions of Microsoft SQL Server are supported for the App-V 4.6 database?

A. The following Microsoft SQL Server versions are supported:

  • SQL Server 2000 (SP3a)
  • SQL Server 2000 (SP4)
  • SQL Server 2005 (SP1)
  • SQL Server 2005 (SP2)
  • SQL Server 2005 Express (all versions – non production only)
  • SQL Server 2008
Q. Can I upgrade my App-V 4.6 pre-release server versions to an App-V 4.6 RTM server version?

A. No. We will not support upgrading a pre-release version to an RTM version. You must perform a new installation using the RTM release version.

Q. What App-V Server versions are supported with App-V 4.6 Clients?

A. We support server versions 4.2 and above with App-V 4.6 Clients. However, it is recommended that all servers remain at the same version level.

Q. Can I upgrade from Microsoft SoftGrid 4.2 or App-V 4.5 to App-V 4.6 with System Center Configuration Manager (SCCM) 2007 R2?

A. Yes. When migrating from SoftGrid 4.2/App-V 4.5 standalone to SCCM 2007 R2 you must:

  • Import packages and create advertisements.
  • Enable the integration through the Advertised Programs Agent to remove all previously deployed virtual application packages that have been published through Full Application Virtualization server or the MSI utility.
  • SCCM Advertisements and policy will be evaluated and the virtual applications will be re-added to the system.
  • There is no need to re-sequence your packages.

With App-V 4.6, there are both 32-bit and 64-bit versions of the Client. Two separate packages, programs, and advertisements will need to be created in order to accommodate both platforms. The appropriate collections for 32-bit and 64-bit applications will need to be used to ensure delivery to the correct platform.

More detailed information can be found in the Application Virtualization 4.5 and SCCM R2 whitepaper.

Application Virtualization Sequencing

Q. Does a Microsoft SoftGrid 4.2 or App-V 4.5 sequenced application work in an App-V 4.6 environment? Is it supported?

A. Yes, a SoftGrid 4.2 or App-V 4.5 sequenced application will work in an App-V 4.6 environment and is a supported scenario. However, some customers may want to re-sequence or update their sequences to take advantage of new App-V 4.6 Sequencer features such as:

  • Improved Sequencing Accuracy:
    • More robust side-by-side handling
    • Better handling of virtualization
  • Dynamic Suite Composition
  • Ability to reliably handle future upgrades to packages as there may be limitations for upgrading legacy packages
  • The MSI features
Q. Does an EN SoftGrid 4.2 sequenced application work on a localized version of App-V 4.6 running on a localized operating system? Is this a supported scenario?

A. This is not a supported scenario and we cannot confirm that this will work properly. SoftGrid 4.2 was not officially supported on languages other than English. It is recommended that customers re-sequence the application to make sure that the sequence is correctly captured as a localized program.

Q. Will my packages and package settings be valid when I upgrade from App-V 4.x to App-V 4.6?

A. Yes. App-V 4.6 will not remove or alter your current package settings. Users will be able to continue to have their settings preserved.

Q. What will happen with my preferences for my existing Microsoft SoftGrid 4.2 packages? Will I lose everything or is there a way to migrate them to App-V 4.6? If so, how?

A. If you perform a package upgrade to App-V 4.6, you will retain your settings. If you perform a brand new sequence, then you will not. We are still formalizing our upgrade scenarios which may introduce some limitations due to changes in virtualization and the Sequencer.

To learn more about Microsoft Application Virtualization and the Microsoft Desktop Optimization Pack for Software Assurance, go to http://www.microsoft.com/windows/enterprise/products/mdop/.