Skip to main content

Internet Explorer 8 Blocker Toolkit

To help our users be more secure and up-to-date, Microsoft will distribute Windows Internet Explorer 8 as a high-priority update through Automatic Updates for Windows XP with Service Pack 2 (SP2), Windows XP with Service Pack 3 (SP3), Windows XP Professional x64 Edition, Windows Server 2003 with Service Pack 2 (SP2) for x64 and x86, Windows Vista for x64 and x86, Windows Vista with Service Pack 1 (SP1) for x64 and x86, and Windows Server 2008 for x64 and x86. Delivery of Internet Explorer 8 through Automatic Updates will begin after Internet Explorer 8 is made available from the Microsoft Download Center.

Note: Users can always decline to install Internet Explorer 8 through Automatic Updates when it is offered.

More information for IT professionals about Internet Explorer 8 delivery through Automatic Updates is available at http://technet.microsoft.com/en-us/updatemanagement/dd365125.aspx.

Microsoft realizes that in a corporate environment, IT organizations may want to delay the introduction of a new Web browser until they have tested compatibility with internal applications and sites. Microsoft has put a lot of work into Internet Explorer 8 to maintain compatibility with sites designed for Internet Explorer 7. However, we know many IT organizations will still want to test Internet Explorer 8 before it is deployed. To help prevent users from installing Internet Explorer 8 through Automatic Update before compatibility testing has been completed, Microsoft is providing the Internet Explorer 8 Blocker Toolkit. This toolkit has no expiration date and can be configured either by running the registry file on the client machines or through Group Policy in domain joined environments. The Blocker Toolkit is available today.

Supported Operating Systems

Windows Server 2003 SP2; Windows Server 2003 SP2 x64 Edition; Windows Server 2008; Windows Vista; Windows Vista 64-bit Editions SP1; Windows Vista Business 64-bit edition; Windows Vista Enterprise 64-bit edition; Windows Vista Home Basic 64-bit edition; Windows Vista Home Premium 64-bit edition; Windows Vista SP1; Windows Vista Ultimate 64-bit edition; Windows XP Professional x64 Edition; Windows XP SP2, and Windows XP SP3.

Note: You must have one of the supported operating systems installed to use this toolkit.

Using the Blocker Toolkit

If you previously used the Internet Explorer 7 Blocker Toolkit to block Internet Explorer 7 from being offered as a high-priority update, you will need to run the Internet Explorer 8 version of the Blocker Toolkit to block Internet Explorer 8 from being offered through Automatic Updates. There are different registry keys used to block or unblock automatic delivery of Internet Explorer 7 and Internet Explorer 8. If you configure the Internet Explorer 8 Blocker Toolkit setting to prevent users from installing Internet Explorer 8 through Windows Update or Automatic Updates, Internet Explorer 8 will not appear in the list of available high-priority or important updates. We believe this approach strikes a good balance by helping customers become more secure and letting organizations control when they are ready to deploy Internet Explorer 8 to their users.

Note: The Internet Explorer 8 Blocker Toolkit will not block the final version of Internet Explorer 8 being offered to users who already have pre-released versions of Internet Explorer 8 installed on their machine. Also, the Internet Explorer 8 Blocker Toolkit will not prevent users from manually installing Internet Explorer 8 from the Microsoft Download Center.

Organizations that use an update management solution such as Windows Server Update Services or Systems Management Server 2003 do not need to deploy the Blocker Toolkit. Windows Server Update Services and Systems Management Server 2003 allow organizations to fully manage deployment of updates released through Windows Update and Microsoft Update, including Internet Explorer 8.