Export (0) Print
Expand All
Expand Minimize

Outlook Web Access requires hotfix for Windows Server 2003 SP1

[This topic is intended to address a specific issue called out by the Exchange Server Analyzer Tool. You should apply it only to systems that have had the Exchange Server Analyzer Tool run against them and are experiencing that specific issue. The Exchange Server Analyzer Tool, available as a free download, remotely collects configuration data from each server in the topology and automatically analyzes the data. The resulting report details important configuration issues, potential problems, and nondefault product settings. By following these recommendations, you can achieve better performance, scalability, reliability, and uptime. For more information about the tool or to download the latest versions, see "Microsoft Exchange Analyzers" at http://go.microsoft.com/fwlink/?linkid=34707.]  

Topic Last Modified: 2006-08-28

The Microsoft® Exchange Server Analyzer Tool queries various Microsoft Windows® Management Instrumentation (WMI) classes to collect the following information:

  • Which version of the Microsoft Windows Server operating system is Exchange Server installed on?

  • Is the Exchange server running on a cluster?

If the Exchange Server Analyzer determines that the following conditions are true, the Exchange Server Analyzer displays a warning:

  • Exchange Server 2003 Service Pack 1 (SP1) is installed.

  • Microsoft Windows Server™ 2003 SP1 is not installed.

  • Cluster service is running.

  • The Version value of Davex.dll is less than 6.5.7232.

If you are running this configuration, you must download and install an Exchange Server hotfix before you install Windows Server 2003 SP1. If you do not install the Exchange Server hotfix, Microsoft Office Outlook® Web Access for Exchange Server 2003 users will not be able to log on to their mailboxes. Users who have mailboxes that are hosted on the clusters will receive the following error message when they try to connect by using Outlook Web Access:

  • "500 - Internal Server Errors"

This error is caused by some of the security enhancements that are included with Windows Server 2003 SP1.

When a user tries to log on to a mailbox by using Outlook Web Access, HTTP submits requests to the clustering API by impersonating the logged-on user. However, there have been security changes in Windows Server 2003 SP1. The security restrictions for the APIs that perform remote registry access have been changed. Therefore, the logon attempt is not successful.

To fix this error, you must download and install the Exchange Server hotfix that is described in the Microsoft Knowledge Base article 841561, "'500 - Internal server error' error message when a user tries to access a clustered Exchange Server 2003 back-end server by using Outlook Web Access" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561).

 
Was this page helpful?
(1500 characters remaining)
Thank you for your feedback

Community Additions

ADD
Show:
© 2014 Microsoft