Export (0) Print
Expand All

Communicator Web Access Server Requirements

[This is preliminary documentation and is subject to change. Blank topics are included as placeholders.]

The infrastructure, hardware, and software that are required to install the 2007 R2 version of Communicator Web Access server are described in this topic.

The network in which the Communicator Web Access server will reside must include a Domain Name System (DNS) server and a public key infrastructure (PKI).

The server where you will install Communicator Web Access must be a member server in the same Active Directory forest as an Office Communications Server 2007 R2 server.

Note:
Installing Communicator Web Access on a workgroup computer is not supported and will cause an error during setup.

The root certification authority (CA) chain is trusted by the server, and a certificate from the trusted root CA is located in the trusted root CA store of the server. For details about how the certificate should be configured, see Preparing Certificates for Communicator Web Access.

The minimum hardware requirements for the Communicator Web Access server are as follows:

  • Processor
    • PC with dual Quad-Core 2.0 gigahertz (GHz) or higher processor
    • PC with 4-way Dual-Core 2.0 GHz or higher processor
  • Memory
    • 8 gigabyte (GB) double data rate (DDR) RAM
  • Disks
    • 2 x 72 GB 15K or 10K RPM disk drives, RAID 0 (striped) or equivalent
  • Network card
    • 2 x gigabit (1 gigabit per second) Ethernet network adapter

The following software must be installed on the computer on which you will be installing Communicator Web Access:

  • Windows Server 2003 Standard or Enterprise Edition with Service Pack 2 (64-bit edition), Windows Server 2003 Standard or Enterprise Edition R2 SP2 (64-bit edition), or Windows Server 2008 Standard or Enterprise Edition (64-bit edition)
  • Windows Installer 3 (included in Windows Server 2003 R2 SP2 or later)
  • .NET Framework 3.5, including ASP.NET 2.0
    Note:
    ASP.NET is automatically registered with IIS if the .NET Framework is installed after IIS is installed. If you install the .NET Framework first, you must manually register ASP.NET. For details, see http://go.microsoft.com/fwlink/?LinkId=125678.
  • IIS 6.0 or IIS 7.0 running in IIS 6.0 compatibility mode
    If you use IIS 7.0 with Communicator Web Access, you must enable the following IIS 7.0 features:

    Table 1.   Common HTTP features

    Feature NameEnabled by default?

    Static Content

    Yes

    Default Document

    Yes

    Directory Browsing

    Yes

    HTTP Errors

    Yes

    HTTP Redirection

    Yes

    Table 2.   Application development features

    Feature NameEnabled by default?

    ASP.NET

    No

    .NET Extensibility

    Yes

    Internet Server API (ISAPI) Extensions

    No

    ISAPI Filters

    No

    Table 3.   Health and diagnostics features

    Feature NameEnabled by default?

    HTTP Logging

    Yes

    Logging Tools

    Yes

    Request Monitor

    Yes

    Tracing

    Yes

    Table 4.   Security features

    Feature NameEnabled by default?

    Basic Authentication

    No

    Windows Authentication

    No

    Request Filtering

    Yes

    Table 5.   Performance features

    Feature NameEnabled by default?

    Static Content Compression

    Yes

    Table 6.   Management tools

    Feature NameEnabled by default?

    IIS Management Console

    Yes

    IIS Management Scripts and Tools

    No

    IIS 6.0 Management Compatibility

    No

    IIS Metabase Compatibility

    No

    IIS 6 Windows Management Instrumentation (WMI) Compatibility

    No

    Table 7.   Windows Process Activation Service features

    Feature NameEnabled by default?

    Process Model

    Yes

    .NET Environment

    No

In addition, the following hotfix and security updates must be installed:

Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft