Export (0) Print
Expand All
Expand Minimize

FrontPage 2002 Server Extensions Requirements

Archived content. No warranty is made as to technical accuracy. Content may contain URLs that were valid when originally published, but now link to sites or pages that no longer exist.

Before you install Microsoft FrontPage 2002 Server Extensions on your Web server, make sure that you have installed the required hardware and software.

Windows hardware requirements

Hardware requirements vary depending on the operating system you use. The following table describes the hardware requirements for Microsoft Windows operating systems.

Operating system

Requirements

Recommendations for ISPs

Microsoft Windows Server 2003, Standard or Enterprise Edition

Same as standard Windows Server 2003 installation requirements

Same as standard Windows Server 2003 installation requirements

Microsoft Windows NT Server 4.0 with Service Pack 6a

166 MHz Intel Pentium processor

128 MB RAM

13 MB free hard-disk space

1 GHz or higher Intel Pentium III

1 GB RAM

13 MB free hard-disk space

Microsoft Windows 2000 Server

P6-200 MHz Intel Pentium processor

128 MB RAM

13 MB free hard-disk space

1 GHz or higher Intel Pentium III

1 GB RAM

13 MB free hard-disk space

Note   On the Microsoft Windows platform, the security features of FrontPage 2002 Server Extensions require the NTFS file system. Microsoft Windows NT includes a conversion utility (Convert.exe) that you can use to convert an existing file allocation table (FAT) volume to NTFS — without losing data.

Windows software requirements

To run FrontPage 2002 Server Extensions, you must first install the following software on your server:

  • Microsoft Windows Server 2003, Standard Edition or Enterprise Edition, configured as a Web Application Server

    – or –

    Microsoft Windows 2000 Server edition with Microsoft Internet Information Services (IIS) 5.0 or later with the World Wide Web service installed

    – or –

    Microsoft Windows NT Server 4.0 with Service Pack 6a or later and Microsoft Internet Information Server (IIS) 4.0 or later with the World Wide Web service installed

  • Microsoft Internet Explorer 4.0 or later

    – or –

    Netscape Navigator version 4 or later

UNIX requirements

Several software platforms are supported for FrontPage 2002 Server Extensions on UNIX, described in the following table.

Platform

Operating System

Alpha

Digital UNIX 4.0.f, 5.0

Intel x86

BSDI 3.3, 4.0
FreeBSD 3.3, 4.0
Linux 6.2 and 7.0 (Red Hat Software)

Solaris 2.7, 2.8

PA-RISC

HP/UX 10.2, 11.0

RS6000, PowerPC

AIX 4.3, 4.3.3

Silicon Graphics

IRIX 6.3, 6.5

SPARC

Solaris 2.7, 2.8

For any of the platforms in this table, you must have between 30 and 70 MB of hard-disk space available for your installation of FrontPage Server Extensions 2002, plus enough hard-disk space to host the Web sites and subwebs your users will create. These requirements are guidelines only, and may vary depending on the platform and operating system.

To run FrontPage 2002 Server Extensions on UNIX, you must first install the following software on your server:

  • Apache Web Server 1.3.19

Client requirements

Any Windows, Macintosh, or UNIX client can use FrontPage 2002 Server Extensions features, providing the client runs the following software:

  • Microsoft Internet Explorer 4.0 or later, or Netscape Navigator 4 or later

  • Microsoft Office XP (required if the user contributes to a Web site, but not necessary for browsing) or Microsoft FrontPage 2002

Users can also contribute to a Web site by using Office 2000 or FrontPage 2000, but a richer editing environment is available when they use Office XP or FrontPage 2002 with FrontPage 2002 Server Extensions.

Cc767980.spacer(en-us,TechNet.10).gif

Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft