Export (0) Print
Expand All

Application Virtualization Sequencer Hardware and Software Requirements

Updated: November 21, 2012

Applies To: Application Virtualization

This topic describes the minimum recommended hardware and software requirements for the computer running the Microsoft Application Virtualization (App-V) Sequencer.

ImportantImportant
You must run the App-V sequencer (SFTSequencer.exe) using an account that has administrator privileges because of the changes the sequencer makes to the local system. These changes can include writing files to the C:\Program Files directory, making registry changes, starting and stopping services, updating security descriptors for files, and changing permissions.

Before you install the Sequencer and after you sequence each application, you must restore a clean operating system image to the sequencing computer. You can use one of the following methods to restore the computer running the Sequencer:

  • Reformat the hard drive and reinstall the operating system.

  • Restore the hard drive on the computer running the Sequencer image by using another disk-imaging software.

  • Revert a virtual operating system image such as a Microsoft Virtual PC image. Using a virtual machine allows for clean sequencing environments to be easily reused with minimal administration.

The following list outlines the recommended hardware requirements for running the App-V Sequencer.

The requirements are listed first for Microsoft Application Virtualization (App-V) 4.6 SP2, followed by the requirements for versions that preceded App-V 4.6 SP2.

Hardware Requirements

  • Processor—Intel Pentium III, 1 GHz (32-bit or 64-bit). The sequencing process is a single-threaded process and does not take advantage of dual processors.

  • Memory—1 GB or above, 2 GB recommended.

  • Hard disk—40 gigabyte (GB) hard disk space with a minimum of 15 GB available hard disk space. We recommend that you have at least three times the hard disk space that the application you are sequencing requires.

    noteNote
    Sequencing requires heavy disk usage. A fast disk speed can decrease the sequencing time.

Software Requirements for App-V 4.6 SP2

The following list outlines the supported operating systems for running the App-V 4.6 SP2 Sequencer.

 

Operating System Edition Service Pack System Architecture

Windows XP

Professional

SP3

x86

Windows Vista

Business, Enterprise, or Ultimate

SP2

x86

Windows 7

Professional, Enterprise, or Ultimate

No service pack or SP1

x86 and x64

Windows 8

Professional or Enterprise Edition

x86 and x64

noteNote
The Application Virtualization (App-V) 4.6 SP2 Sequencer supports 32-bit and 64-bit versions of these operating systems.

You should configure computers running the Sequencer with the same applications that are installed on targeted computers.

Software Requirements for Versions that Precede App-V 4.6 SP2

The following list outlines the supported operating systems for running the Sequencer for versions that precede App-V 4.6 SP2.

 

Operating System Edition Service Pack System Architecture

Windows XP

Professional

SP2 or SP3

x86

Windows Vista

Business, Enterprise, or Ultimate

No service pack, SP1, or SP2

x86

Windows 71

Professional, Enterprise, or Ultimate

x86

1Supported for App-V 4.5 with SP1 or SP2, and App-V 4.6 only

noteNote
The Application Virtualization (App-V) 4.6 Sequencer supports 32-bit and 64-bit versions of these operating systems.

You should configure computers running the Sequencer with the same applications that are installed on targeted computers.

Software Requirements for Remote Desktop Services for App-V 4.6 SP2

 

Operating System Edition Service Pack System Architecture

Windows Server 2003 R2

Standard Edition, Enterprise Edition, or Datacenter Edition

SP2

x86

Windows Server 2008

Standard, Enterprise, or Datacenter Edition

SP2

x86

Windows Server 2008 R2

Standard, Enterprise, or Datacenter Edition

No service pack or SP1

x64

Windows Server 2012

Standard, Enterprise, or Datacenter Edition

x86 or x64

noteNote
Application Virtualization (App-V) 4.6 SP2 for Remote Desktop Services supports 32-bit and 64-bit versions of these operating systems.

Software Requirements for Remote Desktop Services for Versions that Precede App-V 4.6 SP2

 

Operating System Edition Service Pack System Architecture

Windows Server 2003

Standard Edition, Enterprise Edition, or Datacenter Edition

SP1 or SP2

x86

Windows Server 2003 R2

Standard Edition, Enterprise Edition, or Datacenter Edition

No service pack or SP2

x86

Windows Server 2008

Standard, Enterprise, or Datacenter Edition

SP1 or SP2

x86

Windows Server 2008 R2

Standard, Enterprise, or Datacenter Edition

No service pack or SP1

x64

noteNote
Application Virtualization (App-V) 4.6 SP2 for Remote Desktop Services supports 32-bit and 64-bit versions of these operating systems.

See Also

-----
You can learn more about MDOP in the TechNet Library, search for troubleshooting on the TechNet Wiki, or follow us on Facebook or Twitter.
-----
Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft