Export (0) Print
Expand All
This topic has not yet been rated - Rate this topic

Commerce Server 2007 Migration

Commerce Server 2009

Migrating from Microsoft Commerce Server 2000, Microsoft Commerce Server 2002, or Microsoft Commerce Server 2002 Feature Pack 1 (FP1) to Commerce Server 2007 can be divided into three tasks: planning for migration, data migration, and site code migration.

For information about migrating from Commerce Server 2007 to Commerce Server 2009, see Commerce Server 2009 Migration.

Planning for migration involves learning which resources can be upgraded and which have been removed, knowing what data will be modified, and learning about the tools that are available to help you.

In Commerce Server 2009, data migration is performed by the Commerce Server 2007 Upgrade Wizard.

Dd451135.alert_caution(en-US,CS.90).gifImportant Note:

Before you run the Upgrade Wizard on a Commerce Server 2000 site, you must run the Data Warehouse migration tool to migrate the Data Warehouse resource. For information about using the Data Warehouse migration tool, see Data Warehouse Migration Tool.

This topic explains the data that the Upgrade Wizard modifies so that you know what changes are occurring and why.

When you want to do site code migration, you must rewrite side code for existing ASP-based sites.

Dd451135.alert_note(en-US,CS.90).gifNote:

For an example of how to migrate from an application on Microsoft Commerce Server 2002 that is running the Commerce Server 2002 Starter Site to Microsoft Commerce Server 2007, see Commerce Server 2002 Starter Site Migration Example

This section includes a system-by-system comparison of the COM objects that are used in your existing site and their Microsoft .NET Framework counterpart. For frequently asked questions about the COM and the Commerce Server 2007 Class Library, see Planning Commerce Server 2007 Migration. Be aware that ASP.NET-based sites may require API changes because of a change in namespaces. Additional changes may also be required based on the resources that your site uses.

The following table lists the platform requirements for versions of Commerce Server:

Commerce Server 2009

Commerce Server 2007

Commerce Server 2002 on Windows Server 2003

Commerce Server 2002 on Windows 2000

Windows Server 2003 or Windows Server 2008

Windows Server 2003 or Windows Server 2008

Windows Server 2003

Windows 2000 Server

Microsoft SQL Server 2005 or 2008

Microsoft SQL Server 2000 or 2005

Microsoft SQL Server 2000 or SQL Server Enterprise Edition

Microsoft SQL Server 2000 or SQL Server Enterprise Edition

Microsoft Visual Studio 2008 with SP1

Microsoft Visual Studio 2005

Microsoft Visual Studio .NET 2003 (optional)

Microsoft Visual Studio .NET 2003 (optional)

Microsoft .NET Framework 3.5

Microsoft .NET Framework 2.0

Microsoft .NET Framework 1.0 Service Pack 2

Microsoft .NET Framework 1.0 Service Pack 2

Commerce Server 2002 customers must have Commerce Server Service Pack 3 (SP3) or Commerce Server FP1 installed before migrating to Commerce Server 2007.

For more information about how to migrate from Microsoft Windows 2000 to Windows Server 2003, see http://go.microsoft.com/fwlink/?LinkId=46865. For information about how to update to Windows Server 2008, see http://go.microsoft.com/fwlink/?LinkId=115171.

Did you find this helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft. All rights reserved.