Export (0) Print
Expand All

Requirements and Limitations

Updated: November 13, 2009

Applies To: Windows 7, Windows Server 2003, Windows Server 2003 R2, Windows Server 2008, Windows Server 2008 R2, Windows Vista, Windows XP

In order to install Web Deploy, the following requirements must be met:

  • You must be using Windows XP, Windows Server 2003, Windows Vista®, Windows Server® 2008, Windows® 7, or Windows Server® 2008 R2. If you are using Windows® 8 Release Preview or Windows Server® 2012, you must be using version 3.0 or later of Web Deploy.

  • In order to perform operations that use IIS, such as synchronizing a Web site, the appropriate version of IIS must be installed.

  • You must install the tool as an administrator. If User Access Control (UAC) is enabled, you must use the Run as Administrator option when you perform the installation.

  • The .NET Framework version 2.0 Service Pack 1 or later must be installed. You can download the .NET Framework 2.0 SP1 from the following locations:

     

noteNote
When you perform synchronization from IIS 6.0 to IIS 7, you do not have to install the IIS 6.0 Management Compatibility feature on the destination IIS 7 Web server. Metabase compatibility is managed internally by Web Deploy.

  • The files for script maps and the Web Service Extension Restriction List will not be synchronized if the files are not located in a Web site's content directories.

  • Web Deploy will synchronize Web site content and configuration, but it will not synchronize IIS features and installed components. Each component must be installed separately on the target Web server. For example, ASP.NET or Windows authentication must be installed separately on the target Web server. The dependencies list that is returned will indicate which components must be installed.

CautionCaution
Using Web Deploy to synchronize Web content or configuration from a later version of IIS or Windows to an earlier version of IIS or Windows is not recommended. For example, you should not synchronize from IIS 7 to IIS 6.0, or synchronize Web content and configuration from Windows Server® 2008 R2 to Windows Server® 2008. Similarly, you should not synchronize from an operating system that has a service pack to the same operating system that has an earlier service pack or that has no service pack. Differences in schema files can render the results of such synchronizations unusable.

Was this page helpful?
(1500 characters remaining)
Thank you for your feedback

Community Additions

ADD
Show:
© 2014 Microsoft