Export (0) Print
Expand All

Microsoft .NET Framework 3.5 SP1 Requirements

Communications Server 2007 R2

Topic Last Modified: 2010-01-05

Microsoft .NET Framework version 3.5 with Service Pack 1 (SP1) is required for Office Communications Server 2007 R2. If you install Office Communications Server by using the deployment tool wizard, the wizard prompts you to install this prerequisite and automatically installs Microsoft .NET Framework 3.5 SP1 if it is not already installed on the computer. If you choose not to install Microsoft .NET Framework 3.5 SP1, Office Communications Server will not operate correctly.

Dd572521.note(en-us,office.13).gifNote:
If you install Office Communications Server by using the command line, you need to manually install Microsoft .NET Framework 3.5 SP1 on the server where you plan to install Office Communications Server. For details, see the Office Communications Server 2007 R2 Command-Line Reference at http://go.microsoft.com/fwlink/?linkid=161867.

If you are running a supported 64-bit operating system, you must install the 64-bit .NET Framework.

Dd572521.note(en-us,office.13).gifNote:
The .NET Framework 3.5 SP1 installation includes .NET Framework 2.0, .NET Framework 3.0, and .NET Framework 3.5 installations. During the installation of .NET Framework 3.5 SP1, Windows Server 2008 adds its .NET Framework 3.0 Features component as a substitute for the default .NET Framework 3.0 installation. The Windows Server 2008 .NET Framework 3.0 Features component is required for all Office Communications Server 2007 R2 services and applications to function properly on Windows Server 2008.
Was this page helpful?
(1500 characters remaining)
Thank you for your feedback

Community Additions

ADD
Show:
© 2014 Microsoft