Export (0) Print
Expand All

Web Site Clouds troubleshooting

Updated: September 3, 2014

Applies To: Windows Azure Pack for Windows Server

This topic describes troubleshooting issues that pertain to Web site Clouds in Windows Azure Pack for Windows Server. Recommendations are provided for the following issues:

Pertains to: Deploy Windows Azure Pack: Web Sites

Issue

A proxy server needs to be bypassed for various reasons.

Recommendation

Use the netsch command, as shown in the following examples where PROXYSERVERNAME is the name of the server to be bypassed:

netsh winhttp set proxy proxy-server="http=PROXYSERVERNAME;https= PROXYSERVERNAME:88" bypass-list="*.contoso.com"
netsh winhttp set proxy proxy-server="http=PROXYSERVERNAME;https= PROXYSERVERNAME:88" bypass-list="wapserver01"
netsh winhttp set proxy proxy-server="http=PROXYSERVERNAME;https= PROXYSERVERNAME:88" bypass-list="wapadmsrv;wapadmapi;waptenantsrv;wapadmauth"

Back to top

Pertains to: Deploy Windows Azure Pack: Web Sites

Issue

Need a Windows PowerShell script to facilitate the initialization of web sites.

Recommendation

You can use the following example as the basis for your script.

Function  WebSiteCloudInit{
# PowerShell script to configure Web Site Clouds
Import-Module -Name MgmtSvcConfig
Import-Module -Name Websites

$settings = @{}
# Hosting and ResourceMetering database connection strings.
$settings.Add('hosting','Data Source='+$env:computername+';Initial Catalog=Hosting;User ID=sa;Password=$setup.lab.sql.password');
$settings.Add('resourceMetering','Data Source='+$env:computername+';Initial Catalog=ResourceMetering;User ID=sa;Password=$setup.lab.sql.password');

$settings.Add('dnsSuffix','HostedWebSiteCloud.com');

# Optional WebPI feed
# $settings.Add('feedUrl','http://cn-host/WebSiteCloudSetup/Content/webproductlist.xml');

# Admin credentials 
$settings.Add('adminUserName','Administrator');
$settings.Add('adminPassword',$setup.lab.servers.global.password);

# ManagementServer role settings (REST API)
$settings.Add('managementServerName','WAPSitesMN01');
$settings.Add('cloudAdminUserName','CloudAdmin');
$settings.Add('cloudAdminPassword',$setup.lab.servers.global.password);

# Optional credentials; admin credentials used if any are not specified.
$settings.Add('managementServerAdminUserName','Administrator');
$settings.Add('managementServerAdminPassword',$setup.lab.servers.global.password);
$settings.Add('fileServerAdminUserName','Administrator');
$settings.Add('fileServerAdminPassword',$setup.lab.servers.global.password);
$settings.Add('frontEndAdminUserName','Administrator');
$settings.Add('frontEndAdminPassword',$setup.lab.servers.global.password);
$settings.Add('publisherAdminUserName','Administrator');
$settings.Add('publisherAdminPassword',$setup.lab.servers.global.password);
$settings.Add('workerAdminUserName','Administrator');
$settings.Add('workerAdminPassword',$setup.lab.servers.global.password);

# FileServer role settings (WebSites and Certificates shares)
$settings.Add('fileServerName','WAPSitesFS01');
$settings.Add('fileServerType','WindowsSingle');
$settings.Add('fileShareOwnerUserName','fileShareOwner');
$settings.Add('fileShareOwnerPassword',$setup.lab.servers.global.password);
$settings.Add('fileShareUserUserName','fileShareUser');
$settings.Add('fileShareUserPassword',$setup.lab.servers.global.password);     

$settings.Add('centralCertStoreUserName','CertStore_FSUser');
$settings.Add('centralCertStorePassword',$setup.lab.servers.global.password);
$settings.Add('contentShareUNCPath','\\WAPSitesFS01\WebSites');
$settings.Add('contentShareLocalPath','C:\WebSites');
$settings.Add('certificateShareUNCPath','\\WAPSitesFS01\Certificates');
$settings.Add('certificateShareLocalPath','C:\Certificates');
#$settings.Add('skipManagementServerProvisioning', 'False');
#$settings.Add('isVMMBased','False');

Initialize-WebSitesInstance -Settings $settings -Verbose
#Initialize-MgmtSvcFeature -Name HostingController -Settings $settings -Verbose
 }

Back to top

Pertains to: Deploy Windows Azure Pack: Web Sites

Issue

A web worker role for a web site cloud is continuously installing as seen on the dashboard in the management portal for administrators.

Recommendation

On each web worker server, remove the following rule from the autoload.config configuration file located in the %PROGRAM FILES%\IIS\Microsoft Web Hosting Framework\config\ directory.

<rule name="Antares-Abort-Local-Requests" patternSyntax="Wildcard">
    <match url="*" />
    <conditions>
        <add input="{LocalAddresses:{REMOTE_ADDR}}" pattern="1" />
    </conditions>
    <action type="AbortRequest" />
</rule>

Back to top

Pertains to: Deploy Windows Azure Pack: Web Sites

Issue

The web site gallery feed does not populate items for users to access.

Recommendation

Check for the following possible causes:

  • Enable debug logs in the Event Viewer located under Applications and Service Logs > Microsoft > Windows Azure Pack > MgmntSvc-WebAppGallery. In IIS, ensure that the Application Pool for the web site has the credentials to use any proxy servers. 

  • Visit this forum for possible solutions: Web Site Clouds - Web app gallery is empty

You can also consider host your own application gallery as described by Offline a web application gallery feed in this topic.

Back to top

Pertains to: Deploy Windows Azure Pack: Web Sites

Issue

Need to host a copy of a gallery feed internally within an infrastructure that has a firewall.

Recommendation

You can offline a WAG feed and host it locally using the Web Platform Installer command line tool (WebPICmd.exe). For details, see the blog post Offlining Web Application Gallery Feed for Windows Azure Pack

Back to top

Pertains to: Deploy Windows Azure Pack: Web Sites

Issue

Attempts to add a worker role to the existing website cloud returns connection errors.

Recommendation

Make sure that the Internet Protocol version 6 (IPv6) is enabled on all worker role computers.

Back to top

Pertains to: Deploy Windows Azure Pack: Web Sites

Issue

Get errors when attempting to use a pre-configured file server for a web site.

Recommendation

This was fixed for Update 1 and is available in Windows Update. For more information, see Update 1 for Windows Azure Pack.

Back to top

Pertains to: WebMatrix 3

Issue

If a tenant attempts to use the WebMatrix extensions using a Chrome browser, the portal displays the following error messages:

  • An extension required to perform this operation could not be installed.

  • Installs can only be initiated by one of the Chrome Web Store item's verified sites.

Recommendation

We regretfully recommend avoiding this scenario because support for the WebMatrix plugin is not supported by Chrome.

Back to top

See Also

 
Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft