Export (0) Print
Expand All
This topic has not yet been rated - Rate this topic

Administrative Tools Software Requirements

 

Topic Last Modified: 2012-10-16

This topic describes the software required to install and use Microsoft Lync Server 2010 administrative tools in addition to the operating system requirements.

The 64-bit edition of Microsoft .NET Framework 3.5 with SP1 is required for Microsoft Lync Server 2010. Setup prompts you to install this prerequisite and it automatically installs it if it is not already installed on the computer. .NET Framework 4.0 can be installed on the same computer as well, but does not take the place of .NET Framework 3.5 with SP1, which is the required version for Lync Server 2010.

After installing the .NET Framework 3.5 SP1 package, you should immediately install the following updates:

Microsoft Lync Server 2010 uses Windows Installer technology to install, uninstall, and maintain various server roles. Windows Installer version 4.5 is available as a redistributable component for the Windows Server operating system.

Download Windows Installer 4.5 from the Microsoft Download Center at http://go.microsoft.com/fwlink/p/?linkid=197395.

Windows PowerShell 2.0 command-line interface is automatically installed with the Windows Server 2008 R2 operating system and the Windows 7 operating system. On servers running the Windows Server 2008 SP2 operating system or Windows Vista operating system with Service Pack 2 (SP2), you must install Windows PowerShell 2.0 manually. Before doing so, you must remove any previous versions of Windows PowerShell from the computer.

To install Windows PowerShell 2.0, see the Microsoft Knowledge Base article 968929, "Windows Management Framework (Windows PowerShell 2.0, WinRM 2.0, and BITS 4.0)," at http://go.microsoft.com/fwlink/p/?linkid=3052&kbid=968929.

Microsoft Lync Server 2010 Control Panel is a web-based tool and requires that you install Microsoft Silverlight 4 browser plug-in version 4.0.50524.0 or the latest version. When you start Lync Server 2010 Control Panel, if this software is not installed or if an earlier version earlier than 4.0.50524.0 is installed, Lync Server Control Panel prompts you to install the required version.

 
Did you find this helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft. All rights reserved.