Export (0) Print
Expand All

Technical Requirements for Group Chat Server

 

Topic Last Modified: 2012-10-14

Each computer that will host Microsoft Lync Server 2010, Group Chat must have access to an existing Microsoft Lync Server 2010 topology with the following components:

  • Microsoft Lync Server 2010, Front End Server. The Lync Server 2010, Front End Server enables communication between Microsoft Lync Server 2010, Group Chat Admin Tool and the Lync Server 2010, Group Chat components. Before you begin to deploy Group Chat Server, verify the deployment of Microsoft Lync Server 2010, Standard Edition or a Lync Server Front End pool and also of other internal computers running Lync Server 2010, as appropriate to your organization.

  • At least one global catalog server in the forest root. All other Active Directory Domain Services (AD DS) infrastructure requirements are the same as for Lync Server.

  • Microsoft Lync Server 2010, Edge Servers. Lync Server 2010, Edge Servers are required to enable communication with federated partners and other users who are not on the internal network. If your organization wants internal users to be able to include users outside the internal network in group chat sessions, verify that the appropriate Edge Servers are deployed in the perimeter network. At a minimum, this includes deploying the following services:

    • Lync Server Access Edge service

    • Lync Server Web Conferencing Edge service

The following sections describe the specific requirements for the Group Chat Server and the database that stores the Microsoft Lync 2010 Group Chat data.

For details about the recommended hardware for deploying Lync Server and the latest version of Group Chat Server, see Server Hardware Platforms in the Supportability documentation.

For details about the server and tools operating system support for Lync Server and Group Chat Server, see Server and Tools Operating System Support in the Supportability documentation.

For details about additional software required for deploying Lync Server 2010, Group Chat, see the following table.

Group Chat Server Software Prerequisites

Software Description

Microsoft .NET Framework 3.0

Manages the operation of the program. During the installation of Group Chat Server, if this version or a later version of the software is not already installed on the computer, Group Chat Server installs it.

Internet Information Services (IIS)

Hosts the Web service for posting files to chat rooms. Windows Server 2008 users must enable the IIS 6.0 Compatibility feature.

ASP.NET 2.0

Used to build dynamic websites, web applications, and XML web services. ASP.NET 2.0 is a web application.

Message Queuing

Used by the Group Chat Server Compliance service, if deployed.

Microsoft Web Services Enhancements (WSE) 3.0

Implements additional Web-service specifications in areas including security, reliable messaging, and sending attachments. WSE is required on the Group Chat Server only, not on the computer hosting the Compliance service. WSE is an add-on to the .NET Framework.

When the .NET Framework is installed on a computer with an existing .NET Framework installation, most Microsoft ASP.NET applications update to use the newly installed version. The exception is an application bound to a version of the .NET Framework that is either an incompatible version or a later version. If it cannot successfully run on a later version, configure the ASP.NET application to use an earlier version.

Lync 2010 Group Chat also requires two components that are automatically installed when you install Lync Server 2010, Group Chat, if they are not already installed on the user’s computer. The following describes these components.

Required Software That Is Automatically Installed

Component Description

Visual C ++ 2008 Redistributable Runtime version 9.0.2102

Contains the libraries required to run applications developed with the Microsoft Visual C++ development system on a computer that does not have Visual C++ 2008 installed. During the installation of Group Chat Server, if this version or a later version of the software is not already installed on the computer, Group Chat Server installs it.

Microsoft Unified Communications Managed API (UCMA) v2.0 Redist 3.5.6774.0

Used in creating SIP clients and SIP servers. During the installation of Group Chat Server, if this version or a later version of the software is not already installed on the computer, Group Chat Server installs it.

Lync Server 2010, Group Chat uses the Group Chat database to store chat history, configuration, user provisioning data and, optionally, compliance data. You can also use a separate compliance database to support compliance. To prepare a database server platform, ensure that each computer meets the hardware requirements, and then install the prerequisite software.

The server platform for the Group Chat database servers requires the same hardware as the Lync Server back-end database server. For details, see Server Hardware Platforms in the Supportability documentation.

On the database server, ensure that the following software is installed:

 
Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft