Export (0) Print
Expand All

Server and Tools Operating System Support

 

Topic Last Modified: 2011-08-17

All server roles support the same Windows Server operating systems. The required operating system support for other server roles, such as database servers, depends on what software you install on those servers.

Microsoft Lync Server 2010 communications software administrative tools are installed by default on the server running Lync Server 2010, but you can install administrative tools separately on other computers running Windows operating systems. For example, you can use a client computer running Windows 7 as an administrative console for planning purposes.

importantImportant:
Lync Server 2010 is available only in 64-bit, which requires 64-bit hardware and 64-bit editions of Windows Server. Lync Server 2010 is not available in a 32-bit version. This means that all server roles and computers running Lync Server administrative tools run a 64-bit edition operating system.

Microsoft Lync Server 2010 supports the 64-bit editions of the following operating systems:

  • The Windows Server 2008 R2 Standard operating system (required) or latest service pack (recommended)
  • The Windows Server 2008 R2 Enterprise operating system (required) or latest service pack (recommended)
  • The Windows Server 2008 R2 Datacenter operating system (required) or latest service pack (recommended)
  • The Windows Server 2008 Standard operating system with Service Pack 2 (SP2) (required) or latest service pack (recommended)
  • The Windows Server 2008 Enterprise operating system with SP2 (required) or latest service pack (recommended)
  • The Windows Server 2008 Datacenter operating system with SP2 (required) or latest service pack (recommended)
noteNote:
  • If you have an existing server running Windows Server 2008 with Service Pack 1 (SP1), you must upgrade it to either Windows Server 2008 SP2 (or latest service pack), or Windows Server 2008 R2 (or latest service pack) before deploying Lync Server 2010.
  • To deploy Lync Server 2010 on a computer that is running either the Windows Server 2008 R2 Datacenter operating system or the Windows Server 2008 Datacenter operating system with Service Pack 2 (SP2) and that is configured for multiple processor groups (dynamic hardware partitioning), you must upgrade Microsoft SQL Server 2008 Express database software, which is installed by default when you install Lync Server 2010, to Microsoft SQL Server 2008 R2 Express. The SQL instance name is RTC for a Standard Edition server back-end database and RTCLocal for the local configuration store (on each server role). A server running Lync Server 2010 Standard Edition has both SQL instances, and each needs to be upgraded separately.

Lync Server 2010 is not supported on the following operating systems:

  • The Server Core installation option of Windows Server 2008 R2 or Windows Server 2008
  • The Windows Web Server 2008 R2 operating system or the Windows Web Server 2008 operating system
  • Windows Server 2008 R2 HPC Edition or Windows Server 2008 HPC Edition

Operating system support for servers other than those on which you deploy Lync Server 2010 server roles is dependent on the software you plan to install on those servers. For details about requirements for Back End Servers and other database servers, see Database Software and Clustering Support. For details about requirements for reverse proxy servers (for edge deployment), see Internet Information Services (IIS) Support. For details about other software requirements, including infrastructure and virtualization support, see the other topics in the Server Software and Infrastructure Support section.

Lync Server 2010 supports installation of the administrative tools, which includes the Topology Builder, on computers running any of the 64-bit editions of the operating systems supported for deployment of server roles (as described in the previous section). Additionally, you can install administrative tools on the 64-bit editions of the following operating systems:

  • The Windows 7 operating system (required) or latest service pack (recommended)
  • The Windows Vista operating system with SP2 (required) or latest service pack (recommended)

Lync Server 2010 supports installation of the Planning Tool on computers running any of the following operating systems:

  • The 32-bit version of Windows 7 operating system (required) or latest service pack (recommended)
  • The 64-bit version of Windows 7 operating system (required) or latest service pack (recommended) using the WOW64 x86 emulator
  • The 32-bit edition of Windows Vista with SP2 operating system (required) or latest service pack (recommended)
  • The 64-bit edition of Windows Vista with SP2 operating system (required) or latest service pack (recommended) using the WOW64 x86 emulator
  • The 32-bit edition of Windows XP with SP3 operating system (required) or latest service pack (recommended)
  • The 64-bit edition of Windows XP with SP3 operating system (required) or latest service pack (recommended) using WOW64 x86
  • The 32-bit edition of Windows Server 2008 operating system (required) or latest service pack (recommended)
  • The 64-bit edition of Windows Server 2008 operating system (required) or latest service pack (recommended) using WOW64 x86
  • The 64-bit edition of Windows Server 2008 R2 operating system (required) or latest service pack (recommended) using WOW64 x86
 
Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft