Export (0) Print
Expand All

Planning for Migrating from a Previous Version of App-V

Updated: August 13, 2014

Applies To: Application Virtualization 5.0

Use the following information to plan how to migrate to App-V 5.0 from previous versions of App-V.

Migration requirements

Before you start any upgrades, review the following requirements:

  • If you are upgrading from a version earlier than 4.6 SP2, upgrade to version 4.6 SP2 first before upgrading to App-V 5.0 or later. In this scenario, upgrade the App-V clients first, and then upgrade the server components.

  • App-V 5.0 supports only packages that are created using App-V 5.0, or packages that have been converted to the App-V 5.0 (.appv) format.

Running the App-V 5.0 client concurrently with App-V 4.6 SP2

You can run the App-V 5.0 client concurrently on the same computer with the App-V 4.6 SP2 version of the client.

You can:

  • Convert an App-V 4.6 SP2 package to the App-V 5.0 format and publish both packages, when you have both clients running.

  • Define the migration policy for the converted package, which will allow the converted App-V 5.0 package to assume the file type associations and shortcuts from the App-V 4.6 SP2 package.

ImportantImportant
App-V 5.0 can coexist only on computers that run App-V 4.6 SP2. The migration is supported only when App-V 4.6 SP2 is installed, and you must apply App-V 4.6 SP2 before you install App-V 5.0.

For more information about how to configure App-V 5.0 client coexistence, see How to Install the App-V 4.6 SP2 Client and the App-V 5.0 Client on the Same Computer.

Converting “previous-version” packages using the package converter

Before migrating a package, created using App- 4.6 SP2 or earlier, to App-V 5.0, review the following requirements:

  • You must convert the package to the .appv file format.

  • The Package Converter supports only the direct conversion of packages that were created by using App-V 4.5 and later. To use the package converter on a package that was created using a previous version, you must use an App-V 4.5 or later version of the sequencer to upgrade the package, and then you can perform the package conversion.

For more information about using the package converter to convert a package, see How to Convert a Package Created in a Previous Version of App-V. After you convert the file, you can deploy it to target computers that run the App-V 5.0 client.

See Also

Other Resources

Planning to Deploy App-V

-----
You can learn more about MDOP in the TechNet Library, search for troubleshooting on the TechNet Wiki, or follow us on Facebook or Twitter.
-----
Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft