Export (0) Print
Expand All
This topic has not yet been rated - Rate this topic

Installing Prerequisite Software

Before installing Microsoft SQL Server Compact 3.5 components, you must install the following software on your desktop computer. These steps also apply to SQL Server Compact 3.5 Service Pack 1 (SP1).

The following is the list of prerequisite software:

  • Microsoft Windows 2000 SP4 or later, Microsoft Windows XP Professional SP1 or later, or Microsoft Windows Server 2003 should be the operating system for the development computer and the computer that is running IIS if data exchange with SQL Server is planned.
    If you install Windows XP SP2, to use SQL Server Compact connectivity, you will have to enable HTTP access. The default setting is to disable HTTP access. To enable HTTP access, do the following:
    1. Open Control Panel.
    2. Click the Windows Firewall icon.
    3. Click Advanced.
    4. Click Settings in the Network Connection Settings area.
    5. Select the Web Server (HTTP) check box.
    6. Click OK to confirm the change.
      ms171869.note(en-us,SQL.100).gifNote:
      For more information about how to configure the Windows Firewall, see Microsoft Knowledge Base Article 875356.

  • Microsoft .NET Framework 2.0 or a later version is required on the computer that is running IIS. The .NET Framework is installed with Microsoft Visual Studio 2008 and with SQL Server 2008. To download .NET Framework 2.0 from the Microsoft Web site, see .NET Framework 2.0 Download Center.
  • Microsoft ActiveSync 4.0 or a later version is required in the development, together with the server environment. ActiveSync is available as a free download at ActiveSync Download.

Unless you are using the OLEDB data provider, the Microsoft .NET Framework 2.0 or a later version is required to install SQL Server Compact 3.5. You can download the .NET Framework 2.0 from the .NET Framework 2.0 Download Center.

The following software is not required to install SQL Server Compact 3.5 on desktop computers because the SQL Server Compact 3.5 installer for desktop computers has runtime binary files only:

  • Internet Information Services (IIS)
  • ActiveSync
  • Internet Explorer 6
  • Neither Visual Studio nor SQL Server are required to install SQL Server Compact 3.5
Did you find this helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft. All rights reserved.