Bulletin de sécurité Microsoft MS11-069 - Modéré

Une vulnérabilité dans .NET Framework pourrait permettre la divulgation d'informations (2567951)

Paru le: | Mis(e) à jour:

Version: 1.2

Informations générales

Synthèse

Cette mise à jour de sécurité corrige une vulnérabilité signalée confidentiellement dans Microsoft .NET Framework. Cette vulnérabilité pourrait permettre la divulgation d'informations si un utilisateur affichait une page Web spécialement conçue à l'aide d'un navigateur Web pouvant exécuter des applications du navigateur XAML (XBAP). Dans le cas d'une attaque Web, l'attaquant devrait héberger un site Web qui contiendrait une page Web spécialement conçue pour exploiter cette vulnérabilité. En outre, les sites Web compromis et les sites Web qui acceptent ou hébergent des contenus ou des annonces provenant d'utilisateurs pourraient contenir un contenu malveillant susceptible d'exploiter cette vulnérabilité. Cependant, l'attaquant n'aurait aucun moyen de forcer l'utilisateur à visiter ces sites Web. Il devrait y attirer l'utilisateur, généralement en l'incitant à cliquer sur un lien dans un message électronique ou un message instantané qui mène à son site. Cette vulnérabilité pourrait également être utilisée par les applications Windows .NET pour contourner les restrictions de sécurité d'accès du code (CAS).

Cette mise à jour de sécurité est de niveau « modéré » pour Microsoft .NET Framework 2.0 Service Pack 2, Microsoft .NET Framework 3.5.1 et Microsoft .NET Framework 4 sur toutes les éditions en cours de support de Microsoft Windows. Pour plus d'informations, consultez la sous-section « Logiciels concernés et non concernés » plus loin dans ce Bulletin.

Cette mise à jour de sécurité corrige la vulnérabilité en modifiant la façon dont .NET Framework valide le niveau de confiance dans l'espace de noms System.Net.Sockets. Pour obtenir plus d'informations sur la vulnérabilité, consultez la sous-section « Forum aux questions » spécifique à chaque vulnérabilité, dans la section « Informations par vulnérabilité ».

Recommandation. La majorité de nos clients chez lesquels les mises à jour automatiques sont activées n'auront pas besoin d'entreprendre de nouvelle action car cette mise à jour de sécurité sera téléchargée et installée automatiquement. Nos clients chez lesquels les mises à jour automatiques ne sont pas activées doivent rechercher les mises à jour et les installer manuellement. Pour plus d'informations sur les options de configuration spécifiques des mises à jour automatiques, consultez l'Article 294871 de la Base de connaissances Microsoft.

Pour les administrateurs et les installations d'entreprise ou pour les utilisateurs souhaitant installer cette mise à jour de sécurité manuellement, Microsoft recommande d'envisager d'appliquer cette mise à jour de sécurité à l'aide d'un logiciel de gestion des mises à jour ou en recherchant les mises à jour à l'aide du service Microsoft Update.

Consultez également la section « Outils de détection, de déploiement et Conseils » dans ce même Bulletin.

Problèmes connus : L'Article 2567951 de la Base de connaissances Microsoft décrit les problèmes connus auxquels les clients peuvent être confrontés lors de l'installation de cette mise à jour de sécurité. Cet article documente également les solutions palliatives recommandées.

Logiciels concernés et non concernés

Microsoft a testé les logiciels suivants afin de déterminer quelles versions ou éditions sont concernées. Toute autre version ou édition a soit atteint la fin de son cycle de vie ou bien n'est pas affectée. Consultez le site Web Politique de Support Microsoft afin de connaître la politique de support Microsoft pour votre version ou édition.

Logiciels concernés

Système d'exploitationComposantImpact de sécurité maximalIndice de gravité cumuléeBulletins remplacés par cette mise à jour
Windows XP
Windows XP Service Pack 3Microsoft .NET Framework 2.0 Service Pack 2
(KB2539631)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows XP Professionnel Édition x64 Service Pack 2Microsoft .NET Framework 2.0 Service Pack 2
(KB2539631)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2003
Windows Server 2003 Service Pack 2Microsoft .NET Framework 2.0 Service Pack 2
(KB2539631)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2003 Édition x64 Service Pack 2Microsoft .NET Framework 2.0 Service Pack 2
(KB2539631)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2003 avec SP2 pour systèmes ItaniumMicrosoft .NET Framework 2.0 Service Pack 2
(KB2539631)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Vista
Windows Vista Service Pack 2Microsoft .NET Framework 2.0 Service Pack 2
(KB2539633)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Vista Édition x64 Service Pack 2Microsoft .NET Framework 2.0 Service Pack 2
(KB2539633)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2008
Windows Server 2008 pour systèmes 32 bits Service Pack 2Microsoft .NET Framework 2.0 Service Pack 2**
(KB2539633)

Microsoft .NET Framework 4**[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2008 pour systèmes x64 Service Pack 2Microsoft .NET Framework 2.0 Service Pack 2**
(KB2539633)

Microsoft .NET Framework 4**[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2008 pour systèmes Itanium Service Pack 2Microsoft .NET Framework 2.0 Service Pack 2
(KB2539633)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows 7
Windows 7 pour systèmes 32 bitsMicrosoft .NET Framework 3.5.1
(KB2539634)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows 7 pour systèmes 32 bits Service Pack 1Microsoft .NET Framework 3.5.1
(KB2539635)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows 7 pour systèmes x64Microsoft .NET Framework 3.5.1
(KB2539634)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows 7 pour systèmes x64 Service Pack 1Microsoft .NET Framework 3.5.1
(KB2539635)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2008 R2
Windows Server 2008 R2 pour systèmes x64Microsoft .NET Framework 3.5.1*
(KB2539634)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2008 R2 pour systèmes x64 Service Pack 1Microsoft .NET Framework 3.5.1*
(KB2539635)

Microsoft .NET Framework 4*[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2008 R2 pour systèmes ItaniumMicrosoft .NET Framework 3.5.1
(KB2539634)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039
Windows Server 2008 R2 pour systèmes Itanium Service Pack 1Microsoft .NET Framework 3.5.1
(KB2539635)

Microsoft .NET Framework 4[1]
(KB2539636)
Divulgation d'informationsModéréMS11-039

*Installation Server Core concernée. Cette mise à jour s'applique, avec le même indice de gravité, aux éditions en cours de support de Windows Server 2008 R2 telles qu'indiquées, qu'elles aient été installées ou non à l'aide de l'option d'installation Server Core. Pour plus d'informations sur cette option d'installation, consultez les articles TechNet consacrés à la gestion d'une installation Server Core (en anglais) et à l'entretien d'une installation Server Core (en anglais). Sachez que l'option d'installation Server Core ne s'applique pas à certaines éditions de Windows Server 2008 et Windows Server 2008 R2. Reportez-vous à la page Option d'installation Server Core.

**Installation Server Core non concernée. Les vulnérabilités corrigées par cette mise à jour ne concernent pas les éditions en cours de support de Windows Server 2008 ou Windows Server 2008 R2 lorsqu'elles ont été installées à l'aide de l'option d'installation Server Core. Pour plus d'informations sur cette option d'installation, consultez les articles TechNet consacrés à la gestion d'une installation Server Core (en anglais) et à l'entretien d'une installation Server Core (en anglais). Sachez que l'option d'installation Server Core ne s'applique pas à certaines éditions de Windows Server 2008 et Windows Server 2008 R2. Reportez-vous à la page Option d'installation Server Core.

[1].NET Framework 4 et .NET Framework 4 Client Profile sont affectés. Les packages .NET Framework version 4 redistribuables sont disponibles en deux profils : .NET Framework 4 et .NET Framework 4 Client Profile. .NET Framework 4 Client Profile est un sous-ensemble de .NET Framework 4. La vulnérabilité corrigée dans cette mise à jour affecte .NET Framework 4 et .NET Framework 4 Client Profile. Pour plus d'informations, consultez l'article MSDN « Installation du .NET Framework ».

Logiciels non concernés

Système d'exploitation
Microsoft .NET Framework 1.1 Service Pack 1
Microsoft .NET Framework 3.5 Service Pack 1

Forum aux questions concernant cette mise à jour de sécurité

Informations par vulnérabilité

Indices de gravité et identificateurs de vulnérabilité

Vulnérabilité liée au contournement de restriction de socket - CVE-2011-1978

Informations concernant la mise à jour

Outils de détection, de déploiement et Conseils

Déploiement de la mise à jour de sécurité

Autres informations

Remerciements

Microsoft remercie les organismes ci-dessous pour avoir contribué à la protection de ses clients :

  • Michael J. Liu pour avoir signalé la vulnérabilité liée au contournement de restriction de socket (CVE-2011-1978).

Microsoft Active Protections Program (MAPP)

Pour améliorer la protection de ses clients, Microsoft fournit des informations sur les vulnérabilités aux principaux fournisseurs de logiciels de sécurité avant chaque mise à jour de sécurité mensuelle. Les fournisseurs de logiciels de sécurité peuvent ainsi utiliser ces informations pour fournir des protections mises à jour à leurs clients via leurs logiciels ou périphériques de sécurité, tels que les antivirus et les systèmes de détection ou de prévention d'intrusion basés sur le réseau ou sur les hôtes. Pour déterminer si des protections actives sont disponibles, visitez les sites Web des partenaires fournisseurs de logiciels de sécurité, répertoriés sur la page Microsoft Active Protections Program (MAPP) Partners.

Support technique

  • En cas de problème, contactez les services de support sécurité Microsoft. Les appels au Support technique concernant les mises à jour de sécurité ne sont pas facturés par Microsoft. Pour plus d'informations sur les options de support disponibles, consultez le site Web Aide et de support Microsoft.
  • Nos clients internationaux peuvent joindre le Support technique de leur filiale Microsoft locale. Le support technique ayant trait aux mises à jour de sécurité n'est pas facturé par Microsoft. Pour savoir comment contacter le Support Microsoft, consultez le site Web Support international.

Dédit de responsabilité

Les informations contenues dans la Base de connaissances Microsoft sont fournies « en l'état », sans garantie d'aucune sorte. Microsoft exclut toute garantie, expresse ou implicite, notamment toute garantie de qualité et d'adéquation à un usage particulier. En aucun cas la société Microsoft ou ses fournisseurs ne pourront être tenus pour responsables de quelque dommage que ce soit, y compris toute perte de bénéfices directe, indirecte ou accessoire, ou de dommages spéciaux, même si la société Microsoft a été prévenue de l'éventualité de tels dommages. Certains pays n'autorisent pas l'exclusion ou la limitation de responsabilité pour les dommages indirects ou accessoires, de sorte que la restriction mentionnée ci-dessus peut ne pas vous concerner.

Révisions

  • V1.0 (9 août 2011) : Bulletin publié.
  • V1.1 (23 août 2011) : Ajout d'une entrée au Forum aux questions pour annoncer une modification de la logique de détection pour KB2539636 afin de corriger un problème d'installation. Cette modification ne concerne que la logique de détection. Il n'y a aucune modification concernant les fichiers de la mise à jour de sécurité. Nos clients ayant déjà mis à jour leur système n'ont pas besoin d'entreprendre de nouvelle action.
  • V1.2 (26 octobre 2011) : Correction des informations relatives à l'installation Server Core pour .NET Framework 4 sur Windows Server 2008 R2 pour systèmes x64.