Microsoft Dynamics CRM 2011 E-mail Router software requirements

Applies to: Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online

This section applies to Microsoft Dynamics CRM Online and on-premises versions of Microsoft Dynamics CRM 2011. It lists the software and application software requirements for Microsoft Dynamics CRM 2011 E-mail Router.

Microsoft Dynamics CRM E-mail Router Setup consists of two main components: the E-mail Router and the Rule Deployment Wizard. The E-mail Router component installs the E-mail Router service and E-mail Router Configuration Manager. You use the E-mail Router Configuration Manager to configure the E-mail Router. The Rule Deployment Wizard component deploys the rules that enables received e-mail messages to be tracked.

ImportantImportant
Unless specified otherwise, within the Microsoft Dynamics CRM 2011 Support Lifecyle policy, Microsoft Dynamics CRM applications support the latest version and service pack (SP) for all required components, such as Windows Server, SQL Server, Microsoft Office, Internet Explorer, and Exchange Server. However, to fully support the latest version of a required component you should apply the latest update for Microsoft Dynamics CRM.

You can install the E-mail Router and Rule Deployment Wizard on any computer that is running one of the following operating systems, and that has network access to both Microsoft Dynamics CRM and the e-mail server:

  • Windows 7 32-bit and 64-bit editions

  • Windows Server 2008 (x64 versions) or Windows Server 2008 R2

  • Windows Server 2012 (see requirements below)

ImportantImportant
  • Installing on Windows Server 2012. To install Microsoft Dynamics CRM 2011 E-mail Router on Windows Server 2012 you must:

  • Running Microsoft Dynamics CRM E-mail Router and E-mail Router Configuration Manager (32-bit) is not supported on a Windows Server 64-bit operating system, in Windows-On-Windows (WOW) mode. Install and run the 64-bit version of the Microsoft Dynamics CRM E-mail Router.

Rule Deployment Wizard Requires MAPI
The Rule Deployment Wizard requires the Microsoft Exchange Server Messaging API (MAPI) client runtime libraries. To install the MAPI client runtime libraries, see Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1.

ImportantImportant
Installing and running the Rule Deployment Wizard on a computer that has Microsoft Office Outlook installed is not supported. Both applications use a different version of MAPI that are incompatible.

noteNote
MAPI versions 6.5.8147 (or later) are supported by Microsoft Exchange Server 2010.

If you already have a version of the MAPI download installed, you must uninstall it before installing the new version.

If you are installing the Rule Deployment Wizard on a system that uses Microsoft Exchange Server 2010 as its e-mail server, you must also have installed Update Rollup 2 (or later) of Microsoft Exchange Server 2010. For more information, see Update Rollup 2 for Exchange Server 2010 (KB979611).

In This Topic

Exchange Server

Microsoft Exchange Server is only required if you want to use the E-mail Router to connect to an Exchange Server e-mail messaging system. To do this, you can install the E-mail Router on any of the supported Windows or Windows Server operating systems that have a connection to the Exchange Server. The E-mail Router supports the following versions of Exchange Server:

  • Exchange 2003 Standard Edition SP2 or SP3

  • Exchange 2003 Enterprise Edition SP2 or SP3

  • Exchange Server 2007 Standard Edition

  • Exchange Server 2007 Enterprise Edition

  • Microsoft Exchange Server 2010 Standard Edition

  • Microsoft Exchange Server 2010 Enterprise Edition

  • Microsoft Exchange Online

ImportantImportant
Microsoft Exchange 2000 Server editions are not supported when using these versions of Microsoft Dynamics CRM E-mail Router and Rule Deployment Wizard.

If missing, Microsoft Dynamics CRM E-mail Router Setup installs the Microsoft .NET Framework 4 on the computer where you install the E-mail Router.

The Rule Deployment Wizard component must be installed on a computer that is running any of the supported Windows or Windows Server operating systems and that has the MAPI client runtime libraries installed.

Download the MAPI client runtime libraries from the Microsoft Download Center.

Messaging and transport protocols

Microsoft Dynamics CRM E-mail Router supports a variety of e-mail messaging and transport options.

POP3
POP3-compliant e-mail systems are supported for incoming e-mail message routing.

ImportantImportant
When you use the Forward Mailbox option on the User form, the POP3 e-mail server must provide support where an e-mail message can be sent as an attachment to another e-mail message.

If you configure the Microsoft Dynamics CRM E-mail Router to connect to a POP3-compliant e-mail server, the server must support RFC 1939.

Transport protocols
Both SMTP and Exchange Online with Exchange Web Services (EWS) are messaging transport protocols that are supported for outgoing e-mail message routing.

If you configure the Microsoft Dynamics CRM E-mail Router to use an SMTP-compliant transport service, the server must support RFC 2821 and RFC 2822.

Exchange Online

Microsoft Exchange Online is a hosted enterprise messaging service from Microsoft. It provides the robust capabilities of Microsoft Exchange Server as a cloud-based service. To learn more, see Exchange Online.

Additional E-mail Router software requirements

If the following components are missing, they will be installed by Microsoft Dynamics CRM E-mail Router Setup:

  • Microsoft .NET Framework 4

  • Microsoft Visual C++ Redistributable

  • Microsoft Application Error Reporting

  • Windows Identity Framework (WIF)

  • Windows Live ID Sign-in Assistant 6.5

  • Microsoft Online Services Sign-in Assistant (Required for Microsoft Dynamics CRM Online when you subscribe through Microsoft Office 365.)

See Also

Send comments about this article to Microsoft.

© 2013 Microsoft Corporation. All rights reserved.

Community Additions

ADD
Show: