Upgrading to Message Queuing 5.0

Updated: June 25, 2007

Applies To: Windows Server 2008, Windows Vista

Message Queuing 4.0, running on a Windows Server 2008 computer will automatically be updated to Message Queuing 5.0 during the upgrade to a Windows Server 2008 R2 system.

Message Queuing 4.0, running on a Windows Vista computer will automatically be updated to Message Queuing 5.0 during the upgrade to a Windows 7 system.

Message Queuing 3.0, running on a Windows Server 2003 computer will automatically be updated to Message Queuing 5.0 during the upgrade to a Windows Server 2008 R2 system. Likewise, Message Queuing 3.0 running on a Windows XP computer will automatically be updated to Message Queuing 5.0 during the upgrade to a Windows 7 system. Since MSMQ 1.0 and MSMQ 2.0 run on versions of Windows earlier than Windows Server 2003 and Windows XP, and because Windows Server 2008 R2 and Windows 7 do not support upgrading from versions of Windows earlier than Windows Server 2003 or Windows XP, upgrading from versions of Message Queuing earlier than 3.0 to Message Queuing 5.0 is not supported.

Any message queues that exist on the computers to be upgraded should be emptied to minimize the possibility of message loss in the event that that an unexpected problem occurs during the upgrade process.

Community Additions

ADD
Show: