Windows PowerShell Requirements for System Center 2012 R2

 

Updated: September 29, 2016

Applies To: System Center 2012 R2

Use this information to evaluate if your Windows PowerShell environment is ready to support the installation of or upgrade to System Center 2012 R2. Use this information here whether you are deploying one or multiple components.

System Center ComponentWindows PowerShell 2.0Windows PowerShell 3.0Windows PowerShell 4.0Windows PowerShell 5.0
App Controller Windows Server
App Controller Windows PowerShell Module
DPM Central Console
DPM Remote Administration console
DPM Server
Operations Manager Management Server
Operations Manager Data Warehouse Server
Operations Manager Gateway Server
Operations Manager Windows Agent
Service Manager Console
Service Manager Management Server
Service Manager Data Warehouse Management Server
Service Provider Foundation API Web Server
Virtual Machine Manager Management Server
Virtual Machine Manager Console

This information does not apply to System Center 2012 Configuration Manager. For those system requirements, see Supported Configurations for Configuration Manager.

System Requirements for System Center 2012 R2
Preparing your environment for System Center 2012 R2 App Controller
Preparing your environment for System Center 2012 R2 Data Protection Manager (DPM)
Preparing your environment for System Center 2012 R2 Operations Manager
Preparing your environment for System Center 2012 R2 Orchestrator
Preparing your environment for System Center 2012 R2 Service Manager
Preparing your environment for System Center 2012 R2 Service Provider Foundation
Preparing your environment for System Center 2012 R2 Virtual Machine Manager

Show: