System Requirements: VMM Console in System Center 2012 and in System Center 2012 SP1

 

Updated: May 13, 2016

Applies To: System Center 2012 SP1 - Virtual Machine Manager, System Center 2012 - Virtual Machine Manager

The following requirements are the minimum and recommended hardware requirements for the System Center 2012 – Virtual Machine Manager (VMM) console, based on the number of hosts that you manage.

Managing up to 150 hosts

Hardware componentMinimum
ProcessorPentium 4, 1 gigahertz (GHz) or greater
RAM2 gigabytes (GB)
Hard disk space2 GB

Managing more than 150 hosts

Hardware componentMinimum
ProcessorPentium 4, dual processor, 2 GHz or greater
RAM4 GB
Hard disk space4 GB

You must install the following software before you install the VMM console.

SoftwareNotes
A supported operating system for the VMM consoleFor more information, see Supported operating systems in this topic.
Windows PowerShell:

- For System Center 2012 – Virtual Machine Manager: Windows PowerShell 2.0
- For VMM in System Center 2012 SP1: Windows PowerShell 3.0
- Windows PowerShell 2.0 is included in the Windows Server 2008 R2 and Windows 7 operating systems.
- Windows PowerShell 3.0 is included in Windows Server 2012. Otherwise, you can install Windows PowerShell 3.0 from Installing Windows PowerShell.
Microsoft .NET Framework:

- For System Center 2012 – Virtual Machine Manager: Microsoft .NET Framework 3.5 Service Pack 1
- For VMM in System Center 2012 SP1: Microsoft .NET Framework 4 or Microsoft .NET Framework 4.5
- On a computer that runs Windows 7, Microsoft .NET Framework 3.5.1 is installed by default.
- On a computer that runs Windows Server 2008 R2, if Microsoft .NET Framework 3.5.1 is not installed (it is not installed by default), the VMM setup wizard will install it.
- On a computer that runs Windows 8 or Windows Server 2012, Microsoft .NET Framework 4 is included.
- Microsoft .NET Framework 4.5 is available at the Visual Studio Downloads page.
Operating system for System Center 2012 – Virtual Machine ManagerEditionSystem architecture
Windows Server 2008 R2 Service Pack 1 or earlier (full installation)Standard, Enterprise, and Datacenterx64
Windows 7 Service Pack 1 or earlierProfessional, Enterprise, and Ultimatex86 and x64
Operating system for VMM in System Center 2012 SP1EditionSystem architecture
Windows Server 2008 R2 Service Pack 1 (full installation)Standard, Enterprise, and Datacenterx64
Windows 7 with Service Pack 1Professional, Enterprise, and Ultimatex86 and x64
Windows Server 2012Standard and Datacenter64-bit
Windows 8Professional and Enterprise32-bit and 64-bit
Show: