Export (0) Print
Expand All

Microsoft Security Bulletin MS05-029 - Important

Vulnerability in Outlook Web Access for Exchange Server 5.5 Could Allow Cross-Site Scripting Attacks (895179)

Published: June 14, 2005 | Updated: July 06, 2005

Version: 1.1

Summary

Who should read this document: System administrators who have servers that are running Outlook Web Access for Microsoft Exchange Server 5.5

Impact of Vulnerability: Remote Code Execution

Maximum Severity Rating: Important

Recommendation: Customers should apply the update at the earliest opportunity

Security Update Replacement: None

Caveats: None

Version Requirements for Dependent Components for This Update:
For this update to be installed successfully, the Microsoft Outlook Web Access server must have one of the following installed:

  • Internet Explorer 5.01 Service Pack 3 installed when using Windows 2000 Service Pack 3
  • Internet Explorer 5.01 Service Pack 4 installed when using Windows 2000 Service Pack 4
  • Internet Explorer 6 Service Pack 1 installed when using other supported operating systems

Version Recommendations for Dependent Components on the Outlook Web Access Server:
The following versions are recommended for dependent components on the Outlook Web Access server:

  • Microsoft Internet Information Services (IIS):
    • IIS 5.0 on Windows 2000 Service Pack 3 or later
  • Microsoft Internet Explorer:
    • Internet Explorer 6.0 Service Pack 1

Tested Software and Security Update Download Locations:

Affected Software:

Non-Affected Software:

  • Microsoft Exchange 2000 Server Service Pack 3 with the Exchange 2000 Post-Service Pack 3 Update Rollup of August 2004.
  • Microsoft Exchange Server 2003
  • Microsoft Exchange Server 2003 Service Pack 1

For more information about Exchange 2000 Server Post-Service Pack 3 Update Rollup see Microsoft Knowledge Base Article 870540.

The software in this list has been tested to determine whether the versions are affected. Other versions either no longer include security update support or may not be affected. To determine the support life cycle for your product and version, visit the Microsoft Support Lifecycle Web site.

General Information

Executive Summary:

This update resolves a newly-discovered, privately-reported vulnerability. A cross-site scripting and spoofing vulnerability exists in Outlook Web Access for Exchange Server 5.5 that could allow an attacker to convince a user to run a malicious script. The vulnerability is documented in the “Vulnerability Details” section of this bulletin.

An attacker who successfully exploited the vulnerability could perform cross-site scripting attacks.

We recommend customers should apply the update at the earliest opportunity.

Severity Ratings and Vulnerability Identifiers:

Vulnerability IdentifiersImpact of VulnerabilityExchange Server 5.5
Exchange Server Outlook Web Access Vulnerability - CAN-2005-0563Remote Code ExecutionImportant

This assessment is based on the types of systems that are affected by the vulnerability, their typical deployment patterns, and the effect that exploiting the vulnerability would have on them.

I am still using Exchange 2000 Service Pack 3. What should I do?
It should be a priority for customers who have this version to migrate to supported versions to prevent potential exposure to vulnerabilities. The Microsoft Exchange 2000 Server Post-Service Pack 3 (SP3) Update Rollup released on August 2004 is a prerequisite for support on Exchange 2000. The build number is 6603.1. This Update Rollup is a prerequisite for all Exchange 2000 Server updates that are released after June 29, 2004 and that have a build number that is greater than 6603. For more information about the Exchange Service Pack Product Lifecycle, visit the Microsoft Support Lifecycle Web site. For more information about the Exchange Product Lifecycle, visit the Microsoft Support Lifecycle Web site

Microsoft Exchange Server 5.5 Service Pack 4 is on Windows NT 4.0 which has reached the end of its life cycle. What should I do?
Windows NT Server 4.0 Service Pack 6a has reached the end of its life cycle. Exchange Server 5.5 Service Pack 4 customers should make sure that they are using Windows 2000 Server. If you are still using Windows NT Server 4.0 you should upgrade as soon as possible.

For more information, see the Windows Operating System Product Support Lifecycle FAQ.

Can I use the Microsoft Baseline Security Analyzer (MBSA) to determine whether this update is required?

Note Outlook Web Access for Exchange 5.5 can be installed on an Exchange server or as a standalone IIS application that links to an installation of Exchange on a different server.

MBSA will determine whether this update is required for an Exchange 5.5 server with Outlook Web Access installed. For more information about MBSA, visit the MBSA Web site.

MBSA does not support Outlook Web Access when running on a standalone Internet Information Server (IIS) and will not detect whether the update is required in this case. However, Microsoft has developed a version of the Enterprise Update Scanning Tool (EST) that will help customers determine if the security update is required in this case.

Can I use Systems Management Server (SMS) to determine whether this update is required?
Yes. SMS can help detect and deploy this security update. For information about SMS, visit the SMS Web site. The Security Update Inventory Tool is required for detecting Microsoft Windows and other affected Microsoft products. For more information about the limitations of the Security Update Inventory Tool, see Microsoft Knowledge Base Article 306460

For more information about SMS, visit the SMS Web site.

You can deploy this update by using the Inventory and Software Distribution feature of SMS.

Exchange Server Outlook Web Access Vulnerability - CAN-2005-0563:

This is a cross-site scripting vulnerability. The cross-site scripting vulnerability could allow an attacker to convince a user to run a malicious script. If this malicious script is run, it would execute in the security context of the user. Attempts to exploit this vulnerability require user interaction. This vulnerability could allow an attacker access to any data on the Outlook Web Access server that was accessible to the individual user.

Mitigating Factors for Exchange Server Outlook Web Access Vulnerability - CAN-2005-0563:

  • To be affected, the user would have to be logged onto Outlook Web Access (OWA).
  • The following supported versions of Outlook Web Access for Exchange Server are not affected
    • Outlook Web Access for Exchange 2000 Server Exchange 2000 Post-Service Pack 3 Update Rollup of August 2004.
    • Outlook Web Access for Exchange Server 2003
    • Outlook Web Access for Exchange Server 2003 Service Pack 1

Workarounds for Exchange Server Outlook Web Access Vulnerability - CAN-2005-0563:

Microsoft has tested the following workarounds. While these workarounds will not correct the underlying vulnerability, they help block known attack vectors. When a workaround reduces functionality, it is identified in the following section.

Modify the Read.asp file

To modify the Read.asp file, follow these steps.

Note Administrators can modify the Read.asp file.

Note These steps must be performed on each Outlook Web Access server.

  1. Open the Read.asp file in Notepad. This file is located in the following folder:

    C:\Exchsrvr\Webdata\<lang>\Forms\Ipm\Note

  2. Locate the following line of code:

    <%= bstrBody %>&nbsp;

  3. Save the file.
  4. Change that line of code to the following:

    <%= Server.HTMLEncode(bstrBody) %>&nbsp;

Changes will take effect immediately.

Impact of workaround:

E-mail that is formatted in HTML will not display correctly. Users will see the raw HTML behind the e-mail.

Disable Outlook Web Access for each Exchange site

To disable Outlook Web Access follow these steps.

Note These steps must be performed on each Exchange site.

1. Start Exchange Administrator.

2. Expand the Configuration container for the site.

3. Select the Protocols container for the site.

4. Open the properties of the HTTP (Web) Site Settings object.

5. Clear the "Enable Protocol" checkbox.

6. Wait for the change to replicate, and then verify the change has replicated to each server in the site. To do this, bind to each server in the site by using Exchange Administrator, and then view the “Enabled Protocol” check box setting.

Impact of Workaround: Users will have no access to their mailboxes through Outlook Web Access.

Uninstall Outlook Web Access.

For information about how to uninstall Outlook Web Access, see Microsoft Knowledge Base Article 290287.

Impact of Workaround: Users will have no access to their mailboxes through Outlook Web Access.

For more information about how to help make your Exchange environment more secure, visit the Security Resources for Exchange 5.5 Web site.

FAQ for Exchange Server Outlook Web Access Vulnerability - CAN-2005-0563:

What is the scope of the vulnerability?
This is a cross-site scripting vulnerability that could allow an attacker to convince a user to run a malicious script. If this malicious script is run, it would execute in the security context of the user. Attempts to exploit this vulnerability require user interaction.

The script could take any action on the user's computer that the Web site is authorized to take; this could include monitoring the Web session and forwarding information to a third party, running other code on the user's system and reading or writing cookies.

What is Outlook Web Access?
Microsoft Outlook Web Access (OWA) is a service of Exchange Server. By using OWA, a server that is running Exchange Server can also function as a Web site that lets authorized users read and send mail, manage their calendar, and perform other mail functions over the Internet.

What causes the vulnerability?
A cross-site scripting (XSS) vulnerability is caused by the way that Outlook Web Access (OWA) performs HTML encoding in the Compose New Message form.

What is cross-site scripting?
Cross-site scripting (XSS) is a security vulnerability that could enable an attacker to "inject" code into a user's session with a Web site. Unlike most security vulnerabilities, XSS does not apply to any single vendor's products - instead, it can affect any software that generates HTML and that does not follow defensive programming practices.

How does cross-site scripting work?
Web pages contain text and HTML markup. Text and HTML markup are generated by the server and are interpreted by the client. Servers that generate static pages have full control over the way that the client interprets the pages that the server sends. However, servers that generate dynamic pages do not have control over the way that the client interprets the servers’ output. If untrusted content is introduced into a dynamic page, neither the server nor the client has sufficient information to recognize that this action has occurred and to take protective measures.

How could an attacker exploit the vulnerability?
An attacker could try to exploit this vulnerability by sending a specially crafted message to a user. The user would then have to open the message by using Outlook Web Access. The message could then cause the affected system to run script in the context of the user’s Outlook Web Access session.

What systems are primarily at risk from the vulnerability?
Client systems accessing an Exchange Server 5.5 through Outlook Web Access are primarily at risk from this vulnerability.

Are all supported versions of Outlook Web Access vulnerable?
No. The vulnerability affects only Outlook Web Access for Exchange Server 5.5.

On which Exchange servers should I install the update?
This update is intended only for servers that are running Outlook Web Access for Exchange Server 5.5. You do not have to install this update on servers that are not running Outlook Web Access for Exchange Server 5.5. However, we recommend that you install this security update on all other servers running Exchange 5.5 servers to help protect them if they are later designated as Outlook Web Access servers.

What does the update do?
The update removes the vulnerability by making sure that OWA script arguments are encoded so that they cannot be unintentionally executed.

When this security bulletin was issued, had this vulnerability been publicly disclosed?
No. Microsoft received information about this vulnerability through responsible disclosure. Microsoft had not received any information to indicate that this vulnerability had been publicly disclosed when this security bulletin was originally issued.

When this security bulletin was issued, had Microsoft received any reports that this vulnerability was being exploited?
No. Microsoft had not received any information to indicate that this vulnerability had been publicly used to attack customers and had not seen any examples of proof of concept code published when this security bulletin was originally issued.

Affected Software:

For information about the specific security update for your affected software, click the appropriate link:

Exchange Server 5.5 Service Pack 4

Prerequisites
This security update requires Outlook Web Access on Exchange Server 5.5 Service Pack 4.

Inclusion in Future Service Packs:
The update for this issue will be included in a future Service Pack or Update Rollup

Installation Information

For more information about the command options that you can use to apply this update, see Microsoft Knowledge Base Article 257946.

Deployment Information

To install the security update without any user intervention, use the following command at a command prompt for Exchange Server 5.5 Service Pack 4:

  • Exchange5.5-KB895179.EXE /s

Restart Requirement

This update does not require a restart. However, Microsoft Internet Information Services (IIS), the Exchange Store, and the Exchange System Attendant Services will restart when you install the update. Therefore, install the update when no users are logged on through Outlook Web Access.

Removal Information

To remove this update, use the Add or Remove Programs tool in Control Panel or use the following command in a console window:

%EXCHSRVR%\895179\UNINSTALL\UNINST.EXE

File Information:

The English version of this security update has the file attributes that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Exchange Server 5.5 Service Pack 4:

File NameVersionDateTimeSize
Cdohtml.dll5.5.2658.3416-Apr-200519:34537,360
Htmlsnif.dll6.5.6582.015-Nov-200218:4157,344
Safehtml.dll6.5.7547.007-Apr-200517:45201,728
Cdo.dll5.5.2658.3416-Apr-200519:37807,184

Verifying that the Update Has Been Applied

  • Microsoft Baseline Security Analyzer

    To verify that a security update has been applied to an affected system, you may be able to use the Microsoft Baseline Security Analyzer (MBSA) tool. MBSA allows administrators to scan local and remote systems for missing security updates and for common security misconfigurations. For more information about MBSA, visit the Microsoft Baseline Security Analyzer Web site.

  • File Version Verification

    Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

    1. Click Start, and then click Search.
    2. In the Search Results pane, click All files and folders under Search Companion.
    3. In the All or part of the file name box, type a file name from the appropriate file information table, and then click Search.
    4. In the list of files, right-click a file name from the appropriate file information table, and then click Properties.

      Note Depending on the version of the operating system or programs installed, some of the files that are listed in the file information table may not be installed.
    5. On the Version tab, determine the version of the file that is installed on your computer by comparing it to the version that is documented in the appropriate file information table.

      Note Attributes other than the file version may change during installation. Comparing other file attributes to the information in the file information table is not a supported method of verifying that the update has been applied. Also, in certain cases, files may be renamed during installation. If the file or version information is not present, use one of the other available methods to verify update installation.
  • Registry Key Verification

    You may also be able to verify the files that this security update has installed by reviewing the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Exchange Server 5.5\SP5\895179

    Note This registry key may not contain a complete list of installed files. Also, this registry key may not be created correctly when an administrator or an OEM integrates or slipstreams the 895179 security update into the Windows installation source files.

Other Information

Acknowledgments

Microsoft thanks the following for working with us to help protect customers:

Obtaining Other Security Updates:

Updates for other security issues are available at the following locations:

Support:

  • Customers in the U.S. and Canada can receive technical support from Microsoft Product Support Services at 1-866-PCSAFETY. There is no charge for support calls that are associated with security updates.
  • International customers can receive support from their local Microsoft subsidiaries. There is no charge for support that is associated with security updates. For more information about how to contact Microsoft for support issues, visit the International Support Web site.

Security Resources:

Software Update Services:

By using Microsoft Software Update Services (SUS), administrators can quickly and reliably deploy the latest critical updates and security updates to Windows 2000 and Windows Server 2003-based servers, and to desktop systems that are running Windows 2000 Professional or Windows XP Professional.

For more information about how to deploy this security update by using Software Update Services, visit the Software Update Services Web site.

Systems Management Server:

Microsoft Systems Management Server (SMS) delivers a highly-configurable enterprise solution for managing updates. By using SMS, administrators can identify Windows-based systems that require security updates and can perform controlled deployment of these updates throughout the enterprise with minimal disruption to end users. For more information about how administrators can use SMS 2003 to deploy security updates, visit the SMS 2003 Security Patch Management Web site. SMS 2.0 users can also use Software Updates Service Feature Pack to help deploy security updates. For information about SMS, visit the SMS Web site.

Note SMS uses the Microsoft Baseline Security Analyze, Microsoft Office Detection Tool, and the Enterprise Update Scanning Tool to provide broad support for security bulletin update detection and deployment. Some software updates may not be detected by these tools. Administrators can use the inventory capabilities of the SMS in these cases to target updates to specific systems. For more information about this procedure, visit the following Web site. Some security updates require administrative rights following a restart of the system. Administrators can use the Elevated Rights Deployment Tool (available in the SMS 2003 Administration Feature Pack and in the SMS 2.0 Administration Feature Pack) to install these updates.

Disclaimer:

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions:

  • V1.0 (June 14, 2005): Bulletin published
  • V1.1 (July 6, 2005): Bulletin updated to add /s for the “security update without any user intervention” command for Exchange Server 5.5 Service Pack 4

Built at 2014-04-18T13:49:36Z-07:00

Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2015 Microsoft