Microsoft Security Bulletin MS99-038 - Critical

Patch Available for "Spoofed Route Pointer" Vulnerability

Published: September 20, 1999 | Updated: March 21, 2003

Version: 2.0

Patch Availability Information Updated: March 21, 2003
Originally Posted: September 20, 1999

Summary

Microsoft has released a patch that eliminates a vulnerability in Microsoft® Windows® 95, 98 and Windows NT® 4.0 that could allow source routing to be performed, even if it has ostensibly been disabled.

The patch also includes added functionality to provide additional control over source routing. Frequently asked questions regarding this vulnerability can be found at http://www.microsoft.com/technet/security/bulletin/fq99-038.mspx

Issue

Windows NT 4.0 Service Pack 5 introduced the ability to disable source routing on a multi-homed Windows NT machine that acts as a router. However, even if source routing is disabled, it is possible to bypass it by including a specific type of incorrect information within the route pointer in the data packet. Windows 95 and 98 also provide this capability, and are affected by the same vulnerability. The patch restores correct operation to the anti-source routing feature. In addition, it provides additional functionality that enables source routing to be disabled on single-homed machines and on multi-homed machines that are not used as routers.

Customers who are using multi-homed Windows or Windows NT machines to perform routing and who wish to disable source routing should apply the patch to ensure proper operation of the anti-source routing features. In addition, customers who have non-routing machines in vulnerable locations (for example, single-homed machines outside of a firewall or multi-homed machines joining two subnets) may wish to install the patch in order to use the new functionality to disable source routing in these cases as well.

Affected Software Versions

  • Microsoft Windows 95
  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0, Enterprise Edition

Vulnerability Identifier: CVE-1999-0909

Patch Availability

More Information

Please see the following references for more information related to this issue.

Obtaining Support on this Issue

This is a fully supported patch. Information on contacting Microsoft Technical Support is available at http://support.microsoft.com/contactussupport/?ws=support.

Acknowledgments

Microsoft acknowledges McAfee, Inc. (http://www.mcafee.com) for bringing this issue to our attention and working with us to alert customers about it.

Revisions

  • September 20, 1999: Bulletin Created.
  • September 22, 1999: Revised to reflect fact that Windows NT 4.0 Server, Terminal Server Edition, is not affected by this vulnerability.
  • V2.0 (March 21, 2003): Introduced versioning and updated patch availability information.

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Built at 2014-04-18T13:49:36Z-07:00

Show: