Bulletin de sécurité Microsoft MS17-007 - Critique

Mise à jour de sécurité cumulative pour Microsoft Edge (4013071)

Date de publication : 14 mars 2017 | Date de mise à jour : 8 août 2017

Version : 2.0

Cette mise à jour de sécurité corrige des vulnérabilités dans Microsoft Edge. La plus grave de ces vulnérabilités pourrait permettre l'exécution de code à distance si un utilisateur affichait une page web spécialement conçue à l'aide de Microsoft Edge. Un attaquant qui parviendrait à exploiter ces vulnérabilités pourrait prendre le contrôle d'un système affecté. L’attaquant pourrait alors installer des programmes, afficher, modifier ou supprimer des données, ou créer des comptes dotés de tous les privilèges.

Cette mise à jour de sécurité est de niveau « Critique » pour Microsoft Edge sous Windows 10 et de niveau « Modéré » sous Windows Server 2016. Pour plus d'informations, consultez la section Logiciels concernés.

Cette mise à jour corrige les vulnérabilités en modifiant la façon dont Microsoft Edge traite les objets en mémoire.

Pour plus d'informations sur ces vulnérabilités, consultez la section Informations par vulnérabilité. Pour plus d'informations sur cette mise à jour, consultez l'article 4013071 de la Base de connaissances Microsoft.

Les versions ou éditions répertoriées ci-dessous sont concernées. Les versions ou éditions non répertoriées ont atteint la fin de leur cycle de vie ou ne sont pas concernées. Consultez le site web Politique de Support Microsoft afin de connaître la politique de support Microsoft pour votre version ou édition.

Les indices de gravité indiqués pour chaque logiciel concerné supposent l'impact potentiel maximal de la vulnérabilité. Pour plus d'informations sur les risques dans les 30 jours suivant la publication d'un Bulletin concernant l'exploitabilité de la vulnérabilité par rapport à son indice de gravité et à son impact, consultez l'Indice d'exploitabilité dans la synthèse des Bulletins de sécurité de mars.

Remarque Consultez le guide des mises à jour de sécurité pour découvrir la nouvelle approche concernant l'utilisation des informations sur les mises à jour de sécurité. Vous pouvez personnaliser les vues et créer des feuilles de calcul sur les logiciels concernés, ainsi que télécharger des données via une API RESTful. Pour plus d'informations, consultez le Forum aux questions concernant le guide des mises à jour de sécurité. Pour rappel, le guide des mises à jour de sécurité remplacera les Bulletins de sécurité. Pour plus d'informations, consultez notre billet de blog Furthering our commitment to security updates (en anglais uniquement).

Logiciels concernés - Microsoft Edge

Système d'exploitation

Composant

Impact de sécurité maximal

Indice de gravité cumulée

Mises à jour remplacées

Microsoft Edge

Windows 10 pour systèmes 32 bits [1]
(4025338)

Microsoft Edge

Exécution de code à distance

Critique

4022727

Windows 10 pour systèmes x64 [1]
(4025338)

Microsoft Edge

Exécution de code à distance

Critique

4022727

Windows 10 version 1511 pour systèmes 32 bits [1]
(4025338)

Microsoft Edge

Exécution de code à distance

Critique

4022714

Windows 10 version 1511 pour systèmes x64 [1]
(4025338)

Microsoft Edge

Exécution de code à distance

Critique

4022714

Windows 10 version 1607 pour systèmes 32 bits [1]
(4025338)

Microsoft Edge

Exécution de code à distance

Critique

4022715

Windows 10 version 1607 pour systèmes x64 [1]
(4025338)

Microsoft Edge

Exécution de code à distance

Critique

4022715

Windows 10 version 1703 pour systèmes 32 bits [1]
(4025338)

Microsoft Edge

Exécution de code à distance

Critique

4022725

Windows 10 version 1703 pour systèmes x64 [1]
(4025338)

Microsoft Edge

Exécution de code à distance

Critique

4022725

Windows Server 2016

Windows Server 2016 pour systèmes x64 [1]
(4013429)

Microsoft Edge

Exécution de code à distance

Modéré

3213986

[1] Les mises à jour de Windows 10 et Windows Server 2016 sont cumulatives. La mise à jour de sécurité mensuelle comprend tous les correctifs de sécurité pour des vulnérabilités qui concernent Windows 10, en plus de mises à jour non liées à la sécurité. Les mises à jour sont disponibles via le Catalogue Microsoft Update. À partir du 13 décembre 2016, les informations concernant Windows 10 et Windows Server 2016 pour les mises à jour cumulatives seront documentées dans les notes de publication. Consultez les notes de publication en ce qui concerne les numéros de build du système d'exploitation, les problèmes connus et la liste de fichiers concernés.

*La colonne Mises à jour remplacées n'affiche que la dernière mise à jour d'une série de mises à jour remplacées. Pour obtenir la liste complète des mises à jour remplacées, accédez au Catalogue Microsoft Update, recherchez le numéro d'article de la Base de connaissances, puis consultez les détails de la mise à jour (les informations sur les mises à jour remplacées figurent sous l'onglet Détails du package).

La vulnérabilité liée à la bibliothèque PDF décrite dans ce Bulletin est également décrite dans le Bulletin sur Windows PDF (MS17-009) publié en mars. Pour être protégé de cette vulnérabilité, dois-je installer plusieurs mises à jour pour mon système et ma configuration de Microsoft Edge ? 
Non. Les clients qui utilisent les systèmes Windows 10 doivent uniquement installer la mise à jour cumulative pour protéger leur système de la vulnérabilité CVE-2017-0023. La vulnérabilité liée à la bibliothèque PDF est décrite dans le Bulletin sur Microsoft Edge car, sur les systèmes Windows 10, le correctif de sécurité pour cette vulnérabilité réside dans le composant Microsoft Edge livré dans la mise à jour cumulative.

Les indices de gravité suivants considèrent l'impact potentiel maximal de la vulnérabilité. Pour plus d'informations sur les risques dans les 30 jours suivant la publication d'un Bulletin concernant l'exploitabilité de la vulnérabilité par rapport à son indice de gravité et à son impact, consultez l'Indice d'exploitabilité dans la synthèse des Bulletins de sécurité de mars.

Le cas échéant, dans le tableau Indices de gravité et impact, les valeurs « Critique », « Important » et « Modéré » correspondent aux indices de gravité. Pour plus d'informations, consultez l'article consacré au système d'indices de gravité pour les Bulletins de sécurité. Reportez-vous à la légende suivante afin de connaître les abréviations utilisées dans le tableau pour indiquer l'impact maximal :

Abréviation

Impact maximal

RCE

Exécution de code à distance

EoP

Élévation de privilèges

ID

Divulgation d'informations

SFB

Contournement de la fonctionnalité de sécurité

 


Indices de gravité par vulnérabilité et impact

Numéro CVE

Titre de la vulnérabilité

Microsoft Edge

CVE-2017-0009

Vulnérabilité de divulgation d’informations dans les navigateurs Microsoft

Clients Windows :
Important/ID

Serveurs Windows :
Faible/ID

CVE-2017-0010

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0011

Vulnérabilité de divulgation d’informations dans Microsoft Edge

Clients Windows :
Important/ID

Serveurs Windows :
Faible/ID

CVE-2017-0012

Vulnérabilité d'usurpation d'identité dans le navigateur Microsoft

Clients Windows :
Important/Usurpation

Serveurs Windows :
Faible/Usurpation

CVE-2017-0015

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE
(Seuls Windows 10 et Windows 10 version 1511 sont concernés)

CVE-2017-0017

Vulnérabilité de divulgation d’informations dans Microsoft Edge

Clients Windows :
Important/ID

Serveurs Windows :
Faible/ID

CVE-2017-0023

Vulnérabilité d'altération de mémoire dans Microsoft PDF

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0032

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0033

Vulnérabilité d'usurpation d'identité dans le navigateur Microsoft

Clients Windows :
Important/Usurpation

Serveurs Windows :
Faible/Usurpation

CVE-2017-0034

Vulnérabilité d'altération de mémoire dans Microsoft Edge

Clients Windows :
Critique/RCE
(Seul Windows 10 version 1607 est concerné)

Serveurs Windows :
Modéré/RCE

CVE-2017-0035

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0037

Vulnérabilité d'altération de mémoire dans le navigateur Microsoft

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0065

Vulnérabilité de divulgation d’informations dans les navigateurs Microsoft

Clients Windows :
Important/ID

Serveurs Windows :
Faible/ID

CVE-2017-0066

Vulnérabilité de contournement de la fonctionnalité de sécurité dans Microsoft Edge

Clients Windows :
Important/SFB

Serveurs Windows :
Faible/SFB

CVE-2017-0067

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0068

Vulnérabilité de divulgation d’informations dans Microsoft Edge

Clients Windows :
Important/ID

Serveurs Windows :
Faible/ID

CVE-2017-0069

Vulnérabilité d'usurpation dans Microsoft Edge

Clients Windows :
Important/Usurpation

Serveurs Windows :
Faible/Usurpation

CVE-2017-0070

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0071

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0094

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0131

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Important/RCE

Serveurs Windows :
Faible/RCE

CVE-2017-0132

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0133

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE
(Seuls Windows 10 version 1511 et Windows 10 version 1607 sont concernés)

Serveurs Windows :
Modéré/RCE

CVE-2017-0134

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0135

Contournement de la fonctionnalité de sécurité Microsoft Edge

Clients Windows :
Important/SFB

Serveurs Windows :
Faible/SFB

CVE-2017-0136

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE
(Seul Windows 10 version 1607 est concerné)

CVE-2017-0137

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0138

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0140

Contournement de la fonctionnalité de sécurité Microsoft Edge

Clients Windows :
Important/SFB
(Seul Windows 10 version 1607 est concerné)

Serveurs Windows :
Faible/SFB

CVE-2017-0141

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE

Serveurs Windows :
Modéré/RCE

CVE-2017-0150

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE
(Seul Windows 10 version 1607 est concerné)

Serveurs Windows :
Modéré/RCE

CVE-2017-0151

Vulnérabilité d'altération de mémoire dans le moteur de script

Clients Windows :
Critique/RCE
(Seul Windows 10 version 1607 est concerné)

Serveurs Windows :
Modéré/RCE

Vulnérabilités d'altération de mémoire dans les moteurs de script Microsoft

Il existe plusieurs vulnérabilités d’exécution de code à distance dans le rendu des moteurs de script concernés lorsqu’ils traitent les objets en mémoire dans les navigateurs Microsoft. Ces vulnérabilités pourraient altérer la mémoire et permettre à un attaquant d'exécuter du script arbitraire dans le contexte de l'utilisateur actuel. Un attaquant qui parviendrait à exploiter ces vulnérabilités pourrait obtenir les mêmes droits que l'utilisateur actuel. Si l'utilisateur actuel a ouvert une session avec des privilèges d'administrateur, un attaquant qui parviendrait à exploiter ces vulnérabilités pourrait prendre le contrôle d'un système affecté. L'attaquant pourrait alors installer des programmes, afficher, modifier ou supprimer des données, ou créer des comptes dotés de tous les privilèges.

Dans le cas d'une attaque web, un attaquant pourrait héberger un site web spécialement conçu pour exploiter ces vulnérabilités via un navigateur Microsoft, puis inciter un utilisateur à consulter ce site web. Un attaquant pourrait également intégrer un contrôle ActiveX marqué « sûr pour l'initialisation » à une application ou à un document Microsoft Office qui héberge le moteur de rendu de Edge. L'attaquant pourrait également exploiter des sites web compromis et des sites web qui acceptent ou hébergent du contenu ou des annonces fournis par les utilisateurs. Ces sites web pourraient contenir du code spécialement conçu pour exploiter ces vulnérabilités.

Cette mise à jour de sécurité corrige ces vulnérabilités en modifiant la façon dont les moteurs de script Microsoft concernés traitent les objets en mémoire.

Le tableau suivant contient un lien vers l'entrée standard correspondant à chaque vulnérabilité dans la liste de CVE (Common Vulnerabilities and Exposures) :

Titre de la vulnérabilité

Numéro CVE

Révélée publiquement

Exploitée

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0010

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0015

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0032

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0035

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0067

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0070

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0071

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0094

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0131

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0132

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0133

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0134

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0136

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0137

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0138

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0141

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0150

Non

Non

Vulnérabilité d'altération de mémoire dans le moteur de script

CVE-2017-0151

Non

Non

Facteurs atténuants

Microsoft n'a identifié aucun facteur atténuant pour ces vulnérabilités.

Solutions de contournement

Microsoft n'a identifié aucune solution de contournement pour ces vulnérabilités.

Vulnérabilités de divulgation d'informations dans Microsoft Edge

Il existe plusieurs vulnérabilités de divulgation d'informations quant à la manière dont les composants concernés traitent les objets en mémoire. Un attaquant qui parviendrait à exploiter ces vulnérabilités pourrait obtenir des informations permettant de compromettre davantage un système cible.

Dans le cas d'une attaque web, l'attaquant devrait héberger un site web conçu pour tenter d'exploiter les vulnérabilités. En outre, les sites web compromis et les sites web qui acceptent ou hébergent du contenu provenant d'utilisateurs pourraient contenir du contenu spécialement conçu pour exploiter ces vulnérabilités. Dans tous les cas, l'attaquant n'aurait aucun moyen de forcer l'utilisateur à afficher le contenu contrôlé par l'attaquant. L'attaquant devrait convaincre les utilisateurs d'exécuter une action. Par exemple, l'attaquant pourrait inciter l'utilisateur à cliquer sur un lien qui mène à son site.

La mise à jour de sécurité corrige ces vulnérabilités en modifiant la façon dont les composants concernés traitent les objets en mémoire.

Le tableau suivant contient des liens vers l'entrée standard correspondant à chaque vulnérabilité dans la liste de CVE (Common Vulnerabilities and Exposures) :

Titre de la vulnérabilité

Numéro CVE

Révélée publiquement

Exploitée

Vulnérabilité de divulgation d’informations dans les navigateurs Microsoft

CVE-2017-0009

Non

Non

Vulnérabilité de divulgation d’informations dans Microsoft Edge

CVE-2017-0011

Non

Non

Vulnérabilité de divulgation d’informations dans Microsoft Edge

CVE-2017-0017

Non

Non

Vulnérabilité de divulgation d’informations dans les navigateurs Microsoft

CVE-2017-0065

Oui

Non

Vulnérabilité de divulgation d’informations dans Microsoft Edge

CVE-2017-0068

Non

Non

Facteurs atténuants

Microsoft n'a identifié aucun facteur atténuant pour ces vulnérabilités.

Solutions de contournement

Microsoft n'a identifié aucune solution de contournement pour ces vulnérabilités.

Vulnérabilités d'usurpation d'identité dans Microsoft Edge

Il existe des vulnérabilités d’usurpation d’identité lorsqu’un navigateur Microsoft n’analyse pas correctement les réponses HTTP. Un attaquant qui parviendrait à exploiter ces vulnérabilités pourrait tromper un utilisateur en le redirigeant vers un site web spécialement conçu. Le site web spécialement conçu pourrait usurper du contenu ou être utilisé comme pivot pour lier une attaque à d'autres vulnérabilités des services web.

Pour exploiter ces vulnérabilités, l'utilisateur doit cliquer sur une URL spécialement conçue. Dans le cas d'une attaque par courrier électronique, un attaquant pourrait envoyer un message électronique contenant l'URL spécialement conçue à l'utilisateur pour tenter de convaincre celui-ci de cliquer dessus.

Dans le cas d'une attaque web, l'attaquant pourrait héberger un site web spécialement conçu pour sembler légitime aux yeux de l'utilisateur. Cependant, l'attaquant n'aurait aucun moyen de forcer l'utilisateur à visiter le site web spécialement conçu. L'attaquant devrait convaincre l'utilisateur de le faire, généralement par le biais d'une sollicitation envoyée par message électronique ou message instantané, puis l'inciter à interagir avec le contenu du site web.

La mise à jour corrige ces vulnérabilités en modifiant la manière dont les navigateurs Microsoft analysent les réponses HTTP.

Le tableau suivant contient des liens vers l'entrée standard correspondant à chaque vulnérabilité dans la liste de CVE (Common Vulnerabilities and Exposures) :

Titre de la vulnérabilité

Numéro CVE

Révélée publiquement

Exploitée

Vulnérabilité d'usurpation d'identité dans le navigateur Microsoft

CVE-2017-0012

Oui

Non

Vulnérabilité d'usurpation d'identité dans le navigateur Microsoft

CVE-2017-0033

Oui

Non

Vulnérabilité d'usurpation dans Microsoft Edge

CVE-2017-0069

Oui

Non

Facteurs atténuants

Microsoft n'a identifié aucun facteur atténuant pour ces vulnérabilités.

Solutions de contournement

Microsoft n'a identifié aucune solution de contournement pour ces vulnérabilités.

Vulnérabilité d'altération de mémoire dans le navigateur Microsoft - CVE-2017-0037

Il existe une vulnérabilité d'exécution de code à distance lorsque Microsoft Edge accède de façon incorrecte à des objets en mémoire. Cette vulnérabilité pourrait altérer la mémoire en permettant à un attaquant d'exécuter du code arbitraire dans le contexte de l'utilisateur actuel.

Un attaquant pourrait héberger un site web spécialement conçu pour exploiter cette vulnérabilité via Microsoft Edge, puis inciter un utilisateur à consulter ce site. L'attaquant pourrait également exploiter des sites web compromis et des sites web qui acceptent ou hébergent du contenu ou des annonces provenant d'utilisateurs qui pourraient contenir du code spécialement conçu susceptible d'exploiter la vulnérabilité. Toutefois, l'attaquant n'aurait aucun moyen de forcer l'utilisateur à afficher le contenu contrôlé par l'attaquant. Il devrait convaincre l’utilisateur de le faire, généralement par le biais d'une sollicitation envoyée par message électronique ou message instantané, ou en l'incitant à ouvrir une pièce jointe à un message électronique.

Pour réaliser une exécution de code complète, un attaquant devrait également combiner cette vulnérabilité à d'autres failles. Un attaquant qui parviendrait à combiner plusieurs vulnérabilités pour créer une chaîne d'exploitation pourrait obtenir les mêmes droits que l'utilisateur actuel. Si l'utilisateur actuel est connecté avec des privilèges d'administrateur, un attaquant pourrait prendre le contrôle d'un système concerné. L'attaquant pourrait alors installer des programmes, afficher, modifier ou supprimer des données, ou créer des comptes dotés de tous les privilèges.

Cette mise à jour corrige la vulnérabilité en modifiant la façon dont Microsoft Edge traite les objets en mémoire.

Le tableau suivant contient un lien vers l'entrée standard correspondant à la vulnérabilité dans la liste de CVE (Common Vulnerabilities and Exposures) :

Titre de la vulnérabilité

Numéro CVE

Révélée publiquement

Exploitée

Vulnérabilité d'altération de mémoire dans le navigateur Microsoft

CVE-2017-0037

Oui

Non

Facteurs atténuants

Microsoft n'a identifié aucun facteur atténuant pour cette vulnérabilité.

Solutions de contournement

Microsoft n'a identifié aucune solution de contournement pour cette vulnérabilité.

Vulnérabilité d’altération de mémoire dans Microsoft PDF - CVE-2017-0023

Il existe une vulnérabilité d'exécution de code à distance lorsque la bibliothèque PDF Microsoft Windows ne traite pas correctement les objets en mémoire. Cette vulnérabilité pourrait altérer la mémoire et permettre à un attaquant d'exécuter du code arbitraire dans le contexte de l'utilisateur actuel. Un attaquant qui parviendrait à exploiter cette vulnérabilité pourrait obtenir les mêmes droits d'utilisateur que l'utilisateur actuel. Si l'utilisateur actuel est connecté avec des privilèges d'administrateur, un attaquant pourrait prendre le contrôle d'un système concerné. L'attaquant pourrait alors installer des programmes, afficher, modifier ou supprimer des données, ou créer des comptes dotés de tous les privilèges.

Pour exploiter la vulnérabilité sur un système Windows 10 sur lequel Microsoft Edge est défini comme navigateur par défaut, l'attaquant pourrait héberger un site web spécialement conçu comportant du contenu PDF malveillant, puis inciter un utilisateur à consulter ce site web. L'attaquant pourrait également exploiter des sites web compromis ou des sites web qui acceptent ou hébergent du contenu ou des annonces fournies par des utilisateurs, en ajoutant du contenu PDF spécialement conçu à ces sites. Seuls les systèmes Windows 10 sur lesquels Microsoft Edge est défini comme navigateur par défaut peuvent être compromis par la simple consultation d'un site web. Les navigateurs de tous les autres systèmes d'exploitation concernés n'affichent pas automatiquement le contenu PDF. Par conséquent, un attaquant n'aurait aucun moyen de forcer les utilisateurs à afficher le contenu qu'il contrôle. Il devrait convaincre l’utilisateur d'ouvrir un document PDF spécialement conçu, généralement par le biais d'une sollicitation envoyée par message électronique ou message instantané, ou par le biais d'une pièce jointe à un message électronique.

Cette mise à jour corrige la vulnérabilité en modifiant la manière dont les systèmes concernés traitent les objets en mémoire.

Le tableau suivant contient des liens vers l'entrée standard correspondant à chaque vulnérabilité dans la liste de CVE (Common Vulnerabilities and Exposures) :

Titre de la vulnérabilité

Numéro CVE

Révélée publiquement

Exploitée

Vulnérabilité d'altération de mémoire dans Microsoft PDF

CVE-2017-0023

Non

Non

Facteurs atténuants

Microsoft n'a identifié aucun facteur atténuant pour cette vulnérabilité.

Solutions de contournement

Microsoft n'a identifié aucune solution de contournement pour cette vulnérabilité.

Vulnérabilités de contournement de la fonctionnalité de sécurité dans Microsoft Edge

Il existe plusieurs vulnérabilités de contournement de la fonctionnalité de sécurité lorsque Microsoft Edge ne parvient pas à appliquer correctement la stratégie d'origine identique pour les éléments HTML présents dans d'autres fenêtres du navigateur.

Un attaquant pourrait inciter un utilisateur à charger une page renfermant du contenu malveillant. Pour exploiter ces vulnérabilités, un attaquant devrait inciter un utilisateur à charger une page ou à visiter un site. La page pourrait également être injectée dans un réseau publicitaire ou un site compromis.

La mise à jour corrige ces vulnérabilités en modifiant la vérification de la stratégie d'origine identique pour les scripts qui tentent de manipuler des éléments HTML dans d'autres fenêtres du navigateur.

Le tableau suivant contient un lien vers l'entrée standard correspondant à la vulnérabilité dans la liste de CVE (Common Vulnerabilities and Exposures) :

Titre de la vulnérabilité

Numéro CVE

Révélée publiquement

Exploitée

Vulnérabilité de contournement de la fonctionnalité de sécurité dans Microsoft Edge

CVE-2017-0066

Non

Non

Vulnérabilité de contournement de la fonctionnalité de sécurité dans Microsoft Edge

CVE-2017-0135

Non

Non

Vulnérabilité de contournement de la fonctionnalité de sécurité dans Microsoft Edge

CVE-2017-0140

Non

Non

Facteurs atténuants

Microsoft n'a identifié aucun facteur atténuant pour ces vulnérabilités.

Solutions de contournement

Microsoft n'a identifié aucune solution de contournement pour ces vulnérabilités.

Vulnérabilité d'altération de mémoire dans Microsoft Edge - CVE-2017-0034

Il existe une vulnérabilité d'exécution de code à distance lorsque Microsoft Edge accède de façon incorrecte à des objets en mémoire. Cette vulnérabilité pourrait altérer la mémoire et permettre à un attaquant d'exécuter du code arbitraire dans le contexte de l'utilisateur actuel. Un attaquant qui parviendrait à exploiter cette vulnérabilité pourrait obtenir les mêmes droits d'utilisateur que l'utilisateur actuel. Si l'utilisateur actuel est connecté avec des privilèges d'administrateur, un attaquant pourrait prendre le contrôle d'un système concerné. L'attaquant pourrait alors installer des programmes, afficher, modifier ou supprimer des données, ou créer des comptes dotés de tous les privilèges.

Un attaquant pourrait héberger un site web spécialement conçu pour exploiter cette vulnérabilité via Microsoft Edge, puis inciter un utilisateur à consulter ce site. L'attaquant pourrait également exploiter des sites web compromis et des sites web qui acceptent ou hébergent du contenu ou des annonces provenant d'utilisateurs qui pourraient contenir du code spécialement conçu susceptible d'exploiter la vulnérabilité. Toutefois, l'attaquant n'aurait aucun moyen de forcer l'utilisateur à afficher le contenu contrôlé par l'attaquant. Il devrait convaincre l’utilisateur de le faire, généralement par le biais d'une sollicitation envoyée par message électronique ou message instantané, ou en l'incitant à ouvrir une pièce jointe à un message électronique.

Cette mise à jour corrige la vulnérabilité en modifiant la façon dont Microsoft Edge traite les objets en mémoire.

Le tableau suivant contient un lien vers l'entrée standard correspondant à la vulnérabilité dans la liste de CVE (Common Vulnerabilities and Exposures) :

Titre de la vulnérabilité

Numéro CVE

Révélée publiquement

Exploitée

Vulnérabilité d’altération de mémoire dans Microsoft Edge

CVE-2017-0034

Non

Non

Facteurs atténuants

Microsoft n'a identifié aucun facteur atténuant pour la vulnérabilité.

Solutions de contournement

Microsoft n'a identifié aucune solution de contournement pour la vulnérabilité.

Pour plus d'informations sur le déploiement des mises à jour de sécurité, consultez l'article de la Base de connaissances Microsoft référencé ici dans la synthèse.

Microsoft reconnaît les efforts des professionnels de la sécurité qui contribuent à protéger les clients par une divulgation coordonnée des vulnérabilités. Reportez-vous à la page Remerciements pour plus d'informations.

Les informations contenues dans la Base de connaissances Microsoft sont fournies « en l'état », sans garantie d'aucune sorte. Microsoft exclut toute garantie expresse ou implicite, notamment toute garantie de qualité et d'adéquation à un usage particulier. En aucun cas, la société Microsoft ou ses fournisseurs ne pourront être tenus pour responsables de quelque dommage que ce soit, y compris toute perte de bénéfices directe, indirecte ou accessoire, ou de dommages spéciaux, même si la société Microsoft a été prévenue de l'éventualité de tels dommages. Certains pays n'autorisent pas l'exclusion ou la limitation des responsabilités pour les dommages indirects ou accessoires, de sorte que la limitation ci-dessus peut ne pas être applicable.

  • V1.0 (14 mars 2017) : Bulletin publié.
  • V2.0 (8 août 2017) : Afin de résoudre complètement la vulnérabilité CVE-2017-0071, Microsoft a publié les mises à jour de sécurité de juillet pour toutes les versions de Windows 10. À noter que Windows 10 pour systèmes 32 bits, Windows 10 pour systèmes x64, Windows 10 version 1703 pour systèmes 32 bits et Windows 10 version 1703 pour systèmes x64 ont été ajoutés au tableau Produits concernés, car ils sont également concernés par cette vulnérabilité. Microsoft recommande aux clients d’installer, si ce n’est déjà fait, les mises à jour de sécurité de juillet 2017 pour être entièrement protégés contre cette vulnérabilité.
Page générée le 02/08/2017 09:24-07:00.
Afficher: