マイクロソフト セキュリティ情報 MS16-053 - 緊急

JScript および VBScript 用の累積的なセキュリティ更新プログラム (3156764)

公開日:2016 年 5 月 11 日

バージョン: 1.0

このセキュリティ更新プログラムは、Microsoft Windows の VBScript および JScript スクリプト エンジンに存在する脆弱性を解決します。これらの脆弱性により、ユーザーが特別に細工された Web サイトにアクセスすると、リモートでコードが実行される可能性があります。この脆弱性が悪用された場合、攻撃者により現在のユーザーと同じ権限が取得される可能性があります。現在のユーザーが管理者ユーザー権限でログオンしているときに、攻撃者によりこれらの脆弱性が悪用された場合、影響を受けるコンピューターが制御される可能性があります。攻撃者は、その後、プログラムのインストール、データの表示、変更、削除などを行ったり、完全なユーザー権限を持つ新たなアカウントを作成したりする可能性があります。

このセキュリティ更新プログラムは、影響を受けるバージョンの JScript および VBScript スクリプト エンジンについて、サポートされているリリースの Windows Vista 上で深刻度が「緊急」と評価され、Windows Server 2008 および Windows Server 2008 R2 上で「警告」と評価されています。詳細については、「影響を受けるソフトウェア」のセクションを参照してください。

この更新プログラムは、VBScript および JScript スクリプト エンジンがメモリのオブジェクトを処理する方法を変更することにより、この脆弱性を排除します。脆弱性の詳細については、「脆弱性の情報」を参照してください。

この更新プログラムの詳細については、マイクロソフト サポート技術情報 3156764 を参照してください。

次のバージョンの JScript および VBScript が、このセキュリティ情報で説明する脆弱性の影響を受けます。以前のバージョンまたはエディションは、サポート ライフサイクルが終了しているか、この脆弱性の影響を受けません。

オペレーティング システム

コンポーネント

最も深刻な脆弱性の影響

総合的な深刻度

置き換えられる更新プログラム*

Windows Vista

Windows Vista Service Pack 2

VBScript 5.7 
(3158991)

リモートでコードが実行される

緊急

MS16-003 の 3124624

Windows Vista x64 Edition Service Pack 2

VBScript 5.7 
(3158991)

リモートでコードが実行される

緊急

MS16-003 の 3124624

Windows Server 2008

Windows Server 2008 for x32-bit Systems Service Pack 2

VBScript 5.7 
(3158991)

リモートでコードが実行される

警告

MS16-003 の 3124624

Windows Server 2008 for x64-based Systems Service Pack 2

VBScript 5.7 
(3158991)

リモートでコードが実行される

警告

MS16-003 の 3124624

Windows Server 2008 for Itanium-based Systems Service Pack 2

VBScript 5.7 
(3158991)

リモートでコードが実行される

警告

MS16-003 の 3124624

Server Core インストール オプション

Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core インストール)

VBScript 5.7 
(3158991)

リモートでコードが実行される

警告

MS16-003 の 3124624

Windows Server 2008 for x64-based Systems Service Pack 2
(Server Core インストール)

VBScript 5.7 
(3158991)

リモートでコードが実行される

警告

MS16-003 の 3124624

Windows Server 2008 R2 for x64-based Systems Service Pack 1
(Server Core インストール)

JScript 5.8 および VBScript 5.8
(3155413)

リモートでコードが実行される

警告

MS16-003 の 3124625


* "置き換えられる更新プログラム" 列には、置き換えられる一連の更新プログラムの中で、最新の更新プログラムのみが表示されています。置き換えられる更新プログラムの完全な一覧については、Microsoft Update カタログにアクセスし、更新プログラムのサポート技術情報番号を検索してから、更新プログラムの詳細を表示します (置き換えられる更新プログラムの情報は [パッケージの詳細] タブにあります)。

この累積的なセキュリティ更新プログラムのパッケージに JScript.dll と VBScript.dll の両方が表示されるのはなぜですか? 
このセキュリティ更新プログラムは、JScript および VBScript スクリプト エンジン用の累積的な更新プログラムとして出荷されています。このリリースには両方のエンジンが含まれていますが、このセキュリティ情報に記載されているセキュリティ修正プログラムの影響を受けるコンポーネントは、前述の「影響を受けるソフトウェア」に記載されています。

コンピューターにインストールされている JScript および VBScript スクリプト エンジンのバージョンをどのように確認できますか?
JScript および VBScript スクリプト エンジンは、サポートされているリリースの Microsoft Windows と共にインストールされます。また、システムに新しいバージョンの Internet Explorer をインストールすると、インストールされる JScript および VBScript スクリプト エンジンのバージョンが変更される可能性があります。

システムにインストールされている JScript または VBScript スクリプト エンジンのバージョンを確認するには、以下のステップを実行します。

  1. エクスプローラーを起動します。
  2. %systemroot%\system32 ディレクトリに移動します。
  3. VBScript の場合は、[vbscript.dll]を右クリックして [プロパティ]を選択し、次に [詳細]タブをクリックします。
  4. JScript の場合は、[jscript.dll]を右クリックして [プロパティ]を選択し、次に [詳細]タブをクリックします。

バージョン番号は [ファイル バージョン]のフィールドに表示されています。ファイル バージョンが 5.8 で始まる場合 (例: 5.8.7600.16385)、VBScript 5.8 がコンピューターにインストールされています。

コンピューターにインストールされている JScript または VBScript スクリプト エンジンのバージョンを確認したら、どこで更新プログラムを入手できますか?
このセキュリティ情報の影響を受けるソフトウェアは、Internet Explorer がインストールされていないシステム、または Internet Explorer 7 以前がインストールされているシステムに適用されます。Internet Explorer 8 以降を実行しているシステムのユーザーは、Internet Explorer の累積的な更新プログラム (MS16-051) を適用する必要があります。これは、このセキュリティ情報で説明する脆弱性も解決します。

次の深刻度の評価は、脆弱性の影響が最も深刻な場合を想定しています。深刻度の評価およびセキュリティ上の影響に関連して、このセキュリティ情報の公開から 30 日以内にこの脆弱性が悪用される可能性に関する情報については、5 月のセキュリティ情報の概要の Exploitability Index (悪用可能性指標) を参照してください。

影響を受けるソフトウェアごとの脆弱性の深刻度および最大のセキュリティ上の影響

影響を受けるソフトウェア

スクリプト エンジンのメモリ破損の脆弱性 - CVE-2016-0187

スクリプト エンジンのメモリ破損の脆弱性 - CVE-2016-0189

総合的な深刻度

VBScript 5.7 

Windows Vista Service Pack 2 上の VBScript 5.7

対象外

緊急
リモートでコードが実行される

緊急

Windows Vista x64 Edition Service Pack 2 上の VBScript 5.7

対象外

緊急
リモートでコードが実行される

緊急

Windows Server 2008 for 32-bit Systems Service Pack 2 上の VBScript 5.7

対象外

警告
リモートでコードが実行される

警告

Windows Server 2008 for x64-based Systems Service Pack 2 上の VBScript 5.7

対象外

警告
リモートでコードが実行される

警告

Windows Server 2008 for Itanium-based Systems Service Pack 2 上の VBScript 5.7

対象外

警告
リモートでコードが実行される

警告

JScript 5.8 および VBScript 5.8

Windows Server 2008 R2 for x64-based Systems Service Pack 1 上の JScript 5.8 および VBScript 5.8
(Server Core インストールのみ)

警告
リモートでコードが実行される

警告
リモートでコードが実行される

警告

複数のスクリプト エンジンのメモリ破損の脆弱性

Internet Explorer でメモリ内のオブジェクトを処理するときに VBScript および JScript エンジンがレンダリングする方法に、複数のリモートでコードが実行される脆弱性が存在します。これらの脆弱性では、攻撃者が現在のユーザーのコンテキストで任意のコードを実行するような方法で、メモリを破損する可能性があります。攻撃者によりこの脆弱性が悪用された場合、攻撃者が現在のユーザーと同じユーザー権限を取得する可能性があります。現在のユーザーが管理者ユーザー権限でログオンしているときに、攻撃者によりこれらの脆弱性が悪用された場合、影響を受けるコンピューターが制御される可能性があります。攻撃者は、その後、プログラムのインストール、データの表示、変更、削除などを行ったり、完全なユーザー権限を持つ新たなアカウントを作成したりする可能性があります。

Web ベースの攻撃シナリオでは、攻撃者は Internet Explorer を介してこれらの脆弱性を悪用することを目的として特別に細工した Web サイトをホストし、その Web サイトを表示するようにユーザーを誘導する可能性があります。攻撃者は「初期化しても安全」と判断された ActiveX コントロールを、IE レンダリング エンジンをホストするアプリケーションや Microsoft Office ドキュメントに埋め込む可能性もあります。また、攻撃者は侵害された Web サイトおよびユーザーが提供したコンテンツや広告を受け入れる、またはホストする Web サイトを利用する可能性があります。これらの Web サイトには、これらの脆弱性を悪用する可能性のある特別に細工されたコンテンツが含まれている場合があります。

この更新プログラムは、VBScript および JScript スクリプト エンジンがメモリのオブジェクトを処理する方法を変更することにより、この脆弱性を排除します。次の表には、Common Vulnerabilities and Exposures リストの各脆弱性の標準のエントリへのリンクが含まれています。

脆弱性のタイトル

CVE 番号

一般に公開

悪用

スクリプト エンジンのメモリ破損の脆弱性

CVE-2016-0187

なし

なし

スクリプト エンジンのメモリ破損の脆弱性

CVE-2016-0189

なし

あり

問題を緩和する要素

マイクロソフトは、この脆弱性の問題を緩和する要素を確認していません。

回避策

お客様の状況で、次の回避策が役立つ場合があります。

  • VBScript.dll および JScript.dll へのアクセスの制限
    • 32 ビット コンピューターについては、管理コマンド プロンプトから次のコマンドを入力します。
      takeown /f %windir%\system32\vbscript.dll 
      cacls %windir%\system32\vbscript.dll /E /P everyone:N
      cacls %windir%\system32\jscript.dll /E /P everyone:N
      
    • 64 ビット コンピューターについては、管理コマンド プロンプトから次のコマンドを入力します。
      takeown /f %windir%\syswow64\vbscript.dll 
      cacls %windir%\syswow64\vbscript.dll /E /P everyone:N
      cacls %windir%\syswow64\jscript.dll /E /P everyone:N
      

    回避策の影響。 VBScript または JScript を使用する Web サイトが正常に機能しない場合があります。

    回避策の解除方法:

    • 32 ビット コンピューターについては、管理コマンド プロンプトから次のコマンドを入力します。
      cacls %windir%\system32\vbscript.dll /E /R everyone
      cacls %windir%\system32\jscript.dll /E /R everyone
      
    • 64 ビット コンピューターについては、管理コマンド プロンプトから次のコマンドを入力します。
      cacls %windir%\syswow64\vbscript.dll /E /R everyone
      cacls %windir%\syswow64\jscript.dll /E /R everyone
      

セキュリティ更新プログラムの展開については、「概要」のこちらで言及されているマイクロソフト サポート技術情報を参照してください。

マイクロソフトでは、協調的な脆弱性の公開によるお客様の保護に際して、セキュリティ コミュニティの方々からいただいたご助力に感謝いたします。詳細については、謝辞を参照してください。

マイクロソフト サポート技術情報に含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation およびその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation およびその関連会社は、本文書に含まれている情報の使用および使用結果につき、正確性、真実性など、いかなる表明・保証も行いません。Microsoft Corporation、その関連会社およびこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社およびこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含むすべての損害に対して、状況のいかんを問わず一切責任を負いません。結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。

  • V1.0 (2016/05/11): このセキュリティ情報ページを公開しました。
Page generated 2016-05-05 14:07-07:00.
表示: