Microsoft Security Bulletin MS15-121 - Important

Security Update for Schannel to Address Spoofing (3081320)

Published: November 10, 2015 | Updated: April 7, 2016

Version: 1.1

This security update resolves a vulnerability in Microsoft Windows. The vulnerability could allow spoofing if an attacker performs a man-in-the-middle (MiTM) attack between a client and a legitimate server.

This security update is rated Important for all supported releases of Microsoft Windows excluding Windows 10. For more information, see the Affected Software section.

The security update addresses the vulnerability by adding extended master secret binding support to all supported versions of Transport Layer Security (TLS). For more information about the vulnerability, see the Vulnerability Information section.

For more information about this update, see Microsoft Knowledge Base Article 3081320.

The following software versions or editions are affected. Versions or editions that are not listed are either past their support life cycle or are not affected. To determine the support life cycle for your software version or edition, see Microsoft Support Lifecycle.

Operating System

Maximum Security Impact

Aggregate Severity Rating

Updates Replaced*

Windows Vista

Windows Vista Service Pack 2
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Vista x64 Edition Service Pack 2
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Server 2008

Windows Server 2008 for 32-bit Systems Service Pack 2
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Server 2008 for x64-based Systems Service Pack 2
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Server 2008 for Itanium-based Systems Service Pack 2
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows 7

Windows 7 for 32-bit Systems Service Pack 1 [1]
(3081320)

Spoofing

Important

3067505 in MS15-076

Windows 7 for x64-based Systems Service Pack 1 [1]
(3081320)

Spoofing

Important

3067505 in MS15-076

Windows Server 2008 R2

Windows Server 2008 R2 for x64-based Systems Service Pack 1 [1]
(3081320)

Spoofing

Important

3067505 in MS15-076

Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 [1]
(3081320)

Spoofing

Important

3067505 in MS15-076

Windows 8 and Windows 8.1

Windows 8 for 32-bit Systems [2]
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows 8 for x64-based Systems [2]
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows 8.1 for 32-bit Systems
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows 8.1 for x64-based Systems
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Server 2012 and Windows Server 2012 R2

Windows Server 2012 [2]
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Server 2012 R2
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows RT and Windows RT 8.1

Windows RT[3]
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows RT 8.1[3]
(3081320)

Spoofing

Important

3061518 in MS15-055

Server Core installation option

Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)[1]
(3081320)

Spoofing

Important

3067505 in MS15-076

Windows Server 2012 (Server Core installation)[2]
(3081320)

Spoofing

Important

3061518 in MS15-055

Windows Server 2012 R2 (Server Core installation)
(3081320)

Spoofing

Important

3061518 in MS15-055

[1]Note that update 3101746 in MS15-115 and update 3101246 in MS15-122 are releasing concurrently with update 3081320 in this bulletin, MS15-121. Customers who intend to install all three updates manually on Windows 7 Service Pack 1 or Windows Server 2008 R2 Service Pack 1 should install the updates in the following order: 3101246 first, 3081320 second, and 3101746 third (this is taken care of automatically for customers with automatic updating enabled). Alternatively, customers can install only 3101746, which contains the updates for 3101246 and 3081320. For more information see the Known Issues section of Microsoft Knowledge Base Article 3105256.

[2]Note that update 3101746 in MS15-115 and update 3101246 in MS15-122 are releasing concurrently with update 3081320 in this bulletin, MS15-121. Customers who intend to install all three updates manually on Windows 8 or Windows Server 2012 should install the updates in the following order: 3101246 first, 3101746 second, and 3081320 third (this is taken care of automatically for customers with automatic updating enabled). Alternatively, customers can install only 3081320, which contains the updates for 3101246 and 3101746. For more information see the Known Issues section of Microsoft Knowledge Base Article 3105256.

[3]This update is only available via Windows Update.

*The Updates Replaced column shows only the latest update in any chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is provided on the Package Details tab).

The following severity ratings assume the potential maximum impact of the vulnerability. For information regarding the likelihood, within 30 days of this security bulletin's release, of the exploitability of the vulnerability in relation to its severity rating and security impact, please see the Exploitability Index in the November bulletin summary.

Vulnerability Severity Rating and Maximum Security Impact by Affected Software

Affected Software

Schannel TLS Triple Handshake Vulnerability - CVE-2015-6112

Aggregate Severity Rating

Windows Vista

Windows Vista Service Pack 2
(3081320)

Important 
Spoofing

Important

Windows Vista x64 Edition Service Pack 2
(3081320)

Important 
Spoofing

Important

Windows Server 2008

Windows Server 2008 for 32-bit Systems Service Pack 2
(3081320)

Important 
Spoofing

Important

Windows Server 2008 for x64-based Systems Service Pack 2
(3081320)

Important 
Spoofing

Important

Windows Server 2008 for Itanium-based Systems Service Pack 2
(3081320)

Important 
Spoofing

Important

Windows 7

Windows 7 for 32-bit Systems Service Pack 1
(3081320)

Important 
Spoofing

Important

Windows 7 for x64-based Systems Service Pack 1
(3081320)

Important 
Spoofing

Important

Windows Server 2008 R2

Windows Server 2008 R2 for x64-based Systems Service Pack 1
(3081320)

Important 
Spoofing

Important

Windows Server 2008 R2 for Itanium-based Systems Service Pack 1
(3081320)

Important 
Spoofing

Important

Windows 8 and Windows 8.1

Windows 8 for 32-bit Systems
(3081320)

Important 
Spoofing

Important

Windows 8 for x64-based Systems
(3081320)

Important 
Spoofing

Important

Windows 8.1 for 32-bit Systems
(3081320)

Important 
Spoofing

Important

Windows 8.1 for x64-based Systems
(3081320)

Important 
Spoofing

Important

Windows Server 2012 and Windows Server 2012 R2

Windows Server 2012
(3081320)

Important 
Spoofing

Important

Windows Server 2012 R2
(3081320)

Important 
Spoofing

Important

Windows RT and Windows RT 8.1

Windows RT
(3081320)

Important 
Spoofing

Important

Windows RT 8.1
(3081320)

Important 
Spoofing

Important

Server Core installation option

Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
(3081320)

Important 
Spoofing

Important

Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
(3081320)

Important 
Spoofing

Important

Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
(3081320)

Important 
Spoofing

Important

Windows Server 2012 (Server Core installation)
(3081320)

Important 
Spoofing

Important

Windows Server 2012 R2 (Server Core installation)
(3081320)

Important 
Spoofing

Important

Schannel TLS Triple Handshake Vulnerability - CVE-2015-6112

A spoofing vulnerability exists in Microsoft Windows that is caused by a weakness in all supported versions of the TLS protocol. An attacker who successfully exploited this vulnerability could impersonate a victim on any other server that uses the same credentials as those used between the client and server where the attack is initiated.

To exploit the vulnerability an attacker would first have to perform a man-in-the-middle (MiTM) attack between the client and a legitimate server. The update addresses the vulnerability by adding extended master secret binding support to all supported version of TLS.

This vulnerability has been publicly disclosed. It has been assigned Common Vulnerability and Exposure number CVE-2015-6112. At the time this security bulletin was originally issued, Microsoft was unaware of any attack attempting to exploit this vulnerability.

Mitigating Factors

Microsoft has not identified any mitigating factors for this vulnerability.

Workarounds

Microsoft has not identified any workarounds for this vulnerability.

For Security Update Deployment information, see the Microsoft Knowledge Base article referenced here in the Executive Summary.

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure. See Acknowledgments for more information.

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

  • V1.0 (November 10, 2015): Bulletin published.
  • V1.1 (April 7, 2016): Updated the footnotes following the Affected Software table to further clarify installation order for security update 3101746 in MS15-115, 3081320 in MS15-121, and 3101246 in MS15-122. This is an informational change only. Customers who have already successfully installed the update do not need to take any action.

Page generated 2016-04-07 10:16-07:00.
Show: