Microsoft Security Bulletin MS06-056 - Moderada

Vulnerabilidade no ASP.NET 2.0 poderia permitir a Divulgação de Informações (922770)

Data de publicação: 10 de outubro de 2006 | Updated: 29 de novembro de 2006

actualizada: 1.3

Resumo

Quem deve ler este documento: Clientes que utilizam o Microsoft Windows .NET Framework 2.0

Impacto da Vulnerabilidade: Divulgação de Informações

Classificação de Gravidade Máxima: Moderada

Recomendação: Os clientes deveriam considerar a aplicação da actualização de segurança

Substituição de Actualizações de Segurança: Nenhum

Avisos: O artigo 922770 da Base de Dados de Conhecimento da Microsoft documenta as questões actualmente conhecidas que os clientes podem experimentar quando instalam esta actualização de segurança. O artigo também documenta soluções recomendadas para estas questões. Para mais informações, consulte o artigo 922770 da Base de Dados de Conhecimento da Microsoft.

Localizações de Transferência de Actualizações de Segurança e Software Testado:

Software Afectado:

Microsoft .NET Framework 2.0 para as seguintes versões de sistemas operativos: Transfira a actualização.

  • Microsoft Windows 2000 Service Pack 4
  • Microsoft Windows XP Service Pack 1 ou Windows XP Service Pack 2
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows Server 2003 ou Microsoft Windows Server 2003 Service Pack 1
  • Windows Server 2003 com Service Pack 1 para Sistemas baseados em Itanium
  • Microsoft Windows Server 2003 x64 Edition

Software Não Afectado:

  • Microsoft Windows Server 2003 para Sistemas baseados em Itanium

Componentes Testados do Microsoft Windows:

Componentes afectados:

  • Microsoft .NET Framework 2.0

Componentes Não Afectados:

  • Microsoft .NET Framework 1.0
  • Microsoft .NET Framework 1.1

O software referido nesta lista foi testado para determinar se todas as suas versões são afectadas. As outras versões ou não são abrangidas pelo suporte de actualizações de segurança ou podem não ser afectadas. Para determinar o ciclo de vida do suporte do seu produto e versão visite o Web site do Ciclo de Vida do Suporte Microsoft.

Nota As actualizações de segurança para o Microsoft Windows Server 2003, Windows Server 2003 Service Pack 1 e Windows Server 2003 x64 Edition também se aplicam ao Windows Server 2003 R2.

Informações Gerais

Resumo Executivo:

Esta actualização resolve uma vulnerabilidade recentemente descoberta e comunicada de forma privada. A vulnerabilidade está documentada na secção "Detalhes sobre a Vulnerabilidade" deste boletim.

A vulnerabilidade poderia permitir que um intruso obtivesse acesso não autorizado a informação. Tenha em atenção que esta vulnerabilidade não permitiria que um intruso executasse código para elevar directamente os seus privilégios de utilizador, mas poderia ser utilizada para obter informações para comprometer ainda mais o sistema afectado.

Recomendamos que os clientes considerem a aplicação da actualização de segurança.

Classificações da Gravidade e Identificadores da Vulnerabilidade:

Identificadores da VulnerabilidadeImpacto da Vulnerabilidade.NET Framework 2.0
Vulnerabilidade de Execução de Scripts entre sites no .NET Framework 2.0 - CVE-2006-3436Divulgação de InformaçõesModerada

Por que razão está o Microsoft Windows Server 2003 pasa sistemas baseados em Itanium incluído na lista de “Software não afectado”?
O Microsoft .NET Framework 2.0 não é instalado no Microsoft Windows Server 2003 para sistemas baseados em Itanium.

Por que razão não é o Microsoft .NET Framework 2.0 instalado no Microsoft Windows Server 2003 para sistemas baseados em Itanium?
O Windows Installer 3.1 não é suportado no Microsoft Windows Server 2003 para sistemas baseados em Itanium. O Windows Installer 3.1 apenas é suportado no Windows Server 2003 com Service Pack 1 para sistemas baseados em Itanium.

Quais são as questões conhecidas que os clientes poderão experimentar quando instalam esta actualização de segurança?

O artigo 922770 da Base de Dados de Conhecimento da Microsoft documenta as questões actualmente conhecidas que os clientes podem experimentar quando instalam esta actualização de segurança. O artigo também documenta soluções recomendadas para estas questões. Para mais informações, consulte o artigo 922770 da Base de Dados de Conhecimento da Microsoft.

O suporte alargado a actualizações de segurança para o Microsoft Windows NT Workstation 4.0 Service Pack 6a e Windows 2000 Service Pack 2 terminou a 30 de Junho de 2004. O suporte alargado a actualizações de segurança para o Microsoft Windows NT Server 4.0 Service Pack 6a terminou a 31 de Dezembro de 2004. O suporte alargado a actualizações de segurança para o Microsoft Windows 2000 Service Pack 3 terminou a 30 de Junho de 2005. Ainda utilizo um destes sistemas operativos - o que devo fazer?
O Windows NT Workstation 4.0 Service Pack 6a, o Windows NT Server 4.0 Service Pack 6a, o Windows 2000 Service Pack 2 e o Windows 2000 Service Pack 3 chegaram ao fim dos respectivos ciclos de vida. Os utilizadores que tenham estas versões do sistema operativo deviam considerar a migração para versões suportadas como uma prioridade, de modo a poderem proteger os seus sistemas contra a potencial exposição a vulnerabilidades. Para mais informações sobre o Ciclo de Vida dos Produtos Windows, visite o Web site do Ciclo de Vida do Suporte da Microsoft. Para mais informações sobre o período de suporte alargado a actualizações de segurança para estas versões do sistema operativo, visite o Web site de Suporte Técnico da Microsoft.

Os clientes que necessitem de suporte personalizado para estes produtos devem contactar o seu representante de equipa de contas da Microsoft, o seu Gestor Técnico de Contas ou o parceiro ou representante Microsoft adequado para mais informações sobre opções de suporte personalizado. Os clientes que não disponham de um Contrato Alliance, Premier ou Autorizado podem contactar a subsidiária local da Microsoft. Para obter informações de contacto, visite o Web site Microsoft Worldwide Information, seleccione o país e, em seguida, clique em Go para ver uma lista de números de telefone. Quando telefonar, peça para falar com o Gestor de Vendas de Suporte Premier local. Para mais informações, consulte as Perguntas mais frequentes de suporte sobre o ciclo de vida de produto, relativas aos sistemas operativos Windows.

Posso utilizar o Microsoft Baseline Security Analyzer (MBSA) para determinar se esta actualização é necessária?

A tabela seguinte fornece o resumo de detecções do MBSA para esta actualização de segurança.

ProdutoMBSA 1.2.1Enterprise Update Scan Tool (EST)MBSA 2.0
.NET Framework 2.0 NãoSimSim

Para mais informações sobre o MBSA, visite o Web site do MBSA. Para mais informações sobre programas que o Microsoft Update e o MBSA 2.0 não detectam actualmente, consulte o artigo 895660 da Base de Dados de Conhecimento da Microsoft.

Para obter informações mais detalhadas, consulte o Artigo 910723 da Base de Dados de Conhecimento da Microsoft.

O que é a ferramenta Enterprise Update Scan Tool (EST)?
Como parte do compromisso permanente de fornecimento de ferramentas de detecção para actualizações de segurança registadas nos boletins, a Microsoft lança uma ferramenta de detecção independente sempre que o Microsoft Baseline Security Analyzer (MBSA) e a ferramenta Office Detection Tool (ODT) não conseguem detectar se a actualização é necessária para um ciclo de publicação MSRC. Esta ferramenta independente é denominada Enterprise Update Scan Tool (EST) e é concebida para administradores de sistemas empresariais. Quando é criada uma versão da Enterprise Update Scan Tool para um boletim específico, os clientes podem executar a ferramenta a partir de uma interface de linha de comando (CLI) e ver os resultados do ficheiro de saída XML. Para ajudar os clientes a utilizar melhor a ferramenta, será fornecida documentação detalhada juntamente com a ferramenta. Existe também uma versão da ferramenta que oferece uma experiência integrada para administradores SMS.

Posso usar uma versão da ferramenta Enterprise Update Scan Tool (EST) para determinar se esta actualização é necessária?
Sim. A Microsoft criou uma versão da EST que irá determinar se tem de aplicar esta actualização. Para ligações de transferências e para obter mais informações sobre a versão da EST que será lançada este mês, consulte o artigo 894193 da Base de Dados de Conhecimento da Microsoft. Os clientes com o SMS devem consultar a pergunta "Posso utilizar o Systems Management Server (SMS) para determinar se esta actualização é necessária?" na secção Perguntas mais frequentes, para mais informações sobre o SMS e a EST.

Posso utilizar o Systems Management Server (SMS) para determinar se esta actualização é necessária?
A tabela seguinte fornece o resumo de detecções do SMS para esta actualização de segurança.

ProdutoSMS 2.0SMS 2003
.NET Framework 2.0 Sim (com a EST)Sim

O SMS utiliza o MBSA para fins de detecção. Por conseguinte, o SMS tem as mesmas limitações listadas anteriormente neste boletim relacionadas com programas que o MBSA não detecta.

Para o SMS 2.0, o SMS SUS Feature Pack, que inclui a ferramenta Security Update Inventory Tool, pode ser usado pelo SMS para detectar actualizações de segurança. O SMS SUIT utiliza o motor MBSA 1.2.1 para detecção. Para mais informações sobre a ferramenta Security Update Inventory Tool, consulte o seguinte Web site da Microsoft. Para mais informações sobre as limitações da ferramenta Security Update Inventory Tool, consulte o artigo 306460 da Base de Dados de Conhecimento da Microsoft. O SMS SUS Feature Pack também inclui a ferramenta Microsoft Office Inventory Tool para detectar actualizações necessárias para aplicações do Microsoft Office.

Para o SMS 2003, a ferramenta SMS 2003 Inventory Tool para actualizações de software Microsoft pode ser usada pelo SMS para detectar actualizações de segurança que foram oferecidas pelo Microsoft Update e que são suportadas pelos Windows Server Update Services. Para obter mais informações sobre a ferramenta SMS 2003 Inventory Tool for Microsoft Updates, visite o seguinte Web site da Microsoft. O SMS 2003 também pode utilizar a ferramenta Microsoft Office Inventory Tool para detectar as actualizações necessárias para aplicações do Microsoft Office.

Para mais informações sobre o SMS, visite o Web site do SMS.

Para obter informações mais detalhadas, consulte o Artigo 910723 da Base de Dados de Conhecimento da Microsoft.

Vulnerabilidade de Execução de Scripts entre sites no .NET Framework 2.0 - CVE-2006-3436:

Existe uma vulnerabilidade de execução de scripts num servidor que esteja a executar uma versão vulnerável do .NET Framework 2.0 que poderia introduzir um script cliente no browser do utilizador. O script poderia ter conteúdos ocultos, divulgar informações, ou executar qualquer acção que o utilizador pudesse executar no web site afectado. As tentativas de exploração desta vulnerabilidade requerem interacção com o utilizador.

Factores Atenuantes para a Vulnerabilidade de Execução de Scripts entre sites no .NET Framework 2.0 - CVE-2006-3436:

  • Num cenário de ataque baseado na Web, um intruso no servidor da Web poderia introduzir um script cliente no browser do utilizador. O script poderia ter conteúdos ocultos, divulgar informações, ou executar qualquer acção que o utilizador pudesse executar no web site afectado. As tentativas de exploração desta vulnerabilidade requereriam interacção com o utilizador.
  • Por predefinição, os controlos do .NET Framework 2.0 não definem a propriedade AutoPostBack para “verdadeiro”.

Soluções Alternativas para a Vulnerabilidade de Execução de Scripts entre sites no .NET Framework 2.0 - CVE-2006-3436:

A Microsoft testou as seguintes soluções alternativas. Embora estas soluções alternativas não corrijam a vulnerabilidade subjacente, elas ajudam a bloquear vectores de ataque conhecidos. Na secção seguinte identificam-se os casos em que uma solução alternativa reduz a funcionalidade.

  • Em computadores a executar o .NET Framework 2.0, não defina a propriedade AutoPostBack dos controlos de uma página para “verdadeiro”:

Perguntas mais frequentes sobre a Vulnerabilidade de Execução de Scripts entre sites no .NET Framework 2.0 - CVE-2006-3436:

Qual é a abrangência desta vulnerabilidade?
Poderá existir uma vulnerabilidade de execução de scripts num servidor que esteja a executar uma versão vulnerável do .NET Framework 2.0 que poderia introduzir um script cliente no browser do utilizador. A vulnerabilidade existe nos controlos ASP.NET que definem a propriedade AutoPostBack para “verdadeiro”. Num cenário de ataque baseado na Web, um Web site comprometido poderia aceitar ou alojar conteúdos fornecidos pelo utilizador ou anúncios que poderiam conter conteúdos especialmente concebidos que pudessem explorar esta vulnerabilidade.

O script conseguiria executar qualquer acção em lugar do utilizador que o Web site estivesse autorizado a executar. Isto poderia incluir controlar a sessão na Web e encaminhar a informação de controlo para outro utilizador, executando outro código no sistema do utilizador, ou ler e registar cookies.

O que provoca a vulnerabilidade?
Uma vulnerabilidade de execução de scripts entre sites (XSS) é causada pela forma como o .NET Framework 2.0 valida o valor para um pedido HTTP.

O que é o ASP.NET?
O ASP.NET é uma colecção de tecnologias dentro do .NET Framework que permite que os programadores construam aplicações Web e Serviços Web XML.

Ao contrário das páginas Web tradicionais, que usam uma combinação de HTML estático e execução de scripts, o ASP.NET utiliza páginas compiladas e conduzidas por eventos. Isto permite que os programadores construam aplicações baseadas na Web com a mesma riqueza e funcionalidade normalmente associadas às aplicações construídas em linguagens como Visual Basic ou Visual C++. Como o ASP.NET é um ambiente de aplicação baseado na Web, requer um servidor Web subjacente para fornecer funcionalidades HTTP básicas. Por esta razão, o ASP.NET é executado por cima do IIS 5.0 (Internet Information Services) no Windows 2000, do IIS 5.1 no Windows XP e do IIS 6.0 no Windows Server 2003.

O que é o AutoPostBack?
O AutoPostBack é uma propriedade suportada pelos controlos num formulário. Os formulários que suportam esta propriedade podem definir o valor desta para verdadeiro (o valor predefinido é falso), o que faz com que o controlo envie uma mensagem de resposta para o servidor de cada vez que o utilizador interage com o controlo.

O que é a execução de scripts entre sites?
A execução de scripts entre sites (XSS) é uma classe de vulnerabilidades de segurança que pode permitir que um intruso "injecte" scripts numa sessão de um utilizador com um Web site. A vulnerabilidade pode afectar servidores Web que geram dinamicamente páginas HTML. Se estes servidores incorporarem dados do browser nas páginas dinâmicas que enviam para o browser, podem ser manipulados para incluir conteúdos fornecidos maliciosamente nas páginas dinâmicas. Isto pode permitir que sejam executados scripts maliciosos. Os browsers da Web poderiam perpetuar este problema, baseados no princípio de que se tratam de sites "fidedignos" e na forma como utilizam os cookies para manter um estado persistente com os Web sites que frequentam. Um ataque XSS não modifica os conteúdos do Web site. Pelo contrário, insere scripts novos e maliciosos que podem ser executados no browser, no contexto que está associado a um servidor fidedigno.

Como funciona a execução de scripts entre sites?
As páginas Web contêm texto e marcadores HTML. O texto e os marcadores HTML são gerados pelo servidor e são interpretados pelo cliente. Se for introduzido conteúdo não fidedigno numa página dinâmica, nem o servidor nem o cliente possuem informações suficientes para reconhecer que esta introdução teve lugar e para tomar medidas de protecção.

Como poderia um intruso utilizar a vulnerabilidade?
Um intruso que tivesse conseguido explorar esta vulnerabilidade num servidor que esteja a executar a versão vulnerável do .NET Framework 2.0, poderia injectar um script cliente no browser do utilizador. O script poderia ter conteúdos ocultos, divulgar informações, ou executar qualquer acção que o utilizador pudesse executar no web site afectado. As tentativas de exploração desta vulnerabilidade requereriam interacção com o utilizador.

Quem poderia explorar a vulnerabilidade?
Num cenário de ataque através de correio electrónico, um intruso poderia tentar explorar a vulnerabilidade enviando uma mensagem de correio electrónico especialmente concebida para o efeito a um utilizador ou a um servidor que estivesse a executar uma aplicação de software afectada. O intruso poderia então convencer o utilizador a clicar na hiperligação na mensagem de correio electrónico.

Num cenário de ataque baseado na Web, um intruso poderia introduzir um script cliente no browser do utilizador. O script poderia ter conteúdos ocultos, divulgar informações, ou executar qualquer acção que o utilizador pudesse executar no web site afectado. As tentativas de exploração desta vulnerabilidade requereriam interacção com o utilizador.

Quais os sistemas mais susceptíveis a esta vulnerabilidade?
Os sistemas mais susceptíveis a este risco são sistemas voltados para a Internet. Além disso, Web sites internos que usam o ASP.NET para alojar dados importantes podem estar susceptíveis a esta vulnerabilidade.

A vulnerabilidade poderia ser explorada a partir da Internet?
Sim. Um intruso pode tentar explorar esta vulnerabilidade através da Internet.

O que faz a actualização?
A actualização elimina a vulnerabilidade modificando a forma como o .ASP.NET valida o valor de um pedido HTTP.

Quando este boletim de segurança foi publicado, esta vulnerabilidade já tinha sido divulgada publicamente?
Não. A Microsoft recebeu informações sobre esta vulnerabilidade através de divulgação responsável. A Microsoft ainda não tinha recebido informações que indicassem que esta vulnerabilidade tivesse sido divulgada publicamente, quando este boletim de segurança foi publicado pela primeira vez.

Quando este boletim de segurança foi publicado, a Microsoft já tinha recebido informações sobre a exploração desta vulnerabilidade?
Não. A Microsoft não tinha recebido quaisquer informações que indicassem que esta vulnerabilidade tivesse sido utilizada publicamente para atacar clientes e não tinha conhecimento de exemplos publicados de código para prova de conceito quando este boletim de segurança foi criado pela primeira vez.

Software Afectado:

Para obter mais informações sobre a actualização de segurança específica do software afectado, clique na ligação adequada:

Microsoft .NET Framework versão 2.0

Pré-requisitos
Esta actualização de segurança requer o Microsoft .NET Framework versão 2.0.

O Microsoft Windows Installer 3.1 deve estar instalado. Para instalar a mais recente versão do Windows Installer, visite o seguinte Web site da Microsoft:

Windows Installer 3.1 Redistributable (v2)

Inclusão em Service Packs Futuros:
A actualização para este problema será incluída num service pack futuro.

Informações de Instalação

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/help Apresenta as opções da linha de comandos.
Modos de Configuração
/q[n|b|r|f] Define o nível de interface do utilizador.
n - Sem interacção do utilizador
b - Interacção do utilizador básica
r - Interacção do utilizador reduzida
f - Interacção do utilizador total (predefinida)
Opções de instalação
/extract [directory] Extrair o pacote para o directório especificado.
Opções de Reinício
/norestart Não reinicia quando a instalação estiver concluída.
/forcerestart Reinicia o computador depois da instalação e força as outras aplicações a fechar durante o processo de encerramento, sem antes gravar os ficheiros abertos.
/promptrestart Apresenta uma caixa de diálogo pedindo ao utilizador local que autorize o reinício.
Opções de início de sessão
/l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile> i - Mensagens de estado
w - Avisos não fatais
e - Mensagens de erro total
a - Início de acções
r - Gravações específicas de acções
u - Pedidos do utilizador
c - Parâmetros UI iniciais
m - Informação de falta de memória ou saída fatal
o - Mensagens de espaço de disco inexistente
p - Propriedades do terminal
v - Envio de informações detalhadas
x - Informação de depuração adicional
+ - Acrescentar a ficheiro log existente
! - Indexar cada linha ao log
* - Registar todas as informações, excepto para as opções v e x
/log <LogFile> Equivalente de /l* <LogFile>

Nota É possível combinar estes parâmetros num único comando. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o artigo 824687 da Base de Dados de Conhecimento da Microsoft. Para obter mais informações sobre o programa de instalação do Windows, visite o Web site Windows Installer MSDN.

Informações de implementação

Para instalar a actualização de segurança sem qualquer intervenção por parte do utilizador, utilize o comando respectivo numa linha de comandos:

NDP20-KB922770-x86.exe /qn

NDP20-KB922770-x64.exe /qn

NDP20-KB922770-ia64.exe /qn

Nota A utilização do parâmetro /qn irá suprimir todas as mensagens. Isto inclui a supressão de mensagens de falha. Quando utilizam o parâmetro /qn, os administradores devem usar um dos métodos suportados para verificar se a instalação foi bem sucedida.

Para instalar a actualização de segurança sem forçar o sistema a reiniciar, utilize o seguinte comando aplicável na linha de comandos:

NDP20-KB922770-x86.exe /norestart

NDP20-KB922770-x64.exe /norestart

NDP20-KB922770-ia64.exe /norestart

Para obter informações sobre como implementar esta actualização de segurança com os Software Update Services, visite o Web site dos Software Update Services. Para mais informações sobre como implementar esta actualização de segurança usando os Windows Server Update Services, visite o Web site dos Windows Server Update Services. Esta actualização de segurança também estará disponível através do Web site do Microsoft Update.

Requisito de reinício
Esta actualização não requer um reinício. O programa de instalação pára os serviços necessários, aplica a actualização e, em seguida, reinicia os serviços. Contudo, se não for possível interromper os serviços necessários por qualquer motivo, ou se os ficheiros necessários estiverem a ser utilizados, esta actualização vai requerer o reinício do computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre por que razão pode ser solicitada a sua confirmação para o reinício do seu computador, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.

Informações de Remoção
Para remover esta actualização, utilize a ferramenta Adicionar ou Remover Programas no Painel de Controlo.

Informações de Ficheiros
A versão inglesa desta actualização contém os atributos de ficheiro listados na tabela abaixo (ou posteriores). As datas e horas destes ficheiros estão listadas em formato de hora universal coordenada (UTC). Quando vê as informações dos ficheiros, estas são convertidas para a hora local. Para determinar a diferença entre a hora UTC e a hora local, utilize o separador Fuso Horário na ferramenta Data e Hora no Painel de Controlo.

Microsoft .NET Framework versão 2.0

Nome do FicheiroVersãoDataHoraTamanho
aspnet_wp.exe2.0.50727.21013-Set-200600:1023,040
webengine.dll2.0.50727.21013-Set-200600:10300,032
System.web.dll2.0.50727.21013-Set-200600:115,029,888

Microsoft .NET Framework versão 2.0 no Windows Server, 2003 Enterprise Edition para sistemas baseados em Itanium; Windows Server 2003, Datacenter Edition para sistemas baseados em Itanium; Windows Server 2003, Enterprise Edition com SP1 para sistemas baseados em Itanium e Windows Server 2003, Datacenter Edition com SP1 para sistemas baseados em Itanium:

Nome do FicheiroVersãoDataHoraTamanho
aspnet_wp.exe2.0.50727.21012-Set-200604:1873,728
aspnet_wp.exe2.0.50727.21013-Set-200600:1023,040
webengine.dll2.0.50727.21012-Set-200604:18868,864
webengine.dll2.0.50727.21013-Set-200600:10300,032
System.web.dll2.0.50727.21012-Set-200608:244,599,808
System.web.dll2.0.50727.21013-Set-200600:115,029,888

Microsoft .NET Framework versão 2.0 no Windows Server 2003, Standard x64 Edition; Windows Server 2003, Enterprise x64 Edition; e Windows Server 2003, Datacenter x64 Edition; Windows Server 2003 R2, Standard x64 Edition; Windows Server 2003 R2, Enterprise x64 Edition e Windows Server 2003 R2, Datacenter x64 Edition:

Nome do FicheiroVersãoDataHoraTamanho
aspnet_wp.exe2.0.50727.21012-Set-200604:1134,816
aspnet_wp.exe2.0.50727.21013-Set-200600:1023,040
webengine.dll2.0.50727.21012-Set-200604:11540,672
webengine.dll2.0.50727.21013-Set-200600:10300,032
System.web.dll2.0.50727.21012-Set-200607:324,964,352
System.web.dll2.0.50727.21013-Set-200600:115,029,888

Verificação da Instalação da Actualização

Informação sobre a versão do ficheiro

Nota Dado existirem várias versões do Microsoft Windows, os passos que se seguem podem ser diferentes no seu computador. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

  1. Clique em Iniciar e, em seguida, em Procurar.
  2. No painel Resultados da Procura, clique em Todos os ficheiros e pastas no Assistente de Pesquisa.
  3. Na caixa Totalidade ou parte do nome de ficheiro, escreva um nome de ficheiro a partir da tabela de informações de ficheiros adequada e, em seguida, clique em Procurar.
  4. Na lista de ficheiros, clique com o botão direito do rato no nome de ficheiro a partir da tabela de informações de ficheiros adequada e, em seguida, clique em Propriedades.
  5. No separador Versão, determine a versão do ficheiro que está instalada no computador, comparando-a com a versão que é documentada na tabela de informações de ficheiros adequada.

    Nota Outros atributos que não a versão do ficheiro poderão sofrer alterações durante a instalação. Comparar outros atributos de ficheiro com as informações contidas na tabela de informações de ficheiro não é um método suportado para verificar a instalação da actualização. Além disso, em determinados casos, o nome dos ficheiros poderá ser alterado durante a instalação. Se as informações de ficheiro ou de versão não estiverem presentes, utilize um dos outros métodos disponíveis para verificar a instalação da actualização.

Outras informações

Agradecimentos

A Microsoft agradece às seguintes entidades por trabalharem connosco para proteger os clientes:

Obter Outras Actualizações de Segurança:

Estão disponíveis actualizações para outras questões de segurança nas seguintes localizações:

Suporte:

  • Os clientes nos E.U.A. e no Canadá podem receber suporte técnico a partir do web site de Suporte Técnico da Microsoft em 1-866-PCSAFETY. As chamadas de suporte técnico associadas a actualizações de segurança são gratuitas.
  • Os clientes internacionais podem receber suporte das subsidiárias locais da Microsoft. O suporte técnico associado às actualizações de segurança é gratuito. Para mais informações sobre como contactar a Microsoft relativamente a questões de suporte, visite o Web site de Suporte Internacional.

Recursos de Segurança:

Software Update Services:

Utilizando os Microsoft Software Update Services (SUS) os administradores podem implementar rápida e eficazmente as mais recentes actualizações críticas e actualizações de segurança em servidores baseados no Windows 2000 e no Windows Server 2003, bem como em sistemas de computadores de secretária que executem o Windows 2000 Professional ou o Windows XP Professional.

Para obter mais informações sobre como implementar actualizações de segurança com os Software Update Services, visite o Web site dos Software Update Services.

Windows Server Update Services:

Ao utilizar os Windows Server Update Services (WSUS), os administradores podem rápida e fiavelmente implementar as actualizações críticas mais recentes e as actualizações de segurança para os sistemas operativos Windows 2000 e posteriores, Office XP e posteriores, Exchange Server 2003 e SQL Server 2000 até Windows 2000 e sistemas operativos posteriores.

Para mais informações sobre como implementar actualizações de segurança usando os Windows Server Update Services, visite o Web site dos Windows Server Update Services.

Systems Management Server:

O Microsoft Systems Management Server (SMS) fornece uma solução empresarial altamente configurável para gerir actualizações. O SMS permite aos administradores identificarem sistemas baseados no Windows que necessitem de actualizações de segurança e executar a implementação controlada dessas actualizações em toda a empresa, com um mínimo de incómodo para os utilizadores finais. Para mais informações sobre como os administradores podem utilizar o SMS 2003 para implementar actualizações, visite o Web site SMS 2003 Security Patch Management. Os utilizadores do SMS 2.0 também podem utilizar o Software Updates Service Feature Pack para ajudar na implementação das actualizações de segurança. Para obter informações sobre o SMS, visite o Web site do SMS.

Nota O SMS utiliza as ferramentas Microsoft Baseline Security Analyzer, Microsoft Office Detection Tool e Enterprise Update Scan Tool para fornecer um suporte abrangente na detecção e implementação de actualizações dos boletins de segurança. Algumas actualizações de software poderão não ser detectadas por estas ferramentas. Nestes casos, os administradores podem utilizar as capacidades de inventário do SMS para fornecer actualizações a sistemas específicos. Para mais informações sobre este procedimento, visite o seguinte Web site. Algumas actualizações de segurança requerem direitos administrativos após o reinício do sistema. Os administradores podem utilizar a ferramenta Elevated Rights Deployment Tool (disponível no SMS 2003 Administration Feature Pack e no SMS 2.0 Administration Feature Pack) para instalar estas actualizações.

Exclusão de garantia:

As informações fornecidas na Base de Dados de Conhecimento da Microsoft são fornecidas "tal como estão", sem garantias de qualquer tipo. A Microsoft exclui todas as garantias, sejam expressas ou implícitas, incluindo as garantias de comercialização e adequação a um fim específico. Em caso algum serão a Microsoft Corporation ou os seus fornecedores responsáveis por quaisquer prejuízos, incluindo prejuízos directos, indirectos, incidentais ou consequentes, extraordinários ou por perda de lucros negociais, ainda que a Microsoft Corporation, ou os seus fornecedores tenham sido notificados da possibilidade de ocorrência de tais prejuízos. A exclusão ou limitação de responsabilidade por prejuízos consequentes ou incidentais não é permitida em alguns estados ou jurisdições, pelo que a limitação supra poderá não ser aplicável.

Revisões:

  • V1.0 (10 de Outubro de 2006): Boletim publicado.
  • V1.1 (11 de Outubro de 2006): Boletim actualizado na secção "Avisos" e na questão "Quais são as questões conhecidas que os clientes poderão experimentar quando instalam esta actualização de segurança?" na secção "Perguntas mais frequentes relativas a esta actualização de segurança".
  • V1.2 (25 de Outubro de 2006): Boletim actualizado na lista de “Software não-afectado” no que toca ao Microsoft Windows Server 2003 para sistemas baseados em Itanium. Questões “Por que razão está o Microsoft Windows Server 2003 pasa sistemas baseados em Itanium incluído na lista de “Software não afectado?” e “Por que razão não é o Microsoft .NET Framework 2.0 instalado no Microsoft Windows Server 2003 para sistemas baseados em Itanium” na secção “Perguntas mais frequentes relativas a esta actualização de segurança”.
  • V1.3 (29 de Novembro de 2006): Boletim actualizado na secção "Avisos" e na questão "Quais são as questões conhecidas que os clientes poderão experimentar quando instalam esta actualização de segurança?" na secção "Perguntas mais frequentes relativas a esta actualização de segurança".

Built at 2014-04-18T01:50:00Z-07:00

Mostrar: