Microsoft Security Bulletin MS11-074 - Importante

Vulnerabilidades no Microsoft SharePoint Poderiam Permitir Elevação de Privilégios (2451858)

Data de publicação: 13 de setembro de 2011 | Updated: 11 de outubro de 2011

actualizada: 1.3

Informações Gerais

Resumo Executivo

Esta actualização de segurança resolve cinco vulnerabilidades comunicadas de forma privada e uma vulnerabilidade divulgada publicamente no Microsoft SharePoint e no Windows SharePoint Services. As vulnerabilidades mais graves poderiam permitir a elevação de privilégios se um utilizador clicasse num URL ou visitasse um Web site especialmente concebidos para o efeito. Nas vulnerabilidades mais graves, os utilizadores do Internet Explorer 8 e Internet Explorer 9 que naveguem para um site SharePoint na Zona de Internet correm menor risco porque, por predefinição, o Filtro XSS no Internet Explorer 8 e no Internet Explorer 9 ajuda a bloquear os ataques na Zona de Internet. Contudo, o Filtro XSS no Internet Explorer 8 e no Internet Explorer 9 não está activado por predefinição na Zona de Intranet.

Esta actualização de segurança está classificada como Importante para o Microsoft Office Groove 2007, Microsoft SharePoint Workspace 2010, Microsoft Office Forms Server 2007, Microsoft Office SharePoint Server 2007, Microsoft Office SharePoint Server 2010, Microsoft Office Groove Data Bridge Server 2007, Microsoft Office Groove Management Server 2007, Microsoft Groove Server 2010, Microsoft SharePoint Services 2.0, Microsoft SharePoint Services 3.0, Microsoft SharePoint Foundation 2010, Microsoft Office Web Apps 2010 e Microsoft Word Web App 2010. Para mais informações, consulte a subsecção Software Afectado e Software Não Afectado, nesta secção.

A actualização de segurança resolve as vulnerabilidades modificando a forma como o Microsoft SharePoint valida e sanitiza as entradas do utilizador, analisa ficheiros XML e XSL nocivos e processa scripts contidos em parâmetros de pedidos específicos. Para mais informações sobre as vulnerabilidades, consulte a subsecção de Perguntas Mais Frequentes quanto à vulnerabilidade específica na secção seguinte, Informações sobre as Vulnerabilidades.

Recomendação. Os clientes podem configurar as actualizações automáticas para verificar as actualizações online do Microsoft Update utilizando o serviço Microsoft Update. Os clientes que tenham as actualizações automáticas activadas e configuradas para verificar as actualizações online do Microsoft Update geralmente não deverão tomar nenhuma acção porque esta actualização de segurança será transferida e será instalada automaticamente. Os clientes que não tenham as actualizações automáticas activadas necessitam de verificar as actualizações do Microsoft Update e instalar esta actualização manualmente. Para obter informações sobre opções específicas de configuração de actualizações automáticas em edições suportadas do Windows XP e Windows Server 2003, consulte o Artigo 294871 da Base de Dados de Conhecimento da Microsoft. Para obter informações sobre as actualizações automáticas em edições suportadas do Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2, consulte Compreender as actualizações automáticas do Windows.

Para administradores e instalações empresariais, ou utilizadores finais que pretendam instalar esta actualização de segurança manualmente, a Microsoft recomenda que os clientes apliquem a actualização na primeira oportunidade, utilizando software de gestão de actualizações ou verificando as actualizações através do serviço Microsoft Update.

Consulte também a secção Orientações e Ferramentas de Detecção e Implementação, mais à frente neste boletim.

Questões conhecidas. O Artigo 2451858 da Base de Dados de Conhecimento da Microsoft documenta as questões actualmente conhecidas que os clientes podem verificar quando instalam esta actualização de segurança. O artigo também documenta soluções recomendadas para estas questões. Quando as questões actualmente conhecidas e soluções recomendadas software dizem respeito apenas às edições específicas deste software, este artigo não fornece ligações a outros artigos.

Software Afectado e Software Não Afectado

O software que se segue foi testado para determinar quais as versões ou edições afectadas. As outras versões ou edições são antigas, ultrapassaram o respectivo ciclo de vida de suporte ou não são afectadas. Para determinar o ciclo de vida de suporte da versão ou edição do seu software, visite o Web site do Ciclo de Vida de Suporte da Microsoft.

Software Afectado

Microsoft Office

SoftwareImpacto de Segurança MáximoClassificação de Gravidade AgregadaBoletins Substituídos por esta Actualização
Microsoft Office Groove 2007 Service Pack 2
(KB2552997)
Divulgação de InformaçõesImportante MS11-016
Microsoft SharePoint Workspace 2010 e Microsoft SharePoint Workspace 2010 Service Pack 1 (edições de 32 bits)
(KB2566445)
Divulgação de InformaçõesImportanteNenhum
Microsoft SharePoint Workspace 2010 e Microsoft SharePoint Workspace 2010 Service Pack 1 (edições de 64 bits)
(KB2566445)
Divulgação de InformaçõesImportanteNenhum

Software Microsoft Server

SoftwarePacote de Actualização Impacto de Segurança MáximoClassificação de Gravidade AgregadaBoletins Substituídos por esta Actualização
Microsoft Forms Server
Microsoft Office Forms Server 2007 Service Pack 2 (edições de 32 bits)
(KB2553005)
Não aplicávelElevação de PrivilégiosImportanteNenhum
Microsoft Office Forms Server 2007 Service Pack 2 (edições de 64 bits)
(KB2553005)
Não aplicávelElevação de PrivilégiosImportanteNenhum
Microsoft SharePoint Server
Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 32 bits)[1] Microsoft Office SharePoint Server 2007 Service Pack 2 (coreserver) (edições de 32 bits)
(KB2508964)

Microsoft Office SharePoint Server 2007 Service Pack 2 (oserver) (edições de 32 bits)
(KB2553001)

Microsoft Office SharePoint Server 2007 Service Pack 2 (sserverx) (edições de 32 bits)
(KB2553002)

Microsoft Office SharePoint Server 2007 Service Pack 2 (dlc) (edições de 32 bits)
(KB2553003)
Elevação de PrivilégiosImportanteKB2345212 em MS10-072 substituído por KB2508964


Nenhum boletim substituído por KB2553001



Nenhum boletim substituído por KB255002



KB2433089 em MS10-104 substituído por KB2553003
Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 64 bits)[1] Microsoft Office SharePoint Server 2007 Service Pack 2 (coreserver) (edições de 64 bits)
(KB2508964)

Microsoft Office SharePoint Server 2007 Service Pack 2 (oserver) (edições de 64 bits)
(KB2553001)

Microsoft Office SharePoint Server 2007 Service Pack 2 (sserverx) (edições de 64 bits)
(KB2553002)

Microsoft Office SharePoint Server 2007 Service Pack 2 (dlc) (edições de 64 bits)
(KB2553003)
Elevação de PrivilégiosImportanteKB2345212 em MS10-072 substituído por KB2508964


Nenhum boletim substituído por KB2553001



Nenhum boletim substituído por KB255002



KB2433089 em MS10-104 substituído por KB2553003
Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 (osrchwfe)
(KB2494022)

Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 (osrv)
(KB2560885)

Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 (pplwfe)
(KB2560890)

Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 (ppsmawfe)
(KB2566456)

Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 (dlc)
(KB2566954)

Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 (ppsmamui)
(KB2566958)

Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 (wosrv)
(KB2566960)
Elevação de PrivilégiosImportanteNenhum
Microsoft Groove Server
Microsoft Office Groove Data Bridge Server 2007 Service Pack 2
(KB2552999)
Não aplicávelElevação de PrivilégiosImportanteNenhum
Microsoft Office Groove Management Server 2007 Service Pack 2
(KB2552998)
Não aplicávelElevação de PrivilégiosImportanteNenhum
Microsoft Groove Server 2010 e Microsoft Groove Server 2010 Service Pack 1
(KB2508965)
Não aplicávelElevação de PrivilégiosImportante MS10-072
Windows SharePoint Services e Microsoft SharePoint Foundation
Microsoft Windows SharePoint Services 2.0
(KB2494007)
Não aplicávelElevação de PrivilégiosImportanteNenhum
Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 32 bits)
(KB2493987)
Não aplicávelElevação de PrivilégiosImportante MS10-072
Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 64 bits)
(KB2493987)
Não aplicávelElevação de PrivilégiosImportante MS10-072
Microsoft SharePoint Foundation 2010 e Microsoft SharePoint Foundation 2010 Service Pack 1
(KB2494001)
Não aplicávelElevação de PrivilégiosImportante MS10-072

[1]Para as edições suportadas do Microsoft Office SharePoint Server 2007, para além dos pacotes de actualização de segurança para o Microsoft Office SharePoint 2007 (KB2508964, KB2553001, KB2553002 e KB2553003), os clientes têm também de instalar a actualização de segurança para o Microsoft Windows SharePoint Services 3.0 (KB2493987) para estarem protegidos contra as vulnerabilidades descritas neste boletim.

Microsoft Office Web Apps

SoftwareComponentes Impacto de Segurança MáximoClassificação de Gravidade AgregadaBoletins Substituídos por esta Actualização
Microsoft Office Web Apps 2010 e Microsoft Office Web Apps 2010 Service Pack 1
(KB2566449)
Não aplicávelDivulgação de InformaçõesImportante MS11-022
Microsoft Office Web Apps 2010 e Microsoft Office Web Apps 2010 Service Pack 1 Microsoft Word Web App 2010 e Microsoft Word Web App 2010 Service Pack 1
(KB2566450)
Divulgação de InformaçõesImportante MS10-079

Software Não Afectado

Office e Outro Software
Microsoft Office SharePoint Portal Server 2003 Service Pack 3

Por que razão foi revisto este boletim a 11 de Outubro de 2011 ?
A Microsoft reviu este boletim para anunciar as seguintes alterações de lógica de detecção:

  • Para resolver uma questão relacionada com a instalação, a lógica de detecção foi alterada de forma a que a actualização para o Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1 (pplwfe) (KB2560890) deixe de ser oferecida a clientes que executam o Microsoft Office SharePoint Server 2010 em sistemas configurados como parte de conjuntos de servidores SharePoint para sistemas múltiplos. Em vez disso, a actualização deve ser aplicada manualmente num conjunto de servidores Microsoft SharePoint Server 2010. Para obter mais informações sobre a instalação de uma actualização num conjunto de servidores Microsoft SharePoint Server 2010, consulte o artigo TechNet sobre a Instalação de uma actualização de software (SharePoint Server 2010). Trata-se apenas de uma alteração da lógica de detecção. Não foram efectuadas alterações aos ficheiros de actualização de segurança. Os clientes do Microsoft Office SharePoint Server 2010 que tenham aplicado a actualização KB2560890 com sucesso não necessitam de efectuar qualquer acção adicional.
  • Para resolver uma questão de oferta, a lógica de detecção foi corrigida de forma a que a actualização para o Microsoft SharePoint Foundation 2010 e Microsoft SharePoint Foundation 2010 Service Pack 1 (KB2494001) substitua adequadamente os pacotes de actualização anteriores. Trata-se apenas de uma alteração da lógica de detecção. Não foram efectuadas alterações aos ficheiros de actualização de segurança. Os clientes do Microsoft SharePoint Foundation 2010 que tenham aplicado a actualização KB2494001 com sucesso não necessitam de efectuar qualquer acção adicional.

Onde estão os pormenores sobre as informações do ficheiro?
Consulte as tabelas de referência na secção Implementação da Actualização de Segurança para obter a localização dos pormenores sobre as informações do ficheiro.

Como é que esta actualização de segurança está relacionada com o boletim MS11-050?
A Vulnerabilidade de Sanitização de HTML (CVE-2011-1252) é resolvida por esta actualização (MS11-074) e pela Actualização de Segurança Cumulativa para o Internet Explorer (MS11-050).

São necessárias duas actualizações diferentes, uma vez que as modificações necessárias para resolver a questão se encontram em produtos Microsoft diferentes. Esta actualização (MS11-074) resolve a vulnerabilidade em software de produtividade da Microsoft afectado e a MS11-050 resolve a vulnerabilidade no Internet Explorer.

Por que razão esta actualização resolve diversas vulnerabilidades de segurança comunicadas?
Esta actualização contém suporte para diversas vulnerabilidades, porque as modificações necessárias para resolver essas questões estão incluídas nos ficheiros relacionados.

Por que há várias actualizações de pacotes de servidor disponíveis para o Microsoft Office SharePoint Server 2007?
As actualizações necessárias para resolver as vulnerabilidades descritas neste boletim são oferecidas através de diferentes actualizações de pacotes de servidor, conforme indicado na tabela de Software Afectado, devido ao modelo de prestação de serviços em componentes para o Microsoft SharePoint Server 2007. Coreserverx, oserver, sserverx e dlc são os nomes internos dos componentes do SharePoint neste modelo de prestação de serviços.

Por que várias actualizações de pacotes de servidor listadas para o Microsoft Office SharePoint Server 2010?
As actualizações necessárias para resolver as vulnerabilidades descritas neste boletim são oferecidas através de diferentes actualizações de pacotes de servidor, conforme indicado na tabela de Software Afectado, devido ao modelo de prestação de serviços em componentes para o Microsoft SharePoint Server 2010. Mosrchwfe, osrv, pplwfe, ppsmawfe, dlc, ppsmamui e wosrv são os nomes internos dos componentes do SharePoint neste modelo de prestação de serviços.

Utilizo o Microsoft Office SharePoint Server 2007 ou o Microsoft Office SharePoint Server 2010. Tenho de instalar todas as actualizações listadas na tabela de Software Afectado para o software?
Sim. Os clientes devem aplicar todas as actualizações de pacotes de servidor oferecidas para o software instalado nos respectivos sistemas.

Para administradores e instalações empresariais, ou utilizadores finais que pretendam instalar esta actualização de segurança manualmente, dependendo da sua configuração do Microsoft Office SharePoint Server, podem não se aplicar todas as actualizações de pacotes de servidor listadas neste boletim. Para obter mais informações sobre a aplicabilidade destas actualizações de pacotes de servidor num ambiente SharePoint, consulte o Artigo 2451858 da Base de Dados de Conhecimento da Microsoft.

Tenho de instalar estas actualizações de segurança seguindo uma sequência em particular?
Não. As várias actualizações para uma versão do Microsoft Office SharePoint Server podem ser aplicadas seguindo qualquer sequência.

Esta actualização contém outras alterações de segurança em termos de funcionalidade?
Sim. Além das alterações listadas na secção Informações sobre as Vulnerabilidades deste boletim, esta actualização inclui uma actualização de medida de defesa profunda para ajudar a melhorar o processamento de redireccionamentos entre aplicações por parte do Microsoft SharePoint.

O que é uma medida de defesa profunda?
Em termos de segurança de informações, uma medida de defesa profunda refere-se a uma abordagem em que se aplicam múltiplas camadas de defesa para ajudar a impedir que os intrusos comprometam a segurança de uma rede ou sistema.

O que é o Microsoft Groove Server 2010?
O Microsoft Groove Server 2010 oferece serviços abrangentes para gestão do Microsoft SharePoint Workspace. O Groove Server 2010 contém dois componentes: o Groove Server 2010 Manager e o Groove Server 2010 Relay, sendo cada um deles executado num servidor Windows numa rede empresarial.

O que são as Microsoft Office Web Apps?
As Microsoft Office Web Apps são complementos online para as aplicações Office Word, Excel, PowerPoint e OneNote que permitem aos utilizadores aceder e editar documentos, independentemente da sua localização. Os utilizadores podem visualizar, partilhar e trabalhar em documentos com outros utilizadores, utilizando computadores pessoais, telemóveis e a Web. As Office Web Apps encontram-se disponíveis para os clientes empresariais com licenciamento em volume do Microsoft Office 2010 e com soluções de gestão de documentos baseadas em produtos Microsoft SharePoint 2010.

Onde são aplicadas as actualizações para as Microsoft Office Web Apps?
Os clientes que tenham implementado as Microsoft Office Web Apps num ambiente SharePoint terão de aplicar as actualizações para as Microsoft Office Web Apps nos servidores em que estes componentes estão instalados. Para mais informações sobre a implementação de Microsoft Office Web Apps, consulte o artigo Microsoft TechNet sobre como Compreender as Office Web Apps.

Nota A actualização para as Microsoft Office Web Apps não se aplica às estações de trabalho cliente que utilizam um browser da Web para aceder às Microsoft Office Web Apps.

O que é o Microsoft SharePoint Foundation 2010?
O Microsoft SharePoint Foundation 2010 é a nova versão do Microsoft Windows SharePoint Services. É a solução essencial para organizações que necessitam de uma plataforma de colaboração baseada na Web que seja segura e fácil de gerir. O ​SharePoint ajuda a manter as equipadas ligadas e produtivas, proporcionando acesso fácil às pessoas, aos documentos e à informação de que necessitam para tomar decisões bem informadas e concluírem tarefas. Utilize o SharePoint Foundation para coordenar agendas, organizar documentos e participar em discussões através de espaços de trabalho de equipa, blogues, wikis e bibliotecas de documentos na plataforma que serve de infra-estrutura ao SharePoint Server.

O que é o Microsoft Windows SharePoint Services 3.0?
O Windows SharePoint Services 3.0 fornece uma plataforma para aplicações de colaboração, oferecendo um sistema comum para gestão de documentos e um arquivo comum para armazenamento de documentos de todos os tipos. Apresenta serviços do Windows Server essenciais, tais como Windows Workflow Services e Windows Rights Management Services.

O Windows SharePoint Services 3.0 é fornecido como uma transferência gratuita para todas as edições suportadas do Windows Server 2003 e Windows Server 2008.

Qual é a relação entre o Microsoft Windows SharePoint Services 3.0 e o Microsoft Office SharePoint Server 2007?
O Microsoft Office SharePoint Server 2007 é uma suite integrada de capacidades do servidor construídas a partir do Windows SharePoint Services 3.0.

Em sistemas com o Microsoft Office SharePoint Server 2007 instalado, deverá aplicar a actualização KB2493987 para o Windows SharePoint Services 3.0. Em nenhuma configuração poderá ter apenas o Microsoft Office SharePoint Server 2007 e não o Microsoft Windows SharePoint Services 3.0.

Estou a usar uma edição anterior do software discutido neste boletim de segurança. O que devo fazer?
O software afectado incluído neste boletim foi testado para determinar quais as edições afectadas. As outras edições ultrapassaram o respectivo ciclo de vida de suporte. Para obter mais informações sobre o ciclo de vida dos produtos, visite o Web site do Ciclo de Vida de Suporte da Microsoft.

Os utilizadores que tenham edições anteriores do software deviam considerar a migração para edições suportadas como uma prioridade, de modo a poderem proteger os seus sistemas contra a potencial exposição a vulnerabilidades. Para determinar o ciclo de vida de suporte para a edição do seu software, consulte Seleccionar um produto para obter informações sobre o ciclo de vida. Para obter mais informações sobre service packs para estas edições de software, consulte Service Packs com Suporte do Ciclo de Vida.

Os clientes que necessitem de suporte personalizado para software anterior devem contactar o seu representante de equipa de contas da Microsoft, o seu Gestor Técnico de Contas ou o parceiro ou representante Microsoft adequado para mais informações sobre opções de suporte personalizado. Os clientes que não disponham de um Contrato Alliance, Premier ou Autorizado podem contactar a subsidiária local da Microsoft. Para obter informações de contacto, visite o Web site de Informações Microsoft Worldwide, seleccione o país na lista de informações de contacto e, em seguida, clique em Go para ver uma lista de números de telefone. Quando telefonar, peça para falar com o Gestor de Vendas de Suporte Premier local. Para obter mais informações, consulte as Perguntas Mais Frequentes sobre o Ciclo de Vida do Suporte da Microsoft.

Informações sobre as Vulnerabilidades

As seguintes classificações de gravidade presumem o potencial impacto máximo da vulnerabilidade. Para obter informações sobre a probabilidade, dentro de 30 dias após a publicação deste boletim de segurança, de exploração da vulnerabilidade em relação à sua classificação de gravidade e impacto de segurança, consulte o Índice de Possibilidade de Exploração no resumo dos boletins de Setembro. Para obter mais informações, consulte o Índice de Possibilidade de Exploração da Microsoft.

Classificações da Gravidade da Vulnerabilidade e Impacto de Segurança Máximo por Software Afectado
Software AfectadoVulnerabilidade de XSS no Calendário do SharePoint - CVE-2011-0653Vulnerabilidade de Sanitização de HTML - CVE-2011-1252Vulnerabilidade de Introdução de Scripts em Editform - CVE-2011-1890Vulnerabilidade de XSS com Reflexo em Detalhes de Contactos - CVE-2011-1891Vulnerabilidade de Divulgação de Ficheiros Remotos no SharePoint - CVE-2011-1892Vulnerabilidade de XSS no SharePoint - CVE-2011-1893Classificação de Gravidade Agregada
Software Cliente do Microsoft Office
Microsoft Office Groove 2007 Service Pack 2Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft SharePoint Workspace 2010 e Microsoft SharePoint Workspace 2010 Service Pack 1 (edições de 32 bits)Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft SharePoint Workspace 2010 e Microsoft SharePoint Workspace 2010 Service Pack 1 (edições de 64 bits)Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft Forms Server
Microsoft Office Forms Server 2007 Service Pack 2 (edições de 32 bits)Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft Office Forms Server 2007 Service Pack 2 (edições de 64 bits)Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft SharePoint Server
Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 32 bits)Não aplicável Importante
Divulgação de Informações
Não aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 64 bits)Não aplicável Importante
Divulgação de Informações
Não aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft Office SharePoint Server 2010 Importante
Elevação de Privilégios
Importante
Divulgação de Informações
Importante
Elevação de Privilégios
Não aplicável Importante
Divulgação de Informações
Importante
Elevação de Privilégios
Importante
Microsoft Office SharePoint Server 2010 Service Pack 1 Importante
Elevação de Privilégios
Importante
Divulgação de Informações
Não aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft Groove Server
Microsoft Office Groove Data Bridge Server 2007 Service Pack 2 Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft Office Groove Management Server 2007 Service Pack 2 Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft Groove Server 2010 e Microsoft Groove Server 2010 Service Pack 1Não aplicável Importante
Divulgação de Informações
Não aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Windows SharePoint Services e Microsoft SharePoint Foundation
Microsoft Windows SharePoint Services 2.0Não aplicávelNão aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Elevação de Privilégios
Importante
Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 32 bits)Não aplicável Importante
Divulgação de Informações
Não aplicável Importante
Elevação de Privilégios
Importante
Divulgação de Informações
Importante
Elevação de Privilégios
Importante
Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 64 bits)Não aplicável Importante
Divulgação de Informações
Não aplicável Importante
Elevação de Privilégios
Importante
Divulgação de Informações
Importante
Elevação de Privilégios
Importante
SharePoint Foundation 2010 Importante
Elevação de Privilégios
Importante
Divulgação de Informações
Importante
Elevação de Privilégios
Importante
Elevação de Privilégios
Importante
Divulgação de Informações
Importante
Elevação de Privilégios
Importante
SharePoint Foundation 2010 Service Pack 1Não aplicável Importante
Divulgação de Informações
Não aplicável Importante
Elevação de Privilégios
Não aplicávelNão aplicável Importante
Microsoft Office Web Apps
Microsoft Office Web Apps 2010 e Microsoft Office Web Apps 2010 Service Pack 1Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante
Microsoft Office Web Apps 2010 e Microsoft Office Web Apps 2010 Service Pack 1Não aplicávelNão aplicávelNão aplicávelNão aplicável Importante
Divulgação de Informações
Não aplicável Importante

Existe uma vulnerabilidade de processamento de scripts entre sites no Microsoft SharePoint 2010 que poderia resultar em divulgação de informações ou elevação de privilégios se um utilizador clicasse num URL especialmente concebido para o efeito contendo elementos JavaScript nocivos. Devido à vulnerabilidade, quando o JavaScript nocivo é ecoado para o browser do utilizador, a página resultante poderia permitir que um intruso emitisse comandos do SharePoint no contexto do utilizador autenticado no site SharePoint visado.

Para visualizar esta vulnerabilidade como uma entrada comum na lista de Vulnerabilidades e Exposições Comuns, consulte CVE-2011-0653.

Factores Atenuantes para a Vulnerabilidade de XSS no Calendário do SharePoint - CVE-2011-0653

O factor atenuante refere-se a uma definição, uma configuração comum ou uma prática recomendada geral, que existe num estado predefinido, que poderia reduzir a gravidade da exploração de uma vulnerabilidade. Os seguintes factores atenuantes podem ser úteis para a sua situação:

  • No cenário de um ataque baseado na Web, um intruso poderia alojar um Web site contendo uma página Web que fosse utilizada para explorar esta vulnerabilidade. Além disso, os Web sites afectados e os Web sites que aceitam ou alojam conteúdos ou anúncios fornecidos por utilizadores poderiam conter conteúdos especialmente concebidos que poderiam explorar esta vulnerabilidade. Contudo, em qualquer dos casos, o intruso não teria forma de forçar os utilizadores a visitar estes Web sites. Um intruso teria de convencer os utilizadores a visitar o Web site, levando-os normalmente a clicar numa hiperligação presente numa mensagem de correio electrónico, ou numa mensagem de um programa de mensagens instantâneas, que levasse os utilizadores para o Web site do intruso e, em seguida, convencendo-os a clicar num URL especialmente concebido para o efeito, utilizado para explorar esta vulnerabilidade.
  • Os utilizadores do Internet Explorer 8 e do Internet Explorer 9 que naveguem para um site SharePoint na Zona de Internet correm pouco risco, uma vez que, por predefinição, o Filtro XSS no Internet Explorer 8 e no Internet Explorer 9 impede este ataque na Zona de Internet. Contudo, o Filtro XSS no Internet Explorer 8 e no Internet Explorer 9 não está activado por predefinição na Zona de Intranet.
  • Um intruso poderia fazer com que fosse executado código JavaScript arbitrário quando o utilizador clicasse num URL especialmente concebido para o efeito, mas o intruso não seria capaz de furtar as credenciais de autenticação do utilizador com sessão iniciada, graças à forma como o servidor SharePoint processa cookies de autenticação HttpOnly.
  • A vulnerabilidade não pode ser automaticamente explorada através de correio electrónico. Para um ataque poder ser bem sucedido, é necessário que um utilizador clique num URL especialmente concebido para o efeito, enviado numa mensagem de correio electrónico.

Soluções Alternativas para a Vulnerabilidade de XSS no Calendário do SharePoint - CVE-2011-0653

Uma solução alternativa refere-se a uma definição ou alteração de configuração que não corrige a vulnerabilidade subjacente, mas que ajudaria a bloquear vectores de ataque conhecidos antes de aplicar a actualização. A Microsoft testou as seguintes soluções alternativas e indica se a solução alternativa reduz a funcionalidade:

  • Activar o Filtro XSS do Internet Explorer 8 e Internet Explorer 9 na zona de segurança Intranet Local

    Pode ajudar a proteger-se contra a exploração desta vulnerabilidade alterando as suas definições de modo a activar o Filtro XSS na zona de segurança Intranet Local. (O Filtro XSS está activado por predefinição na zona de segurança da Internet.) Para isso, execute os passos seguintes:

    1. No Internet Explorer 8 ou Internet Explorer 9, clique em Opções da Internet, no menu Ferramentas.
    2. Clique no separador Segurança.
    3. Clique em Intranet Local e, em seguida, clique em Personalizar Nível.
    4. Em Definições, na secção de Processamento de scripts, em Activar filtro XSS, clique em Activar e, depois, em OK.
    5. Clique duas vezes em OK para voltar ao Internet Explorer.

    Impacto da solução alternativa. Os sites internos que não estavam anteriormente referenciados com risco de XSS poderiam estar referenciados.

    Como anular esta solução alternativa.

    Para anular esta solução alternativa, siga os seguintes passos.

    1. No Internet Explorer 8 ou Internet Explorer 9, clique em Opções da Internet, no menu Ferramentas.
    2. Clique no separador Segurança.
    3. Clique em Intranet Local e, em seguida, clique em Personalizar Nível.
    4. Em Definições, na secção de Processamento de scripts, em Activar filtro XSS, clique em Desactivar e, depois, em OK.
    5. Clique duas vezes em OK para voltar ao Internet Explorer.

Perguntas Mais Frequentes sobre a Vulnerabilidade de XSS no Calendário do SharePoint - CVE-2011-0653

Qual é a abrangência desta vulnerabilidade?
Esta é uma vulnerabilidade de processamento de scripts entre sites que poderia resultar em elevação de privilégios ou divulgação de informações.

O que provoca a vulnerabilidade?
A vulnerabilidade é provocada quando o Microsoft SharePoint não processa adequadamente elementos JavaScript nocivos contidos num URL especialmente concebido para o efeito, permitindo que o script seja apresentado no browser do utilizador.

O que é a execução de scripts entre sites?
O processamento de scripts entre sites (XSS) é uma classe de vulnerabilidades de segurança que pode permitir que um intruso introduza scripts numa sessão de um utilizador com um Web site. A vulnerabilidade pode afectar servidores Web que geram dinamicamente páginas HTML. Se estes servidores incorporarem dados do browser nas páginas dinâmicas que enviam para o browser, podem ser manipulados para incluir conteúdos fornecidos maliciosamente nas páginas dinâmicas. Isto pode permitir que sejam executados scripts maliciosos. Os browsers da Web poderiam perpetuar este problema, baseados no princípio de que se tratam de sites fidedignos e na forma como utilizam os cookies para manter um estado persistente com os Web sites que frequentam. Um ataque XSS não modifica os conteúdos do Web site. Pelo contrário, insere scripts novos e maliciosos que podem ser executados no browser, no contexto que está associado a um servidor fidedigno.

Como poderia um intruso utilizar a vulnerabilidade?
Um intruso que explorasse esta vulnerabilidade com êxito poderia ler conteúdos que o intruso não estivesse autorizado a ler, utilizar a identidade da vítima para executar acções no site SharePoint em nome da vítima, tais como alteração de permissões e eliminação de conteúdos, e introduzir conteúdos nocivos no browser da vítima.

Como poderia um intruso explorar a vulnerabilidade?
Para que esta vulnerabilidade seja explorada, um utilizador terá de clicar num URL especialmente concebido para o efeito que leve o utilizador para um site SharePoint visado que apresente então o script no browser do utilizador.

Num cenário de ataque com base em correio electrónico, um intruso poderia explorar a vulnerabilidade enviando uma mensagem de correio electrónico que contivesse o URL especialmente concebido para o efeito para o utilizador do site SharePoint visado e convencendo o utilizador a clicar no URL especialmente concebido para o efeito.

No cenário de um ataque baseado na Web, um intruso teria de alojar um Web site contendo um URL especialmente concebido para o efeito no site SharePoint visado que fosse utilizado para tentar explorar esta vulnerabilidade. Além disso, os Web sites afectados e os Web sites que aceitam ou alojam conteúdos fornecidos por utilizadores poderiam conter conteúdos especialmente concebidos que poderiam explorar esta vulnerabilidade. Um intruso não conseguiria obrigar os utilizadores a visitarem um Web site especialmente concebido para o efeito. Um intruso teria de os convencer a visitar o Web site, levando-os normalmente a clicar numa hiperligação presente numa mensagem de correio electrónico, ou numa mensagem de um programa de mensagens instantâneas, que os levasse para o Web site do intruso e, em seguida, convencendo-os a clicar no URL especialmente concebido para o efeito.

Quais os sistemas mais susceptíveis face a esta vulnerabilidade?
Os sistemas em que os utilizadores se ligam a um servidor SharePoint, como estações de trabalho ou servidores de terminal, são mais susceptíveis.

O que é o Filtro de Processamento de Scripts entre Sites (XSS) no Internet Explorer 8 e Internet Explorer 9?
Os ataques de processamento de scripts entre sites tentam explorar as vulnerabilidades dos Web sites que utiliza. No caso desta vulnerabilidade, poderá receber uma mensagem de correio electrónico contendo um endereço de um Web site especialmente concebido para o efeito que inclua elementos JavaScript. Quando clicar no URL, é dirigido para um site SharePoint legítimo, onde é executado o script fornecido pelo intruso. Os ataques de processamento de scripts entre sites têm-se tornado numa das principais ameaças online, pelo que o Internet Explorer 8 e o Internet Explorer 9 incluem um filtro de processamento de scripts entre sites que detecta ataques deste tipo e desactiva os scripts nocivos. Por predefinição, o filtro de processamento de scripts entre sites está ligado no Internet Explorer 8 para a Zona de Internet.

O que faz a actualização?
A actualização resolve a vulnerabilidade corrigindo a forma como o Microsoft SharePoint valida e sanitiza as entradas do utilizador.

Quando este boletim de segurança foi publicado, esta vulnerabilidade já tinha sido divulgada publicamente?
Não. A Microsoft recebeu informações sobre esta vulnerabilidade através de divulgação coordenada de vulnerabilidades.

Quando este boletim de segurança foi publicado, a Microsoft já tinha recebido relatórios indicando que esta vulnerabilidade estava a ser explorada?
Não. A Microsoft ainda não tinha recebido informações que indicassem que esta vulnerabilidade tivesse sido utilizada publicamente para atacar clientes, quando este boletim de segurança foi publicado pela primeira vez.

Existe uma vulnerabilidade de divulgação de informações na forma como a função SafeHTML sanitiza HTML. Um intruso que conseguisse explorar esta vulnerabilidade com êxito poderia efectuar ataques de processamento de scripts entre sites e executar scripts no contexto de segurança do utilizador com sessão iniciada.

Para visualizar esta vulnerabilidade como uma entrada comum na lista de Vulnerabilidades e Exposições Comuns, consulte CVE-2011-1252.

Factores Atenuantes para a Vulnerabilidade de Sanitização de HTML - CVE-2011-1252

A Microsoft não identificou quaisquer factores atenuantes para esta vulnerabilidade.

Soluções Alternativas para a Vulnerabilidade de Sanitização de HTML - CVE-2011-1252

A Microsoft não identificou quaisquer soluções alternativas para esta vulnerabilidade.

Perguntas Mais Frequentes sobre a Vulnerabilidade de Sanitização de HTML - CVE-2011-1252

Qual é a abrangência desta vulnerabilidade?
Trata-se de uma vulnerabilidade ao nível da divulgação de informações. Um intruso que conseguisse explorar esta vulnerabilidade com êxito poderia realizar ataques persistentes de processamento de scripts entre sites contra utilizadores de um site que filtre conteúdo HTML através do SafeHTML.

O que provoca a vulnerabilidade?
A vulnerabilidade é provocada pela forma como a função SafeHTML sanitiza HTML.

O que é a execução de scripts entre sites?
O processamento de scripts entre sites (XSS) é uma classe de vulnerabilidades de segurança que pode permitir que um intruso introduza scripts numa sessão de um utilizador com um Web site. A vulnerabilidade pode afectar servidores Web que geram dinamicamente páginas HTML. Se estes servidores incorporarem dados do browser nas páginas dinâmicas que enviam para o browser, podem ser manipulados para incluir conteúdos fornecidos maliciosamente nas páginas dinâmicas. Isto pode permitir que sejam executados scripts maliciosos. Os browsers da Web poderiam perpetuar este problema, baseados no princípio de que se tratam de sites fidedignos e na forma como utilizam os cookies para manter um estado persistente com os Web sites que frequentam. Um ataque XSS não modifica os conteúdos do Web site. Pelo contrário, insere scripts novos e maliciosos que podem ser executados no browser, no contexto que está associado a um servidor fidedigno.

Como poderia um intruso utilizar a vulnerabilidade?
Um intruso que conseguisse explorar esta vulnerabilidade com êxito poderia realizar ataques de processamento de scripts entre sites contra utilizadores de um site visado que utilize o SafeHTML para sanitizar HTML. Um intruso poderia então executar potencialmente scripts em nome de um utilizador vitimizado no site.

Como poderia um intruso explorar a vulnerabilidade?
Para explorar esta vulnerabilidade, um intruso teria de ter a capacidade de enviar um script especialmente concebido para o efeito para um site visado que utilize SafeHTML. Devido à vulnerabilidade, em situações específicas, o script especialmente concebido para o efeito não é sanitizado de forma correcta, o que poderia levar subsequentemente à execução de um script fornecido pelo intruso no contexto de segurança de um utilizador que visualizasse o conteúdo malicioso.

Em ataques de processamento de scripts entre sites, esta vulnerabilidade requer que um utilizador visite um site afectado para que ocorra alguma acção maliciosa. Por exemplo, depois de um intruso ter submetido com êxito um script especialmente concebido para o efeito para o site visado que utiliza SafeHTML, qualquer página Web naquele site que contenha o script especialmente concebido para o efeito é um potencial vector para ataques persistentes de processamento de scripts entre sites. Quando um utilizador visita uma página Web que contém o script especialmente concebido para o efeito, o script pode ser executado no contexto de segurança do utilizador.

Quais os sistemas mais susceptíveis face a esta vulnerabilidade?
Os sistemas em que os utilizadores se ligam a um servidor que utilize SafeHTML para sanitizar conteúdo HTML, tais como estações de trabalho ou servidores de terminal, são mais susceptíveis.

O que faz a actualização?
A actualização resolve a vulnerabilidade modificando a forma como o SafeHTML sanitiza o conteúdo HTML.

Quando este boletim de segurança foi publicado, esta vulnerabilidade já tinha sido divulgada publicamente?
Sim. Esta vulnerabilidade foi divulgada publicamente. Foi-lhe atribuído o número de Vulnerabilidade e Exposição Comum CVE-2011-1252.

Quando este boletim de segurança foi publicado, a Microsoft já tinha recebido relatórios indicando que esta vulnerabilidade estava a ser explorada?
Não. A Microsoft não tinha recebido quaisquer informações que indicassem que esta vulnerabilidade tivesse sido utilizada publicamente para atacar clientes e não tinha conhecimento de exemplos publicados de código para prova de conceito quando este boletim de segurança foi criado pela primeira vez.

Existe uma vulnerabilidade de processamento de scripts entre sites, divulgação de informações e elevação de privilégios no Microsoft SharePoint 2010 e Microsoft Foundation 2010 se um utilizador visitar um Web site especialmente concebido para o efeito. Devido à vulnerabilidade, pode ser introduzido JavaScript nocivo num artigo apresentado num site SharePoint visado. O script introduzido poderia permitir que um intruso emitisse comandos SharePoint no contexto do utilizador autenticado no site SharePoint visado.

Para visualizar esta vulnerabilidade como uma entrada comum na lista de Vulnerabilidades e Exposições Comuns, consulte CVE-2011-1890.

Factores Atenuantes para a Vulnerabilidade de Introdução de Scripts em Editform - CVE-2011-1890

O factor atenuante refere-se a uma definição, uma configuração comum ou uma prática recomendada geral, que existe num estado predefinido, que poderia reduzir a gravidade da exploração de uma vulnerabilidade. Os seguintes factores atenuantes podem ser úteis para a sua situação:

  • No cenário de um ataque baseado na Web, um intruso poderia alojar um Web site contendo uma página Web que fosse utilizada para explorar esta vulnerabilidade. Além disso, os Web sites afectados e os Web sites que aceitam ou alojam conteúdos ou anúncios fornecidos por utilizadores poderiam conter conteúdos especialmente concebidos que poderiam explorar esta vulnerabilidade. Contudo, em qualquer dos casos, o intruso não teria forma de forçar os utilizadores a visitar estes Web sites. Em vez disso, um intruso teria de convencer os utilizadores a visitar o Web site, levando-os normalmente a clicar numa hiperligação presente numa mensagem de correio electrónico, ou num programa de mensagens instantâneas, que levasse o utilizador para o Web site do intruso.
  • Os utilizadores do Internet Explorer 8 e do Internet Explorer 9 que naveguem para um site SharePoint na Zona de Internet correm pouco risco, uma vez que, por predefinição, o Filtro XSS no Internet Explorer 8 impede este ataque na Zona de Internet. Contudo, o Filtro XSS no Internet Explorer 8 e no Internet Explorer 9 não está activado por predefinição na Zona de Intranet.
  • Um intruso poderia fazer com que fosse executado código JavaScript arbitrário pelo utilizador que visitasse um Web site especialmente concebido para o efeito, mas o intruso não seria capaz de furtar as credenciais de autenticação do utilizador com sessão iniciada, graças à forma como o servidor SharePoint processa cookies de autenticação HttpOnly.
  • A vulnerabilidade não pode ser automaticamente explorada através de correio electrónico. Para que um ataque seja bem sucedido, um utilizador tem de clicar numa hiperligação para um Web site especialmente concebido para o efeito, enviado numa mensagem de correio electrónico.

Soluções Alternativas para a Vulnerabilidade de Introdução de Scripts em Editform - CVE-2011-1890

Uma solução alternativa refere-se a uma definição ou alteração de configuração que não corrige a vulnerabilidade subjacente, mas que ajudaria a bloquear vectores de ataque conhecidos antes de aplicar a actualização. A Microsoft testou as seguintes soluções alternativas e indica se a solução alternativa reduz a funcionalidade:

  • Activar o Filtro XSS do Internet Explorer 8 e Internet Explorer 9 na zona de segurança Intranet Local

    Pode ajudar a proteger-se contra a exploração desta vulnerabilidade alterando as suas definições de modo a activar o Filtro XSS na zona de segurança Intranet Local (o Filtro XSS está activado por predefinição na zona de segurança da Internet). Para isso, execute os passos seguintes:

    1. No Internet Explorer 8 ou Internet Explorer 9, clique em Opções da Internet, no menu Ferramentas.
    2. Clique no separador Segurança.
    3. Clique em Intranet Local e, em seguida, clique em Personalizar Nível.
    4. Em Definições, na secção de Processamento de scripts, em Activar filtro XSS, clique em Activar e, depois, em OK.
    5. Clique duas vezes em OK para voltar ao Internet Explorer.

    Impacto da solução alternativa. Os sites internos que não estavam anteriormente referenciados com risco de XSS poderiam estar referenciados.

    Como anular esta solução alternativa.

    Para anular esta solução alternativa, siga os seguintes passos.

    1. No Internet Explorer 8 ou Internet Explorer 9, clique em Opções da Internet, no menu Ferramentas.
    2. Clique no separador Segurança.
    3. Clique em Intranet Local e, em seguida, clique em Personalizar Nível.
    4. Em Definições, na secção de Processamento de scripts, em Activar filtro XSS, clique em Desactivar e, depois, em OK.
    5. Clique duas vezes em OK para voltar ao Internet Explorer.

Perguntas Mais Frequentes sobre a Vulnerabilidade de Introdução de Scripts em Editform - CVE-2011-1890

Qual é a abrangência desta vulnerabilidade?
Esta é uma vulnerabilidade de processamento de scripts entre sites que poderia resultar em elevação de privilégios ou divulgação de informações.

O que provoca a vulnerabilidade?
Esta vulnerabilidade é provocada quando o Microsoft SharePoint não valida adequadamente entradas do utilizador colocadas em páginas Web EditForm.aspx.

O que é a execução de scripts entre sites?
O processamento de scripts entre sites (XSS) é uma classe de vulnerabilidades de segurança que pode permitir que um intruso introduza scripts numa sessão de um utilizador com um Web site. A vulnerabilidade pode afectar servidores Web que geram dinamicamente páginas HTML. Se estes servidores incorporarem dados do browser nas páginas dinâmicas que enviam para o browser, podem ser manipulados para incluir conteúdos fornecidos maliciosamente nas páginas dinâmicas. Isto pode permitir que sejam executados scripts maliciosos. Os browsers da Web poderiam perpetuar este problema, baseados no princípio de que se tratam de sites fidedignos e na forma como utilizam os cookies para manter um estado persistente com os Web sites que frequentam. Um ataque XSS não modifica os conteúdos do Web site. Pelo contrário, insere scripts novos e maliciosos que podem ser executados no browser, no contexto que está associado a um servidor fidedigno.

Como poderia um intruso utilizar a vulnerabilidade?
Um intruso que explorasse esta vulnerabilidade com êxito poderia utilizar scripts para emitir comandos SharePoint no contexto do utilizador autenticado no site SharePoint visado. .

Como poderia um intruso explorar a vulnerabilidade?
Num cenário de ataque com base em correio electrónico, um intruso poderia explorar a vulnerabilidade enviando ao utilizador uma mensagem de correio electrónico que contivesse uma hiperligação para um Web site especialmente concebido para o efeito e convencendo o utilizador a clicar na hiperligação.

Num cenário de ataque com base na Web, um intruso teria de alojar um Web site contendo uma página Web especialmente concebida para o efeito que fosse utilizada para tentar explorar esta vulnerabilidade. Além disso, os Web sites afectados e os Web sites que aceitam ou alojam conteúdos fornecidos por utilizadores poderiam conter conteúdos especialmente concebidos que poderiam explorar esta vulnerabilidade. Um intruso não conseguiria obrigar os utilizadores a visitarem um Web site especialmente concebido para o efeito. Em vez disso, um intruso teria de convencê-los a visitar o Web site, levando-os normalmente a clicar numa hiperligação presente numa mensagem de correio electrónico ou num programa de mensagens instantâneas que os levasse para o Web site do intruso.

Quais os sistemas mais susceptíveis face a esta vulnerabilidade?
Os sistemas em que os utilizadores se ligam a um servidor SharePoint, como estações de trabalho ou servidores de terminal, são mais susceptíveis.

O que faz a actualização?
A actualização resolve a vulnerabilidade modificando a forma como o Microsoft SharePoint valida entradas do utilizador para impedir a introdução e o processamento de JavaScript nocivo no browser do utilizador.

Quando este boletim de segurança foi publicado, esta vulnerabilidade já tinha sido divulgada publicamente?
Não. A Microsoft recebeu informações sobre esta vulnerabilidade através de divulgação coordenada de vulnerabilidades.

Quando este boletim de segurança foi publicado, a Microsoft já tinha recebido relatórios indicando que esta vulnerabilidade estava a ser explorada?
Não. A Microsoft ainda não tinha recebido informações que indicassem que esta vulnerabilidade tivesse sido utilizada publicamente para atacar clientes, quando este boletim de segurança foi publicado pela primeira vez.

Uma vulnerabilidade de processamento de scripts entre sites no Microsoft SharePoint poderia permitir que um intruso obtivesse controlo sobre contas válidas de utilizadores, executasse operações em nome do utilizador, redireccionasse o utilizador para sites nocivos ou furtasse credenciais do utilizador.

Para visualizar esta vulnerabilidade como uma entrada comum na lista de Vulnerabilidades e Exposições Comuns, consulte CVE-2011-1891.

Factores Atenuantes para a Vulnerabilidade de XSS com Reflexo em Detalhes de Contactos - CVE-2011-1891

O factor atenuante refere-se a uma definição, uma configuração comum ou uma prática recomendada geral, que existe num estado predefinido, que poderia reduzir a gravidade da exploração de uma vulnerabilidade. Os seguintes factores atenuantes podem ser úteis para a sua situação:

  • No cenário de um ataque baseado na Web, um intruso poderia alojar um Web site contendo uma página Web que fosse utilizada para explorar esta vulnerabilidade. Além disso, os Web sites afectados e os Web sites que aceitam ou alojam conteúdos ou anúncios fornecidos por utilizadores poderiam conter conteúdos especialmente concebidos que poderiam explorar esta vulnerabilidade. Contudo, em qualquer dos casos, o intruso não teria forma de forçar os utilizadores a visitar estes Web sites. Um intruso teria de convencer os utilizadores a visitar o Web site, levando-os normalmente a clicar numa hiperligação presente numa mensagem de correio electrónico, ou numa mensagem de um programa de mensagens instantâneas, que levasse os utilizadores para o Web site do intruso e, em seguida, convencendo-os a clicar num URL especialmente concebido para o efeito, utilizado para explorar esta vulnerabilidade.
  • Os utilizadores do Internet Explorer 8 e do Internet Explorer 9 que naveguem para um site SharePoint na Zona de Internet correm pouco risco, uma vez que, por predefinição, o Filtro XSS no Internet Explorer 8 impede este ataque na Zona de Internet. Contudo, o Filtro XSS no Internet Explorer 8 e no Internet Explorer 9 não está activado por predefinição na Zona de Intranet.
  • Um intruso poderia fazer com que fosse executado código JavaScript arbitrário pelo utilizador ao clicar no URL especialmente concebido para o efeito, mas o intruso não seria capaz de furtar as credenciais de autenticação do utilizador com sessão iniciada, graças à forma como o servidor SharePoint processa cookies de autenticação HttpOnly.
  • A vulnerabilidade não pode ser automaticamente explorada através de correio electrónico. Para um ataque poder ser bem sucedido, é necessário que um utilizador clique num URL especialmente concebido para o efeito, enviado numa mensagem de correio electrónico.

Soluções Alternativas para a Vulnerabilidade de XSS com Reflexo em Detalhes de Contactos - CVE-2011-1891

Uma solução alternativa refere-se a uma definição ou alteração de configuração que não corrige a vulnerabilidade subjacente, mas que ajudaria a bloquear vectores de ataque conhecidos antes de aplicar a actualização. A Microsoft testou as seguintes soluções alternativas e indica se a solução alternativa reduz a funcionalidade:

  • Activar o Filtro XSS do Internet Explorer 8 e Internet Explorer 9 na zona de segurança Intranet Local

    Pode ajudar a proteger-se contra a exploração desta vulnerabilidade alterando as suas definições de modo a activar o Filtro XSS na zona de segurança Intranet Local (o Filtro XSS está activado por predefinição na zona de segurança da Internet). Para isso, execute os passos seguintes:

    1. No Internet Explorer 8 ou Internet Explorer 9, clique em Opções da Internet, no menu Ferramentas.
    2. Clique no separador Segurança.
    3. Clique em Intranet Local e, em seguida, clique em Personalizar Nível.
    4. Em Definições, na secção de Processamento de scripts, em Activar filtro XSS, clique em Activar e, depois, em OK.
    5. Clique duas vezes em OK para voltar ao Internet Explorer.

    Impacto da solução alternativa. Os sites internos que não estavam anteriormente referenciados com risco de XSS poderiam estar referenciados.

    Como anular esta solução alternativa.

    Para anular esta solução alternativa, siga os seguintes passos.

    1. No Internet Explorer 8 ou Internet Explorer 9, clique em Opções da Internet, no menu Ferramentas.
    2. Clique no separador Segurança.
    3. Clique em Intranet Local e, em seguida, clique em Personalizar Nível.
    4. Em Definições, na secção de Processamento de scripts, em Activar filtro XSS, clique em Desactivar e, depois, em OK.
    5. Clique duas vezes em OK para voltar ao Internet Explorer.

Perguntas Mais Frequentes sobre a Vulnerabilidade de XSS com Reflexo em Detalhes de Contactos - CVE-2011-1891

Qual é a abrangência desta vulnerabilidade?
Esta é uma vulnerabilidade de processamento de scripts entre sites que poderia resultar em elevação de privilégios ou divulgação de informações.

O que provoca a vulnerabilidade?
Esta vulnerabilidade é provocada por uma sanitização de entradas inadequada em parâmetros específicos do SharePoint.

O que é a execução de scripts entre sites?
O processamento de scripts entre sites (XSS) é uma classe de vulnerabilidades de segurança que pode permitir que um intruso introduza scripts numa sessão de um utilizador com um Web site. A vulnerabilidade pode afectar servidores Web que geram dinamicamente páginas HTML. Se estes servidores incorporarem dados do browser nas páginas dinâmicas que enviam para o browser, podem ser manipulados para incluir conteúdos fornecidos maliciosamente nas páginas dinâmicas. Isto pode permitir que sejam executados scripts maliciosos. Os browsers da Web poderiam perpetuar este problema, baseados no princípio de que se tratam de sites fidedignos e na forma como utilizam os cookies para manter um estado persistente com os Web sites que frequentam. Um ataque XSS não modifica os conteúdos do Web site. Pelo contrário, insere scripts novos e maliciosos que podem ser executados no browser, no contexto que está associado a um servidor fidedigno.

Como poderia um intruso utilizar a vulnerabilidade?
Para activar a vulnerabilidade, o utilizador é induzido a visitar um site que enviará um formulário especialmente concebido para o efeito contendo scripts nocivos para o site SharePoint vulnerável.

Um intruso que explorasse esta vulnerabilidade com êxito poderia introduzir scripts para captar credenciais do utilizador, ou executar acções em nome do utilizador, tais como alterar permissões e modificar ou eliminar conteúdos, num site SharePoint visado.

Como poderia um intruso explorar a vulnerabilidade?
Um intruso poderia explorar esta vulnerabilidade convencendo um utilizador a enviar um formulário especialmente concebido para o efeito que envia scripts nocivos para uma instância afectada do SharePoint 2007.

Quais os sistemas mais susceptíveis face a esta vulnerabilidade?
Os sistemas cliente que se ligam ao SharePoint 2007 e a servidores com o SharePoint 2007 estão susceptíveis a esta vulnerabilidade.

O que é o Filtro de Processamento de Scripts entre Sites (XSS) no Internet Explorer 8 e Internet Explorer 9?
Os ataques de processamento de scripts entre sites tentam explorar as vulnerabilidades dos Web sites que utiliza. No caso desta vulnerabilidade, poderá receber uma mensagem de correio electrónico contendo um endereço de um Web site especialmente concebido para o efeito que inclua elementos JavaScript. Quando clicar no URL, é dirigido para um site SharePoint legítimo, onde é executado o script fornecido pelo intruso. Os ataques de processamento de scripts entre sites têm-se tornado numa das principais ameaças online, pelo que o Internet Explorer 8 e o Internet Explorer 9 incluem um filtro de processamento de scripts entre sites que detecta ataques deste tipo e desactiva os scripts nocivos. Por predefinição, o filtro de processamento de scripts entre sites está activado no Internet Explorer 8 e no Internet Explorer 9 para a Zona de Internet.

O que faz a actualização?
A actualização resolve a vulnerabilidade modificando a forma como o servidor SharePoint processa pedidos de scripts.

Quando este boletim de segurança foi publicado, esta vulnerabilidade já tinha sido divulgada publicamente?
Não. A Microsoft recebeu informações sobre esta vulnerabilidade através de divulgação coordenada de vulnerabilidades.

Quando este boletim de segurança foi publicado, a Microsoft já tinha recebido relatórios indicando que esta vulnerabilidade estava a ser explorada?
Não. A Microsoft ainda não tinha recebido informações que indicassem que esta vulnerabilidade tivesse sido utilizada publicamente para atacar clientes, quando este boletim de segurança foi publicado pela primeira vez.

Existe uma vulnerabilidade de divulgação de ficheiros no Microsoft Office SharePoint que poderia permitir que um utilizador autenticado malicioso utilizasse um ficheiro XML especialmente concebido para o efeito de modo a obter acesso apenas de leitura a um ficheiro local no servidor SharePoint no contexto de segurança da conta em execução no SharePoint.

Para visualizar esta vulnerabilidade como uma entrada comum na lista de Vulnerabilidades e Exposições Comuns, consulte CVE-2011-1892.

Factores Atenuantes para a Vulnerabilidade de Divulgação de Ficheiros Remotos no SharePoint - CVE-2011-1892

O factor atenuante refere-se a uma definição, uma configuração comum ou uma prática recomendada geral, que existe num estado predefinido, que poderia reduzir a gravidade da exploração de uma vulnerabilidade. Os seguintes factores atenuantes podem ser úteis para a sua situação:

  • O intruso não poderia executar código arbitrário no servidor SharePoint visado. Trata-se de uma vulnerabilidade apenas ao nível da divulgação de informações.
  • O intruso teria de estar autenticado no site SharePoint para poder explorar esta vulnerabilidade.

Soluções Alternativas para a Vulnerabilidade de Divulgação de Ficheiros Remotos no SharePoint - CVE-2011-1892

A Microsoft não identificou quaisquer soluções alternativas para esta vulnerabilidade.

Perguntas Mais Frequentes sobre a Vulnerabilidade de Divulgação de Ficheiros Remotos no SharePoint - CVE-2011-1892

Qual é a abrangência desta vulnerabilidade?
Trata-se de uma vulnerabilidade ao nível da divulgação de informações.

O que provoca a vulnerabilidade?
Esta vulnerabilidade é provocada quando o SharePoint não restringe adequadamente a utilização de classes XML e entidades externas especialmente concebidas para o efeito em componentes Web.

Como poderia um intruso utilizar a vulnerabilidade?
Um intruso poderia utilizar esta vulnerabilidade para obter acesso de leitura a ficheiros no sistema de ficheiros do servidor SharePoint local com as permissões de acesso da conta AppPool do IIS.

Como poderia um intruso explorar a vulnerabilidade?
Um utilizador autenticado no site SharePoint poderia utilizar um ficheiro XML e XSL especialmente concebido para o efeito para criar um componente Web nocivo utilizado para obter acesso ao ficheiro no servidor SharePoint visado.

Quais os sistemas mais susceptíveis face a esta vulnerabilidade?
Os servidores com o software Microsoft SharePoint afectado estão mais susceptíveis.

O que faz a actualização?
A actualização resolve a vulnerabilidade modificando a forma como o Microsoft SharePoint analisa ficheiros XML e XSL nocivos, restringindo assim a capacidade de divulgar ficheiros no sistema de ficheiros do servidor SharePoint local.

Quando este boletim de segurança foi publicado, esta vulnerabilidade já tinha sido divulgada publicamente?
Não. A Microsoft recebeu informações sobre esta vulnerabilidade através de divulgação coordenada de vulnerabilidades.

Quando este boletim de segurança foi publicado, a Microsoft já tinha recebido relatórios indicando que esta vulnerabilidade estava a ser explorada?
Não. A Microsoft ainda não tinha recebido informações que indicassem que esta vulnerabilidade tivesse sido utilizada publicamente para atacar clientes, quando este boletim de segurança foi publicado pela primeira vez.

Existe uma vulnerabilidade de processamento de scripts entre sites, divulgação de informações e elevação de privilégios no Microsoft SharePoint Server e no Windows SharePoint Services, em que o JavaScript codificado num URL especialmente concebido para o efeito pode ser reflectido para o utilizador na página resultante, permitindo que um intruso emita comandos SharePoint no contexto do utilizador autenticado num site SharePoint visado.

Para visualizar esta vulnerabilidade como uma entrada comum na lista de Vulnerabilidades e Exposições Comuns, consulte CVE-2011-1893.

Factores Atenuantes para a Vulnerabilidade de XSS no SharePoint - CVE-2011-1893

O factor atenuante refere-se a uma definição, uma configuração comum ou uma prática recomendada geral, que existe num estado predefinido, que poderia reduzir a gravidade da exploração de uma vulnerabilidade. Os seguintes factores atenuantes podem ser úteis para a sua situação:

  • No cenário de um ataque baseado na Web, um intruso poderia alojar um Web site contendo uma página Web que fosse utilizada para explorar esta vulnerabilidade. Além disso, os Web sites afectados e os Web sites que aceitam ou alojam conteúdos ou anúncios fornecidos por utilizadores poderiam conter conteúdos especialmente concebidos que poderiam explorar esta vulnerabilidade. Contudo, em qualquer dos casos, o intruso não teria forma de forçar os utilizadores a visitar estes Web sites. Em vez disso, um intruso teria de convencer os utilizadores a visitar o Web site, levando-os normalmente a clicar numa hiperligação presente numa mensagem de correio electrónico, ou num programa de mensagens instantâneas, que levasse o utilizador para o Web site do intruso.
  • Os utilizadores do Internet Explorer 8 e do Internet Explorer 9 que naveguem para um site SharePoint na Zona de Internet correm pouco risco, uma vez que, por predefinição, o Filtro XSS no Internet Explorer 8 impede este ataque na Zona de Internet. Contudo, o Filtro XSS no Internet Explorer 8 e no Internet Explorer 9 não está activado por predefinição na Zona de Intranet.
  • Um intruso poderia fazer com que fosse executado código JavaScript arbitrário pelo utilizador que visitasse um Web site especialmente concebido para o efeito, mas o intruso não seria capaz de furtar as credenciais de autenticação do utilizador com sessão iniciada, graças à forma como o servidor SharePoint processa cookies de autenticação HttpOnly.
  • A vulnerabilidade não pode ser automaticamente explorada através de correio electrónico. Para que um ataque seja bem sucedido, um utilizador tem de clicar numa hiperligação para um Web site especialmente concebido para o efeito, enviado numa mensagem de correio electrónico.

Soluções Alternativas para a Vulnerabilidade de XSS no SharePoint - CVE-2011-1893

Uma solução alternativa refere-se a uma definição ou alteração de configuração que não corrige a vulnerabilidade subjacente, mas que ajudaria a bloquear vectores de ataque conhecidos antes de aplicar a actualização. A Microsoft testou as seguintes soluções alternativas e indica se a solução alternativa reduz a funcionalidade:

  • Activar o Filtro XSS do Internet Explorer 8 e Internet Explorer 9 na zona de segurança Intranet Local

    Pode ajudar a proteger-se contra a exploração desta vulnerabilidade alterando as suas definições de modo a activar o Filtro XSS na zona de segurança Intranet Local (o Filtro XSS está activado por predefinição na zona de segurança da Internet). Para isso, execute os passos seguintes:

    1. No Internet Explorer 8 ou Internet Explorer 9, clique em Opções da Internet, no menu Ferramentas.
    2. Clique no separador Segurança.
    3. Clique em Intranet Local e, em seguida, clique em Personalizar Nível.
    4. Em Definições, na secção de Processamento de scripts, em Activar filtro XSS, clique em Activar e, depois, em OK.
    5. Clique duas vezes em OK para voltar ao Internet Explorer.

    Impacto da solução alternativa. Os sites internos que não estavam anteriormente referenciados com risco de XSS poderiam estar referenciados.

    Como anular esta solução alternativa.

    Para anular esta solução alternativa, siga os seguintes passos.

    1. No Internet Explorer 8 ou Internet Explorer 9, clique em Opções da Internet, no menu Ferramentas.
    2. Clique no separador Segurança.
    3. Clique em Intranet Local e, em seguida, clique em Personalizar Nível.
    4. Em Definições, na secção de Processamento de scripts, em Activar filtro XSS, clique em Desactivar e, depois, em OK.
    5. Clique duas vezes em OK para voltar ao Internet Explorer.

Perguntas Mais Frequentes sobre a Vulnerabilidade de XSS no SharePoint - CVE-2011-1893

Qual é a abrangência desta vulnerabilidade?
Esta é uma vulnerabilidade de processamento de scripts entre sites que poderia resultar em elevação de privilégios ou divulgação de informações.

O que provoca a vulnerabilidade?
Esta vulnerabilidade é provocada pela sanitização de entradas que permite que um URL nocivo contendo elementos JavaScript seja apresentado ao utilizador.

O que é a execução de scripts entre sites?
O processamento de scripts entre sites (XSS) é uma classe de vulnerabilidades de segurança que pode permitir que um intruso introduza scripts numa sessão de um utilizador com um Web site. A vulnerabilidade pode afectar servidores Web que geram dinamicamente páginas HTML. Se estes servidores incorporarem dados do browser nas páginas dinâmicas que enviam para o browser, podem ser manipulados para incluir conteúdos fornecidos maliciosamente nas páginas dinâmicas. Isto pode permitir que sejam executados scripts maliciosos. Os browsers da Web poderiam perpetuar este problema, baseados no princípio de que se tratam de sites fidedignos e na forma como utilizam os cookies para manter um estado persistente com os Web sites que frequentam. Um ataque XSS não modifica os conteúdos do Web site. Pelo contrário, insere scripts novos e maliciosos que podem ser executados no browser, no contexto que está associado a um servidor fidedigno.

Como poderia um intruso utilizar a vulnerabilidade?
Um intruso que explorasse esta vulnerabilidade com êxito poderia fazer reflectir JavaScript nocivo no browser do utilizador, podendo permitir que o intruso modificasse os conteúdos da página, realizasse phishing e executasse acções em nome do utilizador.

Como poderia um intruso explorar a vulnerabilidade?
Para que esta vulnerabilidade seja explorada, um utilizador terá de clicar num URL especialmente concebido para o efeito.

Num cenário de ataque com base em correio electrónico, um intruso poderia explorar a vulnerabilidade enviando uma mensagem de correio electrónico que contivesse o URL especialmente concebido para o efeito para o utilizador do site SharePoint visado e convencendo o utilizador a clicar no URL especialmente concebido para o efeito.

No cenário de um ataque baseado na Web, um intruso teria de alojar um Web site contendo um URL especialmente concebido para o efeito no site SharePoint visado que fosse utilizado para tentar explorar esta vulnerabilidade. Além disso, os Web sites afectados e os Web sites que aceitam ou alojam conteúdos fornecidos por utilizadores poderiam conter conteúdos especialmente concebidos que poderiam explorar esta vulnerabilidade. Um intruso não conseguiria obrigar os utilizadores a visitarem um Web site especialmente concebido para o efeito. Um intruso teria de os convencer a visitar o Web site, levando-os normalmente a clicar numa hiperligação presente numa mensagem de correio electrónico, ou numa mensagem de um programa de mensagens instantâneas, que os levasse para o Web site do intruso e, em seguida, convencendo-os a clicar no URL especialmente concebido para o efeito.

Quais os sistemas mais susceptíveis face a esta vulnerabilidade?
Os sistemas cliente que utilizam o Microsoft Windows SharePoint Services ou se ligam ao Microsoft SharePoint Server, tais como estações de trabalho ou servidores de terminal, estão mais susceptíveis.

O que faz a actualização?
A actualização resolve a vulnerabilidade modificando a forma como o Microsoft SharePoint valida e sanitiza entradas do utilizador para bloquear o vector de ataque de XSS com reflexo.

Quando este boletim de segurança foi publicado, esta vulnerabilidade já tinha sido divulgada publicamente?
Não. A Microsoft recebeu informações sobre esta vulnerabilidade através de divulgação coordenada de vulnerabilidades.

Quando este boletim de segurança foi publicado, a Microsoft já tinha recebido relatórios indicando que esta vulnerabilidade estava a ser explorada?
Não. A Microsoft ainda não tinha recebido informações que indicassem que esta vulnerabilidade tivesse sido utilizada publicamente para atacar clientes, quando este boletim de segurança foi publicado pela primeira vez.

Informação de Actualização

Centro de segurança

Faça a gestão do software e actualizações de segurança de que necessita para implementação em servidores, ambientes de trabalho e sistemas portáteis na sua organização. Para obter mais informações, visite o TechNet Update Management Center. O Web site Microsoft TechNet Security fornece informações adicionais sobre segurança em produtos Microsoft.

As actualizações de segurança estão disponíveis no Microsoft Update e no Windows Update. As actualizações de segurança estão também disponíveis no Centro de Transferências da Microsoft. Pode encontrá-las mais facilmente através de uma procura pelas palavras "security update".

Para os clientes de Microsoft Office para Mac, o Microsoft AutoUpdate para Mac pode ajudar a manter o seu software da Microsoft actualizado. Para obter mais informações sobre como utilizar o Microsoft AutoUpdate para Mac, consulte Verificar actualizações de software automaticamente.

Por fim, as actualizações de segurança podem ser transferidas a partir do Catálogo do Microsoft Update. O Catálogo do Microsoft Update permite pesquisar conteúdos disponibilizados através do Windows Update e do Microsoft Update, incluindo actualizações de segurança, controladores e service packs. Utilizando o número do boletim de segurança para pesquisar (por exemplo, "MS07-036"), pode adicionar todas as actualizações aplicáveis ao seu cesto (incluindo diferentes idiomas para uma actualização) e transferi-las para uma pasta à sua escolha. Para obter mais informação sobre o Catálogo do Microsoft Update, consulte as Perguntas Mais Frequentes sobre o Catálogo do Microsoft Update.

Orientações de detecção e implementação

A Microsoft fornece orientações sobre detecção e implementação de actualizações de segurança. Estas orientações contêm recomendações e informação que podem auxiliar os profissionais de TI a compreender como utilizar as diversas ferramentas para detecção e implementação de actualizações de segurança. Para obter mais informações, consulte o Artigo 961747 da Base de Dados de Conhecimento da Microsoft.

Microsoft Baseline Security Analyzer

O Microsoft Baseline Security Analyzer (MBSA) permite aos administradores procurar actualizações de segurança em falta e comuns erros de configuração de segurança em sistemas locais e remotos. Para obter mais informações acerca do MBSA, visite o Web site do Microsoft Baseline Security Analyzer.

A tabela seguinte fornece o resumo de detecções do MBSA para esta actualização de segurança.

Software MBSA
Microsoft Office Groove 2007 Service Pack 2Sim
Microsoft SharePoint Workspace 2010 e Microsoft SharePoint Workspace 2010 Service Pack 1Sim
Microsoft Office Forms Server 2007 Service Pack 2 (edições de 32 bits)Sim
Microsoft Office Forms Server 2007 Service Pack 2 (edições de 64 bits)Sim
Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 32 bits)Sim
Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 64 bits)Sim
Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1Sim
Microsoft Office Groove Data Bridge Server 2007 Service Pack 2 Sim
Microsoft Office Groove Management Server 2007 Service Pack 2 Sim
Microsoft Groove Server 2010 e Microsoft Groove Server 2010 Service Pack 1Sim
Microsoft Windows SharePoint Services 2.0Sim
Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 32 bits)Sim
Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 64 bits)Sim
SharePoint Foundation 2010 e SharePoint Foundation 2010 Service Pack 1Sim
Microsoft Office Web Apps 2010 e Microsoft Office Web Apps 2010 Service Pack 1Sim
Microsoft Word Web App 2010 e Microsoft Word Web App 2010 Service Pack 1Sim

Nota Para clientes que utilizam software antigo não suportado pela versão mais recente do MBSA, Microsoft Update e Windows Server Update Services, visite Microsoft Baseline Security Analyzer e consulte a secção Legacy Product Support (Suporte para Produtos Antigos) sobre como criar detecção de actualizações de segurança abrangentes com ferramentas antigas.

Windows Server Update Services

O Windows Server Update Services (WSUS) permite que os administradores de tecnologia de informação implementem as actualizações mais recentes de produtos da Microsoft em computadores que estejam a executar o sistema operativo Windows. Para obter mais informações sobre como implementar actualizações de segurança usando o Windows Server Update Services, consulte o artigo TechNet sobre o Windows Server Update Services.

Systems Management Server

A tabela seguinte fornece o resumo de detecções e implementação do SMS para esta actualização de segurança.

SoftwareSMS 2003 com ITMUConfiguration Manager 2007
Microsoft Office Groove 2007 Service Pack 2SimSim
Microsoft SharePoint Workspace 2010 e Microsoft SharePoint Workspace 2010 Service Pack 1SimSim
Microsoft Office Forms Server 2007 Service Pack 2 (edições de 32 bits)SimSim
Microsoft Office Forms Server 2007 Service Pack 2 (edições de 64 bits)SimSim
Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 32 bits)Sim. Consulte a Nota para o Microsoft Office SharePoint Server 2007 e Microsoft Office SharePoint Server 2010 abaixoSim. Consulte a Nota para o Microsoft Office SharePoint Server 2007 e Microsoft Office SharePoint Server 2010 abaixo
Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 64 bits)Sim. Consulte a Nota para o Microsoft Office SharePoint Server 2007 e Microsoft Office SharePoint Server 2010 abaixoSim. Consulte a Nota para o Microsoft Office SharePoint Server 2007 e Microsoft Office SharePoint Server 2010 abaixo
Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1Sim. Consulte a Nota para o Microsoft Office SharePoint Server 2007 e Microsoft Office SharePoint Server 2010 abaixoSim. Consulte a Nota para o Microsoft Office SharePoint Server 2007 e Microsoft Office SharePoint Server 2010 abaixo
Microsoft Office Groove Data Bridge Server 2007 Service Pack 2 SimSim
Microsoft Office Groove Management Server 2007 Service Pack 2 SimSim
Microsoft Groove Server 2010 e Microsoft Groove Server 2010 Service Pack 1SimSim
Microsoft Windows SharePoint Services 2.0SimSim
Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 32 bits)SimSim
Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 64 bits)SimSim
SharePoint Foundation 2010 e SharePoint Foundation 2010 Service Pack 1SimSim
Microsoft Office Web Apps 2010 e Microsoft Office Web Apps 2010 Service Pack 1SimSim
Microsoft Word Web App 2010 e Microsoft Word Web App 2010 Service Pack 1SimSim

Nota A Microsoft deixou de prestar suporte para o SMS 2.0 a 12 de Abril de 2011. Para o SMS 2003, a Microsoft também deixou de prestar suporte para a ferramenta Security Update Inventory Tool (SUIT) a 12 de Abril de 2011. Aconselha-se que os clientes façam a actualização para o System Center Configuration Manager 2007. Para os clientes que continuarem com o SMS 2003 Service Pack 3, a Inventory Tool for Microsoft Updates (ITMU) também é uma opção.

Para o SMS 2003, a ferramenta SMS 2003 Inventory Tool for Microsoft Updates (ITMU) pode ser usada pelo SMS para detectar actualizações de segurança que foram oferecidas pelo Microsoft Update e que são suportadas pelos Windows Server Update Services. Para obter mais informações sobre o SMS 2003 ITMU, consulte SMS 2003 Inventory Tool for Microsoft Updates. Para obter mais informações sobre as ferramentas de análise do SMS, consulte SMS 2003 Software Update Scanning Tools. Consulte também as transferências para o Systems Management Server 2003.

O System Center Configuration Manager 2007 utiliza o WSUS 3.0 para a detecção de actualizações. Para obter mais informações sobre o Configuration Manager 2007 Software Update Management, visite o System Center Configuration Manager 2007.

Para obter mais informações sobre o SMS, visite o Web site do SMS.

Para obter informações mais detalhadas, consulte o Artigo 910723 da Base de Dados de Conhecimento da Microsoft: Lista de resumo de artigos mensais sobre orientações de detecção e implementação.

Nota para o Microsoft Office SharePoint Server 2007 e Microsoft Office SharePoint Server 2010 A tabela de detecção acima descrita baseia-se em implementações do Microsoft Office SharePoint Server 2007 e do Microsoft Office SharePoint Server 2010 num único servidor. As ferramentas de detecção não detectam a aplicabilidade da actualização em sistemas configurados como parte de conjuntos de servidores SharePoint para sistemas múltiplos.

Nota Se tiver utilizado um Ponto de Instalação Administrativa (AIP) para implementar o Office XP ou o Office 2003, poderá não ser capaz de implementar a actualização utilizando o SMS se tiver actualizado o AIP a partir da linha base original. Para mais informações, consulte o cabeçalho Ponto de instalação administrativa do Office, nesta secção.

Ponto de instalação administrativa do Office

Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador.

Update Compatibility Evaluator e Application Compatibility Toolkit

É frequente as actualizações utilizarem os mesmos ficheiros e configurações de registo necessários para a execução das aplicações. Isso pode dar origem a incompatibilidades e aumentar o tempo necessário para a implementação de actualizações de segurança. Pode simplificar o teste e a validação de actualizações do Windows relativamente às aplicações instaladas com os componentes do Update Compatibility Evaluator incluído no Application Compatibility Toolkit.

O Application Compatibility Toolkit (ACT) contém as ferramentas e documentação necessárias para avaliar e atenuar questões de compatibilidade da aplicação antes de implementar o Microsoft Windows Vista, uma Actualização do Windows, uma Actualização de Segurança da Microsoft ou uma nova versão do Windows Internet Explorer no seu ambiente.

Software Afectado

Para obter mais informações sobre a actualização de segurança específica do software afectado, clique na ligação adequada:

Microsoft Office Groove 2007 (todas as edições)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros A actualização para esta questão será incluída num service pack ou num update rollup futuro
Implementação
Instalação sem intervenção do utilizadorPara o Office Groove 2007 Service Pack 2:
groove2007-kb2552997-fullfile-x86-glb.exe /passive
Instalação sem reiniciarPara o Office Groove 2007 Service Pack 2:
groove2007-kb2552997-fullfile-x86-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Utilize a ferramenta Adicionar ou Remover Programas, no Painel de Controlo.
Informações de Ficheiros Consulte o Artigo 2552997 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Para remover esta actualização de segurança, utilize a ferramenta Adicionar ou Remover Programas no Painel de Controlo.

Nota Quando remove esta actualização, poderá ser-lhe solicitado que introduza o CD do Microsoft Office 2007 na unidade de CD. Além disso, poderá não ter a opção para desinstalar a actualização a partir da ferramenta Adicionar ou Remover Programas no Painel de Controlo. Existem várias causas possíveis para esta questão. Para obter mais informações sobre o processo de remoção, consulte o Artigo 903771 da Base de Dados de Conhecimento da Microsoft.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e depois introduza um nome de ficheiro de actualização na caixa Iniciar Pesquisa.
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.

      Nota Dependendo da edição do sistema operativo, ou dos programas instalados no sistema, alguns dos ficheiros incluídos na tabela de informações de ficheiro poderão não estar instalados.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.

      Nota Outros atributos que não a versão do ficheiro poderão sofrer alterações durante a instalação. Comparar outros atributos de ficheiro com as informações contidas na tabela de informações de ficheiro não é um método suportado para verificar a aplicação da actualização. Além disso, em determinados casos, o nome dos ficheiros poderá ser alterado durante a instalação. Se as informações de ficheiro ou de versão não estiverem presentes, utilize um dos outros métodos disponíveis para verificar a instalação da actualização.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

Microsoft SharePoint Workspace 2010 (todas as edições)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros A actualização para esta questão será incluída num service pack ou num update rollup futuro
Implementação
Instalação sem intervenção do utilizadorPara o SharePoint Workspace 2010 e SharePoint Workspace 2010 Service Pack 1 (edições de 32 bits):
workspaces2010-kb2566445-fullfile-x86-glb.exe /passive
Para o SharePoint Workspace 2010 e SharePoint Workspace 2010 Service Pack 1 (edições de 64 bits):
workspaces2010-kb2566445-fullfile-x64-glb.exe /passive
Instalação sem reiniciarPara o SharePoint Workspace 2010 e SharePoint Workspace 2010 Service Pack 1 (edições de 32 bits):
workspaces2010-kb2566445-fullfile-x86-glb.exe /norestart
Para o SharePoint Workspace 2010 e SharePoint Workspace 2010 Service Pack 1 (edições de 64 bits):
workspaces2010-kb2566445-fullfile-x64-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Utilize a ferramenta Adicionar ou Remover Programas, no Painel de Controlo.
Informações de Ficheiros Consulte o Artigo 2566445 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Para remover esta actualização de segurança, utilize a ferramenta Adicionar ou Remover Programas no Painel de Controlo.

Nota Quando remove esta actualização, poderá ser-lhe solicitado que introduza o CD do Microsoft Office 2007 na unidade de CD. Além disso, poderá não ter a opção para desinstalar a actualização a partir da ferramenta Adicionar ou Remover Programas no Painel de Controlo. Existem várias causas possíveis para esta questão. Para obter mais informações sobre o processo de remoção, consulte o Artigo 903771 da Base de Dados de Conhecimento da Microsoft.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e depois introduza um nome de ficheiro de actualização na caixa Iniciar Pesquisa.
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.

      Nota Dependendo da edição do sistema operativo, ou dos programas instalados no sistema, alguns dos ficheiros incluídos na tabela de informações de ficheiro poderão não estar instalados.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.

      Nota Outros atributos que não a versão do ficheiro poderão sofrer alterações durante a instalação. Comparar outros atributos de ficheiro com as informações contidas na tabela de informações de ficheiro não é um método suportado para verificar a aplicação da actualização. Além disso, em determinados casos, o nome dos ficheiros poderá ser alterado durante a instalação. Se as informações de ficheiro ou de versão não estiverem presentes, utilize um dos outros métodos disponíveis para verificar a instalação da actualização.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

SharePoint Server 2007 (todas as edições) e Forms Server 2007 (todas as edições)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros Não existem mais service packs planeados para este software. A actualização para esta questão poderá ser incluída num update rollup futuro.
Implementação
Instalação sem intervenção do utilizadorPara Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 32 bits):
Office2007-kb2508964-fullfile-x86-glb.exe /passive
Office2007-kb2553001-fullfile-x86-glb.exe /passive
Office2007-kb2553002-fullfile-x86-glb.exe /passive
Office2007-kb2553003-fullfile-x86-glb.exe /passive
Para Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 64 bits):
Office2007-kb2508964-fullfile-x64-glb.exe /passive
Office2007-kb2553001-fullfile-x64-glb.exe /passive
Office2007-kb2553002-fullfile-x64-glb.exe /passive
Office2007-kb2553003-fullfile-x64-glb.exe /passive
Para o Microsoft Office Forms Server 2007 Service Pack 2 (edições de 32 bits):
formsserver2007-kb2553005-fullfile-x86-glb.exe /passive
Para o Microsoft Office Forms Server 2007 Service Pack 2 (edições de 64 bits):
formsserver2007-kb2553005-fullfile-x64-glb.exe /passive
Instalação sem reiniciarPara Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 32 bits):
Office2007-kb2508964-fullfile-x86-glb.exe /norestart
Office2007-kb2553002-fullfile-x86-glb.exe /norestart
Office2007-kb2553003-fullfile-x86-glb.exe /norestart
Para Microsoft Office SharePoint Server 2007 Service Pack 2 (edições de 64 bits):
Office2007-kb2508964-fullfile-x64-glb.exe /norestart
Office2007-kb2553002-fullfile-x64-glb.exe /norestart
Office2007-kb2553003-fullfile-x64-glb.exe /norestart
Para o Microsoft Office Forms Server 2007 Service Pack 2 (edições de 32 bits):
formsserver2007-kb2553005-fullfile-x86-glb.exe /norestart
Para o Microsoft Office Forms Server 2007 Service Pack 2 (edições de 64 bits):
formsserver2007-kb2553005-fullfile-x64-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Esta actualização de segurança não pode ser removida.
Informações de Ficheiros Para o Microsoft Office SharePoint Server 2007, consulte os Artigos 2508964, 2553002 e 2345212 da Base de Dados de Conhecimento da Microsoft
Para o Microsoft Office Forms Server 2007, consulte o Artigo 2553005 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Esta actualização de segurança não pode ser removida.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e, depois, introduza um nome de ficheiro de actualização na caixa Iniciar Pesquisa.
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

SharePoint Server 2010 (todas as edições)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros Não existem mais service packs planeados para este software. A actualização para esta questão poderá ser incluída num update rollup futuro.
Implementação
Instalação sem intervenção do utilizadorPara o Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1:
officeserver2010-kb2494022-fullfile-x64-glb.exe /passive
officeserver2010-kb2560885-fullfile-x64-glb.exe /passive
officeserver2010-kb2560890-fullfile-x64-glb.exe /passive
officeserver2010-kb2566456-fullfile-x64-glb.exe /passive
Officeserver2010-kb2566954-fullfile-x64-glb.exe /passive
officeserver2010-kb2566958-fullfile-x64-glb.exe /passive
officeserver2010-kb2566960-fullfile-x64-glb.exe /passive
Instalação sem reiniciarPara o Microsoft Office SharePoint Server 2010 e Microsoft Office SharePoint Server 2010 Service Pack 1:
officeserver2010-kb2494022-fullfile-x64-glb.exe /norestart
officeserver2010-kb2560885-fullfile-x64-glb.exe /norestart
officeserver2010-kb2560890-fullfile-x64-glb.exe /norestart
officeserver2010-kb2566456-fullfile-x64-glb.exe /norestart
Officeserver2010-kb2566954-fullfile-x64-glb.exe /norestart
officeserver2010-kb2566958-fullfile-x64-glb.exe /norestart
officeserver2010-kb2566960-fullfile-x64-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Esta actualização de segurança não pode ser removida.
Informações de Ficheiros Consulte o Artigo 2494022 da Base de Dados de Conhecimento da Microsoft,
Artigo 2560885 da Base de Dados de Conhecimento da Microsoft,
Artigo 2560890 da Base de Dados de Conhecimento da Microsoft,
Artigo 2566456 da Base de Dados de Conhecimento da Microsoft,
Artigo 2566954 da Base de Dados de Conhecimento da Microsoft,
Artigo 2566958 da Base de Dados de Conhecimento da Microsoft e
Artigo 2566960 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Esta actualização de segurança não pode ser removida.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e depois introduza um nome de ficheiro de actualização em Iniciar Pesquisa.
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

Groove Server 2007 (todas as edições)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros Não existem mais service packs planeados para este software. A actualização para esta questão poderá ser incluída num update rollup futuro.
Implementação
Instalação sem intervenção do utilizadorPara o Microsoft Office Groove Data Bridge Server 2007 Service Pack 2:
groovedatabridge2007-kb2552999-fullfile-x64-glb.exe /passive
Para o Microsoft Office Groove Management Server 2007 Service Pack 2:
groovemanagementserver2007-kb2552998-fullfile-x64-glb.exe /passive
Instalação sem reiniciarPara o Microsoft Office Groove Data Bridge Server 2007 Service Pack 2:
groovedatabridge2007-kb2552999-fullfile-x64-glb.exe /norestart
Para o Microsoft Office Groove Management Server 2007 Service Pack 2:
groovemanagementserver2007-kb2552998-fullfile-x64-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Esta actualização de segurança não pode ser removida.
Informações de Ficheiros Para o Microsoft Office Groove Data Bridge Server 2007, consulte o Artigo 2552999 da Base de Dados de Conhecimento da Microsoft
Para o Microsoft Office Groove Management Server 2007, consulte o Artigo 2552998 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Esta actualização de segurança não pode ser removida.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e, depois, introduza um nome de ficheiro de actualização na caixa Iniciar Pesquisa.
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

Groove Server 2010 (todas as edições)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros Não existem mais service packs planeados para este software. A actualização para esta questão poderá ser incluída num update rollup futuro.
Implementação
Instalação sem intervenção do utilizadorPara o Microsoft Groove Server 2010 e Microsoft Groove Server 2010 Service Pack 1:
grooveserver2010-kb2508965-fullfile-x64-glb.exe /passive
Instalação sem reiniciarPara o Microsoft Groove Server 2010 e Microsoft Groove Server 2010 Service Pack 1:
grooveserver2010-kb2508965-fullfile-x64-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Esta actualização de segurança não pode ser removida.
Informações de Ficheiros Consulte o Artigo 2508965 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Esta actualização de segurança não pode ser removida.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e depois introduza um nome de ficheiro de actualização na caixa Iniciar Pesquisa .
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

SharePoint Windows SharePoint Services 2.0

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros Não existem mais service packs planeados para este software. A actualização para esta questão poderá ser incluída num update rollup futuro.
Implementação
Instalação sem intervenção do utilizadorPara o Microsoft Windows SharePoint Services 2.0:
WSS2003-kb2494007-fullfile-ENU.exe /passive
Instalação sem reiniciarPara o Microsoft Windows SharePoint Services 2.0:
WSS2003-kb2494007-fullfile-ENU.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Esta actualização de segurança não pode ser removida.
Informações de Ficheiros Para o Microsoft Windows SharePoint Services 2.0, consulte o Artigo 2494007 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Esta actualização de segurança não pode ser removida.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e depois introduza um nome de ficheiro de actualização em Iniciar Pesquisa.
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

Windows SharePoint Services 3.0 (todas as versões)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros Não existem mais service packs planeados para este software. A actualização para esta questão poderá ser incluída num update rollup futuro.
Implementação
Instalação sem intervenção do utilizadorPara o Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 32 bits):
wss-kb2493987-fullfile-x86-glb.exe /passive
Para o Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 64 bits):
wss-kb2493987-fullfile-x64-glb.exe /passive
Instalação sem reiniciarPara o Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 32 bits):
wss-kb2493987-fullfile-x86-glb.exe /norestart
Para o Microsoft Windows SharePoint Services 3.0 Service Pack 2 (versões de 64 bits):
wss-kb2493987-fullfile-x64-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Esta actualização de segurança não pode ser removida.
Informações de Ficheiros Consulte Artigo 2493987 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Esta actualização de segurança não pode ser removida.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e depois introduza um nome de ficheiro de actualização em Iniciar Pesquisa.
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

Microsoft SharePoint Foundation 2010 (todas as versões)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros Não existem mais service packs planeados para este software. A actualização para esta questão poderá ser incluída num update rollup futuro.
Implementação
Instalação sem intervenção do utilizadorPara o Microsoft SharePoint Foundation 2010 e Microsoft SharePoint Foundation 2010 Service Pack 1:
sharepointfoundation2010-kb2494001-fullfile-x64-glb.exe /passive
Instalação sem reiniciarPara o Microsoft SharePoint Foundation 2010 e Microsoft SharePoint Foundation 2010 Service Pack 1:
sharepointfoundation2010-kb2494001-fullfile-x64-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Esta actualização de segurança não pode ser removida.
Informações de Ficheiros Consulte o Artigo 2494001 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Esta actualização de segurança não pode ser removida.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e depois introduza um nome de ficheiro de actualização em Iniciar Pesquisa.
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

Office Web Apps e Word Web App (todas as versões)

Tabela de referência

A tabela seguinte contém a informação sobre a actualização de segurança para este software. Pode encontrar informações adicionais na subsecção Informações de Implementação, nesta secção.

Inclusão em Service Packs Futuros Não existem mais service packs planeados para este software. A actualização para esta questão poderá ser incluída num update rollup futuro.
Implementação
Instalação sem intervenção do utilizadorPara o Office Web Apps 2010 e Office Web Apps 2010 Service Pack 1:
webapps-kb2566449-fullfile-x64-glb.exe /passive
Para o Word Web App 2010 e Word Web App 2010 Service Pack 1:
wordwebapp-kb2566450-fullfile-x64-glb.exe /passive
Instalação sem reiniciarPara o Office Web Apps 2010 e Office Web Apps 2010 Service Pack 1:
webapps-kb2566449-fullfile-x64-glb.exe /norestart
Para o Word Web App 2010 e Word Web App 2010 Service Pack 1:
wordwebapp-kb2566450-fullfile-x64-glb.exe /norestart
Ficheiro de registo da actualizaçãoNão aplicável
Informações adicionaisPara detecção e implementação, consulte a secção Orientações e ferramentas de detecção e implementação.
Requisito de Reinício
Reinício necessário?Em alguns casos, esta actualização não requer um reinício. Se os ficheiros necessários estiverem a ser utilizados, esta actualização obrigará a reiniciar o computador. Se for esse o caso, será apresentada uma mensagem aconselhando-o a reiniciar.

Para ajudar a reduzir a hipótese de ser necessário reiniciar o computador, interrompa todos os serviços afectados e feche todas as aplicações que possam usar os ficheiros afectados antes de instalar a actualização de segurança. Para mais informações sobre os motivos que podem levar a que seja solicitada uma confirmação do reinício, consulte o Artigo 887012 da Base de Dados de Conhecimento da Microsoft.
HotPatchingNão aplicável
Informações de Remoção Esta actualização de segurança não pode ser removida.
Informações de Ficheiros Para o Office Web Apps 2010 e Office Web Apps 2010 Service Pack 1, consulte o Artigo 2566449 da Base de Dados de Conhecimento da Microsoft
Para o Word Web App 2010 e Word Web App 2010 Service Pack 1, consulte o Artigo 2566450 da Base de Dados de Conhecimento da Microsoft
Verificação da Chave de Registo Não aplicável

Informações de Implementação

Instalação da Actualização

Pode instalar a actualização a partir da hiperligação de transferência adequada, na secção Software Afectado e Software Não Afectado. Se a aplicação tiver sido instalada a partir de uma localização no servidor, o administrador do servidor terá de actualizar a localização do servidor com a actualização administrativa e implementar essa actualização no sistema do utilizador. Para mais informações sobre os pontos de instalação administrativa, consulte as informações do artigo Ponto de Instalação Administrativa do Office, na secção Orientações e Ferramentas de Detecção e Implementação.

Esta actualização de segurança requer que o Windows Installer 3.1, ou versão posterior, esteja instalado no sistema.

Para instalar a versão 3.1 ou posterior do Windows Installer, consulte um dos seguintes Web sites da Microsoft:

Para mais informações sobre a terminologia que é usada neste boletim, tal como 'correcção' (hotfix), consulte o Artigo 824684 da Base de Dados de Conhecimento da Microsoft.

Esta actualização de segurança suporta os seguintes parâmetros de configuração.

Parâmetros de Instalação de Actualizações de Segurança Suportados
ParâmetroDescrição
/? ou /helpApresenta a caixa de diálogo de utilização.
/passive Especifica o modo passivo. Não requer interacção do utilizador; os utilizadores visualizam as caixas de diálogo de progresso básicas, mas não é possível cancelar.
/quiet Especifica o modo silencioso ou suprime mensagens quando os ficheiros estão a ser extraídos.
/ norestart Suprime o reinício do sistema se a actualização o exigir.
/ forcerestart Reinicia automaticamente o sistema após aplicar a actualização, independentemente de a actualização o exigir ou não.
/extract Extrai os ficheiros sem os instalar. É pedida uma pasta de destino.
/extract:<path> Substitui o comando de instalação definido pelo autor. Especifica o caminho e nome do ficheiro Setup.inf ou .exe.
/ lang :<LCID> Força a utilização de um idioma específico quando o pacote da actualização suporta esse idioma.
/log:<log file> Activa o registo, tanto através do Vnox como do Installer, durante a instalação da actualização.

Nota É possível combinar estes parâmetros no mesmo comando. Para efeitos de retro-compatibilidade, a actualização de segurança também suporta muitos dos parâmetros de configuração que são utilizados pelas versões anteriores do Programa de Configuração. Para obter mais informações sobre os parâmetros de instalação suportados, consulte o Artigo 262841 da Base de Dados de Conhecimento da Microsoft.

Remoção da actualização

Esta actualização de segurança não pode ser removida.

Verificar se a Actualização Foi Aplicada

  • Microsoft Baseline Security Analyzer

    Para verificar se uma actualização de segurança foi aplicada num sistema afectado, poderá utilizar a ferramenta Microsoft Baseline Security Analyzer (MBSA). Consulte a secção "Orientações e Ferramentas de Detecção e Implementação" mais acima neste boletim para obter mais informações.

  • Verificação das Versões dos Ficheiros

    Dado existirem várias edições do Microsoft Windows, os passos que se seguem podem ser diferentes no seu sistema. Caso efectivamente o sejam, consulte a documentação do produto para executar estes passos.

    1. Clique em Iniciar e depois introduza um nome de ficheiro de actualização na caixa Iniciar Pesquisa .
    2. Quando o ficheiro aparecer em Programas, clique com o botão direito do rato no nome do ficheiro e depois em Propriedades.
    3. No separador Geral, compare o tamanho do ficheiro com as tabelas de informação de ficheiros fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    4. Também pode clicar no separador Detalhes e comparar informações, como a versão de ficheiro e a data de modificação, com as tabelas de informação fornecidas no artigo da Base de Dados de Conhecimento do boletim.
    5. Por fim, também pode clicar no separador Versões anteriores e comparar a informação de ficheiros sobre a versão anterior do ficheiro com a informação da versão do ficheiro nova ou actualizada.

Outras informações

Agradecimentos

A Microsoft agradece às seguintes entidades por trabalharem connosco para proteger os clientes:

  • Andrew Connell, da Critical Path Training, LLC por fornecer informações sobre a Vulnerabilidade de XSS no Calendário do SharePoint (CVE-2011-0653)
  • David Feldman, da Raytheon, por fornecer informações sobre a Vulnerabilidade de XSS no Calendário do SharePoint (CVE-2011-0653)
  • Adi Cohen, da IBM Rational Application Security, por fornecer informações sobre a Vulnerabilidade de Sanitização de HTML (CVE-2011-1252)
  • Trend Micro, por trabalhar connosco na Vulnerabilidade de Sanitização de HTML (CVE-2011-1252)
  • Pedro Jimenez, da ITT, por fornecer informações sobre a Vulnerabilidade de Introdução de Scripts em Editform (CVE-2011-1890)
  • Solução de teste automático de segurança para aplicações Seeker, por fornecer informações sobre a Vulnerabilidade de XSS com Reflexo em Detalhes de Contactos (CVE-2011-1891)
  • Nicolas Grégoire, da Agarri, por fornecer informações sobre a Vulnerabilidade de Divulgação de Ficheiros Remotos no SharePoint (CVE-2011-1892)
  • Jim LaValley, da LaValley Consulting, LLC, por fornecer informações sobre a Vulnerabilidade de XSS no SharePoint (CVE-2011-1893)
  • Irene Abezgauz, da Seeker, por trabalhar connosco numa actualização a nível da protecção defensiva profunda para ajudar a melhorar o processamento de redireccionamentos entre aplicações no Microsoft SharePoint

Microsoft Active Protections Program (MAPP)

Para melhorar as protecções de segurança dos clientes, a Microsoft fornece informações sobre as vulnerabilidades aos principais fornecedores de software de segurança antes de cada publicação mensal de actualizações de segurança. Os fornecedores de software de segurança podem então utilizar estas informações sobre as vulnerabilidades para assegurar protecções actualizadas aos clientes através do seu software ou dispositivos de segurança, tais como antivírus, sistemas de detecção de intrusos com base na rede ou sistemas de prevenção de intrusões com base no anfitrião. Para determinar se as protecções activas estão disponíveis nos fornecedores de software de segurança, visite os Web sites de protecções activas disponibilizados pelos parceiros do programa, indicados na lista de parceiros do Microsoft Active Protections Program (MAPP).

Assistência

  • Os clientes nos E.U.A. e no Canadá podem receber suporte técnico através do Suporte de Segurança ou da linha 1-866-PCSAFETY. As chamadas de suporte técnico associadas a actualizações de segurança são gratuitas. Para obter mais informações sobre as opções de suporte disponíveis, consulte a Ajuda e Suporte da Microsoft.
  • Os clientes internacionais podem receber suporte das subsidiárias locais da Microsoft. O suporte técnico associado às actualizações de segurança é gratuito. Para obter mais informações sobre como contactar a Microsoft relativamente a questões de suporte, visite o Web site de Suporte Internacional.

Exclusão de garantia

As informações fornecidas na Base de Dados de Conhecimento da Microsoft são fornecidas "tal como estão", sem garantias de qualquer tipo. A Microsoft exclui todas as garantias, sejam expressas ou implícitas, incluindo as garantias de comercialização e adequação a um fim específico. Em caso algum serão a Microsoft Corporation ou os seus fornecedores responsáveis por quaisquer prejuízos, incluindo prejuízos directos, indirectos, incidentais ou consequentes, extraordinários ou por perda de lucros negociais, ainda que a Microsoft Corporation ou os seus fornecedores tenham sido notificados da possibilidade de ocorrência de tais prejuízos. A exclusão ou limitação de responsabilidade por prejuízos consequentes ou incidentais não é permitida em alguns estados ou jurisdições, pelo que a limitação supra poderá não ser aplicável.

Revisões

  • V1.0 (13 de Setembro de 2011): Boletim publicado.
  • V1.1 (13 de Setembro de 2011): Adicionada uma ligação de actualização e informações sobre o pacote de actualização do Microsoft Office SharePoint Server 2010 e do Microsoft Office SharePoint Server 2010 Service Pack 1 (pplwfe) (KB2560890). Trata-se de uma alteração informativa apenas. Não foram efectuadas alterações aos ficheiros da actualização de segurança ou à lógica de detecção.
  • V1.2 (21 de Setembro de 2011): Removida uma referência errada ao Artigo 2553001 da Base de Dados de Conhecimento da Microsoft na tabela de referência de implementação para o Microsoft Groove Server 2007. Trata-se apenas de uma alteração informativa. Não foram efectuadas alterações aos ficheiros da actualização de segurança ou à lógica de detecção.
  • V1.3 (11 de Outubro de 2011): Anunciadas alterações da lógica de detecção para algumas configurações afectadas. Não foram efectuadas alterações aos ficheiros de actualização de segurança. Para obter mais informações, consulte as perguntas frequentes sobre a actualização.

Built at 2014-04-18T01:50:00Z-07:00

Mostrar: