Планирование миграции с предыдущей версии App-V

Обновлено: Август 2015 г.

Назначение: Application Virtualization 5.1

Используйте следующие сведения для планирования миграции на Microsoft Application Virtualization (App-V) 5.1 с предыдущих версий App-V.

Требования для миграции

Прежде чем выполнять какие-либо обновления, проверьте соблюдение следующих требований.

  • При обновлении с версии более ранней, чем 4.6 с пакетом обновления 2 (SP2), выполните обновление до версии 4.6 с пакетом обновления 2 (SP2) или версии 4.6 с пакетом обновления 3 (SP3) перед обновлением до App-V 5.1 или более поздней версии. В этом сценарии сначала обновляются клиенты App-V, а затем серверные компоненты.

  • App-V 5.1 поддерживает только пакеты, созданные с помощью App-V 5.0 или App-V 5.1, или пакеты, преобразованные в формат APPV.

  • Если выполняется обновление сервера App-V с App-V 5.0 с пакетом обновления 1 (SP1), см. инструкции в разделе Migrating to App-V 5.1.

Запуск клиента App-V 5.1 параллельно с App-V 4.6 с пакетом обновления 2 (SP2) или более поздней версии

Можно запустить клиент App-V 5.1 на одном компьютере параллельно с клиентом App-V 4.6 с пакетом обновления 2 (SP2) или клиентом App-V 4.6 с пакетом обновления 3 (SP3).

При запуске сосуществующих клиентов App-V можно сделать следующее.

  • Преобразовать пакет App-V 4.6 с пакетом обновления 2 (SP2) или 4.6 с пакетом обновления 3 (SP3) в формат App-V 5.1 и опубликовать оба пакета, если выполняются оба клиента.

  • Определить политику миграции для преобразованного пакета, которая позволяет преобразованному пакету App-V 5.1 предполагать сопоставления типов файлов и ярлыки из пакета App-V 4.6 с пакетом обновления 2 (SP2).

Поддерживаемые сценарии сосуществования

В следующей таблице показаны поддерживаемые сценарии сосуществования App-V. При запуске сосуществующих клиентов рекомендуется установить последние доступные обновления конкретной версии.

 

Тип клиента App-V 4.6.x Тип клиента App-V 5.1

App-V 4.6 с пакетом обновления 2 (SP2)

App-V 5.1

RDS App-V 4.6 с пакетом обновления 2 (SP2)

RDS App-V 5.1

App-V 4.6 с пакетом обновления 3 (SP3)

App-V 5.1

RDS App-V 4.6 с пакетом обновления 3 (SP3)

RDS App-V 5.1

Требования для запуска сосуществующих клиентов

Для запуска существующих клиентов необходимо выполнить следующее.

  • Установить клиент App-V 4.6 с пакетом обновления 2 (SP2) или App-V 4.6 с пакетом обновления 3 (SP3) перед установкой клиента App-V 5.1.

  • Включить параметр групповой политики Включить режим миграции, расположенный в узле App-V > Сосуществование клиентов. Сведения о развертывании шаблона ADMX см. в статье Загрузка и развертывание шаблонов групповой политики MDOP (ADMX).

noteПримечание
Пакеты App-V 5.1 могут выполняться параллельно с пакетами App-V 4.X, если App-V 5.1 и 4.X установлены параллельно. При этом пакеты App-V 5.1 не могут взаимодействовать с пакетами App-V 4.X в той же виртуальной среде.

Загрузка клиентов и документация

В следующей таблице приведены ссылки на загружаемые файлы для клиента App-V 4.6.x и на документацию TechNet по выпускам. Загружаемые файлы включают "обычные" клиенты и клиенты RDS App-V. Если не указано иное, документация TechNet по клиенту App-V относится к обоим клиентам.

 

Версия App-V Ссылка для загрузки клиента Ссылки на документацию TechNet

App-V 4.6 с пакетом обновления 2 (SP2)

Microsoft Application Virtualization 4.6 с пакетом обновления 2

Сведения о системе Microsoft Application Virtualization 4.6 с пакетом обновления 2 (SP2)

App-V 4.6 с пакетом обновления 3 (SP3)

Microsoft Application Virtualization 4.6 с пакетом обновления 3

Сведения о системе Microsoft Application Virtualization 4.6 с пакетом обновления 3 (SP3)

Дополнительные сведения о настройке сосуществования клиентов App-V 5.1 см. в следующих разделах.

Преобразование пакетов предыдущей версии с помощью преобразователя пакетов

Перед выполнением миграции пакета, созданного с помощью App-V 4.6 с пакетом обновления 2 (SP2) или более ранней версии, на App-V 5.1 проверьте выполнение следующих требований.

  • Необходимо преобразовать пакет в формат файла APPV.

  • Преобразователь пакетов поддерживает только прямое преобразование пакетов, которые были созданы с помощью App-V 4.5 или более поздней версии. Чтобы использовать преобразователь пакетов в пакете, который был создан с помощью предыдущей версии, необходимо использовать App-V 4.5 или более позднюю версию преобразователя для обновления пакета, а затем выполнить преобразование пакета.

Дополнительные сведения об использовании преобразователя пакетов для преобразования пакета см. в разделе Порядок преобразования пакета, созданного в предыдущей версии App-V. После преобразования файла его можно развернуть на целевых компьютерах, на которых работает клиент App-V 5.1.

Есть предложение для App-V?

Выдвигайте предложения и голосуйте за них здесь. Ответы на вопросы, возникающие при работе с App-V, можно найти на форуме TechNet по App-V.

См. также

-----
Дополнительные сведения о MDOP можно найти в библиотеке TechNet, статьях по устранению неполадок на вики-сайте TechNet или подписавшись на новости в Facebook или Twitter.
-----
Показ: