Microsoft 安全公告 MS10-010 - 重要

Windows Server 2008 Hyper-V 中的漏洞可能允许拒绝服务 (977894)

发布时间: 2010年2月9日

版本: 1.0

一般信息

摘要

此安全更新解决 Windows Server 2008 Hyper-V 和 Windows Server 2008 R2 Hyper-V 中一个秘密报告的漏洞。 如果经身份验证的用户在由 Hyper-V 服务器托管的客户虚拟机上运行错误的计算机指令顺序,则该漏洞可能允许拒绝服务。 攻击者必须拥有有效的登录凭据并能本地登录客户虚拟机才能利用此漏洞。 匿名用户无法利用此漏洞,也无法以远程方式利用此漏洞。

对于 Windows Server 2008 和 Windows Server 2008 R2 的所有受支持的基于 x64 的版本,此安全更新等级为“重要”。有关详细信息,请参阅本节的“受影响和不受影响的软件”小节。

此安全更新通过更正 Hyper-V 服务器在客户虚拟机内部执行的计算机指令上验证编码的方式来解决该漏洞。 有关漏洞的详细信息,请参阅下一节“漏洞信息”下面特定漏洞条目的常见问题 (FAQ) 小节。

建议。 大多数客户均启用了“自动更新”,他们不必采取任何操作,因为此安全更新将自动下载并安装。 尚未启用“自动更新”的客户必须检查更新,并手动安装此更新。 有关自动更新中特定配置选项的信息,请参阅 Microsoft 知识库文章 294871

对于管理员、企业安装或者想要手动安装此安全更新的最终用户,Microsoft 建议客户使用更新管理软件尽早应用此更新或者利用 Microsoft Update 服务检查更新。

另请参阅本公告后面部分中的“检测和部署工具及指导”一节。

已知问题。 无

受影响和不受影响的软件

已对下列软件进行测试,以确定受到影响的版本。 其他版本的支持生命周期已结束或者不受影响。 要确定软件版本的技术支持生命周期,请访问 Microsoft 技术支持生命周期

受影响的软件

操作系统最大安全影响综合严重等级此更新替代的公告
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2*拒绝服务重要
Windows Server 2008 R2(用于基于 x64 的系统)*拒绝服务重要

*服务器核心安装受到影响。 此更新适用于 Windows Server 2008 或 Windows Server 2008 R2 的受支持版本,严重等级相同,无论是否使用“服务器核心”安装选项进行了安装。 有关该安装选项的详细信息,请参阅 MSDN 文章服务器核心Windows Server 2008 R2 的服务器核心。注意,服务器核心安装选项不适用于 Windows Server 2008 和 Windows Server 2008 R2 的某些版本;请参阅比较服务器核心安装选项

不受影响的软件

操作系统
Microsoft Windows 2000 Service Pack 4
Windows XP Service Pack 2 和 Windows XP Service Pack 3
Windows XP Professional x64 Edition Service Pack 2
Windows Server 2003 Service Pack 2
Windows Server 2003 x64 Edition Service Pack 2
Windows Server 2003 SP2(用于基于 Itanium 的系统)
Windows Vista、Windows Vista Service Pack 1 和 Windows Vista Service Pack 2
Windows Vista x64 Edition、Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2
Windows Server 2008(用于基于 Itanium 的系统)和 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2
Windows 7(用于 32 位系统)
Windows 7(用于基于 x64 的系统)
Windows Server 2008 R2(用于基于 Itanium 的系统)

在哪里可以找到文件信息详细资料?  
有关文件信息详细资料的位置,请参阅“安全更新部署”部分中的参考表。

即使我没有启用 Hyper-V,仍将提供此更新吗?
即使没有启用 Hyper-V 角色,也可将此更新手动安装到受影响的平台。 但是,如果启用了 Hyper-V 角色,则此更新只能通过“自动更新”提供。

此更新是否需要应用于 Hyper-V 客户虚拟机?
此更新一定不能应用于 Hyper-V 客户机,而只能应用于启用了 Hyper-V 角色的计算机。 它只能通过“自动更新”提供给 Hyper-V 服务器系统,而不是源自虚拟的客户机。

什么是 Hyper-V Server,它是否也受此漏洞影响?
Microsoft Hyper-V Server 是一个独立的产品,提供一个可靠且经过优化的虚拟化解决方案,使组织可提高服务器利用率并降低成本。 由于 Hyper-V Server 是一款专用的独立产品,仅包括 Windows Hypervisor、Windows Server 驱动程序模型和虚拟化组件,因此其占用面积小且成本最低。

Microsoft Hyper-V Server 2008、Microsoft Hyper-V Server 2008 Service Pack 2 和 Microsoft Hyper-V Server 2008 R2 受此漏洞影响,Windows Server 2008 和 Windows Server 2008 R2 更新必须分别应用,以帮助修复此漏洞。 启用“自动更新”的客户将被自动授予这些更新用于安装。

我正在使用本安全公告中讨论的软件的较旧版本。 我该怎么办?  
已对本公告中列出的受影响的软件进行测试,以确定受到影响的版本。 其他版本的支持生命周期已结束。 有关产品生命周期的详细信息,请访问 Microsoft 产品技术支持生命周期网站

使用该软件的较旧版本的客户应优先考虑迁移到受支持的版本,以防止可能会受到新出现漏洞的影响。 要确定您的软件版本的技术支持生命周期,请参阅选择一项产品以获取生命周期信息。 有关这些软件版本的 Service Pack 的详细信息,请参阅生命周期支持的 Service Pack

如果用户需要获得较旧软件的定制支持,则必须与其 Microsoft 客服小组代表、其技术客户经理或适当的 Microsoft 合作伙伴代表联系以了解定制支持选项。 没有联合合同、优先支持合同或授权合同的客户可与其当地的 Microsoft 销售分支机构联系。 有关联系信息,请访问 Microsoft Worldwide Information 网站,在联系信息列表中选择国家/地区,然后单击“Go”以查看电话号码列表。 在拨打电话时,请找当地的“企业技术咨询支持服务”销售经理进行洽谈。 有关详细信息,请参阅 Microsoft 技术支持生命周期策略常见问题

漏洞信息

以下严重等级假设漏洞的可能的最大影响。 有关此安全公告发布 30 天内,漏洞利用的安全等级和安全影响的可能性的信息,请参阅 2 月份公告摘要中的利用指数。 有关详细信息,请参阅 Microsoft 利用指数

按受影响软件列出的漏洞严重等级和最大安全影响
受影响的软件Hyper-V 指令集验证漏洞 - CVE-2010-0026 综合严重等级
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2* 重要 
拒绝服务
重要
Windows Server 2008 R2(用于基于 x64 的系统)* 重要 
拒绝服务
重要

*服务器核心安装受到影响。 此更新适用于 Windows Server 2008 或 Windows Server 2008 R2 的受支持版本,严重等级相同,无论是否使用“服务器核心”安装选项进行了安装。 有关该安装选项的详细信息,请参阅 MSDN 文章服务器核心Windows Server 2008 R2 的服务器核心。注意,服务器核心安装选项不适用于 Windows Server 2008 和 Windows Server 2008 R2 的某些版本;请参阅比较服务器核心安装选项

Windows Server 2008 和 Windows Server 2008 R2 上的 Hyper-V 中存在一个拒绝服务。该漏洞是由于 Hyper-V 执行的特定计算机指令顺序验证不充分造成的。 成功利用此漏洞的攻击者可能会导致 Hyper-V 系统停止响应。 这将影响受该系统托管的所有虚拟机。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-0026

Hyper-V 指令集验证漏洞 (CVE-2010-0026) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 攻击者必须拥有有效的登录凭据并能本地登录 Hyper-V 虚拟机才能利用此漏洞。 匿名用户无法利用此漏洞,也无法以远程方式利用此漏洞。

Hyper-V 指令集验证漏洞 (CVE-2010-0026) 的变通办法

Microsoft 并未发现此漏洞的任何变通办法。

Hyper-V 指令集验证漏洞 (CVE-2010-0026) 的常见问题

此漏洞的影响范围有多大?  
这是一个拒绝服务漏洞。 利用此漏洞的攻击者可能会导致受影响的 Hyper-V 服务器停止响应并要求系统重新启动。 请注意,虽然攻击者无法利用拒绝服务漏洞来执行代码或提升他们的用户权限,但此漏洞可能导致受影响的系统停止接受请求。

造成漏洞的原因是什么?  
此漏洞由 Hyper-V 服务器错误验证客户虚拟机内执行的特定计算机指令编码而造成。 由于缺少验证,处理这些指令可能导致 Hyper-V 服务器应用程序无响应。

什么是 Hyper-V?  
Hyper-V 是基于虚拟机监控程序的技术,该技术是 Windows Server 2008 和 Windows Server 2008 R2 的主要功能。它提供可伸缩、可靠和高度可用的虚拟化平台。 虚拟化环境非常有用,因为用户可以创建和管理虚拟机,从而让用户在一台物理计算机上运行多个操作系统,并将操作系统相互隔离。

攻击者可能利用此漏洞执行什么操作?  
成功利用此漏洞的攻击者可能导致用户系统无响应,直至系统重新启动。 请注意,利用此漏洞可能导致实际的 Hyper-V 服务器停止响应,包括由该服务器托管的所有客户虚拟机。

攻击者如何利用此漏洞?  
攻击者必须是由 Hyper-V 服务器托管的其中一个客户虚拟机中的经身份验证的用户,且需要具有在系统上执行任意代码的能力。 然后,攻击者可以在系统上运行不受信任的可执行文件而调用错误的计算机指令顺序,从而导致 Hyper-V 服务器无响应。

受此漏洞威胁最大的系统有哪些?  
允许访问不受信任的用户的托管客户虚拟机的 Hyper-V 服务器受此漏洞的威胁最大。

此更新有什么作用?  
此更新通过更正 Hyper-V 服务器在客户虚拟机内部执行的计算机指令上验证编码的方式来解决该漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
否。 Microsoft 通过可靠的披露渠道了解到有关此漏洞的信息。

发布此安全公告时,Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

更新信息

管理需要部署到组织中的服务器、台式机和移动系统的软件和安全更新。 有关详细信息,请参阅 TechNet 更新管理中心Microsoft TechNet 安全网站提供了有关 Microsoft 产品安全的详细信息。

安全更新可从 Microsoft UpdateWindows Update 获得。 Microsoft 下载中心也提供了安全更新。 通过输入关键字“安全更新”可以非常方便地找到些更新。

最后,可以从 Microsoft Update 目录下载安全更新。 Microsoft Update 目录提供通过 Windows Update 和 Microsoft Update 提供的内容的可搜索目录,包括安全更新、驱动程序和 Service Pack。 通过使用安全公告编号(例如“MS07-036”)进行搜索,您可以将所有适用的更新添加到您的篮(包括某个更新的不同语言),然后将其下载到您选择的文件夹。 有关 Microsoft Update 目录的详细信息,请参阅 Microsoft Update 目录常见问题

注意 Microsoft 在 2009 年 8 月 1 日以后不再支持 Office Update 和 Office 更新清单工具。要继续获得 Microsoft Office 产品的最新更新,请使用 Microsoft Update。 有关详细信息,请参阅关于 Microsoft Office Update: 常见问题

检测和部署指南

Microsoft 提供安全更新的检测和部署指南。 该指南包含可帮助 IT 专业人员了解如何使用各种工具检测和部署安全更新的建议和信息。 有关详细信息,请参阅 Microsoft 知识库文章 961747

Microsoft Baseline Security Analyzer

管理员可使用 Microsoft Baseline Security Analyzer (MBSA),在本地和远程系统中扫描缺少的安全更新和常见的安全配置错误。 有关 MBSA 的详细信息,请访问 Microsoft Baseline Security Analyzer

下表提供此安全更新的 MBSA 检测摘要。

软件 MBSA 2.1.1
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2
Windows Server 2008 R2(用于基于 x64 的系统)

MBSA 的最新版本已发布: Microsoft Baseline Security Analyzer 2.1.1。有关详细信息,请参阅 Microsoft Baseline Security Analyzer 2.1

Windows Server Update Services

通过使用 Windows Server Update Services (WSUS),管理员可以部署 Microsoft Windows 2000 操作系统和更高版本、Office XP 和更高版本、Exchange Server 2003 以及 SQL Server 2000 的最新关键更新和安全更新部署。有关如何使用 Windows Server Update Services 部署此安全更新的详细信息,请访问 Windows Server Update Services 网站

Systems Management Server

下表提供此安全更新的 SMS 检测和部署摘要。

软件SMS 2.0SMS 2003(带 SUIT)SMS 2003(带 ITMU)Configuration Manager 2007
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2
Windows Server 2008 R2(用于基于 x64 的系统)

对于 SMS 2.0 和 SMS 2003,安全更新清单工具 (SUIT) 可以由 SMS 用来检测安全更新。 请参阅 Downloads for Systems Management Server 2.0

对于 SMS 2003,SMS 可以使用 Microsoft 更新 SMS 2003 清单工具 (ITMU) 检测 Microsoft Update 提供的以及 Windows Server Update Services 支持的安全更新。 有关 SMS 2003 ITMU 的详细信息,请参阅 SMS 2003 Microsoft 更新清单工具。 有关 SMS 扫描工具的详细信息,请参阅 SMS 2003 软件更新扫描工具。 请参阅 Downloads for Systems Management Server 2003

System Center Configuration Manager 2007 使用 WSUS 3.0 来检测更新。 有关 Configuration Manager 2007 软件更新管理的详细信息,请访问 System Center Configuration Manager 2007

有关 SMS 的详细信息,请访问 SMS 网站

有关详细信息,请参阅 Microsoft 知识库文章 910723: 每月检测和部署指南文章的摘要列表。

更新兼容性评估程序和应用程序兼容性工具箱

此更新通常写入运行应用程序所必需的相同文件和注册表设置。 这可触发不兼容并使安全更新的部署占用更多的时间。 通过使用应用程序兼容性工具包中包含的更新兼容性评估程序组件,您可以简化测试和验证对已安装程序进行的 Windows 更新。

应用程序兼容性工具包 (ACT) 包含必要的工具和文档,以便在您的环境中部署 Microsoft Windows Vista、Windows Update、Microsoft Security Update 或新版本的 Windows Internet Explorer 之前评估和缓减应用程序的兼容性问题。

受影响的软件

有关您的受影响软件的特定安全更新信息,请单击相应的链接:

Windows Server 2008(所有版本)

参考表

下表包含此软件的安全更新信息。 您可以在本节的“部署信息”小节中找到更多信息。

包括在以后的 Service Pack 中 此问题的更新程序将包含在以后的 Service Pack 或更新汇总中
部署
没有用户干预的安装对于 Windows Server 2008 所有受支持的基于 x64 的版本:
Windows6.0-KB977894-x64 /quiet
在不重新启动的情况下安装对于 Windows Server 2008 所有受支持的基于 x64 的版本:
Windows6.0-KB977894-x64 /quiet /norestart
更多信息请参阅“检测和部署工具及指导”小节
重新启动要求
要求重新启动?是,应用此安全更新后必须重新启动系统。
HotPatching不适用。
删除信息 WUSA.exe 不支持卸载更新。 要卸载由 WUSA 安装的更新,请单击“控制面板”,然后单击“安全”。 在“Windows Update”下,单击“查看安装的更新”并从更新列表中选择。
文件信息 请参阅 Microsoft 知识库文章 977894
注册表项验证 没有用于验证此更新是否存在的注册表项。

部署信息

安装更新

当您安装此安全更新时,安装程序将检查系统中正在更新的一个或多个文件是否已由 Microsoft 修补程序更新。

有关本公告中出现的术语(如“修补程序”)的详细信息,请参阅 Microsoft 知识库文章 824684

此安全更新支持以下安装开关。

受支持的安全更新安装开关
开关描述
/?、/h、/help 在支持的开关上显示帮助。
/quiet 抑制显示状态或者错误消息。
/norestart 当与 /quiet 结合使用时,系统在安装之后不会重新启动,即使要求重新启动才能完成安装也是如此。

注意 有关 wusa.exe 安装程序的详细信息,请参阅 Microsoft 知识库文章 934307

验证是否已应用更新

  • Microsoft Baseline Security Analyzer

    要验证受影响的系统上是否应用了安全更新,可以使用 Microsoft Baseline Security Analyzer (MBSA) 工具。 有关详细信息,请参阅本公告前面的“检测和部署工具及指导”一节。

  • 文件版本验证

    由于 Microsoft Windows 有多个版本,因此以下步骤可能会与您的系统上的步骤不同。 如果不同,请参阅产品文档来完成这些步骤。

    1. 单击“开始”,然后在“开始搜索”中输入更新文件名。
    2. 当文件显示在“程序”之下时,右键单击文件名,然后单击“属性”。
    3. 在“常规”选项卡之下,将文件大小与公告知识库文章中提供的文件信息表进行比较。
    4. 您也可以单击“详细信息”选项卡,并将信息(如文件版本和修改日期)与公告知识库文章中提供的文件信息表进行比较。
    5. 最后,您也可以单击“以前的版本”选项卡,并将文件的以前版本的文件信息与新的或经过更新的文件版本的文件信息进行比较。

Windows Server 2008 R2(所有版本)

参考表

下表包含此软件的安全更新信息。 您可以在本节的“部署信息”小节中找到更多信息。

包括在以后的 Service Pack 中 此问题的更新程序将包含在以后的 Service Pack 或更新汇总中
部署
没有用户干预的安装对于 Windows Server 2008 R2 所有受支持的基于 x64 的版本:
Windows6.1-KB977894-x64 /quiet
在不重新启动的情况下安装对于 Windows Server 2008 R2 所有受支持的基于 x64 的版本:
Windows6.1-KB977894-x64 /quiet /norestart
更多信息请参阅“检测和部署工具及指导”小节
重新启动要求
要求重新启动?是,应用此安全更新后必须重新启动系统。
HotPatching不适用。
删除信息 WUSA.exe 不支持卸载更新。 要卸载由 WUSA 安装的更新,请单击“控制面板”,然后单击“安全”。 在“Windows Update”下,单击“查看安装的更新”并从更新列表中选择。
文件信息 请参阅 Microsoft 知识库文章 977894
注册表项验证 没有用于验证此更新是否存在的注册表项。

部署信息

安装更新

当您安装此安全更新时,安装程序将检查系统中正在更新的一个或多个文件是否已由 Microsoft 修补程序更新。

有关本公告中出现的术语(如“修补程序”)的详细信息,请参阅 Microsoft 知识库文章 824684

此安全更新支持以下安装开关。

受支持的安全更新安装开关
开关描述
/?、/h、/help 在支持的开关上显示帮助。
/quiet 抑制显示状态或者错误消息。
/norestart 当与 /quiet 结合使用时,系统在安装之后不会重新启动,即使要求重新启动才能完成安装也是如此。

注意 有关 wusa.exe 安装程序的详细信息,请参阅 Microsoft 知识库文章 934307

验证是否已应用更新

  • Microsoft Baseline Security Analyzer

    要验证受影响的系统上是否应用了安全更新,可以使用 Microsoft Baseline Security Analyzer (MBSA) 工具。 有关详细信息,请参阅本公告前面的“检测和部署工具及指导”一节。

  • 文件版本验证

    由于 Microsoft Windows 有多个版本,因此以下步骤可能会与您的系统上的步骤不同。 如果不同,请参阅产品文档来完成这些步骤。

    1. 单击“开始”,然后在“开始搜索”中输入更新文件名。
    2. 当文件显示在“程序”之下时,右键单击文件名,然后单击“属性”。
    3. 在“常规”选项卡之下,将文件大小与公告知识库文章中提供的文件信息表进行比较。
    4. 您也可以单击“详细信息”选项卡,并将信息(如文件版本和修改日期)与公告知识库文章中提供的文件信息表进行比较。
    5. 最后,您也可以单击“以前的版本”选项卡,并将文件的以前版本的文件信息与新的或经过更新的文件版本的文件信息进行比较。

其他信息

鸣谢

Microsoft 感谢下列人员或组织与我们一起致力于保护客户的利益:

  • Jan Bottorff 报告了 Hyper-V 指令集验证漏洞 (CVE-2010-0026)

Microsoft Active Protections Program (MAPP)

为改进客户的安全保护,Microsoft 在发布每月安全更新之前将向主要的安全软件供应商提供漏洞信息。 然后,安全软件供应商可以使用该漏洞信息通过其安全软件或者设备向客户提供更新的保护,例如防病毒、基于网络的入侵检测系统或者基于主机的入侵防止系统。 要确定是否可从安全软件供应商处得到活动保护,请访问计划合作伙伴(在 Microsoft Active Protections Program (MAPP) 合作伙伴中列出)提供的活动保护网站。

支持

  • 美国和加拿大的客户可以通过安全支持或 1-866-PCSAFETY 获得技术支持。 与安全更新有关的电话支持服务是免费的。 有关可用支持选项的详细信息,请参阅 Microsoft 帮助和支持网站。
  • 其他国家(或地区)的用户可从当地的 Microsoft 分公司获得支持。 与安全更新有关的支持服务不收取任何费用。 有关如何就支持问题与 Microsoft 取得联系方面的详细信息,请访问国际支持网站

免责声明

Microsoft 知识库中的信息“按原样”提供,没有任何形式的担保。 Microsoft 不作任何明示或暗示保证,包括对适销性和针对特定目的的适用性的保证。 Microsoft Corporation 或其供应商不对任何损害(包括直接的、间接的、偶然的、必然的损害,商业利润损失,或特殊损害)承担任何责任,即使 Microsoft Corporation 或其供应商事先已被告知有可能发生此类损害。 有些州不允许排除或限制必然或偶然损害的赔偿责任,因此上述限制可能不适用。

修订版本

  • V1.0(2010 年 2 月 9 日): 已发布公告。

Built at 2014-04-18T01:50:00Z-07:00

显示: