Microsoft 安全公告 MS10-071 - 严重

Internet Explorer 的累积性安全更新 (2360131)

发布时间: 2010年10月12日 | 更新时间: 2010年10月13日

版本: 1.1

一般信息

摘要

此安全更新可解决 Internet Explorer 中七个秘密报告的漏洞和三个公开披露的漏洞。 最严重的漏洞可能在用户使用 Internet Explorer 查看特制网页时允许远程执行代码。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。

对于 Windows 客户端上的 Internet Explorer 6、Internet Explorer 7 和 Internet Explorer 8,此安全更新的等级为“严重”;对于 Windows 服务器上的 Internet Explorer 6、Internet Explorer 7 和 Internet Explorer 8,此安全更新的等级为“重要”。 有关详细信息,请参阅本节中“受影响和不受影响的软件”小节。

此安全更新通过修改 Internet Explorer 在某些过程中处理内存中的对象、CSS 特殊字符、HTML 清理、AutoComplete 功能、锚元素和脚本的方式来解决这些漏洞。 有关漏洞的详细信息,请参阅下一节“漏洞信息”下面的常见问题 (FAQ) 小节。

建议。 大多数客户均启用了“自动更新”,他们不必采取任何操作,因为此安全更新将自动下载并安装。 尚未启用“自动更新”的客户必须检查更新,并手动安装此更新。 有关自动更新中特定配置选项的信息,请参阅 Microsoft 知识库文章 294871

对于管理员、企业安装或者想要手动安装此安全更新的最终用户,Microsoft 建议客户使用更新管理软件立即应用此更新或者利用 Microsoft Update 服务检查更新。

另请参阅本公告后面部分中的“检测和部署工具及指导”一节。

已知问题。 无

受影响和不受影响的软件

已对下列软件进行测试,以确定受到影响的版本。 其他版本的支持生命周期已结束或者不受影响。 要确定软件版本的技术支持生命周期,请访问 Microsoft 技术支持生命周期

受影响的软件

操作系统组件最大安全影响综合严重等级此更新替代的公告
Internet Explorer 6
Windows XP Service Pack 3 Internet Explorer 6 远程执行代码严重 MS10-053
Windows XP Professional x64 Edition Service Pack 2 Internet Explorer 6 远程执行代码严重 MS10-053
Windows Server 2003 Service Pack 2 Internet Explorer 6 远程执行代码重要 MS10-053
Windows Server 2003 x64 Edition Service Pack 2 Internet Explorer 6 远程执行代码重要 MS10-053
Windows Server 2003 SP2(用于基于 Itanium 的系统) Internet Explorer 6 远程执行代码重要 MS10-053
Internet Explorer 7
Windows XP Service Pack 3 Internet Explorer 7 远程执行代码严重 MS10-053
Windows XP Professional x64 Edition Service Pack 2 Internet Explorer 7 远程执行代码严重 MS10-053
Windows Server 2003 Service Pack 2 Internet Explorer 7 远程执行代码重要 MS10-053
Windows Server 2003 x64 Edition Service Pack 2 Internet Explorer 7 远程执行代码重要 MS10-053
Windows Server 2003 SP2(用于基于 Itanium 的系统) Internet Explorer 7 远程执行代码重要 MS10-053
Windows Vista Service Pack 1 和 Windows Vista Service Pack 2 Internet Explorer 7 远程执行代码严重 MS10-053
Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2 Internet Explorer 7 远程执行代码严重 MS10-053
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2 Internet Explorer 7**远程执行代码重要 MS10-053
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 Internet Explorer 7**远程执行代码重要 MS10-053
Windows Server 2008(用于基于 Itanium 的系统)和 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 Internet Explorer 7 远程执行代码重要 MS10-053
Internet Explorer 8
Windows XP Service Pack 3 Internet Explorer 8 远程执行代码严重 MS10-053
Windows XP Professional x64 Edition Service Pack 2 Internet Explorer 8 远程执行代码严重 MS10-053
Windows Server 2003 Service Pack 2 Internet Explorer 8 远程执行代码重要 MS10-053
Windows Server 2003 x64 Edition Service Pack 2 Internet Explorer 8 远程执行代码重要 MS10-053
Windows Vista Service Pack 1 和 Windows Vista Service Pack 2 Internet Explorer 8 远程执行代码严重 MS10-053
Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2 Internet Explorer 8 远程执行代码严重 MS10-053
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2 Internet Explorer 8**远程执行代码重要 MS10-053
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 Internet Explorer 8**远程执行代码重要 MS10-053
Windows 7(用于 32 位系统) Internet Explorer 8 远程执行代码严重 MS10-053
Windows 7(用于基于 x64 的系统) Internet Explorer 8 远程执行代码严重 MS10-053
Windows Server 2008 R2(用于基于 x64 的系统) Internet Explorer 8**远程执行代码重要 MS10-053
Windows Server 2008 R2(用于基于 Itanium 的系统) Internet Explorer 8 远程执行代码重要 MS10-053

** 服务器核心安装不受影响。 如果使用服务器核心安装选项安装如上所述的 Windows Server 2008 或 Windows Server 2008 R2,则此更新所解决的漏洞不会影响其的受支持版本。 有关此安装选项的详细信息,请参阅 TechNet 文章管理服务器核心安装服务服务器核心安装。 注意,服务器核心安装选项不适用于 Windows Server 2008 和 Windows Server 2008 R2 的某些版本;请参阅比较服务器核心安装选项

在哪里可以找到文件信息详细资料?  
有关文件信息详细资料的位置,请参阅“安全更新部署”部分中的参考表。

Windows 7 Service Pack 1 Beta Windows Server 2008 R2 Service Pack 1 Beta 发行版如何受这些漏洞影响?  
Windows 7 Service Pack 1 Beta 和 Windows Server 2008 R2 Service Pack 1 Beta 受此公告中介绍的漏洞影响。 鼓励运行这些测试版本的客户下载并向其系统应用此更新。 安全更新可从 Microsoft UpdateWindows Update 获得。 此安全更新也可以从 Microsoft 下载中心下载。

此安全更新与 MS10-072 有什么联系?  
此公告中描述的 HTML 清理漏洞 (CVE-2010-3243) 和 HTML 清理漏洞 (CVE-2010-3324) 也影响 Microsoft SharePoint。 但您只能安装与您的系统上安装的软件对应的更新。 如果您已安装 Internet Explorer,请根据此公告应用所需更新。 如果您已安装 Microsoft SharePoint,请根据 MS10-072 应用所需更新。

此更新为何消除了多个已报告的安全漏洞?  
此更新之所以包含对某些漏洞的支持,是因为解决这些问题所需的修改位于相关的文件中。 客户只需安装此更新就可以了,而不用安装多个几乎相同的更新。

我选择了 Internet Explorer 之外的其他默认浏览器。 是否仍需要应用此更新?  
Internet Explorer 针对 Windows 以及通过 Internet Explorer 的累积性安全更新维护的第三方程序提供应用程序服务和功能。 Microsoft 建议用户立即应用此更新。 大多数客户均启用了“自动更新”,他们不必采取任何操作,因为此安全更新将自动下载并安装。

我正在使用本安全公告中讨论的软件的较旧版本。 我该怎么办?  
已对本公告中列出的受影响的软件进行测试,以确定受到影响的版本。 其他版本的支持生命周期已结束。 有关产品生命周期的详细信息,请访问 Microsoft 产品技术支持生命周期网站

使用该软件的较旧版本的客户应优先考虑迁移到受支持的版本,以防止可能会受到新出现漏洞的影响。 要确定您的软件版本的技术支持生命周期,请参阅选择一项产品以获取生命周期信息。 有关这些软件版本的 Service Pack 的详细信息,请参阅生命周期支持的 Service Pack

如果用户需要获得较旧软件的定制支持,则必须与其 Microsoft 客服小组代表、其技术客户经理或适当的 Microsoft 合作伙伴代表联系以了解定制支持选项。 没有联合合同、优先支持合同或授权合同的客户可与其当地的 Microsoft 销售分支机构联系。 有关联系信息,请访问 Microsoft Worldwide Information 网站,在联系信息列表中选择国家/地区,然后单击“Go”以查看电话号码列表。 在拨打电话时,请找当地的“企业技术咨询支持服务”销售经理进行洽谈。 有关详细信息,请参阅 Microsoft 技术支持生命周期策略常见问题

漏洞信息

以下严重等级假设漏洞的可能的最大影响。 有关此安全公告发布 30 天内,漏洞利用的安全等级和安全影响的可能性的信息,请参阅 10 月份公告摘要中的利用指数。 有关详细信息,请参阅 Microsoft 利用指数

表:第1部分(后续接第2部分)

按受影响软件列出的漏洞严重等级和最大安全影响
受影响的软件AutoComplete 信息泄露漏洞 - CVE-2010-0808HTML 清理漏洞 - CVE-2010-3243HTML 清理漏洞 - CVE-2010-3324CSS 特殊字符信息泄露漏洞 - CVE-2010-3325未初始化的内存损坏漏洞 - CVE-2010-3326
Internet Explorer 6
Windows XP Service Pack 3 上的 Internet Explorer 6 中等 
信息泄露
不适用不适用 重要 
信息泄露
严重 
远程执行代码
用于 Windows XP Professional x64 Edition Service Pack 2 的 Internet Explorer 6 中等 
信息泄露
不适用不适用 重要 
信息泄露
严重 
远程执行代码
用于 Windows Server 2003 Service Pack 2 的 Internet Explorer 6不适用不适用  
信息泄露
中等 
远程执行代码
用于 Windows Server 2003 x64 Edition Service Pack 2 的 Internet Explorer 6不适用不适用  
信息泄露
中等 
远程执行代码
用于 Windows Server 2003 SP2(用于基于 Itanium 的系统)的 Internet Explorer 6不适用不适用  
信息泄露
中等 
远程执行代码
Internet Explorer 7
Windows XP Service Pack 3 上的 Internet Explorer 7 中等 
信息泄露
不适用不适用 重要 
信息泄露
不适用
用于 Windows XP Professional x64 Edition Service Pack 2 的 Internet Explorer 7 中等 
信息泄露
不适用不适用 重要 
信息泄露
不适用
用于 Windows Server 2003 Service Pack 2 的 Internet Explorer 7不适用不适用  
信息泄露
不适用
用于 Windows Server 2003 x64 Edition Service Pack 2 的 Internet Explorer 7不适用不适用  
信息泄露
不适用
用于 Windows Server 2003 SP2(用于基于 Itanium 的系统)的 Internet Explorer 7不适用不适用  
信息泄露
不适用
Windows Vista Service Pack 1 和 Windows Vista Service Pack 2 中的 Internet Explorer 7 中等 
信息泄露
不适用不适用 重要 
信息泄露
不适用
Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2 中的 Internet Explorer 7 中等 
信息泄露
不适用不适用 重要 
信息泄露
不适用
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2 中的 Internet Explorer 7**不适用不适用  
信息泄露
不适用
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 中的 Internet Explorer 7**不适用不适用  
信息泄露
不适用
Windows Server 2008(用于基于 Itanium 的系统)和 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 中的 Internet Explorer 7不适用不适用  
信息泄露
不适用
Internet Explorer 8
Windows XP Service Pack 3 上的 Internet Explorer 8不适用 重要 
信息泄露
重要 
信息泄露
重要 
信息泄露
不适用
用于 Windows XP Professional x64 Edition Service Pack 2 的 Internet Explorer 8不适用 重要 
信息泄露
重要 
信息泄露
重要 
信息泄露
不适用
用于 Windows Server 2003 Service Pack 2 的 Internet Explorer 8不适用  
信息泄露
 
信息泄露
 
信息泄露
不适用
用于 Windows Server 2003 x64 Edition Service Pack 2 的 Internet Explorer 8不适用  
信息泄露
 
信息泄露
 
信息泄露
不适用
Vista Service Pack 1 和 Windows Vista Service Pack 2 中的 Internet Explorer 8不适用 重要 
信息泄露
重要 
信息泄露
重要 
信息泄露
不适用
Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2 中的 Internet Explorer 8不适用 重要 
信息泄露
重要 
信息泄露
重要 
信息泄露
不适用
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2 中的 Internet Explorer 8**不适用  
信息泄露
 
信息泄露
 
信息泄露
不适用
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 中的 Internet Explorer 8**不适用  
信息泄露
 
信息泄露
 
信息泄露
不适用
Windows 7 中的 Internet Explorer 8(用于 32 位系统)不适用 重要 
信息泄露
重要 
信息泄露
重要 
信息泄露
不适用
Windows 7 中的 Internet Explorer 8(用于基于 x64 的系统)不适用 重要 
信息泄露
重要 
信息泄露
重要 
信息泄露
不适用
Windows Server 2008 R2(用于基于 x64 的系统)中的 Internet Explorer 8**不适用  
信息泄露
 
信息泄露
 
信息泄露
不适用
Windows Server 2008 R2(用于基于 Itanium 的系统)中的 Internet Explorer 8不适用  
信息泄露
 
信息泄露
 
信息泄露
不适用

表:第2部分(前接第1部分)

按受影响软件列出的漏洞严重等级和最大安全影响
受影响的软件锚元素信息泄露漏洞 - CVE-2010-3327未初始化的内存损坏漏洞 - CVE-2010-3328未初始化的内存损坏漏洞 - CVE-2010-3329跨域信息泄露漏洞 - CVE-2010-3330未初始化的内存损坏漏洞 - CVE-2010-3331综合严重等级
Internet Explorer 6
Windows XP Service Pack 3 上的 Internet Explorer 6 中等 
信息泄露
严重 
远程执行代码
不适用 重要 
信息泄露
重要 
远程执行代码
严重
用于 Windows XP Professional x64 Edition Service Pack 2 的 Internet Explorer 6 中等 
信息泄露
严重 
远程执行代码
不适用 重要 
信息泄露
重要 
远程执行代码
严重
用于 Windows Server 2003 Service Pack 2 的 Internet Explorer 6 中等 
信息泄露
中等 
远程执行代码
不适用  
信息泄露
重要 
远程执行代码
重要
用于 Windows Server 2003 x64 Edition Service Pack 2 的 Internet Explorer 6 中等 
信息泄露
中等 
远程执行代码
不适用  
信息泄露
重要 
远程执行代码
重要
用于 Windows Server 2003 SP2(用于基于 Itanium 的系统)的 Internet Explorer 6 中等 
信息泄露
中等 
远程执行代码
不适用  
信息泄露
重要 
远程执行代码
重要
Internet Explorer 7
Windows XP Service Pack 3 上的 Internet Explorer 7 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
用于 Windows XP Professional x64 Edition Service Pack 2 的 Internet Explorer 7 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
用于 Windows Server 2003 Service Pack 2 的 Internet Explorer 7 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
用于 Windows Server 2003 x64 Edition Service Pack 2 的 Internet Explorer 7 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
用于 Windows Server 2003 SP2(用于基于 Itanium 的系统)的 Internet Explorer 7 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
Windows Vista Service Pack 1 和 Windows Vista Service Pack 2 中的 Internet Explorer 7 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2 中的 Internet Explorer 7 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2 中的 Internet Explorer 7** 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 中的 Internet Explorer 7** 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
Windows Server 2008(用于基于 Itanium 的系统)和 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 中的 Internet Explorer 7 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
Internet Explorer 8
Windows XP Service Pack 3 上的 Internet Explorer 8 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
用于 Windows XP Professional x64 Edition Service Pack 2 的 Internet Explorer 8 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
用于 Windows Server 2003 Service Pack 2 的 Internet Explorer 8 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
用于 Windows Server 2003 x64 Edition Service Pack 2 的 Internet Explorer 8 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
Vista Service Pack 1 和 Windows Vista Service Pack 2 中的 Internet Explorer 8 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2 中的 Internet Explorer 8 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2 中的 Internet Explorer 8** 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 中的 Internet Explorer 8** 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
Windows 7 中的 Internet Explorer 8(用于 32 位系统) 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
Windows 7 中的 Internet Explorer 8(用于基于 x64 的系统) 中等 
信息泄露
严重 
远程执行代码
重要 
远程执行代码
重要 
信息泄露
重要 
远程执行代码
严重
Windows Server 2008 R2(用于基于 x64 的系统)中的 Internet Explorer 8** 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要
Windows Server 2008 R2(用于基于 Itanium 的系统)中的 Internet Explorer 8 中等 
信息泄露
中等 
远程执行代码
重要 
远程执行代码
 
信息泄露
重要 
远程执行代码
重要

** 服务器核心安装不受影响。 如果使用服务器核心安装选项安装如上所述的 Windows Server 2008 或 Windows Server 2008 R2,则此更新所解决的漏洞不会影响其的受支持版本。 有关此安装选项的详细信息,请参阅 TechNet 文章管理服务器核心安装服务服务器核心安装。 注意,服务器核心安装选项不适用于 Windows Server 2008 和 Windows Server 2008 R2 的某些版本;请参阅比较服务器核心安装选项

存在一个信息泄露漏洞,可能允许 Internet Explorer 中的表单数据通过 AutoComplete 功能获取。 如果用户查看网页,攻击者可通过构建一个允许信息泄露的特制网页来利用漏洞。 成功利用此漏洞的攻击者可以获取之前启用 AutoComplete 功能后输入字段中的信息。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-0808

AutoComplete 信息泄露漏洞 (CVE-2010-0808) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 此模式将 Internet 区域的安全级别设置为“高”。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 有关 Internet Explorer 增强安全配置的详细信息,请参阅此漏洞的“常见问题”部分。

AutoComplete 信息泄露漏洞 (CVE-2010-0808) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • Internet 和本地 Intranet 安全区域设置设为 ,以便在这些区域中阻止 ActiveX 控件和活动脚本

    通过更改 Internet 安全区域的设置以阻止 ActiveX 控件和活动脚本,可帮助防止利用此漏洞。 通过将浏览器的安全级别设置为“高”可以达到上述目的。

    要提高 Internet Explorer 中的浏览安全级别,请按照以下步骤进行操作:

    1. 在 Internet Explorer 的“工具”菜单上,单击“Internet 选项”。
    2. 在“Internet 选项”对话框中,单击“安全”选项卡,然后单击“Internet”图标。
    3. 在“该区域的安全级别”下,将滑块移至“”。 这将您访问的所有网站的安全级别均设置为“高”。

    注意 如果看不到滑块,请单击“默认级别”,然后再将滑块移至“”。

    注意 将安全级别设置为“高”可能会导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 在这种情况下,即使安全级别设置为“高”,此站点也可以正常工作。

    变通办法的影响。 阻止 ActiveX 控件和活动脚本会带来负面影响。 Internet 或 Intranet 上的许多网站都使用 ActiveX 或活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用 ActiveX 控件来提供菜单、订购单乃至帐户报表。 阻止 ActiveX 控件或活动脚本是一个全局设置,它影响所有 Internet 和 Intranet 站点。 如果不希望针对这些站点阻止 ActiveX 控件或活动脚本,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在 Internet 区域和本地 Intranet 区域中将 Internet Explorer 设置为阻止 ActiveX 控件和活动脚本之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

  • Internet Explorer 配置为在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示

    通过更改设置,以在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示,可帮助防止利用此漏洞。 为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”菜单上的“Internet 选项”。
    2. 单击“安全”选项卡。
    3. 单击“Internet”,然后单击“自定义级别”。
    4. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    5. 单击“本地 Intranet”,然后单击“自定义级别”。
    6. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    7. 单击“确定”两次返回到 Internet Explorer。

    注意 禁用 Internet 和本地 Intranet 安全区域中的活动脚本可能导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 这将允许站点正常工作。

    变通办法的影响。 在运行活动脚本之前提示有负面影响。 Internet 或 Intranet 上的许多网站都使用活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用活动脚本来提供菜单、订购单乃至帐户报表。 在运行活动脚本之前进行提示是一个全局设置,它影响所有 Internet 和 Intranet 站点。 在启用此变通方法后,将会频繁出现提示。 对于每一提示,如果您认为信任您所访问的站点,则单击“”运行活动脚本。 如果您不想在访问所有这些网站时进行提示,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在将 Internet Explorer 设置为在 Internet 区域和本地 Intranet 区域运行 ActiveX 控件和活动脚本之前需要提示之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

AutoComplete 信息泄露漏洞 (CVE-2010-0808) 的常见问题

此漏洞的影响范围有多大?  
这是一个信息泄露漏洞。 在用户查看网页时利用此漏洞的攻击者可捕获启用 AutoComplete 功能后输入表单字段中的内容。

造成此漏洞的原因是什么?  
Internet Explorer 允许自动脚本指令使用 AutoComplete 功能模拟用户操作。

什么是 AutoComplete 功能?  
AutoComplete 是 Internet Explorer 中的一项功能,可帮助用户在表单字段中快速输入信息。 有关详细信息,请参阅 MSDN 文章“在 HTML 表单中使用 AutoComplete”。

攻击者可能利用此漏洞执行什么操作?  
成功利用此漏洞的攻击者可能捕获以前输入浏览器表单中的数据。 默认情况下,将禁用 AutoComplete 功能。

攻击者如何利用此漏洞?  
攻击者可能拥有一个旨在通过 Internet Explorer 利用此漏洞的特制网站,然后诱使用户查看该网站。 攻击者还可能利用受到破坏的网站以及接受或宿主用户提供的内容或广告的网站。 这些网站可能包含可以利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户访问这些网站。 相反,攻击者必须说服用户访问该网站,方法通常是让用户单击电子邮件或 Instant Messenger 消息中的链接以使用户链接到攻击者的网站。 它还可能使用横幅广告或其他方式显示特制的 Web 内容,以便将 Web 内容传递至受影响的系统。

受此漏洞威胁最大的系统有哪些?  
要利用此漏洞执行任何恶意操作,需要用户登录并访问网站。 因此,任何频繁使用 Internet Explorer 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

此更新有什么作用?  
此更新通过修改 Internet Explorer 中的 AutoComplete 功能来解决此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
是。 此漏洞已公开披露。 已为此漏洞分配了常见漏洞和披露号码 CVE-2010-0808

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已被公开用于攻击客户的信息,也没有看到任何发布的概念代码证明示例。

我当前是在 Windows Server 2003 Windows Server 2008 上运行 Internet Explorer,这是否可以减轻此漏洞的影响?  
是。 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 增强安全配置是一组预先配置好的 Internet Explorer 设置,可以减小用户或管理员在服务器上下载并运行特制 Web 内容的可能性。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 另请参阅管理 Internet Explorer 增强安全配置

toStaticHTML API 清理 HTML 的方式中存在一个信息泄露漏洞,可能允许攻击者执行跨站点脚本攻击,并在登录用户的安全上下文中运行脚本。 成功利用此漏洞的攻击者可以执行用户的跨站点脚本攻击,允许攻击者在使用 toStaticHTML API 的站点上的用户安全上下文中执行脚本。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3243

HTML 清理漏洞 (CVE-2010-3243) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 此模式将 Internet 区域的安全级别设置为“高”。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 有关 Internet Explorer 增强安全配置的详细信息,请参阅此漏洞的“常见问题”部分。
  • 只有使用 toStaticHTML 的网站可能会受到影响。

HTML 清理漏洞 (CVE-2010-3243) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • 以纯文本格式阅读电子邮件

    要帮助保护自己免受来自电子邮件攻击媒介的攻击,请以纯文本格式阅读电子邮件。

    已应用了 Office XP Service Pack 1 或更高版本的 Microsoft Office Outlook 2002 用户以及应用了 Internet Explorer 6 Service Pack 1 或更高版本的 Microsoft Office Outlook Express 6 用户可以启用此设置,仅用纯文本格式查看所有不带数字签名的电子邮件或未加密的电子邮件。

    带数字签名的电子邮件或加密的电子邮件不受此设置的影响,可以用其原始格式阅读。 有关在 Outlook 2002 中如何启用此设置的详细信息,请参阅 Microsoft 知识库文章 307594

    有关 Outlook Express 6 中此设置的信息,请参阅 Microsoft 知识库文章 291387

    变通办法的影响。 用纯文本格式查看的电子邮件中不会包含图片、特殊字体、动画或其他丰富内容。 此外:

    • 这些更改适用于预览窗格和打开的邮件。
    • 图片变成了附件,因此不会丢失。
    • 由于存储区中的邮件仍然是 RTF 格式或 HTML 格式,因此对象模型(自定义代码解决方案)可能不按预期方式运行。
  • Internet 和本地 Intranet 安全区域设置设为 ,以便在这些区域中阻止 ActiveX 控件和活动脚本

    通过更改 Internet 安全区域的设置以阻止 ActiveX 控件和活动脚本,可帮助防止利用此漏洞。 通过将浏览器的安全级别设置为“高”可以达到上述目的。

    要提高 Internet Explorer 中的浏览安全级别,请按照以下步骤进行操作:

    1. 在 Internet Explorer 的“工具”菜单上,单击“Internet 选项”。
    2. 在“Internet 选项”对话框中,单击“安全”选项卡,然后单击“Internet”图标。
    3. 在“该区域的安全级别”下,将滑块移至“”。 这将您访问的所有网站的安全级别均设置为“高”。

    注意 如果看不到滑块,请单击“默认级别”,然后再将滑块移至“”。

    注意 将安全级别设置为“高”可能会导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 在这种情况下,即使安全级别设置为“高”,此站点也可以正常工作。

    变通办法的影响。 阻止 ActiveX 控件和活动脚本会带来负面影响。 Internet 或 Intranet 上的许多网站都使用 ActiveX 或活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用 ActiveX 控件来提供菜单、订购单乃至帐户报表。 阻止 ActiveX 控件或活动脚本是一个全局设置,它影响所有 Internet 和 Intranet 站点。 如果不希望针对这些站点阻止 ActiveX 控件或活动脚本,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在 Internet 区域和本地 Intranet 区域中将 Internet Explorer 设置为阻止 ActiveX 控件和活动脚本之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

  • Internet Explorer 配置为在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示

    通过更改设置,以在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示,可帮助防止利用此漏洞。 为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”菜单上的“Internet 选项”。
    2. 单击“安全”选项卡。
    3. 单击“Internet”,然后单击“自定义级别”。
    4. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    5. 单击“本地 Intranet”,然后单击“自定义级别”。
    6. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    7. 单击“确定”两次返回到 Internet Explorer。

    注意 禁用 Internet 和本地 Intranet 安全区域中的活动脚本可能导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 这将允许站点正常工作。

    变通办法的影响。 在运行活动脚本之前提示有负面影响。 Internet 或 Intranet 上的许多网站都使用活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用活动脚本来提供菜单、订购单乃至帐户报表。 在运行活动脚本之前进行提示是一个全局设置,它影响所有 Internet 和 Intranet 站点。 在启用此变通方法后,将会频繁出现提示。 对于每一提示,如果您认为信任您所访问的站点,则单击“”运行活动脚本。 如果您不想在访问所有这些网站时进行提示,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在将 Internet Explorer 设置为在 Internet 区域和本地 Intranet 区域运行 ActiveX 控件和活动脚本之前需要提示之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

HTML 清理漏洞 (CVE-2010-3243) 的常见问题

此漏洞的影响范围有多大?  
这是一个信息泄露漏洞。 在用户查看使用 toStaticHTML API 的网页时,利用此漏洞的攻击者可能会执行用户的跨站点脚本攻击。

造成此漏洞的原因是什么?  
Internet Explorer 在清理 HTML 时处理使用特定字符串的方式中存在漏洞。

什么是 toStaticHTML API   
toStaticHTML API 可用于在将用户输入显示为 HTML 之前从中删除事件属性和脚本。 有关详细信息,请参阅下列 MSDN 库文章 toStaticHTML 方法

此漏洞与 MS10-072 中的 CVE-2010-3243 有何关系, toStaticHTML 中的漏洞是否允许信息泄露?  
是的,HTML 清理漏洞 CVE-2010-4243 也影响 Microsoft SharePoint。

是否需要安装两个更新以免遭漏洞的攻击?   
不,每个更新都针对单独的应用程序。 只需应用与您的系统运行的软件对应的更新。

攻击者可能利用此漏洞执行什么操作?  
当用户在未由 Internet Explorer 正确清理的网站上查看 HTML 时,成功利用此漏洞的攻击者可以在用户的安全上下文中对站点执行脚本。

攻击者如何利用此漏洞?  
要利用此漏洞,攻击者必须能够向目标站点提交特制脚本。 在特定情况下,此漏洞会导致不能使用 toStaticHTML 正确清理特制脚本,因而可能导致在查看网站恶意内容的用户的安全上下文中运行攻击者提供的脚本。

对于跨站点脚本攻击,此漏洞需要用户访问被破坏的网站,才能发生恶意行为。 例如,在攻击者将特制脚本成功提交给目标站点后,包含特制脚本的站点上的任何网页都是持续跨站点脚本攻击的潜在媒介。 当用户访问包含特制脚本的网页时,此脚本可以在站点上用户的安全上下文中运行。

受此漏洞威胁最大的系统有哪些?  
要利用此漏洞执行任何恶意操作,需要用户登录并访问网站。 因此,任何频繁使用 Internet Explorer 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

我当前是在 Windows Server 2003 Windows Server 2008 上运行 Internet Explorer ,这是否可以减轻此漏洞的影响?  
是。 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 增强安全配置是一组预先配置好的 Internet Explorer 设置,可以减小用户或管理员在服务器上下载并运行特制 Web 内容的可能性。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 另请参阅管理 Internet Explorer 增强安全配置

此更新有什么作用?  
此更新通过修改 Internet Explorer 使用 toStaticHTML 处理 HTML 清理的方式来解决此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
否。 Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

toStaticHTML API 清理 HTML 的方式中存在一个信息泄露漏洞,可能允许攻击者执行跨站点脚本攻击,并在登录用户的安全上下文中运行脚本。 成功利用此漏洞的攻击者可以执行用户的跨站点脚本攻击,允许攻击者在使用 toStaticHTML API 的站点上的用户安全上下文中执行脚本。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3324

HTML 清理漏洞 (CVE-2010-3324) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 此模式将 Internet 区域的安全级别设置为“高”。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 有关 Internet Explorer 增强安全配置的详细信息,请参阅此漏洞的“常见问题”部分。
  • 只有使用 toStaticHTML 的网站可能会受到影响。

HTML 清理漏洞 (CVE-2010-3324) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • 以纯文本格式阅读电子邮件

    要帮助保护自己免受来自电子邮件攻击媒介的攻击,请以纯文本格式阅读电子邮件。

    已应用了 Office XP Service Pack 1 或更高版本的 Microsoft Office Outlook 2002 用户以及应用了 Internet Explorer 6 Service Pack 1 或更高版本的 Microsoft Office Outlook Express 6 用户可以启用此设置,仅用纯文本格式查看所有不带数字签名的电子邮件或未加密的电子邮件。

    带数字签名的电子邮件或加密的电子邮件不受此设置的影响,可以用其原始格式阅读。 有关在 Outlook 2002 中如何启用此设置的详细信息,请参阅 Microsoft 知识库文章 307594

    有关 Outlook Express 6 中此设置的信息,请参阅 Microsoft 知识库文章 291387

    变通办法的影响。 用纯文本格式查看的电子邮件中不会包含图片、特殊字体、动画或其他丰富内容。 此外:

    • 这些更改适用于预览窗格和打开的邮件。
    • 图片变成了附件,因此不会丢失。
    • 由于存储区中的邮件仍然是 RTF 格式或 HTML 格式,因此对象模型(自定义代码解决方案)可能不按预期方式运行。
  • Internet 和本地 Intranet 安全区域设置设为 ,以便在这些区域中阻止 ActiveX 控件和活动脚本

    通过更改 Internet 安全区域的设置以阻止 ActiveX 控件和活动脚本,可帮助防止利用此漏洞。 通过将浏览器的安全级别设置为“高”可以达到上述目的。

    要提高 Internet Explorer 中的浏览安全级别,请按照以下步骤进行操作:

    1. 在 Internet Explorer 的“工具”菜单上,单击“Internet 选项”。
    2. 在“Internet 选项”对话框中,单击“安全”选项卡,然后单击“Internet”图标。
    3. 在“该区域的安全级别”下,将滑块移至“”。 这将您访问的所有网站的安全级别均设置为“高”。

    注意 如果看不到滑块,请单击“默认级别”,然后再将滑块移至“”。

    注意 将安全级别设置为“高”可能会导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 在这种情况下,即使安全级别设置为“高”,此站点也可以正常工作。

    变通办法的影响。 阻止 ActiveX 控件和活动脚本会带来负面影响。 Internet 或 Intranet 上的许多网站都使用 ActiveX 或活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用 ActiveX 控件来提供菜单、订购单乃至帐户报表。 阻止 ActiveX 控件或活动脚本是一个全局设置,它影响所有 Internet 和 Intranet 站点。 如果不希望针对这些站点阻止 ActiveX 控件或活动脚本,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在 Internet 区域和本地 Intranet 区域中将 Internet Explorer 设置为阻止 ActiveX 控件和活动脚本之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

  • Internet Explorer 配置为在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示

    通过更改设置,以在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示,可帮助防止利用此漏洞。 为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”菜单上的“Internet 选项”。
    2. 单击“安全”选项卡。
    3. 单击“Internet”,然后单击“自定义级别”。
    4. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    5. 单击“本地 Intranet”,然后单击“自定义级别”。
    6. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    7. 单击“确定”两次返回到 Internet Explorer。

    注意 禁用 Internet 和本地 Intranet 安全区域中的活动脚本可能导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 这将允许站点正常工作。

    变通办法的影响。 在运行活动脚本之前提示有负面影响。 Internet 或 Intranet 上的许多网站都使用活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用活动脚本来提供菜单、订购单乃至帐户报表。 在运行活动脚本之前进行提示是一个全局设置,它影响所有 Internet 和 Intranet 站点。 在启用此变通方法后,将会频繁出现提示。 对于每一提示,如果您认为信任您所访问的站点,则单击“”运行活动脚本。 如果您不想在访问所有这些网站时进行提示,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在将 Internet Explorer 设置为在 Internet 区域和本地 Intranet 区域运行 ActiveX 控件和活动脚本之前需要提示之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

HTML 清理漏洞 (CVE-2010-3324) 的常见问题解答

此漏洞的影响范围有多大?  
这是一个信息泄露漏洞。 在用户查看使用 toStaticHTML API 的网页时,利用此漏洞的攻击者可能会执行用户的跨站点脚本攻击。

造成此漏洞的原因是什么?  
Internet Explorer 在清理 HTML 时处理使用特定字符串的方式中存在漏洞。

什么是 toStaticHTML API   
toStaticHTML API 可用于在将用户输入显示为 HTML 之前从中删除事件属性和脚本。 有关详细信息,请参阅下列 MSDN 库文章 toStaticHTML 方法

此漏洞与 MS10-072 中的 CVE-2010-3324 有何关系, toStaticHTML 中的漏洞是否允许信息泄露?  
是的,HTML 清理漏洞 CVE-2010-3324 也影响 Microsoft SharePoint。

是否需要安装两个更新以免遭漏洞的攻击?   
不,每个更新都针对单独的应用程序。 只需应用与您的系统运行的软件对应的更新。

攻击者可能利用此漏洞执行什么操作?  
当用户在未由 Internet Explorer 正确清理的网站上查看 HTML 时,成功利用此漏洞的攻击者可以在用户的安全上下文中对站点执行脚本。

攻击者如何利用此漏洞?  
要利用此漏洞,攻击者必须能够向目标站点提交特制脚本。 在特定情况下,此漏洞会导致不能使用 toStaticHTML 正确清理特制脚本,因而可能导致在查看网站恶意内容的用户的安全上下文中运行攻击者提供的脚本。

对于跨站点脚本攻击,此漏洞需要用户访问被破坏的网站,才能发生恶意行为。 例如,在攻击者将特制脚本成功提交给目标站点后,包含特制脚本的站点上的任何网页都是持续跨站点脚本攻击的潜在媒介。 当用户访问包含特制脚本的网页时,此脚本可以在站点上用户的安全上下文中运行。

受此漏洞威胁最大的系统有哪些?  
要利用此漏洞执行任何恶意操作,需要用户登录并访问网站。 因此,任何频繁使用 Internet Explorer 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

此更新有什么作用?  
此更新通过修改 Internet Explorer 使用 toStaticHTML 处理 HTML 清理的方式来解决此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
是。 此漏洞已公开披露。 已为此漏洞分配了常见漏洞和披露号码 CVE-2010-3324

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

Internet Explorer 处理 CSS 特殊字符的方式中存在一个信息泄露漏洞。 如果用户查看网页,攻击者可通过构建一个允许信息泄露的特制网页来利用漏洞。 成功利用此漏洞的攻击者可查看其他域或 Internet Explorer 区域中的内容。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3325

CSS 特殊字符信息泄露漏洞 (CVE-2010-3325) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助。

  • 在基于 Web 的攻击情形中,攻击者可能拥有一个网站,并在上面放置用来利用此漏洞的网页。 另外,接受或宿主用户提供的内容或广告的网站以及受到破坏的网站可能包含可能利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户访问这些网站。 相反,攻击者必须说服用户访问该网站,方法通常是让用户单击电子邮件或 Instant Messenger 消息中的链接以使用户链接到攻击者的网站。
  • 默认情况下,Microsoft Outlook、Microsoft Outlook Express 和 Windows Mail 的所有支持版本在受限制的站点区域打开 HTML 电子邮件信息(会禁用脚本和 ActiveX 控件),同时删除可利用此漏洞的攻击者执行恶意代码的风险。 在基于 Web 的攻击情形中,如果攻击者单击电子邮件中的链接,他们可能仍然容易受到利用此漏洞的影响。
  • 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 此模式将 Internet 区域的安全级别设置为“高”。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 有关 Internet Explorer 增强安全配置的详细信息,请参阅此漏洞的“常见问题”部分。

CSS 特殊字符信息泄露漏洞 (CVE-2010-3325) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • Internet 和本地 Intranet 安全区域设置设为 ,以便在这些区域中阻止 ActiveX 控件和活动脚本

    通过更改 Internet 安全区域的设置以阻止 ActiveX 控件和活动脚本,可帮助防止利用此漏洞。 通过将浏览器的安全级别设置为“高”可以达到上述目的。

    要提高 Internet Explorer 中的浏览安全级别,请按照以下步骤进行操作:

    1. 在 Internet Explorer 的“工具”菜单上,单击“Internet 选项”。
    2. 在“Internet 选项”对话框中,单击“安全”选项卡,然后单击“Internet”图标。
    3. 在“该区域的安全级别”下,将滑块移至“”。 这将您访问的所有网站的安全级别均设置为“高”。

    注意 如果看不到滑块,请单击“默认级别”,然后再将滑块移至“”。

    注意 将安全级别设置为“高”可能会导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 在这种情况下,即使安全级别设置为“高”,此站点也可以正常工作。

    变通办法的影响。 阻止 ActiveX 控件和活动脚本会带来负面影响。 Internet 或 Intranet 上的许多网站都使用 ActiveX 或活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用 ActiveX 控件来提供菜单、订购单乃至帐户报表。 阻止 ActiveX 控件或活动脚本是一个全局设置,它影响所有 Internet 和 Intranet 站点。 如果不希望针对这些站点阻止 ActiveX 控件或活动脚本,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在 Internet 区域和本地 Intranet 区域中将 Internet Explorer 设置为阻止 ActiveX 控件和活动脚本之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

  • Internet Explorer 配置为在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示

    通过更改设置,以在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示,可帮助防止利用此漏洞。 为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”菜单上的“Internet 选项”。
    2. 单击“安全”选项卡。
    3. 单击“Internet”,然后单击“自定义级别”。
    4. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    5. 单击“本地 Intranet”,然后单击“自定义级别”。
    6. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    7. 单击“确定”两次返回到 Internet Explorer。

    注意 禁用 Internet 和本地 Intranet 安全区域中的活动脚本可能导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 这将允许站点正常工作。

    变通办法的影响。 在运行活动脚本之前提示有负面影响。 Internet 或 Intranet 上的许多网站都使用活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用活动脚本来提供菜单、订购单乃至帐户报表。 在运行活动脚本之前进行提示是一个全局设置,它影响所有 Internet 和 Intranet 站点。 在启用此变通方法后,将会频繁出现提示。 对于每一提示,如果您认为信任您所访问的站点,则单击“”运行活动脚本。 如果您不想在访问所有这些网站时进行提示,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在将 Internet Explorer 设置为在 Internet 区域和本地 Intranet 区域运行 ActiveX 控件和活动脚本之前需要提示之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

CSS 特殊字符信息泄露漏洞 (CVE-2010-3325) 的常见问题解答

此漏洞的影响范围有多大?  
这是一个信息泄露漏洞。 在用户查看网页时,利用此漏洞的攻击者可查看其他域或 Internet Explorer 区域而不是攻击者网页的域或区域中的内容。

造成此漏洞的原因是什么?  
Internet Explorer 未正确处理 CSS 特殊字符,可能允许泄露敏感数据。

攻击者可能利用此漏洞执行什么操作?  
成功利用此漏洞的攻击者可查看其他域或 Internet Explorer 区域中的内容。

攻击者如何利用此漏洞?  
攻击者可能拥有一个旨在通过 Internet Explorer 利用此漏洞的特制网站,然后诱使用户查看该网站。 攻击者还可能利用受到破坏的网站以及接受或宿主用户提供的内容或广告的网站。 这些网站可能包含可以利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户访问这些网站。 相反,攻击者必须说服用户访问该网站,方法通常是让用户单击电子邮件或 Instant Messenger 消息中的链接以使用户链接到攻击者的网站。 它还可能使用横幅广告或其他方式显示特制的 Web 内容,以便将 Web 内容传递至受影响的系统。

受此漏洞威胁最大的系统有哪些?  
要利用此漏洞执行任何恶意操作,需要用户登录并访问网站。 因此,任何频繁使用 Internet Explorer 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

我当前是在 Windows Server 2003 Windows Server 2008 上运行 Internet Explorer ,这是否可以减轻此漏洞的影响?  
是。 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 增强安全配置是一组预先配置好的 Internet Explorer 设置,可以减小用户或管理员在服务器上下载并运行特制 Web 内容的可能性。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 另请参阅管理 Internet Explorer 增强安全配置

此更新有什么作用?  
此更新通过修改 Internet Explorer 处理 CSS 特殊字符的方式来解决此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
是。 此漏洞已公开披露。 已为此漏洞分配了常见漏洞和披露号码 CVE-2010-3325

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已被公开用于攻击客户的信息,也没有看到任何发布的概念代码证明示例。

Internet Explorer 访问尚未正确初始化或已被删除的对象的方式中存在一个远程执行代码漏洞。 攻击者可以通过构建特制的网页来利用该漏洞。 当用户查看网页时,该漏洞可能允许远程执行代码。 成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 如果用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。 攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3326

未初始化的内存损坏漏洞 (CVE-2010-3326) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 在基于 Web 的攻击情形中,攻击者可能拥有一个网站,并在上面放置用来利用此漏洞的网页。 另外,接受或宿主用户提供的内容或广告的网站以及受到破坏的网站可能包含可能利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户访问这些网站。 相反,攻击者必须说服用户访问该网站,方法通常是让用户单击电子邮件或 Instant Messenger 消息中的链接以使用户链接到攻击者的网站。
  • 成功利用此漏洞的攻击者可以获得与本地用户相同的用户权限。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。
  • 默认情况下,Microsoft Outlook、Microsoft Outlook Express 和 Windows Mail 的所有支持版本在受限制的站点区域打开 HTML 电子邮件信息(会禁用脚本和 ActiveX 控件),同时删除可利用此漏洞的攻击者执行恶意代码的风险。 在基于 Web 的攻击情形中,如果攻击者单击电子邮件中的链接,他们可能仍然容易受到利用此漏洞的影响。
  • 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 此模式将 Internet 区域的安全级别设置为“高”。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 有关 Internet Explorer 增强安全配置的详细信息,请参阅此漏洞的“常见问题”部分。

未初始化的内存损坏漏洞 (CVE-2010-3326) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • Internet 和本地 Intranet 安全区域设置设为 ,以便在这些区域中阻止 ActiveX 控件和活动脚本

    通过更改 Internet 安全区域的设置以阻止 ActiveX 控件和活动脚本,可帮助防止利用此漏洞。 通过将浏览器的安全级别设置为“高”可以达到上述目的。

    要提高 Internet Explorer 中的浏览安全级别,请按照以下步骤进行操作:

    1. 在 Internet Explorer 的“工具”菜单上,单击“Internet 选项”。
    2. 在“Internet 选项”对话框中,单击“安全”选项卡,然后单击“Internet”图标。
    3. 在“该区域的安全级别”下,将滑块移至“”。 这将您访问的所有网站的安全级别均设置为“高”。

    注意 如果看不到滑块,请单击“默认级别”,然后再将滑块移至“”。

    注意 将安全级别设置为“高”可能会导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 在这种情况下,即使安全级别设置为“高”,此站点也可以正常工作。

    变通办法的影响。 阻止 ActiveX 控件和活动脚本会带来负面影响。 Internet 或 Intranet 上的许多网站都使用 ActiveX 或活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用 ActiveX 控件来提供菜单、订购单乃至帐户报表。 阻止 ActiveX 控件或活动脚本是一个全局设置,它影响所有 Internet 和 Intranet 站点。 如果不希望针对这些站点阻止 ActiveX 控件或活动脚本,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在 Internet 区域和本地 Intranet 区域中将 Internet Explorer 设置为阻止 ActiveX 控件和活动脚本之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

  • Internet Explorer 配置为在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示

    通过更改设置,以在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示,可帮助防止利用此漏洞。 为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”菜单上的“Internet 选项”。
    2. 单击“安全”选项卡。
    3. 单击“Internet”,然后单击“自定义级别”。
    4. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    5. 单击“本地 Intranet”,然后单击“自定义级别”。
    6. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    7. 单击“确定”两次返回到 Internet Explorer。

    注意 禁用 Internet 和本地 Intranet 安全区域中的活动脚本可能导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 这将允许站点正常工作。

    变通办法的影响。 在运行活动脚本之前提示有负面影响。 Internet 或 Intranet 上的许多网站都使用活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用活动脚本来提供菜单、订购单乃至帐户报表。 在运行活动脚本之前进行提示是一个全局设置,它影响所有 Internet 和 Intranet 站点。 在启用此变通方法后,将会频繁出现提示。 对于每一提示,如果您认为信任您所访问的站点,则单击“”运行活动脚本。 如果您不想在访问所有这些网站时进行提示,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在将 Internet Explorer 设置为在 Internet 区域和本地 Intranet 区域运行 ActiveX 控件和活动脚本之前需要提示之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

未初始化的内存损坏漏洞 (CVE-2010-3326) 的常见问题解答

此漏洞的影响范围有多大?  
这是一个远程执行代码漏洞。 成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。

造成此漏洞的原因是什么?  
当 Internet Explorer 尝试访问未初始化或已删除的对象时,攻击者可以在登录用户的上下文中执行任意代码,从而可能破坏内存。

攻击者可能利用此漏洞执行什么操作?  
成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 如果用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。 攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

攻击者如何利用此漏洞?  
攻击者可能拥有一个旨在通过 Internet Explorer 利用此漏洞的特制网站,然后诱使用户查看该网站。 攻击者也可能在宿主 IE 呈现引擎的应用程序或 Microsoft Office 文档中嵌入标有“安全初始化”的 ActiveX 控件。 攻击者还可能利用受到破坏的网站以及接受或宿主用户提供的内容或广告的网站。 这些网站可能包含可以利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户查看由攻击者控制的内容。 相反,攻击者必须说服用户采取行动,通常是单击电子邮件或即时消息中的链接(该链接会将用户定向到攻击者的网站),或者打开通过电子邮件发送的附件。

受此漏洞威胁最大的系统有哪些?  
要利用此漏洞执行任何恶意操作,需要用户登录并访问网站。 因此,任何频繁使用 Internet Explorer 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

我当前是在 Windows Server 2003 Windows Server 2008 上运行 Internet Explorer ,这是否可以减轻此漏洞的影响?  
是。 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 增强安全配置是一组预先配置好的 Internet Explorer 设置,可以减小用户或管理员在服务器上下载并运行特制 Web 内容的可能性。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 另请参阅管理 Internet Explorer 增强安全配置

此更新有什么作用?  
此更新通过修改 Internet Explorer 处理内存中对象的方式来消除此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
否。 Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

Internet Explorer 未正确处理锚元素的方式中存在一个信息泄露漏洞。 在内容粘贴和编辑过程中未删除锚元素时的用户操作期间会发生此行为,可能泄露要删除的个人身份信息。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3327

锚元素信息泄露漏洞 (CVE-2010-3327) 的缓解因素

Microsoft 并未发现此漏洞的任何缓解因素。

锚元素信息泄露漏洞 (CVE-2010-3327) 的变通办法

Microsoft 并未发现此漏洞的任何变通办法。

锚元素信息泄露漏洞 (CVE-2010-3327) 的常见问题

此漏洞的影响范围有多大?  
这是一个信息泄露漏洞。 可能删除的信息将保留在 HTML 内容中。

造成此漏洞的原因是什么?  
在特定用户操作期间,未从可编辑 HTML 元素中删除锚元素。

攻击者如何利用此漏洞?  
此问题不是一个可利用的漏洞。 相反,它可能会在用户操作期间暴露之前删除的内容。

受此漏洞威胁最大的系统有哪些?  
此漏洞需要用户登录并利用浏览器创建 HTML 内容。 因此,任何频繁使用 Internet Explorer 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

此更新有什么作用?  
此更新通过修改 Internet Explorer 处理锚元素的方式来解决此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
否。 Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

Internet Explorer 访问尚未正确初始化或已被删除的对象的方式中存在一个远程执行代码漏洞。 攻击者可以通过构建特制的网页来利用该漏洞。 当用户查看网页时,该漏洞可能允许远程执行代码。 成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 如果用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。 攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3328

未初始化的内存损坏漏洞 (CVE-2010-3328) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 在基于 Web 的攻击情形中,攻击者可能拥有一个网站,并在上面放置用来利用此漏洞的网页。 另外,接受或宿主用户提供的内容或广告的网站以及受到破坏的网站可能包含可能利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户访问这些网站。 相反,攻击者必须说服用户访问该网站,方法通常是让用户单击电子邮件或 Instant Messenger 消息中的链接以使用户链接到攻击者的网站。
  • 成功利用此漏洞的攻击者可以获得与本地用户相同的用户权限。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。
  • 默认情况下,Microsoft Outlook、Microsoft Outlook Express 和 Windows Mail 的所有支持版本在受限制的站点区域打开 HTML 电子邮件信息(会禁用脚本和 ActiveX 控件),同时删除可利用此漏洞的攻击者执行恶意代码的风险。 在基于 Web 的攻击情形中,如果攻击者单击电子邮件中的链接,他们可能仍然容易受到利用此漏洞的影响。
  • 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 此模式将 Internet 区域的安全级别设置为“高”。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 有关 Internet Explorer 增强安全配置的详细信息,请参阅此漏洞的“常见问题”部分。

未初始化的内存损坏漏洞 (CVE-2010-3328) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • Internet 和本地 Intranet 安全区域设置设为 ,以便在这些区域中阻止 ActiveX 控件和活动脚本

    通过更改 Internet 安全区域的设置以阻止 ActiveX 控件和活动脚本,可帮助防止利用此漏洞。 通过将浏览器的安全级别设置为“高”可以达到上述目的。

    要提高 Internet Explorer 中的浏览安全级别,请按照以下步骤进行操作:

    1. 在 Internet Explorer 的“工具”菜单上,单击“Internet 选项”。
    2. 在“Internet 选项”对话框中,单击“安全”选项卡,然后单击“Internet”图标。
    3. 在“该区域的安全级别”下,将滑块移至“”。 这将您访问的所有网站的安全级别均设置为“高”。

    注意 如果看不到滑块,请单击“默认级别”,然后再将滑块移至“”。

    注意 将安全级别设置为“高”可能会导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 在这种情况下,即使安全级别设置为“高”,此站点也可以正常工作。

    变通办法的影响。 阻止 ActiveX 控件和活动脚本会带来负面影响。 Internet 或 Intranet 上的许多网站都使用 ActiveX 或活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用 ActiveX 控件来提供菜单、订购单乃至帐户报表。 阻止 ActiveX 控件或活动脚本是一个全局设置,它影响所有 Internet 和 Intranet 站点。 如果不希望针对这些站点阻止 ActiveX 控件或活动脚本,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在 Internet 区域和本地 Intranet 区域中将 Internet Explorer 设置为阻止 ActiveX 控件和活动脚本之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

  • Internet Explorer 配置为在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示

    通过更改设置,以在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示,可帮助防止利用此漏洞。 为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”菜单上的“Internet 选项”。
    2. 单击“安全”选项卡。
    3. 单击“Internet”,然后单击“自定义级别”。
    4. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    5. 单击“本地 Intranet”,然后单击“自定义级别”。
    6. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    7. 单击“确定”两次返回到 Internet Explorer。

    注意 禁用 Internet 和本地 Intranet 安全区域中的活动脚本可能导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 这将允许站点正常工作。

    变通办法的影响。 在运行活动脚本之前提示有负面影响。 Internet 或 Intranet 上的许多网站都使用活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用活动脚本来提供菜单、订购单乃至帐户报表。 在运行活动脚本之前进行提示是一个全局设置,它影响所有 Internet 和 Intranet 站点。 在启用此变通方法后,将会频繁出现提示。 对于每一提示,如果您认为信任您所访问的站点,则单击“”运行活动脚本。 如果您不想在访问所有这些网站时进行提示,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在将 Internet Explorer 设置为在 Internet 区域和本地 Intranet 区域运行 ActiveX 控件和活动脚本之前需要提示之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

未初始化的内存损坏漏洞 (CVE-2010-3328) 的常见问题

此漏洞的影响范围有多大?  
这是一个远程执行代码漏洞。 成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。

造成此漏洞的原因是什么?  
当 Internet Explorer 尝试访问未初始化或已删除的对象时,攻击者可以在登录用户的上下文中执行任意代码,从而可能破坏内存。

攻击者可能利用此漏洞执行什么操作?  
成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 如果用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。 攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

攻击者如何利用此漏洞?  
攻击者可能拥有一个旨在通过 Internet Explorer 利用此漏洞的特制网站,然后诱使用户查看该网站。 攻击者也可能在宿主 IE 呈现引擎的应用程序或 Microsoft Office 文档中嵌入标有“安全初始化”的 ActiveX 控件。 攻击者还可能利用受到破坏的网站以及接受或宿主用户提供的内容或广告的网站。 这些网站可能包含可以利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户查看由攻击者控制的内容。 相反,攻击者必须说服用户采取行动,通常是单击电子邮件或即时消息中的链接(该链接会将用户定向到攻击者的网站),或者打开通过电子邮件发送的附件。

受此漏洞威胁最大的系统有哪些?  
要利用此漏洞执行任何恶意操作,需要用户登录并访问网站。 因此,任何频繁使用 Internet Explorer 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

我当前是在 Windows Server 2003 Windows Server 2008 上运行 Internet Explorer ,这是否可以减轻此漏洞的影响?  
是。 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 增强安全配置是一组预先配置好的 Internet Explorer 设置,可以减小用户或管理员在服务器上下载并运行特制 Web 内容的可能性。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 另请参阅管理 Internet Explorer 增强安全配置

此更新有什么作用?  
此更新通过修改 Internet Explorer 处理内存中对象的方式来消除此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
否。 Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

在 Microsoft Word 中打开 HTML 格式的文档时,Internet Explorer 访问未正确初始化或已删除的对象的方式中存在一个远程执行代码漏洞。 攻击者可通过诱使用户打开恶意 Word 文档来利用此漏洞。 当用户关闭该文档时,此漏洞可能允许远程执行代码。 成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 如果用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。 攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3329

未初始化的内存损坏漏洞 (CVE-2010-3329) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 此漏洞无法通过电子邮件自动加以利用。 用户必须打开电子邮件附件,以电子邮件为载体的攻击才会得逞。
  • 成功利用此漏洞的攻击者可以获得与本地用户相同的用户权限。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。

未初始化的内存损坏漏洞 (CVE-2010-3329) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • 阻止 COM 对象在 Internet Explorer 中运行

    您可以通过在注册表中为控件设置 kill bit 来禁止尝试在 Internet Explorer 中实例化 HtmlDlgHelper 类 COM 对象。

    警告 如果不正确地使用注册表编辑器,可能导致严重的问题,或许需要您重新安装操作系统。 Microsoft 不保证您可以解决因错误运用注册表编辑器而产生的问题。 使用注册表编辑器的风险由您自己承担。

    有关阻止控件在 Internet Explorer 中运行的详细步骤,请参阅 Microsoft 知识库文章 240797。按照文中所述的步骤在注册表内创建一个 Compatibility Flags 值,以阻止 COM 对象在 Internet Explorer 中实例化。

    要为值为 {3050f4e1-98b5-11cf-bb82-00aa00bdce0b} 的 CLSID 设置 kill bit,请将以下文本粘贴到记事本等文本编辑器中。 然后,使用 .reg 文件扩展名保存文件。

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{3050f4e1-98b5-11cf-bb82-00aa00bdce0b}]
    "Compatibility Flags"=dword:00000400

    您可以通过双击此 .reg 文件将其应用到各个系统。 您还可以使用组策略跨域应用该文件。 有关组策略的详细信息,请访问以下 Microsoft 网站:

    注意 您必须重新启动 Internet Explorer 才能使更改生效。

    变通办法的影响。 当不在 Internet Explorer 中使用对象时,没有任何影响。

    如何撤消变通方法。 删除之前在实施此变通办法过程中添加的注册表项。

未初始化的内存损坏漏洞 (CVE-2010-3329) 的常见问题

此漏洞的影响范围有多大?  
这是一个远程执行代码漏洞。 成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。

造成此漏洞的原因是什么?  
在已关闭 Microsoft Word 后,当 Internet Explorer 尝试访问未初始化或已删除的对象时,攻击者可以在登录用户的上下文中执行任意代码,从而可能破坏内存。

攻击者可能利用此漏洞执行什么操作?  
成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 如果用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。 攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

攻击者如何利用此漏洞?  
攻击者可向用户发送旨在通过 Microsoft Word 利用此漏洞并诱使用户查看 Word 文档的特制 Word 文档。 但是在所有情况下,攻击者无法强制用户查看由攻击者控制的内容。 相反,攻击者必须说服用户采取行动,通常是单击电子邮件或即时消息中的链接(该链接会将用户定向到攻击者的网站),或者打开通过电子邮件发送的附件。 此问题无法直接通过 Internet Explorer 利用。

受此漏洞威胁最大的系统有哪些?  
此漏洞需要用户登录并打开恶意 Word 文档以便进行任何恶意操作。 因此,任何频繁使用 Microsoft Word 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

此更新有什么作用?  
此更新通过修改 Internet Explorer 处理内存中对象的方式来消除此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
否。 Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

Internet Explorer 中存在一个信息泄露漏洞,可能允许脚本访问另一个域或 Internet Explorer 区域中的信息。 如果用户查看网页,攻击者可通过构建一个允许信息泄露的特制网页来利用漏洞。 成功利用此漏洞的攻击者可查看其他域或 Internet Explorer 区域中的内容。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3330

跨域信息泄露漏洞 (CVE-2010-3330) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 此模式将 Internet 区域的安全级别设置为“高”。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 有关 Internet Explorer 增强安全配置的详细信息,请参阅此漏洞的“常见问题”部分。
  • 在基于 Web 的攻击情形中,攻击者可能拥有一个网站,并在上面放置用来利用此漏洞的网页。 另外,接受或宿主用户提供的内容或广告的网站以及受到破坏的网站可能包含可能利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户访问这些网站。 相反,攻击者必须说服用户访问该网站,方法通常是让用户单击电子邮件或 Instant Messenger 消息中的链接以使用户链接到攻击者的网站。

跨域信息泄露漏洞 (CVE-2010-3330) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • 以纯文本格式阅读电子邮件

    要帮助保护自己免受来自电子邮件攻击媒介的攻击,请以纯文本格式阅读电子邮件。

    已应用了 Office XP Service Pack 1 或更高版本的 Microsoft Office Outlook 2002 用户以及应用了 Internet Explorer 6 Service Pack 1 或更高版本的 Microsoft Office Outlook Express 6 用户可以启用此设置,仅用纯文本格式查看所有不带数字签名的电子邮件或未加密的电子邮件。

    带数字签名的电子邮件或加密的电子邮件不受此设置的影响,可以用其原始格式阅读。 有关在 Outlook 2002 中如何启用此设置的详细信息,请参阅 Microsoft 知识库文章 307594

    有关 Outlook Express 6 中此设置的信息,请参阅 Microsoft 知识库文章 291387

    变通办法的影响。 用纯文本格式查看的电子邮件中不会包含图片、特殊字体、动画或其他丰富内容。 此外:

    • 这些更改适用于预览窗格和打开的邮件。
    • 图片变成了附件,因此不会丢失。
    • 由于存储区中的邮件仍然是 RTF 格式或 HTML 格式,因此对象模型(自定义代码解决方案)可能不按预期方式运行。
  • Internet 和本地 Intranet 安全区域设置设为 ,以便在这些区域中阻止 ActiveX 控件和活动脚本

    通过更改 Internet 安全区域的设置以阻止 ActiveX 控件和活动脚本,可帮助防止利用此漏洞。 通过将浏览器的安全级别设置为“高”可以达到上述目的。

    要提高 Internet Explorer 中的浏览安全级别,请按照以下步骤进行操作:

    1. 在 Internet Explorer 的“工具”菜单上,单击“Internet 选项”。
    2. 在“Internet 选项”对话框中,单击“安全”选项卡,然后单击“Internet”图标。
    3. 在“该区域的安全级别”下,将滑块移至“”。 这将您访问的所有网站的安全级别均设置为“高”。

    注意 如果看不到滑块,请单击“默认级别”,然后再将滑块移至“”。

    注意 将安全级别设置为“高”可能会导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 在这种情况下,即使安全级别设置为“高”,此站点也可以正常工作。

    变通办法的影响。 阻止 ActiveX 控件和活动脚本会带来负面影响。 Internet 或 Intranet 上的许多网站都使用 ActiveX 或活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用 ActiveX 控件来提供菜单、订购单乃至帐户报表。 阻止 ActiveX 控件或活动脚本是一个全局设置,它影响所有 Internet 和 Intranet 站点。 如果不希望针对这些站点阻止 ActiveX 控件或活动脚本,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在 Internet 区域和本地 Intranet 区域中将 Internet Explorer 设置为阻止 ActiveX 控件和活动脚本之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

  • Internet Explorer 配置为在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示

    通过更改设置,以在 Internet 和本地 Intranet 安全区域中运行活动脚本或禁用活动脚本之前进行提示,可帮助防止利用此漏洞。 为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”菜单上的“Internet 选项”。
    2. 单击“安全”选项卡。
    3. 单击“Internet”,然后单击“自定义级别”。
    4. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    5. 单击“本地 Intranet”,然后单击“自定义级别”。
    6. 在“设置”下方,在“脚本”部分的“活动脚本”下方单击“提示”或“禁用”,然后单击“确定”。
    7. 单击“确定”两次返回到 Internet Explorer。

    注意 禁用 Internet 和本地 Intranet 安全区域中的活动脚本可能导致某些网站无法正常工作。 在更改此设置后,如果您在使用某个网站时遇到困难,但您确定该站点是安全的,则可以将该站点添加到受信任的站点列表中。 这将允许站点正常工作。

    变通办法的影响。 在运行活动脚本之前提示有负面影响。 Internet 或 Intranet 上的许多网站都使用活动脚本来提供附加功能。 例如,在线电子商务站点或银行站点可能使用活动脚本来提供菜单、订购单乃至帐户报表。 在运行活动脚本之前进行提示是一个全局设置,它影响所有 Internet 和 Intranet 站点。 在启用此变通方法后,将会频繁出现提示。 对于每一提示,如果您认为信任您所访问的站点,则单击“”运行活动脚本。 如果您不想在访问所有这些网站时进行提示,请使用“将您信任的站点添加到 Internet Explorer 的“受信任的站点”区域”中概述的步骤。

    将您信任的站点添加到 Internet Explorer 受信任的站点 区域。

    在将 Internet Explorer 设置为在 Internet 区域和本地 Intranet 区域运行 ActiveX 控件和活动脚本之前需要提示之后,可以将受信任的站点添加到 Internet Explorer 的“受信任的站点”区域。 这样,您就可以照常使用受信任的网站,同时又有助于防范非受信任站点上的此类攻击。 我们建议您只将信任的站点添加到“受信任的站点”区域。

    为此,可执行以下步骤:

    1. 在 Internet Explorer 中,单击“工具”,单击“Internet 选项”,然后单击“安全”选项卡。
    2. 在标为“请为不同区域的 Web 内容指定安全设置”的框中,单击“受信任的站点”,然后单击“站点”。
    3. 如果您想要添加不需要加密频道的站点,请单击以清除“对该区域中的所有站点要求服务器验证 (https:)”复选框。
    4. 在“将该站点添加到区域中”框中,键入您信任的站点的 URL,然后单击“添加”。
    5. 对想添加到区域中的每一个站点重复这些步骤。
    6. 单击“确定”两次,接受更改并返回到 Internet Explorer。

    注意 添加您相信不会在您的系统上执行恶意操作的任何站点。 特别是,您可能需要添加两个站点:*.windowsupdate.microsoft.com*.update.microsoft.com。这些站点将提供此更新,需要使用 ActiveX 控件来安装更新。

跨域信息泄露漏洞 (CVE-2010-3330) 的常见问题

此漏洞的影响范围有多大?  
这是一个信息泄露漏洞。 在用户查看网页时,利用此漏洞的攻击者可查看其他域或 Internet Explorer 区域而不是攻击者网页的域或区域中的内容。

造成此漏洞的原因是什么?  
在某些过程中,Internet Explorer 不正确地允许脚本从其他域中访问和读取内容。

攻击者可能利用此漏洞执行什么操作?  
成功利用此漏洞的攻击者可查看其他域或 Internet Explorer 区域中的内容。

攻击者如何利用此漏洞?  
攻击者可能拥有一个旨在通过 Internet Explorer 利用此漏洞的特制网站,然后诱使用户查看该网站。 攻击者还可能利用受到破坏的网站以及接受或宿主用户提供的内容或广告的网站。 这些网站可能包含可以利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户访问这些网站。 相反,攻击者必须说服用户访问该网站,方法通常是让用户单击电子邮件或 Instant Messenger 消息中的链接以使用户链接到攻击者的网站。 它还可能使用横幅广告或其他方式显示特制的 Web 内容,以便将 Web 内容传递至受影响的系统。

受此漏洞威胁最大的系统有哪些?  
要利用此漏洞执行任何恶意操作,需要用户登录并访问网站。 因此,任何频繁使用 Internet Explorer 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

我当前是在 Windows Server 2003 Windows Server 2008 上运行 Internet Explorer ,这是否可以减轻此漏洞的影响?  
是。 默认情况下,Windows Server 2003 和 Windows Server 2008 上的 Internet Explorer 在一种称为“增强安全配置”的受限模式下运行。 增强安全配置是一组预先配置好的 Internet Explorer 设置,可以减小用户或管理员在服务器上下载并运行特制 Web 内容的可能性。 此缓解因素适用于未被添加到 Internet Explorer“受信任的站点”区域的网站。 另请参阅管理 Internet Explorer 增强安全配置

此更新有什么作用?  
此更新通过修改 Internet Explorer 在某些过程中处理脚本的方式来解决此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
否。 Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

Internet Explorer 访问尚未正确初始化或已被删除的对象的方式中存在一个远程执行代码漏洞。 攻击者可通过诱使用户查看特制 Word 文档来利用此漏洞。 当用户关闭 Word 文档时,此漏洞可能允许远程执行代码。 成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 如果用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。 攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2010-3331

未初始化的内存损坏漏洞 (CVE-2010-3331) 的缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。 以下缓解因素在您遇到的情形中可能会有所帮助:

  • 此漏洞无法通过电子邮件自动加以利用。 用户必须打开电子邮件附件,以电子邮件为载体的攻击才会得逞。
  • 成功利用此漏洞的攻击者可以获得与本地用户相同的用户权限。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。
  • 在基于 Web 的攻击情形中,攻击者可能拥有一个网站,并在上面放置用来利用此漏洞的网页。 另外,接受或宿主用户提供的内容或广告的网站以及受到破坏的网站可能包含可能利用此漏洞的特制内容。 但是在所有情况下,攻击者无法强制用户访问这些网站。 相反,攻击者必须说服用户访问该网站,方法通常是让用户单击电子邮件或 Instant Messenger 消息中的链接以使用户链接到攻击者的网站。

未初始化的内存损坏漏洞 (CVE-2010-3331) 的变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。 Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • 使用 Microsoft Office 文件阻止策略禁止打开来自未知或不可信来源和位置的 HTML 文档

    下列注册表脚本可以用于设置文件阻止策略。

    注意 如果注册表使用不当,可能会导致严重的问题,或许需要您重新安装操作系统。 Microsoft 不保证能够解决因注册表修改不当而导致的问题。 修改注册表的风险由您自己承担。

    对于 Office 2003 

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Security\FileOpenBlock]

    "HtmlFiles"=dword:00000001

    注意 为了对 Microsoft Office 2003 使用“FileOpenBlock”,必须应用所有最新的 Microsoft Office 2003 安全更新。

    对于 2007 Office System 

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Word\Security\FileOpenBlock]

    "HtmlFiles"=dword:00000001

    注意 为了对 2007 Microsoft Office system 使用“FileOpenBlock”,必须应用所有最新的 2007 Microsoft Office system 安全更新。

    变通办法的影响。 配置了文件阻止策略但是尚未按照 Microsoft 知识库文章 922848 所述配置特殊“例外目录”的用户在 Office 2003 或 2007 Microsoft Office System 中无法打开 Office 2003 文件或更早版本。

    如何撤消变通方法。

    对于 Office 2003

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Security\FileOpenBlock]

    "HtmlFiles"=dword:00000000

    对于 2007 Office system

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Word\Security\FileOpenBlock]

    "HtmlFiles"=dword:00000000

未初始化的内存损坏漏洞 (CVE-2010-3331) 的常见问题

此漏洞的影响范围有多大?  
这是一个远程执行代码漏洞。 成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。

造成此漏洞的原因是什么?  
当 Internet Explorer 尝试访问未初始化或已删除的对象时,攻击者可以在登录用户的上下文中执行任意代码,从而可能破坏内存。

攻击者可能利用此漏洞执行什么操作?  
成功利用此漏洞的攻击者可以获得与登录用户相同的用户权限。 如果用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。 攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

攻击者如何利用此漏洞?  
攻击者可向用户发送旨在通过 Microsoft Word 利用此漏洞并诱使用户查看 Word 文档的特制 Word 文档。 但是在所有情况下,攻击者无法强制用户查看由攻击者控制的内容。 相反,攻击者必须说服用户采取行动,通常是单击电子邮件或即时消息中的链接(该链接会将用户定向到攻击者的网站),或者打开通过电子邮件发送的附件。 此问题无法直接通过 Internet Explorer 利用。

受此漏洞威胁最大的系统有哪些?  
此漏洞需要用户登录并打开恶意 Word 文档以便进行攻击。 因此,任何频繁使用 Microsoft Word 的系统(如工作站或终端服务器)受此漏洞的威胁最大。

此更新有什么作用?  
此更新通过修改 Internet Explorer 处理内存中对象的方式来消除此漏洞。

发布此安全公告时,此漏洞是否已公开披露?  
否。 Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

在发布此安全公告时, Microsoft 是否收到任何有关此漏洞已被利用的报告?  
否。 在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

更新信息

管理需要部署到组织中的服务器、台式机和移动系统的软件和安全更新。 有关详细信息,请参阅 TechNet 更新管理中心Microsoft TechNet 安全网站提供了有关 Microsoft 产品安全的详细信息。

安全更新可从 Microsoft UpdateWindows Update 获得。 Microsoft 下载中心也提供了安全更新。 通过输入关键字“安全更新”可以非常方便地找到这些更新。

最后,可以从 Microsoft Update 目录下载安全更新。 Microsoft Update 目录提供通过 Windows Update 和 Microsoft Update 提供的内容的可搜索目录,包括安全更新、驱动程序和 Service Pack。 通过使用安全公告编号(例如“MS07-036”)进行搜索,您可以将所有适用的更新添加到您的篮(包括某个更新的不同语言),然后将其下载到您选择的文件夹。 有关 Microsoft Update 目录的详细信息,请参阅 Microsoft Update 目录常见问题

检测和部署指南

Microsoft 提供安全更新的检测和部署指南。 该指南包含可帮助 IT 专业人员了解如何使用各种工具检测和部署安全更新的建议和信息。 有关详细信息,请参阅 Microsoft 知识库文章 961747

Microsoft Baseline Security Analyzer

管理员可使用 Microsoft Baseline Security Analyzer (MBSA),在本地和远程系统中扫描缺少的安全更新和常见的安全配置错误。 有关 MBSA 的详细信息,请访问 Microsoft Baseline Security Analyzer

下表提供此安全更新的 MBSA 检测摘要。

软件 MBSA
Windows XP Service Pack 3
Windows XP Professional x64 Edition Service Pack 2
Windows Server 2003 Service Pack 2
Windows Server 2003 x64 Edition Service Pack 2
Windows Server 2003 SP2(用于基于 Itanium 的系统)
Windows Vista Service Pack 1 和 Windows Vista Service Pack 2
Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2
Windows Server 2008(用于基于 Itanium 的系统)和 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2
Windows 7(用于 32 位系统)
Windows 7(用于基于 x64 的系统)
Windows Server 2008 R2(用于基于 x64 的系统)
Windows Server 2008 R2(用于基于 Itanium 的系统)

注意 对于使用不受最新版 MBSA、Microsoft Update 和 Windows Server Update Services 支持的旧版软件的客户,请访问 Microsoft Baseline Security Analyzer 并参考旧版产品支持部分,了解如何使用旧版工具创建全面的安全更新检测。

Windows Server Update Services

Windows Server Update Services (WSUS) 使信息技术管理员能够将最新的 Microsoft 产品更新部署到运行 Windows 操作系统的计算机。 有关如何使用 Windows Server Update Services 部署安全更新的详细信息,请参阅 TechNet 文章 Windows Server Update Services

Systems Management Server

下表提供此安全更新的 SMS 检测和部署摘要。

软件SMS 2.0SMS 2003(带 SUIT)SMS 2003(带 ITMU)Configuration Manager 2007
Windows XP Service Pack 3是*是*
Windows XP Professional x64 Edition Service Pack 2
Windows Server 2003 Service Pack 2是*是*
Windows Server 2003 x64 Edition Service Pack 2
Windows Server 2003 SP2(用于基于 Itanium 的系统)
Windows Vista Service Pack 1 和 Windows Vista Service Pack 2
Windows Vista x64 Edition Service Pack 1 和 Windows Vista x64 Edition Service Pack 2
Windows Server 2008(用于 32 位系统)和 Windows Server 2008(用于 32 位系统)Service Pack 2
Windows Server 2008(用于基于 x64 的系统)和 Windows Server 2008(用于基于 x64 的系统)Service Pack 2
Windows Server 2008(用于基于 Itanium 的系统)和 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2
Windows 7(用于 32 位系统)
Windows 7(用于基于 x64 的系统)
Windows Server 2008 R2(用于基于 x64 的系统)
Windows Server 2008 R2(用于基于 Itanium 的系统)

*仅 Internet Explorer 6。 有关详细信息,请参阅 Microsoft 知识库文章 924178

对于 SMS 2.0 和 SMS 2003,安全更新清单工具 (SUIT) 可以由 SMS 用来检测安全更新。 请参阅 Downloads for Systems Management Server 2.0

对于 SMS 2003,SMS 可以使用 Microsoft 更新 SMS 2003 清单工具 (ITMU) 检测 Microsoft Update 提供的以及 Windows Server Update Services 支持的安全更新。 有关 SMS 2003 ITMU 的详细信息,请参阅 SMS 2003 Microsoft 更新清单工具。 有关 SMS 扫描工具的详细信息,请参阅 SMS 2003 软件更新扫描工具。 请参阅 Downloads for Systems Management Server 2003

System Center Configuration Manager 2007 使用 WSUS 3.0 来检测更新。 有关 Configuration Manager 2007 软件更新管理的详细信息,请访问 System Center Configuration Manager 2007

有关 SMS 的详细信息,请访问 SMS 网站。

有关详细信息,请参阅 Microsoft 知识库文章 910723: 每月检测和部署指南文章的摘要列表。

更新兼容性评估程序和应用程序兼容性工具箱

此更新通常写入运行应用程序所必需的相同文件和注册表设置。 这可触发不兼容并使安全更新的部署占用更多的时间。 通过使用应用程序兼容性工具包中包含的更新兼容性评估程序组件,您可以简化测试和验证对已安装程序进行的 Windows 更新。

应用程序兼容性工具包 (ACT) 包含必要的工具和文档,以便在您的环境中部署 Microsoft Windows Vista、Windows Update、Microsoft Security Update 或新版本的 Windows Internet Explorer 之前评估和缓减应用程序的兼容性问题。

受影响的软件

有关您的受影响软件的特定安全更新信息,请单击相应的链接:

Windows XP(所有版本)

参考表

下表包含此软件的安全更新信息。 您可以在本节的“部署信息”小节中找到更多信息。

包括在以后的 Service Pack 此问题的更新程序将包含在以后的 Service Pack 或更新汇总中
部署
没有用户干预的安装所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 6:
WindowsXP-KB2360131-x86-ENU /quiet
所有受支持的 x64 版本 Windows XP 的 Internet Explorer 6:
WindowsServer2003.WindowsXP-KB2360131-x64-ENU /quiet
所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 7:
IE7-WindowsXP-KB2360131-x86-enu /quiet
所有受支持的基于 x64 版本 Windows XP 的 Internet Explorer 7:
IE7-WindowsServer2003.WindowsXP-KB2360131-x64-enu /quiet
所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 8:
IE8-WindowsXP-KB2360131-x86-enu /quiet
所有受支持的基于 x64 版本 Windows XP 的 Internet Explorer 8:
IE8-WindowsServer2003.WindowsXP-KB2360131-x64-enu /quiet
在不重新启动的情况下安装所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 6:
WindowsXP-KB2360131-x86-ENU /norestart
所有受支持的 x64 版本 Windows XP 的 Internet Explorer 6:
WindowsServer2003.WindowsXP-KB2360131-x64-ENU /norestart
所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 7:
IE7-WindowsXP-KB2360131-x86-enu /norestart
所有受支持的基于 x64 版本 Windows XP 的 Internet Explorer 7:
IE7-WindowsServer2003.WindowsXP-KB2360131-x64-enu /norestart
所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 8:
IE8-WindowsXP-KB2360131-x86-enu /norestart
所有受支持的基于 x64 版本 Windows XP 的 Internet Explorer 8:
IE8-WindowsServer2003.WindowsXP-KB2360131-x64-enu /norestart
更新日志文件适用于 Windows XP 的所有受支持版本的 Internet Explorer 6:
KB2360131.log
适用于 Windows XP 的所有受支持版本的 Internet Explorer 7:
KB2360131-IE7.log
适用于 Windows XP 的所有受支持版本的 Internet Explorer 8:
KB2360131-IE8.log
更多信息请参阅“检测和部署工具及指导”小节
重新启动要求
要求重新启动?是,应用此安全更新后必须重新启动系统
Hotpatching不适用
删除信息 适用于 Windows XP 的所有受支持版本的 Internet Explorer 6:

使用控制面板中的“添加或删除程序”工具或 %Windir%\$NTUninstallKB2360131$\Spuninst 文件夹中的 Spuninst.exe 实用工具

适用于 Windows XP 的所有受支持版本的 Internet Explorer 7:
使用控制面板中的“添加或删除程序”工具或 %Windir%\ie7updates\KB2360131-IE7\spuninst 文件夹中的 Spuninst.exe 实用程序
适用于 Windows XP 的所有受支持版本的 Internet Explorer 8:
使用控制面板中的“添加或删除程序”工具或 %Windir%\ie8updates\KB2360131-IE8\spuninst 文件夹中的 Spuninst.exe 实用程序
文件信息 请参阅 Microsoft 知识库文章 2360131
注册表项验证 所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 6:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP4\KB2360131\Filelist
所有受支持的 x64 版本 Windows XP 的 Internet Explorer 6:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP Version 2003\SP3\KB2360131\Filelist
所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 7:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP0\KB2360131-IE7\Filelist
所有受支持的基于 x64 版本 Windows XP 的 Internet Explorer 7:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP Version 2003\SP0\KB2360131-IE7\Filelist
所有受支持的 32 位版本 Windows XP 上的 Internet Explorer 8:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP0\KB2360131-IE8\Filelist
所有受支持的基于 x64 版本 Windows XP 的 Internet Explorer 8:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP Version 2003\SP0\KB2360131-IE8\Filelist

注意 对于受支持版本的 Windows XP Professional x64 Edition,此安全更新与受支持版本的 Windows Server 2003 x64 Edition 的安全更新相同。

部署信息

安装更新

当您安装此安全更新时,安装程序将检查系统中正在更新的一个或多个文件是否已由 Microsoft 修补程序更新。

如果以前安装的修补程序已经更新过其中的某个文件,安装程序就会将 RTMQFE、SP1QFE 或 SP2QFE 文件复制到系统中。 否则,安装程序将 RTMGDR、SP1GDR 或 SP2GDR 文件复制到您的系统中。 安全更新可能不包含这些文件的所有版本。 有关此行为的详细信息,请参阅 Microsoft 知识库文章 824994

有关安装程序的详细信息,请访问 Microsoft TechNet 网站。

有关本公告中出现的术语(如“修补程序”)的详细信息,请参阅 Microsoft 知识库文章 824684

此安全更新支持以下安装开关。

受支持的安全更新安装开关
开关描述
/help 显示命令行选项。
安装模式
/passive 无人参与安装模式。 无需用户交互操作,但会显示安装状态。 如果安装结束时需要重新启动,将显示一个带有计时器的对话框,警告计算机将在 30 秒后重新启动。
/quiet 安静模式。 这与无人参与模式相同,但是不显示任何状态或错误消息。
重新启动选项
/norestart 安装完成后不重新启动。
/forcerestart 安装后重新启动计算机,且在关机时强制其他应用程序关闭而不先保存打开的文件。
/warnrestart[:x] 显示一个带有计时器的对话框,警告计算机将在 x 秒后重新启动。 (默认设置为 30 秒。) 与 /quiet 开关或 /passive 开关一起使用。
/promptrestart 显示提示本地用户允许重新启动的对话框。
特殊选项
/overwriteoem 不经提示而覆盖 OEM 文件。
/nobackup 不备份卸载所需的文件。
/forceappsclose 在计算机关机时强制关闭其他程序。
/log:path 允许重定向安装日志文件。
/integrate:path 将更新集成到 Windows 源文件中。 这些文件位于开关中指定的路径中。
/extract[:path] 提取文件而不启动安装程序。
/ER 启用扩展错误报告功能。
/verbose 启用详细日志记录。 在安装期间,创建 %Windir%\CabBuild.log。此日志详述了被复制的文件。 使用此开关可能导致安装过程变慢。

注意 这些开关可以在一个命令中组合使用。 为了保持向后兼容,此安全更新还支持以前版本的安装程序所使用的安装开关。 有关受支持的安装开关的详细信息,请参阅 Microsoft 知识库文章 262841

删除更新

此安全更新支持以下安装开关。

受支持的 Spuninst.exe 开关
开关描述
/help 显示命令行选项。
安装模式
/passive 无人参与安装模式。 无需用户交互操作,但会显示安装状态。 如果安装结束时需要重新启动,将显示一个带有计时器的对话框,警告计算机将在 30 秒后重新启动。
/quiet 安静模式。 这与无人参与模式相同,但是不显示任何状态或错误消息。
重新启动选项
/norestart 安装完成后不重新启动
/forcerestart 安装后重新启动计算机,且在关机时强制其他应用程序关闭而不先保存打开的文件。
/warnrestart[:x] 显示一个带有计时器的对话框,警告计算机将在 x 秒后重新启动。 (默认设置为 30 秒。) 与 /quiet 开关或 /passive 开关一起使用。
/promptrestart 显示提示本地用户允许重新启动的对话框。
特殊选项
/forceappsclose 在计算机关机时强制关闭其他程序。
/log:path 允许重定向安装日志文件。

验证是否已应用更新

  • Microsoft Baseline Security Analyzer

    要验证受影响的系统上是否应用了安全更新,可以使用 Microsoft Baseline Security Analyzer (MBSA) 工具。 有关详细信息,请参阅本公告前面的“检测和部署工具及指导”一节。

  • 文件版本验证

    由于 Microsoft Windows 有多个版本,因此以下步骤可能会与您的系统上的步骤不同。 如果不同,请参阅产品文档来完成这些步骤。

    1. 单击“开始”,然后单击“搜索”。
    2. 在“搜索结果”窗格中,单击“搜索助理”下的“所有文件和文件夹”。
    3. 在“完整或部分文件名”框中,键入相应文件信息表中的一个文件名,然后单击“搜索”。
    4. 在文件列表中,用鼠标右键单击相应文件信息表中的一个文件名,然后单击“属性”。

      注意 根据系统上安装的操作系统或程序的版本,文件信息表中所列的某些文件可能并未安装。
    5. 在“版本”选项卡上,通过将系统上安装的文件与相应文件信息表中记录的版本进行比较来确定该文件的版本。

      注意 在安装过程中,除文件版本以外的其他属性均可能会发生变化。 不支持通过将其他文件属性与文件信息表中的信息进行比较这种方法来验证是否应用了更新。 另外,在某些情况下,在安装过程中还可能会重命名文件。 如果没有文件或版本信息,请使用另外一种方法来验证更新安装。
  • 注册表项验证

    您也可以通过查看本节“参考表”中列出的注册表项来验证此安全更新安装的文件。

    这些注册表项可能不包含已安装文件的完整列表。 另外,如果管理员或 OEM 将此安全更新集成或组合到 Windows 安装源文件中,则可能无法正确创建这些注册表项。

Windows Server 2003(所有版本)

参考表

下表包含此软件的安全更新信息。 您可以在本节的“部署信息”小节中找到更多信息。

包括在以后的 Service Pack 此问题的更新程序将包含在以后的 Service Pack 或更新汇总中
部署
没有用户干预的安装所有受支持的 32 位版本 Windows Server 2003 上的 Internet Explorer 6:
WindowsServer2003-KB2360131-x86-ENU.exe /quiet
所有受支持的 x64 版本的 Windows Server 2003 上的 Internet Explorer 6:
WindowsServer2003.WindowsXP-KB2360131-x64-ENU.exe /quiet
所有受支持的基于 Itanium 版本的 Windows Server 2003 上的 Internet Explorer 6:
WindowsServer2003-KB2360131-ia64-ENU.exe /quiet
所有受支持的 32 位版本 Windows Server 2003 上的 Internet Explorer 7:
IE7-WindowsServer2003-KB2360131-x86-ENU.exe /quiet
所有受支持的基于 x64 版本的 Windows Server 2003 上的 Internet Explorer 7:
IE7-WindowsServer2003.WindowsXP-KB2360131-x64-ENU.exe /quiet
对于 Windows Server 2003 所有受支持的基于 x64 的版本:
IE7-WindowsServer2003-KB2360131-ia64-ENU.exe /quiet
所有受支持的 32 位版本 Windows Server 2003 上的 Internet Explorer 8:
IE8-WindowsServer2003-KB2360131-x86-ENU.exe /quiet
所有受支持的基于 x64 版本的 Windows Server 2003 上的 Internet Explorer 8:
IE8-WindowsServer2003.WindowsXP-KB2360131-x64-ENU.exe /quiet
在不重新启动的情况下安装所有受支持的 32 位版本 Windows Server 2003 上的 Internet Explorer 6:
WindowsServer2003-KB2360131-x86-ENU.exe /norestart
所有受支持的 x64 版本的 Windows Server 2003 上的 Internet Explorer 6:
WindowsServer2003.WindowsXP-KB2360131-x64-ENU.exe /norestart
所有受支持的基于 Itanium 版本的 Windows Server 2003 上的 Internet Explorer 6:
WindowsServer2003-KB2360131-ia64-ENU.exe /norestart
所有受支持的 32 位版本 Windows Server 2003 上的 Internet Explorer 7:
IE7-WindowsServer2003-KB2360131-x86-ENU.exe /norestart
所有受支持的基于 x64 版本的 Windows Server 2003 上的 Internet Explorer 7:
IE7-WindowsServer2003.WindowsXP-KB2360131-x64-ENU.exe /norestart
对于 Windows Server 2003 所有受支持的基于 x64 的版本:
IE7-WindowsServer2003-KB2360131-ia64-ENU.exe /norestart
所有受支持的 32 位版本 Windows Server 2003 上的 Internet Explorer 8:
IE8-WindowsServer2003-KB2360131-x86-ENU.exe /norestart
所有受支持的基于 x64 版本的 Windows Server 2003 上的 Internet Explorer 8:
IE8-WindowsServer2003.WindowsXP-KB2360131-x64-ENU.exe /norestart
更新日志文件所有受支持的 32 位版本、基于 x64 版本和基于 Itanium 版本的 Windows Server 2003 上的 Internet Explorer 6:
KB2360131.log
所有受支持的 32 位版本、x64 版本和基于 Itanium 版本的 Windows Server 2003 上的 Internet Explorer 7:
KB2360131-IE7.log
所有受支持的 32 位版本、基于 x64 的版本和基于 Itanium 的版本的 Windows Server 2003 上的 Internet Explorer 8:
KB2360131-IE8.log
更多信息请参阅“检测和部署工具及指导”小节
重新启动要求
要求重新启动?是,应用此安全更新后必须重新启动系统。
HotPatching此安全更新不支持 HotPatching。 有关 HotPatching 的详细信息,请参阅 Microsoft 知识库文章 897341
删除信息 所有受支持的 32 位版本、基于 x64 版本和基于 Itanium 版本的 Windows Server 2003 上的 Internet Explorer 6:
使用控制面板中的“添加或删除程序”工具或 %Windir%\$NTUninstallKB2360131$\Spuninst 文件夹中“使用 Spuninst.exe 实用程序”内的 Spuninst.exe 实用程序
所有受支持的 32 位版本、x64 版本和基于 Itanium 版本的 Windows Server 2003 上的 Internet Explorer 7:
使用控制面板中的“添加或删除程序”工具或 %Windir%\ie7updates\KB2360131-IE7\spuninst 文件夹中的 Spuninst.exe 实用程序
所有受支持的 32 位版本和基于 x64 版本的 Windows Server 2003 上的 Internet Explorer 8:
使用控制面板中的“添加或删除程序”工具或 %Windir%\ie8updates\KB2360131-IE8\spuninst 文件夹中的 Spuninst.exe 实用程序
文件信息 请参阅 Microsoft 知识库文章 2360131
注册表项验证 所有受支持的 32 位版本、基于 x64 版本和基于 Itanium 版本的 Windows Server 2003 上的 Internet Explorer 6:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows Server 2003\SP3\KB2360131\Filelist
所有受支持的 32 位版本、x64 版本和基于 Itanium 版本的 Windows Server 2003 上的 Internet Explorer 7:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows Server 2003\SP0\KB2360131-IE7\Filelist
所有受支持的 32 位版本和基于 x64 版本的 Windows Server 2003 上的 Internet Explorer 8:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows Server 2003\SP0\KB2360131-IE8\Filelist

部署信息

安装更新

当您安装此安全更新时,安装程序将检查系统中正在更新的一个或多个文件是否已由 Microsoft 修补程序更新。

如果以前安装的修补程序已经更新过其中的某个文件,安装程序就会将 RTMQFE、SP1QFE 或 SP2QFE 文件复制到系统中。 否则,安装程序将 RTMGDR、SP1GDR 或 SP2GDR 文件复制到您的系统中。 安全更新可能不包含这些文件的所有版本。 有关此行为的详细信息,请参阅 Microsoft 知识库文章 824994

有关安装程序的详细信息,请访问 Microsoft TechNet 网站。

有关本公告中出现的术语(如“修补程序”)的详细信息,请参阅 Microsoft 知识库文章 824684

此安全更新支持以下安装开关。

受支持的安全更新安装开关
开关描述
/help 显示命令行选项。
安装模式
/passive 无人参与安装模式。 无需用户交互操作,但会显示安装状态。 如果安装结束时需要重新启动,将显示一个带有计时器的对话框,警告计算机将在 30 秒后重新启动。
/quiet 安静模式。 这与无人参与模式相同,但是不显示任何状态或错误消息。
重新启动选项
/norestart 安装完成后不重新启动。
/forcerestart 安装后重新启动计算机,且在关机时强制其他应用程序关闭而不先保存打开的文件。
/warnrestart[:x] 显示一个带有计时器的对话框,警告计算机将在 x 秒后重新启动。 (默认设置为 30 秒。) 与 /quiet 开关或 /passive 开关一起使用。
/promptrestart 显示提示本地用户允许重新启动的对话框。
特殊选项
/overwriteoem 不经提示而覆盖 OEM 文件。
/nobackup 不备份卸载所需的文件。
/forceappsclose 在计算机关机时强制关闭其他程序。
/log:path 允许重定向安装日志文件。
/integrate:path 将更新集成到 Windows 源文件中。 这些文件位于开关中指定的路径中。
/extract[:path] 提取文件而不启动安装程序。
/ER 启用扩展错误报告功能。
/verbose 启用详细日志记录。 在安装期间,创建 %Windir%\CabBuild.log。此日志详述了被复制的文件。 使用此开关可能导致安装过程变慢。

注意 这些开关可以在一个命令中组合使用。 为了保持向后兼容,此安全更新还支持以前版本的安装程序所使用的许多安装开关。 有关受支持的安装开关的详细信息,请参阅 Microsoft 知识库文章 262841

删除更新

此安全更新支持以下安装开关。

受支持的 Spuninst.exe 开关
开关描述
/help 显示命令行选项。
安装模式
/passive 无人参与安装模式。 无需用户交互操作,但会显示安装状态。 如果安装结束时需要重新启动,将显示一个带有计时器的对话框,警告计算机将在 30 秒后重新启动。
/quiet 安静模式。 这与无人参与模式相同,但是不显示任何状态或错误消息。
重新启动选项
/norestart 安装完成后不重新启动。
/forcerestart 安装后重新启动计算机,且在关机时强制其他应用程序关闭而不先保存打开的文件。
/warnrestart[:x] 显示一个带有计时器的对话框,警告计算机将在 x 秒后重新启动。 (默认设置为 30 秒。) 与 /quiet 开关或 /passive 开关一起使用。
/promptrestart 显示提示本地用户允许重新启动的对话框。
特殊选项
/forceappsclose 在计算机关机时强制关闭其他程序。
/log:path 允许重定向安装日志文件。

验证是否已应用更新

  • Microsoft Baseline Security Analyzer

    要验证受影响的系统上是否应用了安全更新,可以使用 Microsoft Baseline Security Analyzer (MBSA) 工具。 有关详细信息,请参阅本公告前面的“检测和部署工具及指导”一节。

  • 文件版本验证

    由于 Microsoft Windows 有多个版本,因此以下步骤可能会与您的系统上的步骤不同。 如果不同,请参阅产品文档来完成这些步骤。

    1. 单击“开始”,然后单击“搜索”。
    2. 在“搜索结果”窗格中,单击“搜索助理”下的“所有文件和文件夹”。
    3. 在“完整或部分文件名”框中,键入相应文件信息表中的一个文件名,然后单击“搜索”。
    4. 在文件列表中,用鼠标右键单击相应文件信息表中的一个文件名,然后单击“属性”。

      注意 根据系统上安装的操作系统或程序的版本,文件信息表中所列的某些文件可能并未安装。
    5. 在“版本”选项卡上,通过将系统上安装的文件与相应文件信息表中记录的版本进行比较来确定该文件的版本。

      注意 在安装过程中,除文件版本以外的其他属性均可能会发生变化。 不支持通过将其他文件属性与文件信息表中的信息进行比较这种方法来验证是否应用了更新。 另外,在某些情况下,在安装过程中还可能会重命名文件。 如果没有文件或版本信息,请使用另外一种方法来验证更新安装。
  • 注册表项验证

    您也可以通过查看本节“参考表”中列出的注册表项来验证此安全更新安装的文件。

    这些注册表项可能不包含已安装文件的完整列表。 另外,如果管理员或 OEM 将此安全更新集成或组合到 Windows 安装源文件中,则可能无法正确创建这些注册表项。

Windows Vista(所有版本)

参考表

下表包含此软件的安全更新信息。 您可以在本节的“部署信息”小节中找到更多信息。

包括在以后的 Service Pack 此问题的更新程序将包含在以后的 Service Pack 或更新汇总中
部署
没有用户干预的安装所有受支持的 32 位版本 Windows Vista 上的 Internet Explorer 7:
Windows6.0-KB2360131-x86.msu /quiet
所有受支持的基于 x64 版本 Windows Vista 上的 Internet Explorer 7:
Windows6.0-KB2360131-x64.msu /quiet
所有受支持的 32 位版本 Windows Vista 上的 Internet Explorer 8:
IE8-Windows6.0-KB2360131-x86.msu /quiet
所有受支持的 x64 版本 Windows Vista 上的 Internet Explorer 8:
IE8-Windows6.0-KB2360131-x64.msu /quiet
在不重新启动的情况下安装所有受支持的 32 位版本 Windows Vista 上的 Internet Explorer 7:
Windows6.0-KB2360131-x86.msu /quiet /norestart
所有受支持的基于 x64 版本 Windows Vista 上的 Internet Explorer 7:
Windows6.0-KB2360131-x64.msu /quiet /norestart
所有受支持的 32 位版本 Windows Vista 上的 Internet Explorer 8:
IE8-Windows6.0-KB2360131-x86.msu /quiet /norestart
所有受支持的 x64 版本 Windows Vista 上的 Internet Explorer 8:
IE8-Windows6.0-KB2360131-x64.msu /quiet /norestart
更多信息请参阅“检测和部署工具及指导”小节
重新启动要求
要求重新启动?是,应用此安全更新后必须重新启动系统
Hotpatching不适用
删除信息 WUSA.exe 不支持卸载更新。 要卸载由 WUSA 安装的更新,请单击“控制面板”,然后单击“安全”。 在“Windows Update”下,单击“查看安装的更新”并从更新列表中选择。
文件信息 请参阅 Microsoft 知识库文章 2360131
注册表项验证 注意 没有用于验证此更新是否存在的注册表项。

部署信息

安装更新

当您安装此安全更新时,安装程序将检查系统中正在更新的一个或多个文件是否已由 Microsoft 修补程序更新。

有关本公告中出现的术语(如“修补程序”)的详细信息,请参阅 Microsoft 知识库文章 824684

此安全更新支持以下安装开关。

受支持的安全更新安装开关
开关描述
/?, /h, /help 在支持的开关上显示帮助。
/quiet 抑制显示状态或者错误消息。
/norestart 当与 /quiet 结合使用时,系统在安装之后不会重新启动,即使要求重新启动才能完成安装也是如此。

注意 有关 wusa.exe 安装程序的详细信息,请参阅 Microsoft 知识库文章 934307

验证是否已应用更新

  • Microsoft Baseline Security Analyzer

    要验证受影响的系统上是否应用了安全更新,可以使用 Microsoft Baseline Security Analyzer (MBSA) 工具。 有关详细信息,请参阅本公告前面的“检测和部署工具及指导”一节。

  • 文件版本验证

    由于 Microsoft Windows 有多个版本,因此以下步骤可能会与您的系统上的步骤不同。 如果不同,请参阅产品文档来完成这些步骤。

    1. 单击“开始”,然后在“开始搜索”框中输入更新文件名。
    2. 当文件显示在“程序”之下时,右键单击文件名,然后单击“属性”。
    3. 在“常规”选项卡上,将文件大小与公告知识库文章中提供的文件信息表进行比较。
    4. 您也可以单击“详细信息”选项卡,并将信息(如文件版本和修改日期)与公告知识库文章中提供的文件信息表进行比较。
    5. 最后,您也可以单击“以前的版本”选项卡,并将文件的以前版本的文件信息与新的或经过更新的文件版本的文件信息进行比较。

Windows Server 2008(所有版本)

参考表

下表包含此软件的安全更新信息。 您可以在本节的“部署信息”小节中找到更多信息。

包括在以后的 Service Pack 此问题的更新程序将包含在以后的 Service Pack 或更新汇总中
部署
没有用户干预的安装所有受支持的 32 位版本的 Windows Server 2008 上的 Internet Explorer 7:
Windows6.0-KB2360131-x86.msu /quiet
所有受支持的基于 x64 版本的 Windows Server 2008 上的 Internet Explorer 7:
Windows6.0-KB2360131-x64.msu /quiet
所有受支持的基于 Itanium 版本的 Windows Server 2008 上的 Internet Explorer 7:
Windows6.0-KB2360131-ia64.msu /quiet
所有受支持的 32 位版本的 Windows Server 2008 上的 Internet Explorer 8:
IE8-Windows6.0-KB2360131-x86.msu /quiet
所有受支持的基于 x64 版本的 Windows Server 2008 上的 Internet Explorer 8:
IE8-Windows6.0-KB2360131-x64.msu /quiet
在不重新启动的情况下安装所有受支持的 32 位版本的 Windows Server 2008 上的 Internet Explorer 7:
Windows6.0-KB2360131-x86.msu /quiet /norestart
所有受支持的基于 x64 版本的 Windows Server 2008 上的 Internet Explorer 7:
Windows6.0-KB2360131-x64.msu /quiet /norestart
所有受支持的基于 Itanium 版本的 Windows Server 2008 上的 Internet Explorer 7:
Windows6.0-KB2360131-ia64.msu /quiet /norestart
所有受支持的 32 位版本的 Windows Server 2008 上的 Internet Explorer 8:
IE8-Windows6.0-KB2360131-x86.msu /quiet /norestart
所有受支持的基于 x64 版本的 Windows Server 2008 上的 Internet Explorer 8:
IE8-Windows6.0-KB2360131-x64.msu /quiet /norestart
更多信息请参阅“检测和部署工具及指导”小节
重新启动要求
要求重新启动?是,应用此安全更新后必须重新启动系统。
HotPatching不适用。
删除信息 WUSA.exe 不支持卸载更新。 要卸载由 WUSA 安装的更新,请单击“控制面板”,然后单击“安全”。 在“Windows Update”下,单击“查看安装的更新”并从更新列表中选择。
文件信息 请参阅 Microsoft 知识库文章 2360131
注册表项验证 注意 没有用于验证此更新是否存在的注册表项。

部署信息

安装更新

当您安装此安全更新时,安装程序将检查系统中正在更新的一个或多个文件是否已由 Microsoft 修补程序更新。

有关本公告中出现的术语(如“修补程序”)的详细信息,请参阅 Microsoft 知识库文章 824684

此安全更新支持以下安装开关。

受支持的安全更新安装开关
开关描述
/?, /h, /help 在支持的开关上显示帮助。
/quiet 抑制显示状态或者错误消息。
/norestart 当与 /quiet 结合使用时,系统在安装之后不会重新启动,即使要求重新启动才能完成安装也是如此。

注意 有关 wusa.exe 安装程序的详细信息,请参阅 Microsoft 知识库文章 934307

验证是否已应用更新

  • Microsoft Baseline Security Analyzer

    要验证受影响的系统上是否应用了安全更新,可以使用 Microsoft Baseline Security Analyzer (MBSA) 工具。 有关详细信息,请参阅本公告前面的“检测和部署工具及指导”一节。

  • 文件版本验证

    由于 Microsoft Windows 有多个版本,因此以下步骤可能会与您的系统上的步骤不同。 如果不同,请参阅产品文档来完成这些步骤。

    1. 单击“开始”,然后在“开始搜索”框中输入更新文件名。
    2. 当文件显示在“程序”之下时,右键单击文件名,然后单击“属性”。
    3. 在“常规”选项卡上,将文件大小与公告知识库文章中提供的文件信息表进行比较。
    4. 您也可以单击“详细信息”选项卡,并将信息(如文件版本和修改日期)与公告知识库文章中提供的文件信息表进行比较。
    5. 最后,您也可以单击“以前的版本”选项卡,并将文件的以前版本的文件信息与新的或经过更新的文件版本的文件信息进行比较。

Windows 7(所有版本)

参考表

下表包含此软件的安全更新信息。 您可以在本节的“部署信息”小节中找到更多信息。

包括在以后的 Service Pack 此问题的更新程序将包含在以后的 Service Pack 或更新汇总中
部署
没有用户干预的安装所有受支持的 32 位版本 Windows 7 上的 Internet Explorer 8:
Windows6.1-KB2360131-x86 /quiet
Windows 7 的所有受支持的 x64 版本上的 Internet Explorer 8:
Windows6.1-KB2360131-x64 /quiet
在不重新启动的情况下安装所有受支持的 32 位版本 Windows 7 上的 Internet Explorer 8:
Windows6.1-KB2360131-x86 /quiet /norestart
Windows 7 的所有受支持的 x64 版本上的 Internet Explorer 8:
Windows6.1-KB2360131-x64 /quiet /norestart
更多信息请参阅“检测和部署工具及指导”小节
重新启动要求
要求重新启动?是,应用此安全更新后必须重新启动系统
Hotpatching不适用
删除信息 要卸载 WUSA 安装的更新,请使用 /Uninstall 安装开关,或者单击“控制面板”,单击“系统和安全”,然后在 Windows Update 下单击“查看安装的更新”,并从更新列表中进行选择。
文件信息 请参阅 Microsoft 知识库文章 2360131
注册表项验证 注意 没有用于验证此更新是否存在的注册表项。

部署信息

安装更新

当您安装此安全更新时,安装程序将检查系统中正在更新的一个或多个文件是否已由 Microsoft 修补程序更新。

有关本公告中出现的术语(如“修补程序”)的详细信息,请参阅 Microsoft 知识库文章 824684

此安全更新支持以下安装开关。

受支持的安全更新安装开关
开关描述
/?, /h, /help 在支持的开关上显示帮助。
/quiet 抑制显示状态或者错误消息。
/norestart 当与 /quiet 结合使用时,系统在安装之后不会重新启动,即使要求重新启动才能完成安装也是如此。
/warnrestart:< > 当与 /quiet 结合使用时,在重新启动之前,安装程序将发出警告。
/promptrestart 当与 /quiet 结合使用时,在重新启动之前,安装程序将进行提示。
/forcerestart 当与 /quiet 结合使用时,安装程序将强制关闭应用程序并重新启动。
/log:< 文件名 > 将日志记录到指定的文件。
/extract:< 目标 > 将程序包内容提取到目标文件夹。
/uninstall /kb:<KB 编号 > 卸载安全更新。

注意 有关 wusa.exe 安装程序的详细信息,请参阅 TechNet 文章 Windows 7 中的其他更改中的“Windows Update 独立安装程序”。

验证是否已应用更新

  • Microsoft Baseline Security Analyzer

    要验证受影响的系统上是否应用了安全更新,可以使用 Microsoft Baseline Security Analyzer (MBSA) 工具。 有关详细信息,请参阅本公告前面的“检测和部署工具及指导”一节。

  • 文件版本验证

    由于 Microsoft Windows 有多个版本,因此以下步骤可能会与您的系统上的步骤不同。 如果不同,请参阅产品文档来完成这些步骤。

    1. 单击“开始”,然后在“搜索”框中输入更新文件名。
    2. 当文件显示在“程序”之下时,右键单击文件名,然后单击“属性”。
    3. 在“常规”选项卡上,将文件大小与公告知识库文章中提供的文件信息表进行比较。
    4. 您也可以单击“详细信息”选项卡,并将信息(如文件版本和修改日期)与公告知识库文章中提供的文件信息表进行比较。
    5. 最后,您也可以单击“以前的版本”选项卡,并将文件的以前版本的文件信息与新的或经过更新的文件版本的文件信息进行比较。

Windows Server 2008 R2(所有版本)

参考表

下表包含此软件的安全更新信息。 您可以在本节的“部署信息”小节中找到更多信息。

包括在以后的 Service Pack 此问题的更新程序将包含在以后的 Service Pack 或更新汇总中
部署
没有用户干预的安装Windows Server 2008 R2 的所有受支持的基于 x64 版本上的 Internet Explorer 8:
Windows6.1-KB2360131-x64 /quiet
Windows Server 2008 R2 的所有受支持的基于 Itanium 版本上的 Internet Explorer 8:
Windows6.1-KB2360131-ia64 /quiet
在不重新启动的情况下安装Windows Server 2008 R2 的所有受支持的基于 x64 版本上的 Internet Explorer 8:
Windows6.1-KB2360131-x64 /quiet /norestart
Windows Server 2008 R2 的所有受支持的基于 Itanium 版本上的 Internet Explorer 8:
Windows6.1-KB2360131-ia64 /quiet /norestart
更多信息请参阅“检测和部署工具及指导”小节
重新启动要求
要求重新启动?是,应用此安全更新后必须重新启动系统
Hotpatching不适用
删除信息 要卸载 WUSA 安装的更新,请使用 /Uninstall 安装开关,或者单击“控制面板”,单击“系统和安全”,然后在 Windows Update 下单击“查看安装的更新”,并从更新列表中进行选择。
文件信息 请参阅 Microsoft 知识库文章 2360131
注册表项验证 注意 没有用于验证此更新是否存在的注册表项。

部署信息

安装更新

当您安装此安全更新时,安装程序将检查系统中正在更新的一个或多个文件是否已由 Microsoft 修补程序更新。

有关本公告中出现的术语(如“修补程序”)的详细信息,请参阅 Microsoft 知识库文章 824684

此安全更新支持以下安装开关。

受支持的安全更新安装开关
开关描述
/?, /h, /help 在支持的开关上显示帮助。
/quiet 抑制显示状态或者错误消息。
/norestart 当与 /quiet 结合使用时,系统在安装之后不会重新启动,即使要求重新启动才能完成安装也是如此。
/warnrestart:< > 当与 /quiet 结合使用时,在重新启动之前,安装程序将发出警告。
/promptrestart 当与 /quiet 结合使用时,在重新启动之前,安装程序将进行提示。
/forcerestart 当与 /quiet 结合使用时,安装程序将强制关闭应用程序并重新启动。
/log:< 文件名 > 将日志记录到指定的文件。
/extract:< 目标 > 将程序包内容提取到目标文件夹。
/uninstall /kb:<KB 编号 > 卸载安全更新。

注意 有关 wusa.exe 安装程序的详细信息,请参阅 TechNet 文章 Windows 7 中的其他更改中的“Windows Update 独立安装程序”。

验证是否已应用更新

  • Microsoft Baseline Security Analyzer

    要验证受影响的系统上是否应用了安全更新,可以使用 Microsoft Baseline Security Analyzer (MBSA) 工具。 有关详细信息,请参阅本公告前面的“检测和部署工具及指导”一节。

  • 文件版本验证

    由于 Microsoft Windows 有多个版本,因此以下步骤可能会与您的系统上的步骤不同。 如果不同,请参阅产品文档来完成这些步骤。

    1. 单击“开始”,然后在“开始搜索”框中输入更新文件名。
    2. 当文件显示在“程序”之下时,右键单击文件名,然后单击“属性”。
    3. 在“常规”选项卡上,将文件大小与公告知识库文章中提供的文件信息表进行比较。
    4. 您也可以单击“详细信息”选项卡,并将信息(如文件版本和修改日期)与公告知识库文章中提供的文件信息表进行比较。
    5. 最后,您也可以单击“以前的版本”选项卡,并将文件的以前版本的文件信息与新的或经过更新的文件版本的文件信息进行比较。

其他信息

鸣谢

Microsoft 感谢下列人员或组织与我们一起致力于保护客户的利益:

  • Google Inc. 的 Sirdarckcat 报告了 HTML 清理漏洞 (CVE-2010-3243)
  • Mario Heiderich 报告了 HTML 清理漏洞 (CVE-2010-3324)
  • IBM ISS X-Force 的 Takehiro Takahashi 报告了未初始化的内存损坏漏洞 (CVE-2010-3326)
  • Peter VreugdenhilTippingPointZero Day Initiative 合作报告了未初始化的内存损坏漏洞 (CVE-2010-3328)
  • Core Security Technologies 的 Damián Frizza 报告了未初始化的内存损坏漏洞 (CVE-2010-3329)
  • Cigital 的 Aldwin Saugere 和 Radoslav Vasilev 报告了跨域信息泄露漏洞 (CVE-2010-3330)
  • Check Point IPS Research Center 的 Rodrigo Rubira Branco 报告了未初始化的内存损坏漏洞 (CVE-2010-3331)

Microsoft Active Protections Program (MAPP)

为改进客户的安全保护,Microsoft 在发布每月安全更新之前将向主要的安全软件供应商提供漏洞信息。 然后,安全软件供应商可以使用该漏洞信息通过其安全软件或者设备向客户提供更新的保护,例如防病毒、基于网络的入侵检测系统或者基于主机的入侵防止系统。 要确定是否可从安全软件供应商处得到活动保护,请访问计划合作伙伴(在 Microsoft Active Protections Program (MAPP) 合作伙伴中列出)提供的活动保护网站。

支持

  • 美国和加拿大的客户可以通过安全支持或 1-866-PCSAFETY 获得技术支持。 与安全更新有关的电话支持服务是免费的。 有关可用支持选项的详细信息,请参阅 Microsoft 帮助和支持网站。
  • 其他国家(或地区)的用户可从当地的 Microsoft 分公司获得支持。 与安全更新有关的支持服务不收取任何费用。 有关如何就支持问题与 Microsoft 取得联系方面的更多信息,请访问国际支持网站。

免责声明

Microsoft 知识库中的信息“按原样”提供,没有任何形式的担保。 Microsoft 不作任何明示或暗示保证,包括对适销性和针对特定目的的适用性的保证。 Microsoft Corporation 或其供应商不对任何损害(包括直接的、间接的、偶然的、必然的损害,商业利润损失,或特殊损害)承担任何责任,即使 Microsoft Corporation 或其供应商事先已被告知有可能发生此类损害。 有些州不允许排除或限制必然或偶然损害的赔偿责任,因此上述限制可能不适用。

修订版本

  • V1.0(2010 年 10 月 12 日): 已发布公告。
  • V1.1(2010 年 10 月 13 日): 更正了 Windows Server 2008 部署参考表中 Internet Explorer 的更新程序包名称。 这仅仅是一个信息更改。 已经成功更新了其系统的客户不需要执行任何操作。

Built at 2014-04-18T01:50:00Z-07:00

显示: