當您嘗試在 Windows PowerShell 中執行 Exchange 管理命令介面嵌入式管理單元時出現錯誤訊息

Exchange 2007
 

上次修改主題的時間: 2009-04-20

本主題說明如何對您在 Windows PowerShell 或使用 System.Management.Automation 命名空間的 Microsoft .NET 程式碼中嘗試執行 Microsoft Exchange 管理命令介面嵌入式管理單元時所出現的錯誤訊息進行疑難排解。在此情況下,Exchange 管理命令介面嵌入式管理單元並未執行,而且您看見下列錯誤訊息:

 

沒有適用於第 1 版的 Windows PowerShell 嵌入式管理單元。

若您嘗試在 32 位元版的 Windows PowerShell 上執行 Exchange 管理命令介面嵌入式管理單元,即會發生此錯誤。Exchange 管理命令介面嵌入式管理單元為 64 位元程式,因此必須使用 64 位元版的 Windows PowerShell。同樣地,使用 System.Management.Automation 命名空間執行 Exchange 管理命令介面嵌入式管理單元的 .NET 程式碼,也必須在 64 位元系統上才可相容。

若要解決此問題,請使用 64 位元版的 Windows PowerShell 執行 Exchange 管理命令介面嵌入式管理單元。或者,當您使用 System.Management.Automation 命名空間執行 Exchange 管理命令介面嵌入式管理單元時,請編譯 64 位元系統的 .NET 程式碼。

note附註:
當您安裝 Windows PowerShell 時,32 位元版與 64 位元版的 Windows Powershell.exe 皆會安裝在 64 位元版的 Windows 上。但是,Exchange Server 2007 只會安裝 64 位元版的 Exchange 管理命令介面延伸。
64 位元版的 Windows PowerShell 位於 C:\WINNT\Syswow64\Windowspowershell\v1.0\Powershell.exe 資料夾中。32 位元版的 Windows PowerShell 位於 C:\WINNT\System32\Windowspowershell\v1.0\Powershell.exe 資料夾中。

若要確保您目前閱讀的是最新資訊,並尋找其他的 Exchange Server 2007 說明文件,請造訪 Exchange Server 技術資源中心.
顯示: